2000/xp命令行可以一次多个命令
现在和流行的UNIX SHELL一样了，可以用 && 和 || 组合两条命令，依次执行……

比如

aa && bb
就是执行aa，成功后再执行bb

aa || bb
先执行aa，若执行成功则不再执行bb，若失败则执行bb

好象用 & 和 | 也可以

“执行成功”的意思是返回的errorlevel=0


WIN NT/2000 中的 NET 命令
NET命令是Windows NT中的一个功能强大的工具。虽然必须用命令行方式执行，但它的功能确覆盖了Windows NT中大部分重要的管理功能。例如，它可以管理网络环境、各种服务程序的运行和配置、进行用户和登陆管理等。它还可以查看服务器的许多本地信息。Windows98中也包含NET命令，但其功能比在NT中少得多。

   可以通过以下两种方法获得NET命令的帮助信息：
  (1)在NT下可以用图形的方式，通过开始菜单>帮助>索引，然后输入NET。
(2)也可以在命令行方式下输入NET /?或NET或NET HELP得到它的功能（COMMAND）列表，然后通过NET COMMAND /HELP或NET HELP COMMAND 或NET COMMAND /? 命令得到相应功能的帮助信息。

    在使用NET命令时需要注意的是：它的有一些命令是会马上产生作用并永久保存的，使用的时候要慎重。
    下面对NET命令的不同参数的基本用法做一些初步的介绍：

    1. NET VIEW
    作用：显示域列表、计算机列表或指定计算机的共享资源列表。
    命令格式：net view [\\computername | /domain[:domainname]]
  参数介绍：
(1)键入不带参数的net view显示当前域的计算机列表。
    (2)\\computername 指定要查看其共享资源的计算机。
    (3)/domain[:domainname]指定要查看其可用计算机的域。
    举例说明：
    (1)net view \\XIAOHU查看XIAOHU的共享资源列表。
    (2)net view /domain:MYDOMAIN查看MYDOMAIN域中的机器列表。

    2. NET USER 　　作用：添加或更改用户帐号或显示用户帐号信息。
该命令也可以写为 net users
    命令格式：net user [username [password | *] [options]] [/domain]
    参数介绍：(1)键入不带参数的net user查看计算机上的用户帐号列表。
    (2)username添加、删除、更改或查看用户帐号名。
    (3)password为用户帐号分配或更改密码。
    (4)*提示输入密码。
    (5)/domain在计算机主域的主域控制器中执行操作。
    举例说明：(1)net user xiaohu查看用户XIAOHU的信息。

    3. NET USE
    作用：连接计算机或断开计算机与共享资源的连接，或显示计算机的连接信息。
    命令格式：
net use [devicename | *] [\\computername\sharename[\volume]] [password | *]]
[/user:[domainname\]username] [[/delete] | [/persistent:{yes | no}]]
参数介绍：
(1)键入不带参数的net use列出网络连接。
    (2)devicename指定要连接到的资源名称或要断开的设备名称。
    (3)\\computername\sharename服务器及共享资源的名称。
    (4)password访问共享资源的密码。
    (5)*提示键入密码。
    (6)/user指定进行连接的另外一个用户。
    (7)domainname指定另一个域。
  (8)username指定登录的用户名。
    (9)/home将用户连接到其宿主目录。
    (10)/delete取消指定网络连接。
    (11)/persistent控制永久网络连接的使用。
    举例说明：
    (1)net use e: \\XIAOHU\TEMP将\\XIAOHU\TEMP目录建立为E盘。
    (2)net use e: \\XIAOHU\TEMP /delete断开连接。

    4. NET TIME 　　作用：使计算机的时钟与另一台计算机或域的时间同步。
    命令格式：net time [\\computername | /domain[:name]] [/set]
    参数介绍：
    (1)\\computername要检查或同步的服务器名。
    (2)/domain[:name]指定要与其时间同步的域。
    (3)/set使本计算机时钟与指定计算机或域的时钟同步。
    下面的这4个参数是相关的，所以一起介绍：

5. Net Start
    作用：启动服务，或显示已启动服务的列表。
    命令格式：net start service

    6. Net Pause
    作用：暂停正在运行的服务。
    命令格式：net pause service

    7. Net Continue
    作用：重新激活挂起的服务。
    命令格式：net continue service

    8. NET STOP
    作用：停止 Windows NT 网络服务。
    命令格式：net stop service
    参数介绍：
    (1)alerter(警报)
    (2)client service for netware(Netware 客户端服务)
    (3)clipbook server(剪贴簿服务器)
    (4)computer browser(计算机浏览器)
    (5)directory replicator(目录复制器)
    (6)ftp publishing service (ftp )(ftp 发行服务)
    (7)lpdsvc
    (8)net logon(网络登录)
    (9)network dde(网络 dde)
    (10)network dde dsdm(网络 dde dsdm)
    (11)network monitor agent(网络监控代理)
    (12)nt lm security support provider(NT LM 安全性支持提供)
    (13)ole(对象链接与嵌入)
    (14)remote access connection manager(远程访问连接管理器)
    (15)remote access isnsap service(远程访问 isnsap 服务)
    (16)remote access server(远程访问服务器)
    (17)remote procedure call (rpc) locator(远程过程调用定位器)
    (18)remote procedure call (rpc) service(远程过程调用服务)
    (19)schedule(调度)
    (20)server(服务器)
    (21)simple tcp/ip services(简单 TCP/IP 服务)
    (22)snmp
    (23)spooler(后台打印程序)
    (24)tcp/ip netbios helper(TCP/IP NETBIOS 辅助工具)
    (25)ups
    (26)workstation(工作站)
    (27)messenger(信使)
    (28)dhcp client
    (29)eventlog

    9. Net Statistics
    作用：显示本地工作站或服务器服务的统计记录。
    命令格式：net statistics [workstation | server]
    参数介绍：(1)键入不带参数的net statistics列出其统计信息可用的运行服务。
  (2)workstation显示本地工作站服务的统计信息。
    (3)server显示本地服务器服务的统计信息。
  举例说明：net statistics server | more显示服务器服务的统计信息。

10. Net Share
    作用：创建、删除或显示共享资源。
    命令格式：net share share name=drive:path [/users:number | /unlimited] [/remark:"text"]
参数介绍：(1)键入不带参数的net share显示本地计算机上所有共享资源的信息。 　 (2)sharename是共享资源的网络名称。
    (3)drive:path指定共享目录的绝对路径。
(4)/users:number设置可同时访问共享资源的最大用户数。
    (5)/unlimited不限制同时访问共享资源的用户数。
    (6)/remark:"text "添加关于资源的注释，注释文字用引号引住。
    举例说明：
(1)net share mymydomain=c:\temp /remark:"my first share"以mymydomain为共享名共享C:\temp。
(2)net share mymydomain /delete停止共享mymydomain目录。

  11. Net Session
  作用：列出或断开本地计算机和与之连接的客户端的会话，也可以写为net sessions或net sess。
  命令格式：net session [\\computername] [/delete]
  参数介绍：(1)键入不带参数的net session显示所有与本地计算机的会话的信息。
(2)\\computername标识要列出或断开会话的计算机。
   举例说明： net session \\XIAOHU要显示计算机名为XIAOHU的客户端会话信息列表。

  12. Net Send
    作用：向网络的其他用户、计算机或通信名发送消息。
    命令格式：net send {name | * | /domain[:name] | /users} message
    参数介绍：(1)name要接收发送消息的用户名、计算机名或通信名。
  (2)*将消息发送到组中所有名称。
    (3)/domain[:name]将消息发送到计算机域中的所有名称。
    (4)/users将消息发送到与服务器连接的所有用户。
    (5)message作为消息发送的文本。
    举例说明：
(1)net send /users server will shutdown in 5 minutes给所有连接到服务器的用户发送关机消息。

    13. Net Print
   作用：显示或控制打印作业及打印队列。
   命令格式：net print [\\computername ] job# [/hold | /release | /delete]
参数介绍： (1)computername共享打印机队列的计算机名。
  (2)sharename打印队列名称.
(3)job#在打印机队列中分配给打印作业的标识号。
  (4)/hold使用 job# 时，在打印机队列中使打印作业等待。
(5)/release释放保留的打印作业。
(6)/delete从打印机队列中删除打印作业。
    举例说明：(1)net print \\XIAOHU\SEEME列出\\XIAOHU计算机上SEEME打印机队列的目录。

    14. Net Name
    作用：添加或删除消息名（有时也称别名），或显示计算机接收消息的名称列表。
    命令格式：net name [name [/add | /delete]]
    参数介绍：(1)键入不带参数的net name列出当前使用的名称。
    (2)name指定接收消息的名称。
    (3)/add将名称添加到计算机中。
    (4)/delete从计算机中删除名称。

    15. Net Localgroup
    作用：添加、显示或更改本地组。
    命令格式：
net localgroup groupname {/add [/comment:"text "] | /delete} [/domain]
    参数介绍：
(1)键入不带参数的net localgroup显示服务器名称和计算机的本地组名称。 　　 (2)groupname要添加、扩充或删除的本地组名称。
    (3)/comment: "text "为新建或现有组添加注释。
    (4)/domain在当前域的主域控制器中执行操作，否则仅在本地计算机上执行操作?
    (5)name [ ...]列出要添加到本地组或从本地组中删除的一个或多个用户名或组名。
    (6)/add将全局组名或用户名添加到本地组中。
    (7)/delete从本地组中删除组名或用户名。
    举例说明：
(1)net localgroup mydomain /add将名为mydomain的本地组添加到本地用户帐号数据库。
    (2)net localgroup mydomain显示mydomain本地组中的用户。

16. Net Group
    作用：在 Windows NT Server 域中添加、显示或更改全局组。
    命令格式：
net group groupname {/add [/comment:"text "] | /delete} [/domain]
    参数介绍：(1)键入不带参数的net group显示服务器名称及服务器的组名称。
    (2)groupname要添加、扩展或删除的组。
    (3)/comment:"text "为新建组或现有组添加注释。
    (4)/domain在当前域的主域控制器中执行该操作，否则在本地计算机上执行操作?
    (5)username[ ...]列表显示要添加到组或从组中删除的一个或多个用户。
    (6)/add添加组或在组中添加用户名。
    (7)/delete删除组或从组中删除用户名。
    举例说明：net group mydomain xiaohu1 xiaohu2 /add将现有用户帐号xiaohu1和xiaohu2添加到本地计算机的mydomain组。

    17. Net Config
    作用：显示当前运行的可配置服务，或显示并更改某项服务的设置。
    命令格式：net config [service [options]]
    参数介绍：

(1)键入不带参数的net config显示可配置服务的列表。
(2)service通过net config命令进行配置的服务(server或workstation)。
(3)options服务的特定选项。

    18. Net Computer
    作用：从域数据库中添加或删除计算机。
    命令格式：
net computer \\computername {/add | /del}
    参数介绍：(1)\\computername指定要添加到域或从域中删除的计算机。
    (2)/add将指定计算机添加到域。
    (3)/del将指定计算机从域中删除。
    举例说明：net computer \\cc /add将计算机 cc 添加到登录域。

    19. Net Accounts
    作用：更新用户帐号数据库、更改密码及所有帐号的登录要求。
    命令格式：net accounts [/forcelogoff:{minutes | no}] [/minpwlen:length] [/maxpwage:{days | unlimited}] [/minpwage:days] [/uniquepw:number] [/domain]
    参数介绍：
(1)键入不带参数的net accounts显示当前密码设置、登录时限及域信息。
(2)/forcelogoff:{minutes | no}设置当用户帐号或有效登录时间过期时。
(3)/minpwlen:length设置用户帐号密码的最少字符数。
(4)/maxpwage:{days | unlimited}设置用户帐号密码有效的最大天数。
(5)/minpwage:days设置用户必须保持原密码的最小天数。
(6)/uniquepw:number要求用户更改密码时，必须在经过number次后才能重复使用与之相同的密码。 (7)/domain在当前域的主域控制器上执行该操作。
(8)/sync当用于主域控制器时，该命令使域中所有备份域控制器同步。
    举例说明：net accounts /minpwlen:7将用户帐号密码的最少字符数设置为7。


win2000小技巧：在任意目录进入命令行模式！
在HKEY_CLASSES_ROOT\Directory\shell下新建“项”DOSHere，默认值是“从此进入DOS方式(&D)”（不包括引号，下同）
    在HKEY_CLASSES_ROOTDirectoryshellDOSHere下新建“项”command默认值是“cmd /k cd %1”，现在在任意一个目录上边单击右键，你可以在命令行进入这个目录了。


win2k运行进程详解=================

Svchost.exe
Svchost.exe文件对那些从动态连接库中运行的服务来说是一个普通的主机进程名。Svhost.exe文件定位
在系统的%systemroot%\system32文件夹下。在启动的时候，Svchost.exe检查注册表中的位置来构建需要
加载的服务列表。这就会使多个Svchost.exe在同一时间运行。每个Svchost.exe的回话期间都包含一组服务，
以至于单独的服务必须依靠Svchost.exe怎样和在那里启动。这样就更加容易控制和查找错误。

Svchost.exe 组是用下面的注册表值来识别。

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost
每个在这个键下的值代表一个独立的Svchost组，并且当你正在看活动的进程时，它显示作为一个单独的
例子。每个键值都是REG_MULTI_SZ类型的值而且包括运行在Svchost组内的服务。每个Svchost组都包含一个
或多个从注册表值中选取的服务名，这个服务的参数值包含了一个ServiceDLL值。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Service

更多的信息
为了能看到正在运行在Svchost列表中的服务。
开始－运行－敲入cmd
然后在敲入 tlist -s （tlist 应该是win2k工具箱里的冬冬）
Tlist 显示一个活动进程的列表。开关 -s 显示在每个进程中的活动服务列表。如果想知道更多的关于
进程的信息，可以敲 tlist pid。

Tlist 显示Svchost.exe运行的两个例子。
0 System Process
8 System
132 smss.exe
160 csrss.exe Title:
180 winlogon.exe Title: NetDDE Agent
208services.exe
Svcs: AppMgmt, Browser, Dhcp, dmserver, Dnscache, Eventlog, lanmanserver, LanmanWorkstation, LmHosts, Messenger, PlugPlay, ProtectedStorage, seclogon, TrkWks, W32Time, Wmi
220 lsass.exe Svcs: Netlogon,PolicyAgent,SamSs
404 svchost.exe Svcs: RpcSs
452 spoolsv.exe Svcs: Spooler
544 cisvc.exe Svcs: cisvc
556 svchost.exe Svcs: EventSystem,Netman,NtmsSvc,RasMan,SENS,TapiSrv
580 regsvc.exe Svcs: RemoteRegistry
596 mstask.exe Svcs: Schedule
660 snmp.exe Svcs: SNMP
728 winmgmt.exe Svcs: WinMgmt
852 cidaemon.exe Title: OleMainThreadWndName
812 explorer.exe Title: Program Manager
1032 OSA.EXE Title: Reminder
1300 cmd.exe Title: D:\WINNT5\System32\cmd.exe - tlist -s
1080 MAPISP32.EXE Title: WMS Idle
1264 rundll32.exe Title:
1000 mmc.exe Title: Device Manager
1144 tlist.exe
在这个例子中注册表设置了两个组。
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Svchost:
netsvcs: Reg_Multi_SZ: EventSystem Ias Iprip Irmon Netman Nwsapagent Rasauto Rasman Remoteaccess SENS Sharedaccess Tapisrv Ntmssvc
rpcss :Reg_Multi_SZ: RpcSs

smss.exe
csrss.exe

这个是用户模式Win32子系统的一部分。csrss代表客户/服务器运行子系统而且是一个基本的子系统
必须一直运行。csrss 负责控制windows，创建或者删除线程和一些16位的虚拟MS-DOS环境。

explorer.exe
这是一个用户的shell（我实在是不知道怎么翻译shell），在我们看起来就像任务条，桌面等等。这个
进程并不是像你想象的那样是作为一个重要的进程运行在windows中，你可以从任务管理器中停掉它，或者重新启动。
通常不会对系统产生什么负面影响。

internat.exe

这个进程是可以从任务管理器中关掉的。
internat.exe在启动的时候开始运行。它加载由用户指定的不同的输入点。输入点是从注册表的这个位置
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload 加载内容的。
internat.exe 加载“EN”图标进入系统的图标区，允许使用者可以很容易的转换不同的输入点。
当进程停掉的时候，图标就会消失，但是输入点仍然可以通过控制面板来改变。

lsass.exe
这个进程是不可以从任务管理器中关掉的。
这是一个本地的安全授权服务，并且它会为使用winlogon服务的授权用户生成一个进程。这个进程是
通过使用授权的包，例如默认的msgina.dll来执行的。如果授权是成功的，lsass就会产生用户的进入
令牌，令牌别使用启动初始的shell。其他的由用户初始化的进程会继承这个令牌的。

mstask.exe
这个进程是不可以从任务管理器中关掉的。
这是一个任务调度服务，负责用户事先决定在某一时间运行的任务的运行。

smss.exe
这个进程是不可以从任务管理器中关掉的。
这是一个会话管理子系统，负责启动用户会话。这个进程是通过系统进程初始化的并且对许多活动的，
包括已经正在运行的Winlogon，Win32（Csrss.exe）线程和设定的系统变量作出反映。在它启动这些
进程后，它等待Winlogon或者Csrss结束。如果这些过程时正常的，系统就关掉了。如果发生了什么
不可预料的事情，smss.exe就会让系统停止响应（就是挂起）。

spoolsv.exe
这个进程是不可以从任务管理器中关掉的。
缓冲（spooler）服务是管理缓冲池中的打印和传真作业。

service.exe
这个进程是不可以从任务管理器中关掉的。
大多数的系统核心模式进程是作为系统进程在运行。

System Idle Process
这个进程是不可以从任务管理器中关掉的。
这个进程是作为单线程运行在每个处理器上，并在系统不处理其他线程的时候分派处理器的时间。

taskmagr.exe
这个进程是可以在任务管理器中关掉的。
这个进程就是任务管理器。

winlogon.exe
这个进程是管理用户登录和推出的。而且winlogon在用户按下CTRL+ALT+DEL时就激活了，显示安全对话框。

winmgmt.exe
winmgmt是win2000客户端管理的核心组件。当客户端应用程序连接或当管理程序需要他本身的服务时这个进程初始化。

问：我系统里有个"LOADQM.EXE"你知是什么吗?
答：loadqm 是你安装msn的时候，他自己安装的，主要用于自动更新等。一般没什么用，可以删除。微软的原文解释在这里


安全配置Win2000服务器
目前，WIN2000 SERVER是比较流行的服务器操作系统之一，但是要想安全的配置微软的这个操作系统，却不是一件容易的事。本文试图对win2000 SERVER的安全配置进行初步的探讨。

一、 定制自己的WIN2000 SERVER:
1．版本的选择：WIN2000有各种语言的版本，对于我们来说，可以选择英文版或简体中文版，我强烈建议：在语言不成为障碍的情况下，请一定使用英文版。要知道，微软的产品是以Bug & Patch而著称的，中文版的Bug远远多于英文版，而补丁一般还会迟至少半个月（也就是说一般微软公布了漏洞后你的机子还会有半个月处于无保护状况）
2．组件的定制：win2000在默认情况下会安装一些常用的组件，但是正是这个默认安装是极度危险的（米特尼科说过，他可以进入任何一台默认安装的服务器，我虽然不敢这么说，不过如果你的主机是WIN2000 SERVER的默认安装，我可以告诉你，你死定了）你应该确切的知道你需要哪些服务，而且仅仅安装你确实需要的服务，根据安全原则，最少的服务+最小的权限=最大的安全。典型的WEB服务器需要的最小组件选择是：只安装IIS的Com Files，IIS Snap-In，WWW Server组件。如果你确实需要安装其他组件，请慎重，特别是：Indexing Service, FrontPage 2000 Server Extensions, Internet Service Manager (HTML)这几个危险服务。
3．管理应用程序的选择： 选择一个好的远程管理软件是非常重要的事，这不仅仅是安全方面的要求，也是应用方面的需。Win2000的Terminal Service是基于RDP（远程桌面协议）的远程控制软件，他的速度快，操作方便，比较适合用来进行常规操作。但是，Terminal Service也有其不足之处，由于它使用的是虚拟桌面，再加上微软编程的不严谨，当你使用Terminal Service进行安装软件或重起服务器等与真实桌面交互的操作时，往往会出现哭笑不得的现象，例如：使用Terminal Service重起微软的认证服务器（Compaq, IBM等）可能会直接关机。所以，为了安全起见，我建议你再配备一个远程控制软件作为辅助，和Terminal Service互补，象PcAnyWhere就是一个不错的选择。

二、 正确安装WIN2000 SERVER:
1．分区和逻辑盘的分配，有一些朋友为了省事，将硬盘仅仅分为一个逻辑盘，所有的软件都装在C驱上，这是很不好的，建议最少建立两个分区，一个系统分区，一个应用程序分区，这是因为，微软的IIS经常会有泄漏源码/溢出的漏洞，如果把系统和IIS放在同一个驱动器会导致系统文件的泄漏甚至入侵者远程获取ADMIN。推荐的安全配置是建立三个逻辑驱动器，第一个大于2G，用来装系统和重要的日志文件，第二个放IIS，第三个放FTP，这样无论IIS或FTP出了安全漏洞都不会直接影响到系统目录和系统文件。要知道，IIS和FTP是对外服务的，比较容易出问题。而把IIS和FTP分开主要是为了防止入侵者上传程序并从IIS中运行。（这个可能会导致程序开发人员和编辑的苦恼，管他呢，反正你是管理员）
2．安装顺序的选择：不要觉得：顺序有什么重要？只要安装好了，怎么装都可以的。错！win2000在安装中有几个顺序是一定要注意的： 首先，何时接入网络：Win2000在安装时有一个漏洞，在你输入Administrator密码后，系统就建立了ADMIN$的共享，但是并没有用你刚刚输入的密码来保护它，这种情况一直持续到你再次启动后，在此期间，任何人都可以通过ADMIN$进入你的机器；同时，只要安装一完成，各种服务就会自动运行，而这时的服务器是满身漏洞，非常容易进入的，因此，在完全安装并配置好win2000 SERVER之前，一定不要把主机接入网络。其次，补丁的安装：补丁的安装应该在所有应用程序安装完之后，因为补丁程序往往要替换/修改某些系统文件，如果先安装补丁再安装应用程序有可能导致补丁不能起到应有的效果，例如：IIS的HotFix就要求每次更改IIS的配置都需要安装（变不变态？）

三、 安全配置WIN2000 SERVER:
即使正确的安装了WIN2000 SERVER，系统还是有很多的漏洞，还需要进一步进行细致地配置。
1．端口：端口是计算机和外部网络相连的逻辑接口，也是计算机的第一道屏障，端口配置正确与否直接影响到主机的安全，一般来说，仅打开你需要使用的端口会比较安全，配置的方法是在网卡属性-TCP/IP-高级-选项-TCP/IP筛选中启用TCP/IP筛选，不过对于win2000的端口过滤来说，有一个不好的特性：只能规定开哪些端口，不能规定关闭哪些端口，这样对于需要开大量端口的用户就比较痛苦。

2．IIS：IIS是微软的组件中漏洞最多的一个，平均两三个月就要出一个漏洞，而微软的IIS默认安装又实在不敢恭维，所以IIS的配置是我们的重点，现在大家跟着我一起来： 首先，把C盘那个什么Inetpub目录彻底删掉，在D盘建一个Inetpub（要是你不放心用默认目录名也可以改一个名字，但是自己要记得）在IIS管理器中将主目录指向D:\Inetpub； 其次，那个IIS安装时默认的什么scripts等虚拟目录一概删除（罪恶之源呀，忘了 [image] http://www.target.com/scripts/..%c1%1c../winnt/system32/cmd.exe了？我们虽然已经把Inetpub从系统盘挪出来了，但是还是小心为上），如果你需要什么权限的目录可以自己慢慢建，需要什么权限开什么。（特别注意写权限和执行程序的权限，没有绝对的必要千万不要给）

3: 应用程序配置：在IIS管理器中删除必须之外的任何无用映射，必须指的是ASP, ASA和其他你确实需要用到的文件类型，例如你用到stml等（使用server side include），实际上90%的主机有了上面两个映射就够了，其余的映射几乎每个都有一个凄惨的故事：htw, htr, idq, ida……想知道这些故事？去查以前的漏洞列表吧。什么？找不到在哪里删？在IIS管理器中右击主机->属性->WWW服务 编辑->主目录 配置->应用程序映射，然后就开始一个个删吧（里面没有全选的，嘿嘿）。接着在刚刚那个窗口的应用程序调试书签内将脚本错误消息改为发送文本（除非你想ASP出错的时候用户知道你的程序/网络/数据库结构）错误文本写什么？随便你喜欢，自己看着办。点击确定退出时别忘了让虚拟站点继承你设定的属性。为了对付日益增多的cgi漏洞扫描器，还有一个小技巧可以参考，在IIS中将HTTP404 Object Not Found出错页面通过URL重定向到一个定制HTM文件，可以让目前绝大多数CGI漏洞扫描器失灵。其实原因很简单，大多数CGI扫描器在编写时为了方便，都是通过查看返回页面的HTTP代码来判断漏洞是否存在的，例如，著名的IDQ漏洞一般都是通过取1.idq来检验，如果返回HTTP200，就认为是有这个漏洞，反之如果返回HTTP404就认为没有，如果你通过URL将HTTP404出错信息重定向到HTTP404.htm文件，那么所有的扫描无论存不存在漏洞都会返回HTTP200，90%的CGI扫描器会认为你什么漏洞都有，结果反而掩盖了你真正的漏洞，让入侵者茫然无处下手（武侠小说中常说全身漏洞反而无懈可击，难道说的就是这个境界？）不过从个人角度来说，我还是认为扎扎实实做好安全设置比这样的小技巧重要的多。最后，为了保险起见，你可以使用IIS的备份功能，将刚刚的设定全部备份下来，这样就可以随时恢复IIS的安全配置。还有，如果你怕IIS负荷过高导致服务器满负荷死机，也可以在性能中打开CPU限制，例如将IIS的最大CPU使用率限制在70%。

4．账号安全： Win2000的账号安全是另一个重点，首先，Win2000的默认安装允许任何用户通过空用户得到系统所有账号/共享列表，这个本来是为了方便局域网用户共享文件的，但是一个远程用户也可以得到你的用户列表并使用暴力法破解用户密码。很多朋友都知道可以通过更改注册表Local_Machine\System\CurrentControlSet\Control\LSA-RestrictAnonymous = 1来禁止139空连接，实际上win2000的本地安全策略（如果是域服务器就是在域服务器安全和域安全策略中）就有这样的选项RestrictAnonymous（匿名连接的额外限制），这个选项有三个值：
0：None. Rely on default permissions（无，取决于默认的权限）
1：Do not allow enumeration of SAM accounts and shares（不允许枚举SAM帐号和共享）
2：No access without explicit anonymous permissions（没有显式匿名权限就不允许访问）
0这个值是系统默认的，什么限制都没有，远程用户可以知道你机器上所有的账号、组信息、共享目录、网络传输列表(NetServerTransportEnum等等，对服务器来说这样的设置非常危险。
1这个值是只允许非NULL用户存取SAM账号信息和共享信息。
2这个值是在win2000中才支持的，需要注意的是，如果你一旦使用了这个值，你的共享估计就全部完蛋了，所以我推荐你还是设为1比较好。 好了，入侵者现在没有办法拿到我们的用户列表，我们的账户安全了……慢着，至少还有一个账户是可以跑密码的，这就是系统内建的administrator，怎么办？我改改改，在计算机管理->用户账号中右击administrator然后改名，改成什么随便你，只要能记得就行了。不对不对，我都已经改了用户名了，怎么还是有人跑我管理员的密码？幸好我的密码够长，但是这也不是办法呀？嗯，那肯定是在本地或者Terminal Service的登录界面看到的，好吧，我们再来把HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\winlogon项中的Don’t Display Last User Name串数据改成1，这样系统不会自动显示上次的登录用户名。将服务器注册表HKEY_LOCAL_ MACHINE\SOFTWARE\Microsoft\ WindowsNT\CurrentVersion\Winlogon项中的Don‘t Display Last User Name串数据修改为1，隐藏上次登陆控制台的用户名。（哇，世界清静了）

5．安全日志：我遇到过这样的情况，一台主机被别人入侵了，系统管理员请我去追查凶手，我登录进去一看：安全日志是空的，倒，请记住：Win2000的默认安装是不开任何安全审核的！那么请你到本地安全策略->审核策略中打开相应的审核，推荐的审核是：
账户管理 成功 失败
登录事件 成功 失败
对象访问 失败
策略更改 成功 失败
特权使用 失败
系统事件 成功 失败
目录服务访问 失败
账户登录事件 成功 失败
审核项目少的缺点是万一你想看发现没有记录那就一点都没辙；审核项目太多不仅会占用系统资源而且会导致你根本没空去看，这样就失去了审核的意义。

与之相关的是：
在账户策略->密码策略中设定：
密码复杂性要求 启用
密码长度最小值 6位
强制密码历史 5次
最长存留期 30天
在账户策略->账户锁定策略中设定：
账户锁定 3次错误登录
锁定时间 20分钟
复位锁定计数 20分钟

同样，Terminal Service的安全日志默认也是不开的，我们可以在Terminal Service Configration（远程服务配置）-权限-高级中配置安全审核，一般来说只要记录登录、注销事件就可以了。
6.目录和文件权限： 为了控制好服务器上用户的权限，同时也为了预防以后可能的入侵和溢出，我们还必须非常小心地设置目录和文件的访问权限，NT的访问权限分为：读取、写入、读取及执行、修改、列目录、完全控制。在默认的情况下，大多数的文件夹对所有用户（Everyone这个组）是完全敞开的（Full Control），你需要根据应用的需要进行权限重设。
在进行权限控制时，请记住以下几个原则：
1>限是累计的：如果一个用户同时属于两个组，那么他就有了这两个组所允许的所有权限；
2>拒绝的权限要比允许的权限高（拒绝策略会先执行）如果一个用户属于一个被拒绝访问某个资源的组，那么不管其他的权限设置给他开放了多少权限，他也一定不能访问这个资源。所以请非常小心地使用拒绝，任何一个不当的拒绝都有可能造成系统无法正常运行；
3>文件权限比文件夹权限高（这个不用解释了吧？）
4>利用用户组来进行权限控制是一个成熟的系统管理员必须具有的优良习惯之一；
5>仅给用户真正需要的权限，权限的最小化原则是安全的重要保障；

7:预防DoS：
在注册表HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters中更改以下值可以帮助你防御一定强度的DoS攻击
SynAttackProtect REG_DWORD 2
EnablePMTUDiscovery REG_DWORD 0
NoNameReleaseOnDemand REG_DWORD 1
EnableDeadGWDetect REG_DWORD 0
KeepAliveTime REG_DWORD 300,000
PerformRouterDiscovery REG_DWORD 0
EnableICMPRedirects REG_DWORD 0

ICMP攻击：ICMP的风暴攻击和碎片攻击也是NT主机比较头疼的攻击方法，其实应付的方法也很简单，win2000自带一个Routing & Remote Access工具，这个工具初具路由器的雏形（微软真是的，什么都要做？听说最近又要做防火墙了）在这个工具中，我们可以轻易的定义输入输出包过滤器，例如，设定输入ICMP代码255丢弃就表示丢弃所有的外来ICMP报文（让你炸？我丢、丢、丢）

四、需要注意的一些事：
实际上，安全和应用在很多时候是矛盾的，因此，你需要在其中找到平衡点，毕竟服务器是给用户用而不是做OPEN HACK的，如果安全原则妨碍了系统应用，那么这个安全原则也不是一个好的原则。网络安全是一项系统工程，它不仅有空间的跨度，还有时间的跨度。很多朋友（包括部分系统管理员）认为进行了安全配置的主机就是安全的，其实这其中有个误区：我们只能说一台主机在一定的情况一定的时间上是安全的，随着网络结构的变化、新的漏洞的发现，管理员/用户的操作，主机的安全状况是随时随地变化着的，只有让安全意识和安全制度贯穿整个过程才能做到真正的安全。


关于WIN2000默认共享的问题
当装了网卡后，WIN2000对硬盘的各个分区进行默认隐蔽共享，存在暴露数据的危险。可以通过把共享彻底删除：在HKEY＿LOCAL＿MACHINE\SYSTEM\CURRENT CONTROLSET\SEVICES\LANMANSERVER\PARAMETERS下新建一双字节值，名为AUTOSHAREWKS（如果是SERVER或者是高级SERVER版就是AUTOSHARESERVER），取其值为0就可以了。

回复： 是新建一双字节值，就是新建一个键。(34字) － 谷风，2002年10月30日
回复： 哦,我没有找到那个键,!我装了网卡,只是为了上宽带(46字) － 无尘，2002年10月29日
回复： 把协议除"INTERNET 协议(TCP/IP)"之外的协议与服务都删除吧,再右键点硬盘,没有了共享选项.(85字) － 无尘，2002年10月29日


foxmail如何设置代理

qing :foxmail如何设置代理
不设置代理， 登录时会出现“网络忙。。。” 之类的提示。 但是我用代理去邮箱没问题。
后来我设置了foxmail中的系统中的代理， 可是仍然不好使，
出现的问题有： 设置了代理也经常上不邮箱。

回复： foxmail 不需要在scokscap里打开(30字) － jzx，2002年10月30日
回复： 谢谢jzx,谢谢jzx,我按照您说的,修改了。很好用，速度很快。
我想问是不是只要我的ssso可以用，foxmail就能用？(103字) － qing，2002年10月31日
回复： 是的，foxmail不需随ssso变更..(120字) － jzx，2002年10月31日
回复： 如果ssso用不了怎么办？是不是foxmail也要按照ssso的设置变更？我自己判断不用。对吗？(69字) － qing，2002年10月31日
回复： 跳板或者ssso 加foxmail ,将foxmail代理设置为socks5，..(66字) － jzx，2002年10月30日
回复： 引用jzx在2002-10-30 15:43:17的发言：
谢谢您的帮助！ 就您的回答我还有问题不懂：

（跳板或者ssso 加foxmail） 怎么个加法？
我通过cgi获得了ssso的2.7版， 安装了， 现在用的就是ssso。
foxmail我也有， 跳板我也有， 是傻瓜跳板。 您能详细说一下怎么加吗？

（,将foxmail代理设置为socks5，127.0.0.1：1913）

是直接设吗？ 是否需要调整各个软件的安装目录呢？

另外用ssso 是安全吗？ 使用中还需要注意些什么？(457字) － qing，2002年10月30日

回复： 设置foxmail代理后，要把foxmail的系统默认时间调大，否则会显示系统超时;直接在foxmail的“选项“里设置-系统设置-代理-邮件代理服务器设置为socks5代理(68字) － jzx，2002年10月30日
回复： 直接在foxmail的“选项“里设置-系统设置-代理-邮件代理服务器设置为socks5代理..(76字) － jzx，2002年10月30日


电子邮箱篇

电子邮箱 篇--作者：小铭
http://www.cnhack.org
小铭：电子邮箱是大家使用最多的东西。那么，它的安全性又如何呢？我们一起来探讨！
E-mail，也就是“电子邮箱”。它是网络联系的一个重要工具。
许多大公司大企业都需要电子邮箱来传送文件。其中，机密的文件就有很多。虽然，我们今天不是讨论怎样盗取这些机密文件。但我希望大家知道，一个脆弱的密码，它的危害性是多么的大！

破解邮箱密码最好、最常用的就是“穷举破解”。意思就是，不断地尝试密码，直到试出一个正确的密码。
当然，除了这个办法外，还有很多很多的办法。
例如：利用“忘记密码”的功能，刺探密码。
这方面的程序就有 —— 嗍雪
它也属于“穷举破解”，只不过方法不一样。它破解的不是密码，而是生日。
还有：利用服务器漏洞。
有人会问：这么大型的网站怎么可能有漏洞呢？
世上没有一台主机是绝对安全的。邮件服务器也一样。
最近，微软属下的hotmail网站发现严重漏洞。此漏洞允许你浏览其他用户的E-mail

只需三个步骤，你可以浏览其他用户的E-mail：
1、用你的普通ID（或者其他人的ID）登陆hotmail。

2、使用下面的链接以得到其他指定用户的特殊信息。
http://pv2fd.pav2.hotmail.msn.com/cgi-bin/saferd?_lang=EN&hm___tg=http%3a%2f%2f64%2e4%2e36%2e250%2fcgi%2dbin%2fgetmsg&hm___qs=%26msg%3dMSG998047250%2e22%26start%3d9702%26len%3d9687%26raw%3d0%26disk%3d64%2e4%2e36%2e68_d1577%26login%3dusername%26domain%3dhotmail%2ecom&hm___fl=attrd&domain=hotmail.com
或者：http://lw14fd.law14.hotmail.msn.com/cgi-bin/saferd?_lang=EN&hm___tg=http%3a%2f%2f64%2e4%2e36%2e250%2fcgi%2dbin%2fgetmsg&hm___qs=%26msg%3dMSG998047250%2e22%26start%3d9702%26len%3d9687%26raw%3d0%26disk%3d64%2e4%2e36%2e68_d1577%26login%3dusername%26domain%3dhotmail%2ecom&hm___fl=attrd&domain=hotmail.com
其中：
MSG943322803%2e16 （信笺内容的编号,，它仅仅是编号作用. %2e=.）
username　　　　　（你想浏览hotmail用户的ID）
（如果你不想浏览所有的正常email，而只是浏览邮件信箱,
那么从上面的链接移去:"%26raw%3d0".）
（如果你不想让hotmail的广告或者信息出现在frame的上面,请移去:"&hm___fl=attrd&domain=hotmail.com".）
3、完成。
如果你输入了正确的用户名以及信笺编号,那么你就可以直接浏览了。：）
（请使用自己的hotmail信箱进行测试。）
hotmail已经得到通报并修正了该问题！
从此可以说明，再好的服务器也存在漏洞。
不过，今天我们只谈“POP3 穷举破解”。
“穷举破解”就是一个一个不断地试。如果一个3位数的纯数字密码，不用几分钟就可以破解出来。但，如果换一个15位的符号加数字的密码，可能要80年！
所以，“POP3 穷举破解”对于一些“笨蛋”用户是很有用的。

本次范例需要的系统及程序情况如下：
操作系统：Windows98
程序（一）：黑雨 —— POP3邮箱密码探测器
本机IP：127.0.0.1
POP3服务器IP：127.0.0.7
POP3用户名：test
新程序说明：
“黑雨 —— POP3邮箱密码探测器”是由黑客力量成员廖长科制作的。
主要功能概述：验证用户名和密码是否正确。
独创 —— 深度算法：这是一种很特殊的算法，如果你位数猜得准，就可以将时间缩短30%-70%。
独创 —— 广度算法：此算法CPU占用比上面的兄弟多2%，速度快一点点点儿，但它是一种老实的算法，现大多数类似功能的程序都采用它，其对短小密码（3位以下）非常强！
独创 —— 多线程深度算法：如果你是K7、P3一类的强列推荐，它理论上可以提高速度700%以上！！
此软件特色：
简单、易用
功能强大
独创多项算法
首先，我们打开“bkrain.exe”。
设置：
“Pop3地址”： 127.0.0.7（例如www.163.net的pop3为：pop.163.net。）
“Pop3端口”：110
“Pop3用户名”：test
“密码位数”：5
接着，我们可以选择猜测的密码类型：
“选择字符集：”
这里可以选择密码的字符类型。例如，要猜测数字，就选择数字。
“自定字符集：”
如果，上面的字符类型都满足不了你。你可以在这里定义。
“字典文件：”
这里可以选择密码字典。
设置完毕后，我们就可以点击“深度算法”、“广度算法”或“多线程深度算法”开始猜测了。
如何防御POP3穷举破解？
方法很简单：
1、设置一个8位以上，字符加数字加标点的密码。
2、不要用单词作为密码。
3、经常更改密码。


关于SMTP服务器（转自轻舟）

关于SMTP服务器
大家知道，发邮件必须通过SMTP服务器，但现在大多数SMTP服务器都要求身份认证，也就是说你必须有该域的一个合法邮箱，并在发信时提供相应的密码，你才能发信。

一个域的SMTP服务器通常不只一个，但大多数提供给用户的那个SMTP服务器是要求身份认证的，该SMTP允许你将邮件发给其它域的用户。实际上所有的域都至少会有一个不需身份认证的SMTP服务器，该服务器只接收发给本域用户的邮件，不接受发给其它域用户的邮件，也就是不允许中转。

也就是说发邮件可以不必通过自己的邮箱，而直接发到目的域的SMTP服务器上，这种发邮件的方式在一些邮件软件中被称为“直邮”。直邮一个优点是快捷，不需要中转的SMTP服务器，另外一个优点就是不需要身份认证。

现在的关键就是如何找到负责某个域的邮件发送的“直邮”服务器。其实该服务器的信息被存放在DNS(域名服务器)中被称为MX(Mail Exchange-邮件交换)的记录中。Windows NT/2000/XP中有一个命令行的工具NSLookup.exe可被用于查找该信息。当然，你也可以使用其它一些网络工具。

我们以新浪网为例，其邮箱类似于xxx@sina.com，域后缀为sina.com 。

1. 开始->运行->NSLookup

出现DOS窗口后，然后出现一个大于号的提示符“>”。

2. set type=mx

这一行语句是指明要查询的是MX记录。

3. sina.com

出现查询结果，其中有一行为：

sina.com MX preference = 20, mail exchanger = sinamx.sina.com.cn

这一行表示负责sina.com的邮件服务器为sinamx.sina.com.cn。

有的域还不止有一个，每个邮件服务器都设置有一个MX preference的值，表示该其优先级，数值越小优先级越高。发给该域的邮件时，应首先试图去找优先级高的邮件服务器，如果该服务器联系不上，再发给优先级较低的邮件服务器。

查询结果中还可能有一条记录显示出邮件服务器的IP地址。

sinamx.sina.com.cn internet address = 202.106.187.150

如果没有这个信息，我们也可以通过Ping sinamx.sina.com.cn命令来查看其IP地址。

4. exit

退出“>”提示符，即退出NSLookup程序。

通过本例，我们就找到了sina.com域的“直邮”服务器为202.106.187.150 。下面是通过该方法查找到的部分常见域的SMTP服务器的信息

域后缀 邮件服务器 优先级 IP地址
-----------------------------------------------------------------
sina.com sinamx.sina.com.cn 20 202.106.187.150
sina.com.cn sinamx.sina.com.cn 10 202.106.187.150
vip.sina.com pop3.vip.sina.com 10 202.108.35.190
263.sina.com smx.263.sina.com 10 202.106.182.142
sohu.com sohumx.sohu.com 10 61.135.132.100
163.net bjmx.163.net 10 202.108.255.203
263.net mx01.263.net 10 211.157.130.151
mx03.263.net 10 211.157.130.153
mx04.263.net 20 211.157.130.154
etang.com mx1.etang.com 10 61.152.250.171
mx2.etang.com 20 61.152.250.199
mx3.etang.com 10 61.152.250.171
elong.com mf2.elong.com 10 202.130.239.153
mf3.elong.com 10 202.130.239.159
mf0.elong.com 10 202.130.239.200
yeah.net mx.yeah.net 10 202.103.36.214
nmx.yeah.net 10 202.108.36.215
371.net mx.371.net 10 202.102.242.177
chinaren.com mx2.chinaren.com 10 61.135.132.233
mx6.chinaren.com 10 61.135.131.219
mx8.chinaren.com 10 61.135.131.3
eyou.com smtp.eyou.com 10 61.136.62.73
163.com m180.163.com 50 202.108.44.180
m207.163.com 50 202.108.44.207
m208.163.com 50 202.108.44.208
m209.163.com 50 202.108.44.209
m210.163.com 50 202.108.44.210
m214.163.com 50 202.108.44.214
m218.163.com 50 202.108.44.218
m229.163.com 50 202.108.44.229
m246.163.com 50 202.108.44.246
m247.163.com 50 202.108.44.247
m155.163.com 50 202.108.44.155
vip.163.com mx.vip.163.com 50 202.106.168.87

实际操作时，可先将手头的邮箱按域分类，一次发送一个域的邮件，设置相应的SMTP服务器。操作可能麻烦一些，但避免了找那种不需身份认证而又能中转邮件的服务器。

其中新浪网的sina.com我已测试过，其它的SMTP服务器希望大家测试一下，将结果在这里公布。

若有错误之处请大家指正。


[原创]ssso中s.exe的修改方法
一、SSL默认端口修改（将默认端口443改为其它任意端口）：将NTService.ini中的第六行的443改为其它值，
你在用客户端时也要把运行ghip.bat后stunnel.conf文件中的第四行的端口改成上面的值。
二、socks5默认端口修改（将默认端口1122改为其它任意端口）：将NTService.ini中的第六行的1122改为
其它值xxx；将az.bat中的第二行1122同样改为xxx。
三、自制证书添加（将自制证书保存在一个地方，不必在每次推出新版本时重新制作证书，而只需
添加至s.exe中即可）
四、服务器端跳板阶联（如果使用者有不只一个跳板，在上传s.exe之前，可以设定下一跳板，增加安全性）：
在az.bat文件中的第二行下插入一行－－msservice -config myserver add ip port y（ip和port为另外一
个跳板的地址和socks5服务端口号）
以上内容我都做过，只是惭愧不会做程序，建议白云做一个修改服务器安装程序s.exe的小程序，可以类似
SSSO－FRIEND的界面，我想这样大家又可以省些事了。


转帖]命令行下安装ccproxy！
论坛刚开不久时，有网友问命令行下安装ccproxy的方法，昨天才在灰色轨迹找到：
首先，要下载CCProxy5.2破解版 [image] http://www.sandflee.net/down/show.asp?id=155。
这是一款国人编的代理服务程序，支持HTTP、SCOK、FTP、Telnet等多种代理，如果你觉得不错，而且有比较好的经济条件，请购买正版。

按照说明安装CCproxy，并把破解文件拷贝到安装目录覆盖原文件。运行CCProxy，点设置，更改各个代理的端口，自动启动和自动隐藏一定要选上。如果你对代理比较了解，可以在高级中设定二级代理、DNS服务器等等。点确定退出。

这时你可以在账号里设定用户名和密码。不设置也没关系。只要你的端口不是8080，别人也不会知道有这个代理的。

现在点退出。你会发现在CCProxy的安装目录下多了一个CCProxy.ini文件。这个文件保存了你刚刚所做的设置。用记事本打开它，添加如下两行：
ALLHIDE=1
AUTOSETUP=1
第一行是使系统左下角的系统栏里不会出现CCProxy的图标。第二行则使CCProxy在第一次运行时会自动安装，是在命令行下安装CCProxy的关键。

现在将CCProxy.exe、CCProxy.ini、CDial.dll、uuid.dll拷贝到肉鸡上的CCProxy目录里（也可以是别的目录，总之这几个文件必须在同一目录中）。你可以把language中的文件也考过去，不过既然是在命令行下安装，也不用看界面，当然用不着管是什么语言的。

现在telnet上肉鸡，运行CCProxy.EXE，快打开IE，试试这个代理吧！


发现我这里不能用跳板的原由

阿蒙：发现我这里不能用跳板的原由
前几天,攀峰说他那里用不了跳板,我试了几次都没成功,今天换了网吧仍不行,每次都是用SCOCKS控制台内置的那个IE浏览器,跳板是清心提供的应没问题.突然想到攀峰那里和我这一样:都有网警110,为了闪开它平时我都是用MYIE浏览的啊,.于是在SNAKE的控制台里放上了MYIE的图标,一点下去,跳板终于开始狂飙了!
希望对各位有启发

回复： http://www.ttian.net 网吧幽灵V2.0，本软件适合被网吧管理软件下使用，可以杀死你想关闭的程式...具体请看说明。感谢作者19821119提供下载。经测试时发现软件会打开本地一随机端口，经联系作者回复会连www.gwgirl.org.(211字) － qfl861，2002年10月27日
回复： 用柳页肯定能发现那些怪异的东西(30字) － 阿蒙，2002年10月26日
回复： 除了110以外还有很多类似的软件，例如“火眼金睛”什么的(53字) － 乐助，2002年10月26日
回复： 我这里机器上没有啊可是也上不了，不是110的原因(47字) － 攀峰，2002年10月26日
回复： 按热起动键，会显示内存里有NETGUARD这项，有时还不显现就用柳页擦眼肯定现原形，..(76字) － 阿蒙，2002年10月26日
回复： 可是我这里的机器上好象没有装110啊怎么才能知道有没有??为什么myie可以而ie 就不行.(82字) － 攀峰，2002年10月26日
回复： 厉害啊，阿蒙(12字) － 攀峰，2002年10月26日


请教关于ssso3.6的证书问题

请教关于ssso3.6的证书问题。[求助]
请问创建证书后，是如何对证书进行验证的？ssso3.6的客户端和服务端安装工具是分开的，而证书的创建是在服务端安装工具目录下完成的,和客户端不在一个目录下，那么证书是如何验证的呢？

白云: 证书是给服务器加密用的，如果你不制作服务器就不用制作证书。服务器谁都可以用，就像SSL网站谁都可以浏览一样。


清心论坛--计算机安全相关技术浏览：请问ssso代理是否可以当作普通的socks5代理使用呢？

主题： 请问ssso代理是否可以当作普通的socks5代理使用呢？
攀峰
请问ssso代理是否可以当作普通的socks5代理使用呢？谢谢，
乐助
可以，不过功能不全
攀峰

请乐助，说说都缺少什么功能，好么？
还有要是我想把ssso的代理直接填写在sockscap中使用，端口应该怎么填？
谷风
其实就是1122，ssso一直没有改过这个端口。
乐助

具体少了哪些功能我也不太清楚。谷风 说的对
阳光
清心公布的代理，端口不一定都是1122
乐助

如果不确定可以扫描一下


让你的ssso更快、更安全、更稳定

等级：版主
文章：24
积分：62
让你的ssso更快、更安全、更稳定
现在的ssso3.0较以前已经改进了许多，但每个人还有进一步修改的余地，使之更好些。
    Ssso是由三部分组成：加密部分、socks5代理部分和安装部分。加密部分包括：stunnel-3.22.exe、stunnel.pem、libeay32.dll、libssl32.dll；socks部分是snake的代理跳板sss.exe；安装部分是其它的文件。下面我们一个一个来。
    加密部分：这里有两个地方可改，就是stunnel-3.22.exe可改名，还有就是ssl的端口可改，不要小瞧这个，在肉鸡上安装时是很有用的，但相应用到的地方也得跟着改。
    Socks5代理部分：snake的跳板是很好，但主要的级连、协议转换和加密功能在ssso中用不上，只用上一个socks5功能。而且虽然新版本在传输的稳定性上有了很大改进，但还是不能尽人意，这里我用ccproxy代替它，它本是商业软件，需要在windows图形界面上安装，但经过改装之后，可在命令行下安装。具体使用方法，在自带的说明文件中很详细。共需4个文件ccproxy.exe（可改名）、ccproxy.ini、cdial.dll、uuid.dll。
    安装部分：新版用的是ntservice。这个无需替换了，只简单说明一下：这个软件是自己以服务方式安装，然后运行其配置文件中的程序，最多可带动20个程序，而且支持带运行参数的程序，但有一点要注意，就是要带动的程序必须在system32目录里。共有两个文件ntservice.exe和ntservice.ini，这两个文件都可以改名（但必须要一致），而且可以自定义服务名称。具体使用方法可看自带的说明。
    这个改装后ssso相对也安全一些，因为文件名可以自定义，服务名可以自定义，端口可以自定义，而且ccproxy要比snake跳板稳定，如果愿意的话还可以同时作其他的代理。
    好了，现在可以动手了，把上面10个文件复制到一个文件夹，然后加上hiderun.exe和一个123.bat，仿照ssso的安装也做一个自解压文件，把命令都写在123.bat里。OK，到肉鸡上试一下吧，看看这个ssso是否更快了。
    （注意，本文提到的ccproxy是破解版才行）

本不想写这个东西，因为对新手来说论述的过于简单，对高手来说又没什么可看的，只希望通过本文能抛砖引玉，使ssso这个新型的破网工具更完善，更成熟。

回复： 我现在用的是2.4版的，会有什么安全问题吗？(41字) － yunsky，2002年10月28日
回复： 7楼老大：请问命令行下如何使用CCPROXY？(38字) － jb2002，2002年10月27日
回复： CCProxy可惜体积太大了，我本来也想用它的。(41字) － 白云，2002年10月27日
回复： http://24.165.21.10/articles/ssso/index.htm 有详细说明及软件下载。.(164字) － 同心，2002年10月26日
回复： 我用的就是灰色轨迹的，呵呵。(28字) － asd，2002年10月25日
回复： 补充一下，有的肉鸡ntservice会安装失败，这时可用srvany来替代。..(61字) － 沧海一粟，2002年10月25日
回复： 灰色轨迹的CCProxy v5.2 破解版是否合适？(39字) － qfl861，2002年10月25日


在win98下如何使用ssso？？
我下了ssso3。6但是不好用呀！所有的网站都上不去；用ssso2。7，我的kv3000说是有病毒？？！！

答：什么病毒都没有，误报。换诺顿吧！国内的杀毒软件把snake跳板当病毒杀.
请看此版主题为精华帖电子书打包下载＋必备软件及注册码里面的“ssso-jap-msn"使用教程的贴
打开“开始-程序-ssso-proxy设置"菜单
用61.222.74.194:443
代替掉proxy设置文件中的255.255.255.255：443
然后存盘。
详情看下载的ssso解压后其中的使用说明，
深入了解请看教程。


在无盘网吧使用Ssso3.6
无盘网吧做了很多的限制，权限很低。平时大家可能除了动态网,其它工具都不能使用,这里教大家用最傻瓜的方法使用ssso3.6(因为网吧基本上使用的都是windows98)
一)得到下载的权限:
访问 [image] http://cy07.126.com 点击下方"解除对文件下载的限制".成功后会有提示.
二)下载ssso3.6和myie
这两个软件可以备份到自己得邮箱里,每次下载就不必到处找了.因网吧的限制, ssso默认得ie无法工作,所以必须下载一个浏览器.
点击下载连接后会出现一个对话匡,选者"在当前位置运行该程序",下载完毕后会弹出对话匡,把文件解压到本地硬盘,比如 c:\ssso3.6 .
三)安装ssso3.6
安装后在'开始'-'程序'里是无法找到快捷键的,必须在c盘找到 Ssso 文件夹.
找到 ssso.bat 和 ghip.bat 两个文件,分别运行.
四)在sockscap里添加myie,在记事本(stunnel.conf)把ssso代理更换255.255.255.255后保存.
五)使用myie冲浪.

注:如果网吧没有c盘的话可能就无法安装ssso了.
请各位高手补充


转帖某网站对ssso原理的理解和扩展应用[转帖]
对SSSO原理的初步解析

（一）ssso是openssl＋stunnel＋socks5构架，第一个是提供ssl加密，第三个是以socks5方式联网，stunnel是把两个连起来，使socks5变成ssl。同理，还有openssl＋stunnel＋http构架，openssl＋stunnel＋socks4构架，等等，这些构架都是使用了“端口映射”的概念。“映射”是什么意思呢？举个例子说，在网络上，可以通过IPC命令把远端机器的c盘映射成本机的z盘，例如，我有两个机器，IP地址分别是127.0.0.1和192.168.0.1，分别位于北京和广州。我在127.0.0.1，想把我的d盘上一个文件复制到192.168.0.1的c盘上，可以通过网络连接到192.168.0.1，然后通过ipc命令把192.168.0.1地c盘映射到127.0.0.1的z盘，这时，127.0.0.1的资源管理器就会多出一个z盘，我可以把这个z盘当成自己本机上的一个硬盘对待，复制、粘贴、剪切等等。这个z盘实际上是192.168.0.1的c盘，但我通过“映射”把它变为127.0.0.1上的z盘，罗嗦了这么多就是让大家对“映射”有个概念。上面说的是“磁盘映射”，其实“端口映射”也是一个道理，就是把远端的一个端口变成本机的一个端口。

好了，现在先从ssso说起：假如我的IP是127.0.0.1，然后在网络的另一端有一个192.168.0.1，网管恰好是我的朋友，已知192.168.0.1已经安装一个snake跳板，端口是1122。现在我想用socks5代理上msn，就想：如果这个192.168.0.1的1122变成我的1913端口就好了，那就可以用它来上msn了。这时就需要openssl和stunnel了，现在那个朋友动手了，运行stunnel，把自己（192.168.0.1）的1122端口映射成自己的（192.168.0.1）443端口（就是本机两个端口之间映射），OK他那里完事了。然后我这里动手，我也运行一个stunnel，把192.168.0.1的443端口映射到我（127.0.0.1）的1913端口,好了，现在我的1913端口就有一个socks5代理了。现在，运行msn，打开代理设置，选socks5代理，填入127.0.0.1：1913，然后开始登陆，信息流向是这样的：msn→127.0.0.1：1913→192.168.0.1：443→192.168.0.1：1122→微软msn服务器，OK，登陆成功，可以和好友聊天了。

如果我想用socks5代理浏览怎么办呢？直接是无法用的，因为IE不支持socks5代理，在1913端口空有一个socks5代理，但IE用不上。这时就需要sockscap了，通过它，象IE这类不能使用socks5代理的软件也可以使用socks5代理了。因为192.168.0.1的socks5代理已经映射过来了，所以sockscap中的socks5代理服务器就是127.0.0.1：1913。

（二）

其实端口映射软件有很多，不必这么麻烦的，把192.168.0.1：1122直接就可以映射到本机（127.0.0.1）的1913端口，而上面的方法多了一道手续，映射了两次。为什么？安全、安全第一啊！这样做从本机（127.0.0.1）的1913到远端（192.168.0.1）之间是有一个ssl通道的，而其他软件只是简单的映射，中间没有加密。
好了，看到这里大家也许明白了，stunnel＋openssl主要起了一个ssl加密通道的作用，而以那种代理方式上网是取决于远端是何种代理，如果远端是http代理，那么映射过来就是一个http代理，这时，msn就应该选http代理，而IE直接就可在“属性”里设置代理了。那ssso为什么选择socks5代理呢，因为socks5代理功能比较多，而且通过sockscap还可以实现远端解析，用来突破网络封锁十分有效。
还有一个没什么用的小技巧顺便说一下，就是本机可以同时运行多个ssso客户端。比如我有两个ssso服务器：10.10.0.1和10.10.0.2，我想通过10.10.0.1上网浏览，通过10.10.0.2上msn，可以这么做，先到轻舟网下载一个shp，只需要其中的stunnel的exe部分，以3.22为例：把3.22的文件夹在c盘复制一个，在d盘复制一个，打开c盘的stunnel文件夹，编辑client_run.bat，把里面的127.0.0.1:80改为127.0.0.1:4444，192.168.0.1:443改为10.10.0.1:443，保存退出，然后运行client_run.bat，打开sockscap，把代理改为127.0.0.1：4444，然后运行sockcap中的浏览器，就可以自由冲浪了；在打开d盘的stunnel文件夹，编辑client_run.bat，把里面的127.0.0.1:80改为127.0.0.1:5555，192.168.0.1:443改为10.10.0.2:443，保存退出，然后运行client_run.bat，打开msn，代理设置为127.0.0.1:5555，然后登陆，就可以和好友惬意地聊天了。上面也是说出了如何改本机ssso端口的方法。

（三）

下面在说一下代理，现在ssso采用的socks5代理是snake的代理跳板，snake的代理跳板虽然还不是很完善，但能替代它的socks5代理还没有出现，它的两个小功能可能大多数人没有注意到，就是server端的串连功能和客户端设置功能。原先大家在使用傻瓜跳板时，是在skservergui中设置经过的跳板，其实skserver也能设置串连的跳板，比如有两台服务器分别是172.168.0.1和172.168.0.2，都在1234端口装有跳板，如果想先经过172.168.0.1，然后连到172.168.0.2，可以这样做：在172.168.0.1上，在命令行下进入跳板所在文件夹，“net stop skserver”（停止跳板的服务）、“sss -config skserver add 172.168.0.2 1234 y”（设置下一个连接的跳板）、“net start skserver”（启动跳板），这时，当你连接172.168.0.1时，它会自动串连172.168.0.2，如果要删除串连的跳板，可以“sss -config skserver del 172.168.0.2 1234”，会提示“The unit is deleted.”；如果172.168.0.2上的跳板只允许172.168.0.1这一个IP连接，可以这样做：在命令行下进入跳板所在文件夹，“net stop skserver”（停止跳板的服务）、“sss -config client add 172.168.0.1 255.255.255.0 y”（设置允许连接的客户端）、“net start skserver”（启动跳板），也可以多允许几个，删除是“sss -config client del 172.168.0.1 255.255.255.0”。这两项设置在某些情况下还是比较有用的，比如在用ssso时想进一步隐藏身份，可以设置跳板的串连，在172.168.0.1上安装ssso，在172.168.0.2上安装snake跳板，这样，对外显示的是172.168.0.2，增强了反跟踪的能力，此时，本机到172.168.0.1是ssl加密，172.168.0.1到172.168.0.2是跳板加密；如果有的人想利用自己的条件向朋友提供跳板服务，却不想被别人占便宜，可以指定特定的IP连接。这两种方法也可结合使用。
如果有的朋友想方便别人，在自己机器上装SSSO服务，可以直接运行ssso2.4版中的s.exe就完成了，它会安装在系统盘中，这个文件是隐藏运行，运行时看不出任何变化，不要以为没有安装而反复运行，里面已经有跳板了，不用先装跳板，安装过程一般一分钟之内就能完成。如果安装之后想看看ssso是否已经启动了，可以这样：先查看跳板是否启动，在“服务”中查看Snake SockProxy Service是否已经启动，也可在命令行下键入net start，看看有没有Snake SockProxy Service；然后在命令行下键入netstat –an,看看有没有443端口，如果都有那基本上可以确定ssso已经在运行中了。如果还不好使可以查看一下是否是防火墙的原因，如是否封锁了1122或443端口，禁止了sss或stunnel连网。为了安全起见，最好改一下跳板的服务端口，因为使用默认的设置有一定的安全隐患，可以这样做：“net stop skserver”（停止跳板的服务）、“sss -config port 12345” （更改端口为12345）、“net start skserver”（启动跳板），也可以改成其它端口，端口号大一些比较好，不要选1024以下的端口。然后到system32目录下，编辑yx.bat，把1122改成12345，重新启动计算机即可。

好了，我对ssso的理解就这些了，个人理解，难免有误，欢迎大家进一步探讨。
（转帖自某网站）


QQ 篇
小铭：“QQ”是中国发展最迅速的即时聊天软件，用户人数已经达到7000万。所谓“树大招风”，用户多，也就代表黑客软件的数量也多：）

腾信QQ，原名OICQ（因版权问题，在2001年正式改名。）。是腾信公司开发的中文网络寻呼系统。作为一种即时通信工具，QQ支持显示朋友在线、寻呼、聊天、即时传送文字、语音和文件等功能。因为，软件开发时间早、功能完善、使用方便、支持中文显示等，引来一大群用户。使用人数直追“ICQ”的使用人数。
一个软件和一台主机一样都存在漏洞。
在黑客程序方面，针对QQ的，可谓“丰富多彩”！
有针对QQ的聊天（刷屏机），有针对QQ的密码（破解程序），有针对QQ的即时信息（炸弹程序），有针对QQ用户的IP（查询IP的补丁），还有专门针对QQ的用户密码而制作的“QQ木马”！
今天，我就向大家介绍两个程序：
（一）魔亦神QQ 0710显示IP补丁完美版
（二）QQ聊天机器人 V2.1
本次范例需要的系统及程序情况如下：
操作系统：Windows98
程序（一）：QQ聊天机器人 V2.1
本机IP：127.0.0.1
新程序说明：QQ聊天机器人 V2.1
作者：佳园
程序主要功能概述：
一：动态循环发送方式：
1：如果使用OICQ聊天，请选择QQ模式；如果在聊天室或‘QQ二人世界’聊天请选择聊天室模式。
2：点击‘发送’按钮后用鼠标点击一下QQ或聊天室发言框即可循环发送语句。
3：为了避免在切换窗口时造成发送混乱，建议选择锁定窗口发送（将鼠标在聊天窗口点击一下，然后按下ctrl+F8即可获得窗口标题）。
4：可以根据情况选择发送速度,还可以在功能设置中自定义发送时间间隔。
二：静态单句发送方式：
1：打开所选的QQ聊天窗口，双击列表框中的语句，即可自动发送语句到所选的各类QQ聊天窗口和QQ聊天室。
2：为了使聊天更富情趣，可任意选择数十种句尾表情。
三：自动回复功能
1：填入要自动回复的好友或其他人的QQ号码（最多可填三个）；选择单句回复或循环回复，点击‘启动’按钮启动自动回复功能；
2：在QQ系统参数设置中选择‘自动弹出窗口’。
3：每当有对应的QQ号码发来的消息时，便可自动选择聊天语句发送。
4：如果没有在系统参数设置中选择‘自动弹出窗口’。当发来消息时，点击闪动的头像亦可自动发送。
四：其他功能
1:可以任意编辑语句或导入文本。软件附带有多个组别聊天语句数百条，可以方便地修改或增加聊天语句。
2:可以依据个人习惯进行个性化功能设置。
测试情况：
打开程序后，简单看了看。程序非常稳定，功能多不胜数，简单易用。
（因为功能过多，所以只测试一些主要功能。）
测试（一）：动态循环发送
选择“QQ模式”。
发送速度：中速
锁定窗口发送：空
打开QQ的发送信息的窗口，选择“对话模式”。
接着，按照程序的指示去到等待测试的窗口（发送信息的窗口），按ctrl+F8获得活动窗口标题。
点击“发送”。


清心论坛--计算机安全相关技术浏览：[灌水]安全上网杂谈

* 贴子主题： [灌水]安全上网杂谈
谷风

[灌水]安全上网杂谈
我上网时经常发现有来自北京的扫描，地址是218.11.***.***，我们知道HACKER对3389等端口进行扫描是用来寻找“肉鸡”，这种方法也可能被用来对付使用某些特殊软件的人群。在此提醒使用破网软件的朋友，更改软件的本机默认端口，如JAP的4001端口，跳板类软件的1913、1813、1122、54321端口，一些代理软件的8088、8080、8081、1080端口，SSSO使用的443端口，最好放弃使用高端口而尽量使用80、20等常用端口，在DOS下用netstat –an命令看看本机尚未使用的端口，自己设上就行了。
使用WINDOWS98的朋友注意不要使用共享并安装好防火墙；使用WINDOWS2000的朋友注意升级自己的操作系统，使之保持版本最新，并一定要在设置－－控制面板－－用户和密码中修改默认的ADMINISTRATOR和GUEST口令，口令切不要用与用户名相同、用户名＋数字、123456等简单数字，另外还要在计算机管理－－本地用户和组－－用户中禁用GUEST。IE浏览器的版本也注意及时更新。用WINDOWS2000且使用中文输入法的朋友，可以用WINDOWS优化大师4.9的系统安全优化解决3389漏洞问题。
各种破网软件组合使用时要考虑清楚原理。如SSSO和傻瓜跳板在同FLASHGET、NETANTS等下载软件一起使用时，先启动SSSO或傻瓜跳板，然后在下载软件（以FLASHGET为例）的工具－－选项－－代理服务器中添加SOCK5代理127.0.0.1:＊＊＊＊（注：SOCKSCAP32中设置的端口值），并选中它设为默认使用代理，使用时FLASHGET将从本地端口127.0.0.1:＊＊＊＊通过跳板下载，内容被加密；同理，使用MSN时将其设置成使用SOCK5（127.0.0.1:＊＊＊＊）也可以起到相同的作用。其实在SOCKSCAP中使用的软件如IE也是通过127.0.0.1:＊＊＊＊经跳板获取数据的。但是，跳板加JAP等软件是否能起到相同作用有待初创者说明，JAP和自助冲浪等软件本身就设计了将本地端口和远程端口建立联系的机制，它同跳板类软件结合使用时，这个联系本身应该是没有插入跳板，那么数据是否真的经过了跳板加密呢？以JAP为例，它的数据和请求都是经过127.0.0.1:4001（默认）同海外主机这一通道，而跳板是经过127.0.0.1:1913（默认）同海外跳板主机这一通道，它们两个是如何结合的呢？虽然能用，但这两者之间的机制是否是理顺了呢？
如果是为了解决DNS远端也就是海外解析的问题，可以用搜索引擎搜一下儿，也可以用DNSQ或VisualRoute随便填入个海外网站试试，中间显示的地址就是其经过的路径，其中就有DNS，在本机上填入这些地址试试就有可用的。

----------------------------------------------
沉舟侧畔千帆过，病树前头万木春。

编辑这个贴子 鲜花(0) 鸡蛋(0)
asd

等级：版主
文章：26
积分：61
注册：2002-10-23

我对Jap和跳板的理解是这样的：正常使用时，Jap启动后，在本机4001端口接收数据，然后连接德国的服务器，如果和跳板联合使用时，第一步一样，也是在本机4001监听，然后连接sockscap，然后127.0.0.1:1913，在经过国外跳板，才到达德国的服务器。
谷风
在本机的两个端口之间传输数据是可行的吗？
乐助回复：当然可以啦：）而且很快、很安全


暴露自己IP地址的危险

暴露自己的IP地址是很危险的，道理很简单，暴露了IP地址，也就等价于告诉了敌人要攻击的目标。那么，暴露自己的IP地址究竟有什么危险呢？我们又该如何减少这些危险呢？不要着急，听我慢慢道来。 　　首先谈一下危险。如果你用的是Windows系列操作系统，而又没有打什么补丁的话， 那么暴露了自己的IP地址，你也许就会经常遇到莫名其妙蓝屏的情况，这就可能是被人炸了，目前最经常利用的就是IGMP漏洞，而这方面的工具就要数IPHacker了。被炸的症状就是网络连接被切断，重新启动后恢复，补救的办法就是即使安装相应的补丁。另外，我也遇到过一种叫做ArpTest的小工具， 他可以攻击某个IP地址或某段IP地址，但是只能在局域网中使用。现象是出现对话框，回车后对话框消失。危险就在于这个软件可以设定发送次数和时间间隔，设想时间间隔为0，发送次数为999999999次，你会有什么感觉？另外，如果你在聊天室或IRC聊天时暴露了自己的IP地址，那么麻烦就更大了， 恐怕你就不能好好聊天了。 　　 大家都用过OICQ吧？答案应该是肯定的。目前针对OICQ的工具实在是太多了，如果你暴露了自己的IP地址，现在就有工具查到你这个IP地址的OICQ的号码是什么，进一步的又有远程OICQ密码破解工具，看来你的OICQ号码真的不安全哦！如果你看过我的《BBS2000和BBS3000的安全隐患》和《OICQ脆弱的加密机制》这两篇文章的话，你应该知道暴露自己的IP地址的危险不止于此！目前基于Yuzi的BBS2000和BBS3000的论坛到处都是，想必你一定去过，看过那篇文章的人也一定知道这个论坛的Cookie的漏洞，那么危险就来了，恶意攻击者就可以运用类似社会工程学的方法诱使你访问他的一个网页，而这个网页中内嵌的脚本就可以很容易的从你机器上的Cookie中提取出你在那个论坛的用户名和密码。另外，如果你是NT的用户，并且上OICQ，那么暴露了自己的IP地址，攻击者就很可能利用目前一抓一大把的NT漏洞来获取你的主机上的任意文件， 而破解OICQ的密码应该要比破解SAM密码方便多了。不仅如此，如果你暴露了自己的IP地址，追捕能查到你系统上的很多信息，扫描器能找出你主机上的很多漏洞，而掌握了你的系统漏洞的人，就可以入侵你的主机，进而控制你的机器，还有令人讨厌的监听软件，呵呵。。。是不是很恐怖？！ 　　然后，我谈一下如何减少这些危险。至于系统和软件的安全，应该注意及时更新版本和安装补丁还要经常去一些安全站点转转，及时了解关于你使用的系统和软件的安全动态。另外，还要安装杀毒软件和防火墙。呵呵。。。好象有点跑题了，下面我说说关于IP地址的安全问题。以前有个号称可以隐藏IP地址的软件，结果证明是假的。另外，据我所知，目前还没有什么好办法完全隐藏自己的IP地址。不过，还是有一些办法减少暴露IP地址的危险的。例如，你可以通过设置防火墙策略过滤ICMP协议，那么别人PING你这个IP地址的时候就回返回超时错误，就有可能让人误以为你这个IP不可用，自然就不会攻击你了。还有，合理的使用代理服务器也能相对隐藏你的IP地址，也就减少了被攻击的危险，是不是？(analysist) 注：保护好自己的ip地址，尽量用代理服务器上网


清心论坛--计算机安全相关技术浏览：菜鸟的安全心得

JZX:菜鸟的安全心得
上网的时候，我总是喜欢开至少2个myie，一个不用代理，去浏览yahoo.com,msn.com等一些无关紧要的网站（不看的），一个用代理，去浏览你需要看的网站。现在我一般开3个myie,两个用代理，一个用ssso直接上，另一个用jap+ssso上，因为每次如果都去找ip是很烦人的一件事，特别是用些网站你用ip上去了，下载时其连接又不是ip因此对此类网站还是用jap+ssso方便。下载的工具你只要将127.0.0.1：4001设为默认连接就行了。当然知道ip的还是直接用ssso方便和快。
若你只用一个连接（myie)你所有的数据都是加密的，会让人怀疑的。
感谢畅游,给了我们一个好的myie.
伟大的畅游！无畏的畅游！你的在天之灵定会看着我们将黎明的迎来！

回复： 关于jap请到http://www.chinaproxy.net的论坛去看看，好象11月20日以前国内的留言薄、论坛都被迫关闭了，所以我去了，打不开。.(212字) － root，2002年11月5日
回复： 我按照jzx的提醒做，却发现无法使用普通浏览器了。(108字) － qing，2002年11月5日
回复： 不是拖到里面，而是在sockscap里点击新建。myie分别在sockscap打开和直接打开。..(76字) － jzx，2002年11月5日
回复： 各位老兄好JAP我一直不会用能给一个详细教程吗？ .(137字) － 糊苞米，2002年11月5日
回复： 我也是27岁了... ...(19字) － 东周列国，2002年11月5日
回复： 唉，难怪他的论坛没有更新了，伟大的勇士啊(40字) － ，2002年11月4日
回复： http://anyboard.net/comp/pcsoft/changyouie/index.html，需要加密代理。MyIE3.2帮助菜单中有他论坛的网址。(90字) － QFL861，2002年11月3日
回复： 将jap放在sockscap里打开就行了(29字) － jzx，2002年11月3日
回复： 在天之灵？(10字) － 同心，2002年11月3日
回复： 去他的论坛你就知道了。转贴：畅游不堪忍受非人的折磨，已于02年05月13日17：35永远的离开了我们，时年27岁。更多内容请关注我们的报道！..(132字) － jzx，2002年11月3日
回复： 这个你是怎么用的（另一个用jap+ssso上，因为每次如果都去找ip是很烦人的一件事，特别是用些网站你用ip上去了，下载时其连接又不是ip因此对此类网站还是用jap+ssso方便。下载的工具你只要将127.0.0.1：4001设为默认连接就行了。当然知道ip的还是直接用ssso方便和快。）能详细说说吗？.(267字) － 春意，2002年11月3日


检测是否真正加密访问代理[原创]

blade:检测是否真正加密访问代理[原创]
以前可以访问被封的地址，就已经可以确定这代理是好的，安全的，其实不是这样的。
    现在封网都很有技术，象google，不给访问"网页快照"，你一用代理访问，那代理即死翘一阵子(不知你们那里是否这样？)。代理跳板号称可以加密访问被封地址，但我用代理跳板上goole，访问“网页快照”同样死翘一阵子。
    所以我大胆说，我用的跳板其加密是假的。我用的跳板全是网上找来的，可能存在一定的安全问题。
    其实封网技术是两刃刀，他提供给网民验证代理的真确性,得知代理是否真正的安全。
回复： 跳板现在安全性到底如何?用域名直接访问是不行了!(46字) － root，2002年11月1日
回复： 尽量使用ssso吧，安全性比跳板高多了。如果使用域名不能直接访问，在浏览器中再设置一个国外匿名代理就可以了。 (李文，
回复： 你说的那个现象是因为他们现在有个内容过滤。如果你浏览的网页有过滤的内容，就会被断开连接一段时间。但是加密的内容无法过滤，比如SSL加密或者传输加密的方法（跳板、花园等）。 你的跳板是否设置正确也很有关系，具体的原因就很复杂了。
(223字) － admin，2002年11月1日


木马病毒的通用解法
注：最好的办法就是您先准备好杀毒软件以及最新的病毒库，在刚装完系统后马上安装上，那是最安全的了，当然别忘了定期升级哦！再有不要轻易下载不知名站点的文件，和运行一些有“诱惑”的文件…

由于很多新手对安全问题了解不多，所以并不知道自己的计算机中了“木马”该怎么样清除。虽然现在市面上有很多新版杀毒软件都可以自动清除“木马”，但它们并不能防范新出现的“木马”程序，因此最关键的还是要知道“木马”的工作原理，这样就会很容易发现“木马”。相信你看了这篇文章之后，就会成为一名查杀“木马”的高手了。

    “木马”程序会想尽一切办法隐藏自己，主要途径有：在任务栏中隐藏自己，这是最基本的只要把Form的Visible属性设为False、ShowInTaskBar设为False，程序运行时就不会出现在任务栏中了。在任务管理器中隐形：将程序设为“系统服务”可以很轻松地伪装自己。 当然它也会悄无声息地启动，你当然不会指望用户每次启动后点击“木马”图标来运行服务端，:)，“木马”会在每次用户启动时自动装载服务端，Windows系统启动时自动加载应用程序的方法，“木马”都会用上，如：启动组、win.ini、system.ini、注册表等等都是“木马”藏身的好地方。下面具体谈谈“木马”是怎样自动加载的。

    在win.ini文件中，在[WINDOWS]下面，“run=”和“load=”是可能加载“木马”程序的途径，必须仔细留心它们。一般情况下，它们的等号后面什么都没有，如果发现后面跟有路径与文件名不是你熟悉的启动文件，你的计算机就可能中上“木马”了。当然你也得看清楚，因为好多“木马”，如“AOL Trojan木马”，它把自身伪装成command.exe文件，如果不注意可能不会发现它不是真正的系统启动文件。

    在system.ini文件中，在[BOOT]下面有个“shell=文件名”。正确的文件名应该是“explorer.exe”，如果不是“explorer.exe”，而是“shell= explorer.exe 程序名”，那么后面跟着的那个程序就是“木马”程序，就是说你已经中“木马”了。

    在注册表中的情况最复杂，通过regedit命令打开注册表编辑器，在点击至：“HKEY－LOCAL－MACHINE\Software\Microsoft\Windows\CurrentVersion\Run”目录下，查看键值中有没有自己不熟悉的自动启动文件，扩展名为EXE，这里切记：有的“木马”程序生成的文件很像系统自身文件，想通过伪装蒙混过关，如“Acid Battery v1.0木马”，它将注册表“HKEY－LOCAL－MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run”下的 Explorer 键值改为Explorer=“C:\WINDOWS\expiorer.exe”，“木马”程序与真正的Explorer之间只有“i”与“l”的差别。当然在注册表中还有很多地方都可以隐藏“木马”程序，如：“HKEY－CURRENT－USER\Software\Microsoft\Windows\CurrentVersion\Run”、“HKEY－USERS\＊＊＊＊\Software\Microsoft\Windows\CurrentVersion\Run”的目录下都有可能，最好的办法就是在“HKEY－LOCAL－MACHINE\Software\Microsoft\Windows\CurrentVersion\Run”下找到“木马”程序的文件名，再在整个注册表中搜索即可。

    知道了“木马”的工作原理，查杀“木马”就变得很容易，如果发现有“木马”存在，最安全也是最有效的方法就是马上将计算机与网络断开，防止黑客通过网络对你进行攻击。然后编辑win.ini文件，将[WINDOWS]下面，“run=“木马”程序”或“load=“木马”程序”更改为“run=”和“load=”；编辑system.ini文件，将[BOOT]下面的“shell=‘木马’文件”，更改为：“shell=explorer.exe”；在注册表中，用regedit对注册表进行编辑，先在“HKEY－LOCAL－MACHINE\Software\Microsoft\Windows\CurrentVersion\Run”下找到“木马”程序的文件名，再在整个注册表中搜索并替换掉“木马”程序，有时候还需注意的是：有的“木马”程序并不是直接将“HKEY－LOCAL－MACHINE\Software\Microsoft\Windows\CurrentVersion\Run”下的“木马”键值删除就行了，因为有的“木马”如：BladeRunner“木马”，如果你删除它，“木马”会立即自动加上，你需要的是记下“木马”的名字与目录，然后退回到MS－DOS下，找到此“木马”文件并删除掉。重新启动计算机，然后再到注册表中将所有“木马”文件的键值删除。至此，我们就大功告成了。


如何修复被网站恶意修改的WIN9X系统
现在很多网站为了提高知名度，在网页上加了恶意代码，当你访问到该站时，会使你的系统被恶意修改。
如以前的“万X谷”是最令人深恶的。最近又出现了一些如“天长地久”的站，对WIN系统的修改等，如果你中
招了，请按照下面方法修改。
一、症状
1、对于只要一开机，就出现一个“欢迎访问XXXXX”的对话框。
2、在你的IE标题窗口加上了该站的信息和连接URL等。
3、修改了你的“我的电脑”和“回收站”名字。
二、修改还原
打开注册表，找到以下的键值
"HKCU\\Software\\Classes\\CLSID\\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\\","强加的内容");
"HKCU\\Software\\Microsoft\\Internet Explorer\\Main\\Search Page"," [image] http://XXX.XXX.net";); //此处修改你IE的首页
"HKCU\\Software\\Microsoft\\Internet Explorer\\Main\\Start Page"," [image] http://XXX.XXX.net";); //此处修改你IE的首页
"HKCR\\CLSID\\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\\","强加的内容"); //此处修改“我的电脑”
"HKCR\\CLSID\\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\\InfoTip","强加的内容");
"HKCR\\CLSID\\{645FF040-5081-101B-9F08-00AA002F954E}\\","强加的内容"); //此处修改“回收站”
"HKCR\\CLSID\\{645FF040-5081-101B-9F08-00AA002F954E}\\InfoTip","强加的内容");
"HKLM\\Software\\Microsoft\\Windows\\Currentversion\\Winlogon\\LegalNoticeCaption","强加的内容");
"HKLM\\Software\\Microsoft\\Windows\\Currentversion\\Winlogon\\LegalNoticeText","强加的内容"); //此处修改后出现你启动时的对话框
"HKLM\\Software\\Microsoft\\Internet Explorer\\Main\\Window Title", "强加的内容 [image] http://XXX.XXX.net";); //此处修改你IE的首页上的文字
"HKCU\\Software\\Microsoft\\Internet Explorer\\Main\\Window Title", "强加的内容 [image] http://XXX.XXX.net";); //此处修改你IE的首页上的文字
把注册表的内容恢复后，你就可以恢复正常了。

现在有些网站一浏览的时侯，就提醒你下载安装一个认证过的保护你的机器不被这类脚本修改的程序，我却不怎么相信他，谁知道会不会借机给你装个后门呢！建议大家别太相信国产的东西，不是不好，而是不可靠


特洛伊木马 篇
作者：小铭

http://www.cnhack.org

小铭：大家经常会听到“木马”一词。究竟木马是什么东西呢？这篇文章里我会向大家介绍“特洛伊木马”、“特洛伊木马”的使用以及特洛伊木马的防范等。

木马，全称为：特洛伊木马（Trojan Horse）。

“特洛伊木马”这一词最早出先在希腊神话传说中。相传在3000年前，在一次希腊战争中。麦尼劳斯（人名）派兵讨伐特洛伊（王国），但久攻不下。他们想出了一个主意：首先他们假装被打败，然后留下一个木马。而木马里面却藏着最强悍的勇士！最后等时间一到，木马里的勇士全部冲出来把敌人打败了！

这就是后来有名的“木马计”。—— 把预谋的功能隐藏在公开的功能里，掩饰真正的企图。

至于黑客程序里的特洛伊木马和故事里的特洛伊木马差不多。

黑客程序里的特洛伊木马有以下的特点：

（1）主程序有两个，一个是服务端，另一个是控制端。

（2）服务端需要在主机执行。

（3）一般特洛伊木马程序都是隐蔽的进程。

（4）当控制端连接服务端主机后，控制端会向服务端主机发出命令。而服务端主机在接受命令后，会执行相应的任务。

（5）每个系统都存在特洛伊木马。（包括Windows，Unix，liunx等）

在许多人眼中，特洛伊木马是一种病毒。其实特洛伊木马并不是一种病毒，它没有完全具备病毒的性质。（包括：转播，感染文件等。）

特洛伊木马程序的发展历史：

第一代木马：控制端 —— 连接 —— 服务端

特点：属于被动型木马。能上传，下载，修改注册表，得到内存密码等。

典型木马：冰河，NetSpy，back orifice（简称：BO）等。

第二代木马：服务端 —— 连接 —— 控制端

特点：属于主动型木马。隐蔽性更强，有利用ICMP协议隐藏端口的，有利用DLL（动态连接库）隐藏进程的，甚至出现能传播的木马。

典型木马：网络神偷，广外女生等。（反弹端口型木马）


怎样得到个人电脑的IP地址
个人电脑的IP地址和服务器的IP地址不同。
拨号上网用户的IP地址会变的，而服务器的IP地址是不会变的。
那么，怎样获得别人的IP地址呢？
告诉大家，最好的办法，就是厚着面皮问人家拿。不过这是没人会给你的。：）当然，我们不是用这种方法取得IP地址。
下面是我总结出来的经验：
万能法：
需要的程序：防火墙及网站提供的域名转向系统。
1、安装一个防火墙（例如：天网防火墙），并打开。
2、获得自己的IP地址。范例：127.0.0.1
3、在网上寻找“域名转向系统”，例如：http://my.yeah.net
4、申请一个新域名，并指向你的IP地址的7626端口（此端口为特洛伊木马冰河的监听端口。）。范例：127.0.0.1:7626
5、将申请成功的网址发给别人。范例：http://cnhack.yeah.net
6、当那个人访问刚才的网址时，防火墙就会发出警报并记录下那个人的IP地址。
原理讲解：当有人试图连接你的电脑时（特别是特洛伊木马的监听端口。），防火墙就会发出警报，并记录下试图连接的IP地址。
OICQ（QQ）法：
在OICQ（QQ）里查询别人的IP，主要有两种方法：第一种：装一个OICQ显示IP地址的补叮（网上很多的。）第二种：1、在OICQ上通知你的好友到OICQ的“二人世界”里。
2、然后，在“开始”——“程序”——“MS-DOS方式”输入：netstat -nD:\>netstat -nActive ConnectionsProto Local Address Foreign Address StateTCP 127.0.0.1:1811 127.0.0.3:10098 ESTABLISHEDD:\>其中，“127.0.0.1”是我的IP地址，“ 127.0.0.3”是他的IP地址。


dos窗口的复制与剪贴
有时候我们希望把2000的dos窗口中的东东复制到记事本中，可ctrl+c肯定是不管用了，怎么办？
可以先按鼠标左键选择希望copy的内容，这时选中的部分呈白色，然后在白色区域中点一下右键就可以把当前内容复制到剪贴板。
那么想要把记事本或网页中的文本复制到dos窗口中怎么办呢？
先ctrl+c把希望copy的内容复制到剪贴板，然后在dos窗口中点一下右键就ok了。
2000的ms-dos方式有很多类windows的操作，例如想要进入多层中文目录中执行文件可以在资源管理器中把待执行的文件直接拖曳到dos窗口中即可，抛砖引玉，希望大家把使用中的小技巧都写出来...


测试几本电子书

神雕侠: 测试几本电子书--等待纠正。
大家的老朋友了新人类的代理电子书ftp://24.185.94.35/20020622184301.zip
跳板教程ftp://24.185.94.35/20020924222147.zip
ssso安装教程ftp://24.185.94.35/20021007221120.zip
代理猎手教程ftp://24.185.94.35/r8r8001.zip
黑客攻防ftp://24.185.94.35/r8r8.zip
看学论坛加密解密教程ftp://24.185.94.35/0195.rar

回复： 我的油箱：tasw000@yahoo.com.cn(30字) － liaoliao，2002年10月30日
回复： 无法下载为森么(14字) － liaoliao，2002年10月30日
回复： 我的点目标另存为。。。就是无法下载，但是用IE进入ftp这个目录后，是可以下载的..(77字) － no.1，2002年10月27日
回复： 你用什么下载的？如果你可以上本站，就应该可以下载。 可能是你的ftp软件设置不对。&nb..(108字) － admin，2002年10月27日
回复： 都无法下载哦一定要登录服务器才能下载的[align=right][color=#000066][此..(135字) － no.1，2002年10月26日


动态网发现突破域名劫持方法：在线查询[转帖]

【大纪元11月4日讯】自从9月底中国开始大规模劫持海外网站包括动态网在内的域名以来，许多网友反映很难用以前的域名上动态网。许多志愿者设的网站也受到影响。这里介绍一种简单的办法在线查一个被劫持的域名IP的办法。
在Google上搜索online nslookup，可以找到上万条。这其中有许多网页是提供nslookup程
序的服务。只要您输入所要查讯的域名，就可以给出正确的IP。然后就可以试试用 https://IP 上网了。这种方法对于动态网和多数网站来说都是可以的。

如果那一页上有复杂的选项，您用缺省值试试就一般就可以了。不懂英文的朋友可以找到“domain，host name”的空格填入要找的网址。(参见上图 http://www.hexillion.
com/utilities/NsLookup.vbs.asp 的例子，点击可看大图。)

这里给几个我们测试过的网页(注意不能加空格或http)：
http://www.hexillion.com/utilities/NsLookup.vbs.asp
http://www.philjones.net/nslookup.php
http://nocops.pacific.net.sg/serviceLink/tools.html (要选中“nslookup”)
http://www.intnet.net/Support/utility.html
http://network-tools.com/
http://us.mirror.menandmice.com/cgi-bin/DoDig

原载《网络自由联盟》( [image] http://www.dajiyuan.com)

主题： 动态网发现突破域名劫持方法：在线查询[转帖](1028字) － athena，2002年11月4日
回复： 本站常用文章里面也有一堆类似的网址，如果不够，再给大家找找。(60字) － admin，2002年11月4日
回复： http://216.92.207.177/tools1.htm这也是一个办法...(49字) － particle，2002年11月4日
回复： 好像不太理想！(14字) － redboy，2002年11月4日


端口大全
注：SuperScan 3.0 的端口列表好像也挺全的
1　tcpmux　TCP Port Service Multiplexer 传输控制协议端口服务多路开关选择器
2　compressnet　Management Utility　　　　 compressnet 管理实用程序
3　compressnet　Compression Process　　　　压缩进程
5　rje　Remote Job Entry　　　　　　　　　 远程作业登录
7　echo　Echo　　　　　　　　　　　　　　　回显
9　discard　Discard　　　　　　　　　　　　丢弃
11　systat　Active Users　　　　　　　　　 在线用户
13　daytime　Daytime　　　　　　　　　　　 时间
17　qotd　Quote of the Day　　　　　　　　 每日引用
18　msp　Message Send Protocol　　　　　　 消息发送协议
19　chargen　Character Generator　　　　　 字符发生器
20　ftp-data　File Transfer [Default Data]　文件传输协议(默认数据口)
21　ftp　File Transfer [Control]　　　　　　文件传输协议(控制)
22　ssh　SSH Remote Login Protocol　　　　 SSH远程登录协议
23　telnet　Telnet　　　　　　　　　　　　 终端仿真协议
24　?　any private mail system　　　　　　 预留给个人用邮件系统
25　smtp　Simple Mail Transfer　　　　　　 简单邮件发送协议
27　nsw-fe　NSW User System FE　　　　　　 NSW 用户系统现场工程师
29　msg-icp　MSG ICP　　　　　　　　　　　 MSG　ICP
31　msg-auth　MSG Authentication　　　　　 MSG验证
33　dsp　Display Support Protocol　　　　　显示支持协议
35　?　any private printer server　　　　　预留给个人打印机服务
37　time　Time　　　　　　　　　　　　　　 时间
38　rap　Route Access Protocol　　　　　　 路由访问协议
39　rlp　Resource Location Protocol　　　　资源定位协议
41　graphics　Graphics　　　　　　　　　　 图形
42　nameserver　WINS Host Name Server　　　WINS 主机名服务
43　nicname　Who Is　　　　　　　　　　　　"绰号" who is服务
44　mpm-flags　MPM FLAGS Protocol　　　　　MPM(消息处理模块)标志协议
45　mpm　Message Processing Module [recv]　消息处理模块
46　mpm-snd　MPM [default send]　　　　　　消息处理模块(默认发送口)
47　ni-ftp　NI FTP　　　　　　　　　　　　 NI FTP
48　auditd　Digital Audit Daemon　　　　　 数码音频后台服务
49　tacacs　Login Host Protocol (TACACS)　 TACACS登录主机协议
50　re-mail-ck　Remote Mail Checking Protocol　远程邮件检查协议
51　la-maint　IMP Logical Address Maintenance　IMP(接口信息处理机)逻辑地址维护
52　xns-time　XNS Time Protocol　　　　　　施乐网络服务系统时间协议
53　domain　Domain Name Server　　　　　　 域名服务器
54　xns-ch　XNS Clearinghouse　　　　　　　施乐网络服务系统票据交换
55　isi-gl　ISI Graphics Language　　　　　ISI图形语言
56　xns-auth　XNS Authentication　　　　　 施乐网络服务系统验证
57　?　any private terminal access　　　　 预留个人用终端访问
58　xns-mail　XNS Mail　　　　　　　　　　 施乐网络服务系统邮件
59　?　any private file service　　　　　　预留个人文件服务
60　?　Unassigned　　　　　　　　　　　　　未定义
61　ni-mail　NI MAIL　　　　　　　　　　　 NI邮件?
62　acas　ACA Services　　　　　　　　　　 异步通讯适配器服务
63　whois+ whois+　　　　　　　　　　　　　 WHOIS+
64　covia　Communications Integrator (CI)　通讯接口
65　tacacs-ds　TACACS-Database Service　　 TACACS数据库服务
66　sql*net　Oracle SQL*NET　　　　　　　　Oracle SQL*NET
67　bootps　Bootstrap Protocol Server　　　引导程序协议服务端
68　bootpc　Bootstrap Protocol Client　　　引导程序协议客户端
69　tftp　Trivial File Transfer　　　　　　小型文件传输协议
70　gopher　Gopher　　　　　　　　　　　　 信息检索协议
71　netrjs-1　Remote Job Service　　　　　 远程作业服务
72　netrjs-2　Remote Job Service　　　　　 远程作业服务
73　netrjs-3　Remote Job Service　　　　　 远程作业服务
74　netrjs-4　Remote Job Service　　　　　 远程作业服务
75　?　any private dial out service　　　　预留给个人拨出服务
76　deos　Distributed External Object Store 分布式外部对象存储
77　?　any private RJE service　　　　　　预留给个人远程作业输入服务
78　vettcp　vettcp　　　　　　　　　　　　 修正TCP?
79　finger　Finger　　　　　　　　　　　　 FINGER(查询远程主机在线用户等信息)
80　http　World Wide Web HTTP　　　　　　　全球信息网超文本传输协议
81　hosts2-ns　HOSTS2 Name Server　　　　　HOST2名称服务
82　xfer　XFER Utility　　　　　　　　　　 传输实用程序
83　mit-ml-dev　MIT ML Device　　　　　　　模块化智能终端ML设备
84　ctf　Common Trace Facility　　　　　　 公用追踪设备
85　mit-ml-dev　MIT ML Device　　　　　　　模块化智能终端ML设备
86　mfcobol　Micro Focus Cobol　　　　　　 Micro Focus Cobol编程语言
87　?　any private terminal link　　　　　 预留给个人终端连接
88　kerberos　Kerberos　　　　　　　　　　 Kerberros安全认证系统
89　su-mit-tg　SU/MIT Telnet Gateway　　　 SU/MIT终端仿真网关
90　dnsix　DNSIX Securit Attribute Token Map　DNSIX 安全属性标记图
91　mit-dov　MIT Dover Spooler　　　　　　 MIT Dover假脱机
92　npp　Network Printing Protocol　　　　 网络打印协议
93　dcp　Device Control Protocol　　　　　 设备控制协议
94　objcall　Tivoli Object Dispatcher　　　Tivoli对象调度
95　supdup　SUPDUP
96　dixie　DIXIE Protocol Specification　　DIXIE协议规范
97　swift-rvf　Swift Remote Virtural File Protocol　快速远程虚拟文件协议
98　tacnews　TAC News　　　　　　　　　　　TAC(东京大学自动计算机?)新闻协议
99　metagram　Metagram Relay
101/tcp hostname NIC Host Name Server
102/tcp iso-tsap ISO-TSAP Class 0
103/tcp gppitnp Genesis Point-to-Point Trans Net
104/tcp acr-nema ACR-NEMA Digital Imag. & Comm. 300
105/tcp cso CCSO name server protocol
105/tcp csnet-ns Mailbox Name Nameserver
106/tcp 3com-tsmux 3COM-TSMUX
107/tcp rtelnet Remote Telnet Service
108/tcp snagas SNA Gateway Access Server
109/tcp pop2 Post Office Protocol - Version 2
110/tcp pop3 Post Office Protocol - Version 3
111/tcp sunrpc SUN Remote Procedure Call
112/tcp mcidas McIDAS Data Transmission Protocol
113/tcp ident
114/tcp audionews Audio News Multicast
115/tcp sftp Simple File Transfer Protocol
116/tcp ansanotify ANSA REX Notify
117/tcp uucp-path UUCP Path Service
118/tcp sqlserv SQL Services
119/tcp nntp Network News Transfer Protocol
120/tcp cfdptkt CFDPTKT
121/tcp erpc Encore Expedited Remote Pro.Call
122/tcp smakynet SMAKYNET
123/tcp ntp Network Time Protocol
124/tcp ansatrader ANSA REX Trader
125/tcp locus-map Locus PC-Interface Net Map Ser
126/tcp unitary Unisys Unitary Login
127/tcp locus-con Locus PC-Interface Conn Server
128/tcp gss-xlicen GSS X License Verification
129/tcp pwdgen Password Generator Protocol
130/tcp cisco-fna cisco FNATIVE
131/tcp cisco-tna cisco TNATIVE
132/tcp cisco-sys cisco SYSMAINT
133/tcp statsrv Statistics Service
134/tcp ingres-net INGRES-NET Service
135/tcp epmap DCE endpoint resolution
136/tcp profile PROFILE Naming System
137/tcp netbios-ns NETBIOS Name Service
138/tcp netbios-dgm NETBIOS Datagram Service
139/tcp netbios-ssn NETBIOS Session Service
140/tcp emfis-data EMFIS Data Service
141/tcp emfis-cntl EMFIS Control Service
142/tcp bl-idm Britton-Lee IDM
143/tcp imap Internet Message Access Protocol
144/tcp uma Universal Management Architecture
145/tcp uaac UAAC Protocol
146/tcp iso-tp0 ISO-IP0
147/tcp iso-ip ISO-IP
148/tcp jargon Jargon
149/tcp aed-512 AED 512 Emulation Service
150/tcp sql-net SQL-NET
151/tcp hems HEMS
152/tcp bftp Background File Transfer Program
153/tcp sgmp SGMP
154/tcp netsc-prod NETSC
155/tcp netsc-dev NETSC
156/tcp sqlsrv SQL Service
157/tcp knet-cmp KNET/VM Command/Message Protocol
158/tcp pcmail-srv PCMail Server
159/tcp nss-routing NSS-Routing
160/tcp sgmp-traps SGMP-TRAPS
161/tcp snmp SNMP
162/tcp snmptrap SNMPTRAP
163/tcp cmip-man CMIP/TCP Manager
164/tcp cmip-agent CMIP/TCP Agent
165/tcp xns-courier Xerox
166/tcp s-net Sirius Systems
167/tcp namp NAMP
168/tcp rsvd RSVD
169/tcp send SEND
170/tcp print-srv Network PostScript
171/tcp multiplex Network Innovations Multiplex
172/tcp cl/1 Network Innovations CL/1
173/tcp xyplex-mux Xyplex
174/tcp mailq MAILQ
175/tcp vmnet VMNET
176/tcp genrad-mux GENRAD-MUX
177/tcp xdmcp X Display Manager Control Protocol
178/tcp nextstep NextStep Window Server
179/tcp bgp Border Gateway Protocol
180/tcp ris Intergraph
181/tcp unify Unify
182/tcp audit Unisys Audit SITP
183/tcp ocbinder OCBinder
184/tcp ocserver OCServer
185/tcp remote-kis Remote-KIS
186/tcp kis KIS Protocol
187/tcp aci Application Communication Interface
188/tcp mumps Plus Five's MUMPS
189/tcp qft Queued File Transport
190/tcp gacp Gateway Access Control Protocol
191/tcp prospero Prospero Directory Service
192/tcp osu-nms OSU Network Monitoring System
193/tcp srmp Spider Remote Monitoring Protocol
194/tcp irc Internet Relay Chat Protocol
195/tcp dn6-nlm-aud DNSIX Network Level Module Audit
196/tcp dn6-smm-red DNSIX Session Mgt Module Audit Redir
197/tcp dls Directory Location Service
198/tcp dls-mon Directory Location Service Monitor
199/tcp smux SMUX
200/tcp src IBM System Resource Controller
201/tcp at-rtmp AppleTalk Routing Maintenance
202/tcp at-nbp AppleTalk Name Binding
203/tcp at-3 AppleTalk Unused
204/tcp at-echo AppleTalk Echo
205/tcp at-5 AppleTalk Unused
206/tcp at-zis AppleTalk Zone Information
207/tcp at-7 AppleTalk Unused
208/tcp at-8 AppleTalk Unused
209/tcp qmtp The Quick Mail Transfer Protocol
210/tcp z39.50 ANSI Z39.50
211/tcp 914c/g Texas Instruments 914C/G Terminal
212/tcp anet ATEXSSTR
214/tcp vmpwscs VM PWSCS
215/tcp softpc Insignia Solutions
216/tcp CAIlic Computer Associates Int'l License Server
217/tcp dbase dBASE Unix
218/tcp mpp Netix Message Posting Protocol
219/tcp uarps Unisys ARPs
220/tcp imap3 Interactive Mail Access Protocol v3
221/tcp fln-spx Berkeley rlogind with SPX auth
222/tcp rsh-spx Berkeley rshd with SPX auth
223/tcp cdc Certificate Distribution Center
242/tcp direct Direct
243/tcp sur-meas Survey Measurement
244/tcp dayna Dayna
245/tcp link LINK
246/tcp dsp3270 Display Systems Protocol
247/tcp subntbcst_tftp SUBNTBCST_TFTP
248/tcp bhfhs bhfhs
256/tcp rap RAP
257/tcp set Secure Electronic Transaction
258/tcp yak-chat Yak Winsock Personal Chat
259/tcp esro-gen Efficient Short Remote Operations
260/tcp openport Openport
263/tcp hdap HDAP
264/tcp bgmp BGMP
280/tcp http-mgmt http-mgmt
309/tcp entrusttime EntrustTime
310/tcp bhmds bhmds
312/tcp vslmp VSLMP
315/tcp dpsi DPSI
316/tcp decauth decAuth
317/tcp zannet Zannet
321/tcp pip PIP
344/tcp pdap Prospero Data Access Protocol
345/tcp pawserv Perf Analysis Workbench
346/tcp zserv Zebra server
347/tcp fatserv Fatmen Server
348/tcp csi-sgwp Cabletron Management Protocol
349/tcp mftp mftp
351/tcp matip-type-b MATIP Type B
351/tcp bhoetty bhoetty (added 5/21/97)
353/tcp ndsauth NDSAUTH
354/tcp bh611 bh611
357/tcp bhevent bhevent
362/tcp srssend SRS Send
365/tcp dtk DTK
366/tcp odmr ODMR
368/tcp qbikgdp QbikGDP
371/tcp clearcase Clearcase
372/tcp ulistproc ListProcessor
373/tcp legent-1 Legent Corporation
374/tcp legent-2

木马的：
15=NETSTAT PORT
21=Blade Runner, Doly Trojan, Fore, FTP trojan, Invisible FTP, Larva, ebEx, WinCrash
22=SSH PORT
23=Tiny Telnet Server
25=Shtrilitz Stealth, Terminator, WinPC, WinSpy, Kuang2 0.17A-0.30, Antigen, Email Password Sender, Haebu Coceda, Kuang2, ProMail trojan, Tapiras
31=Agent 31, Hackers Paradise, Masters Paradise
41=DeepThroat
53=DOMAIN PORT
58=DMSetup
63=WHOIS PORT
79=Firehotcker
80=Executor 110=ProMail trojan
90=DNS PORT
101=HOSTNAME PORT
110=POP3 PORT
121=JammerKillah
137=NETBIOS Name Service PORT
138=NETBIOS Datagram Service PORT
139=NETBIOS Session Service PORT
194=IRC PORT
406=IMSP PORT
421=TCP Wrappers
456=Hackers Paradise
531=Rasmin
555=Ini-Killer, Phase Zero, Stealth Spy
666=Attack FTP, Satanz Backdoor
911=Dark Shadow
999=DeepThroat
1001=Silencer, WebEx
1011=Doly Trojan
1012=Doly Trojan
1024=NetSpy
1045=Rasmin
1090=Xtreme
1095=Rat
1097=Rat
1098=Rat
1099=Rat
1170=Psyber Stream Server
1170=Voice
1234=Ultors Trojan
1243=BackDoor-G, SubSeven
1245=VooDoo Doll
1349=BO DLL
1492=FTP99CMP
1600=Shivka-Burka
1807=SpySender
1080=SOCKS PORT
1981=Shockrave
1999=BackDoor 1.00-1.03
2001=Trojan Cow
2023=Ripper
2115=Bugs
2140=Deep Throat
2140=The Invasor
2565=Striker
2583=WinCrash
2801=Phineas Phucker
3024=WinCrash
3129=Masters Paradise
3150=Deep Throat, The Invasor
3700=Portal of Doom
4092=WinCrash
4567=File Nail
4590=ICQTrojan
5000=Bubbel, Back Door Setup, Sockets de Troie
5001=Back Door Setup, Sockets de Troie
5321=Firehotcker
5400=Blade Runner
5401=Blade Runner
5402=Blade Runner
5550=JAPAN Trojan-xtcp
5555=ServeMe
5556=BO Facil
5557=BO Facil
5569=Robo-Hack
5742=WinCrash
6400=The Thing
6666=IRC SERVER PORT
6667=IRC CHAT PORT
6670=DeepThroat
6711=SubSeven
6771=DeepThroat
6776=BackDoor-G, SubSeven
6939=Indoctrination
6969=GateCrasher
6969=Priority
7000=Remote Grab
7300=NetMonitor
7301=NetMonitor
7306=NetMonitor
7307=NetMonitor
7308=NetMonitor
7626=G_Client(冰河)
7789=Back Door Setup, ICKiller
9872=Portal of Doom
9873=Portal of Doom
9874=Portal of Doom
9875=Portal of Doom
9989=iNi-Killer
10067=Portal of Doom
10167=Portal of Doom
10520=Acid Shivers
10607=Coma
11000=Senna Spy
11223=Progenic trojan
12223=Hack?9 KeyLogger
12345=GabanBus, NetBus, Pie Bill Gates, X-bill
12346=GabanBus, NetBus, X-bill
12361=Whack-a-mole
12362=Whack-a-mole
12631=WhackJob
13000=Senna Spy
16969=Priority
20001=Millennium
20034=NetBus 2 Pro
21544=GirlFriend
22222=Prosiak
23456=Evil FTP, Ugly FTP
26274=Delta Source
29891=The Unexplained
30029=AOL Trojan 30100=NetSphere 1.27a, NetSphere 1.31
30101=NetSphere 1.31, NetSphere 1.27a
30102=NetSphere 1.27a, NetSphere 1.31
30103=NetSphere 1.31
30303=Sockets de Troie
31337=Baron Night, BO client, BO2, Bo Facil, BackFire, Back Orifice, DeepBO
31338=NetSpy DK 31338=Back Orifice, DeepBO
31339=NetSpy DK
31666=BOWhack
31785=Hack Attack
31787=Hack Attack
31789=Hack Attack
31791=Hack Attack
33333=Prosiak
34324=BigGluck, TN
40412=The Spy
40421=Agent 40421, Masters Paradise
40422=Masters Paradise
40423=Masters Paradise
40426=Masters Paradise
47262=Delta Source
50505=Sockets de Troie
50766=Fore
53001=Remote Windows Shutdown
54321=School Bus .69-1.11
60000=Deep Throat
61466=Telecommando
65000=Devil
69123=ShitHeep


还原卡终结篇 [转帖]
刚从特种兵那挖来的,
_________________________________________________________________
还原卡终结篇
2002-4-11 17:33:32 校园黑客联盟 容克 阅读1330次
★★还原卡终结篇
还原卡这无聊的东东现在好像很流行,特别是在众学校,可把同学们给还原苦了, 一旦重启,别无所有. 众人怒曰:"把机器给卸了!!!!!!!!!"

菜人俺也曾深受其害,本来做好的想给给MM们看的小程序,随着reset,一去不回了!!!!
怒从胆边生,一定要废了它.

其实破解还原卡比破解cmos还要快,*作上就那几步,只是*作上有点吓人(俺菜嘛. 本来想给这篇起名"10秒内破解硬盘还原卡",不过上次那篇"15秒内破解cmos"让众网友臭骂了一顿:"如果设了开机密码看你怎么办!!",俺无语凝噎...555555...5555555~~~ 因此还是15秒吧,踏实些!

本篇文章的目的:让从未接触过debug的弟兄,也能顺利的破解还原卡,俺也会加上适当的注释 ,权当了解吧. 说白了,就是没学过计算机的也能按照俺的步骤破解它!!!!! 高手止步,请回

原理性的东东我不想在这废话,想和俺讨论或指点俺的朋友请到
最后一 [image] httP://lastknife.yeah.net ;

废话不说了,进入正题,破解方法有2:
第一种破解率还可以.
第二种好像是万能的(俺还没碰到破解不了的----见识短的表现-

第一种:
开机时(也就是在你曾经进入cmos的时刻),同时按住ctrl+home,这样你就进入了
还原卡的密码输入窗口,只要输入正确的密码即可获得admin,以后随你怎样设置.
关于是密码的问题:一般还原卡都有默认密码的,默认密码怎么找,很简单,到网上搜索
关键词"还原卡"就行了,找到你用的那个牌子的还原卡,进入站点,在一个比较偏僻的角落
一般可以找到默认密码的.
而一般机房管理员是不会修改其默认密码的,比如俺学校的
台湾远志牌的还原卡的默认密码是12345678,
小哨兵的是manager, 机房管理员一个也没改,好爽!!!!!!!!!!
不过我可没破坏任何东东,一旦惹怒了俺,嘿嘿....俺也不会破坏的,
恶意破坏计算机就是对自己的不尊重!!!!

如果管理员把密码改了呢?那就拿出宝刀---
方法二:
此法实施过程看起来挺麻烦,不过熟悉了*作起来超不过15秒的-
高手sinister曰:
其实所谓硬盘保护卡就是在ROM中写了一段HOOK INT 13的程序，屏蔽了
一些功能调用如AH=3，5等，在中断向量表中INT 13的SEG，OFFSET
描述为[13h*4+2]，[13h*4]，将此中的程序先保存后，再替换为自己的代码，
当你AH=2的时，它便会call原始INT 13地址来完成*作.
只要找到原始INT 13入口便可以为所欲为.
不知看了这段感觉如何?慢慢消化吧.

主要矛盾:关键是要找到原始的int 13入口.
测试*作系统:win98
测试对象: 台湾远志还原卡
测试地点: 学校机房
测试目的: 控制还原卡,但不破坏.

注:本篇文章不对其实施过程中出现的任何不可预料的情况负责!!!!!
具体过程如下:
开机过程按住F8键,进入纯dos环境, 注";"后为注释.
出现提示符c:,
键入c:\debug,
- a100
- xor ax,ax
- int 13
- int3
; 寻找原始的int 13入口.
然后输入t回车，不断的重复，直到显示的地址形如 F000:xxxx
,后面的指令为:mov dl,80 (练练眼力-。按q退出.
记下这一地址, 在(0:13H*4)=0:4cH 处填入这个地址。
例如俺的得到的地址是F000:9A95
再次运行debug ,键入:
-e 0:4c 95 9A 00 F0 ;e的作用将数据表"95 9A 00 f0",写入地址0:4c开始的字节中.
-q

注： 填的时候要仔细，填错的话会死机。ok,破解完成.
这时在提示符c:\键入
c:\win
进入win98系统即可,那么这次你在win98系统中的一切*作,随着下一次
的启动都会被还原卡存储起来。
不过下一次进入系统的的时候，你还是需要重写地址0:4c,才可以让还原卡存储你的东东。
这时只需要在纯dos下进入debug,键入
-e 0:4c 95 9A 00 F0
-q 即可。
哈哈。。。这样也挺好，只有你才是这台computer的真正的主人 -。
别人还是受还原卡的限制的except--you 。

此文仅供参考


几个电子书的网址
中国数字图书馆
http://www.d-library.com.cn/ ;
权威的在线图书馆。
瑞德超星在线图书馆
http://www.rol.cn.net/library ;
规模大，藏书丰富，包括社会科学、人文科学、自然科学等领域的著作和历史文献等。
可是…下载图书要花钱噢。
全景中文图书
http://www.cnovel.com/ ;
中文图书收集下载。
E书时空 （推荐）
http://www.eshunet.com/ ;
大量图书免费下载，门类繁多，而且不花钱！

大唐中文书库
http://www8.silversand.net/com/dtbook/ ;

书香门第
http://www.bookhome.net/ ;
别具一格的电子书籍主页，提供别处没有的电子书籍，也接受申请，帮助网友寻找电子
书或者OCR。

人民书城
http://www.peopledaily.com.cn/bookshop ;
人民日报的网上书城。

快意恩仇书社 （推荐）
http://fastbook.9797.com/Learning/ZheXueZongJiao/ ;
2G超大容量书库，内容丰富，涉及面广，提供打包下载，每日书讯推介。

书吧
http://www.book8.com/ ;
一个内容丰富的在线中文书库。

凤凰书城
www.sd.cninfo.net/library/>http://lw [image] www.sd.cninfo.net/library/ ;

世纪书城
http://www.52read.com/ ;
以内容取胜，搜集了大量各方面的书籍、资料，内容丰富而实用。

中华书库
http://hff.21cn.com:83/book/bg/ ;

书海
http://www.booksea.com/ ;

电脑书城
http://computerbooks.yeah.net/ ;

读书时空
http://book.szonline.net/ ;

东方公益书库
http://www.eastlib.com/ ;
读书、求知、休闲。

女性文选
http://www.yuedu.com/ ;

世纪童话
http://smileyue.soim.net/ ;

苹果书局
http://bookfans.126.com/ ;

三石图书文化传播网
http://www.3stonebook.com/ ;

电子图书基地 （推荐）
http://kahn.xj.cninfo.net/ljw/ ;
提供各种电子图书。

电脑书籍下载城 （推荐）
http://www.yuyux.com/ ;
顾名思义，这个网站提供了数百本电脑书籍供下载，很专业呀。

书秀坊
http://booksshow.myrice.com/ ;
凡尔赛宫收藏的中国历代名家作品。

亦凡公益图书馆
http://www.shuku.net/ .

http://medlem.spray.se/shakefishman/wdb/index.php

推荐好站！（文学、武侠、言情、影视、漫画、时尚、人物、IT、哲学、侦探...)

http://www.e-huaihai.com/ebook/ exe格式，内容丰富

http://202.99.217.52/downlading/ ... oad-ebook-index.htm 同媒网书库，exe格式，内容丰富

http://book.joyie.com/ 乐乐书城，多为exe格式，内容非常丰富，有许多全套漫画，需注册

http://www.xicn.net/download/ebook/ 喜满你电子图书下载，各种类型、格式的书都有

http://www.ebookpub.com.cn/ 明日出版在线，多为pdf格式

http://netbooks.my163.com/ 书网（“创作”目录中），exe格式，书比较少

http://www.c2000.com.cn/c3/book/book.asp 靓书店，有一些热门书籍的介绍及下载，多为exe格式

http://book.fm365.com/freedownload/ fm365免费下载专区，exe格式

http://jxx.hzic.edu.cn/xxsq/ 杭州商学院-休闲社区
转载一批下载电子书地址
http://ebook99.myetang.com/

书籍大全，绝对专业，分类详细，但是制作粗糙，很多都是站长收集没有整理的HTML文件。?;?;?;?;?;

http://www.ebook007.com/xueshu01.html

北极星书库，没什么说的，站长层次很高，书比较高雅专业?;?;?;?;?;

http://www.guxiang.com/epubcn/index.htm

e类出版物，制作绝对精美，各个精品，强烈推荐。?;?;?;?;?;

超星 [image] http://www.ssreader.com/
不用我说了吧?;?;?;?;

国家图书馆 [image] http://www.nlc.gov.cn/
不用我说了吧?;?;?;?;
以上需要下载软件才能下载阅读图书，请到软件区看看

http://www.cnovel.com/
全景中文图书/小说大全，我经常去，更新慢 ?;?;?;?;
http://www.shulu.net/

《书路》 很著名的书籍下载网站。
?;?;?;?;

http://goldnets.myrice.com/
黄金书屋 国内最著名的书籍下载、阅读网站 ，大多为在线
?;?;?;?;

http://cn.cartoonwin.lycosasia.com/
Lycos中国 在线阅读，净骗人的东西，广告多 ?;?;?;

http://www.bkdown.com/
伟伟阅览室?;?;?;

http://www.bbook.net/
百博书城 提供给您大量免费图书在线阅读或下载 ?;?;?;

www.hb.cninfo.net/wenyi/" target="_blank"> [image] www.hb.cninfo.net/wenyi/>http://xf [image] www.hb.cninfo.net/wenyi/
阳光书屋 ?;?;?;

http://www.eshunet.com/
e书时空，专业站点，强烈推荐?;?;?;?;?;

计算机图书

http://www.yuyux.com/
非常书城，强烈推荐?;?;?;?;?;

http://www.helpwork.net/
清华大学博士网提供大量的电子图书，控件，软件，代码，由于版权的问题，书不是很全。?;?;?;?;

3 [image] http://bookwu.net/
书屋?;?;?;?;

http://www.pcbookcn.com/
中华电脑书库?;?;?;?;速度慢

http://www.ebooksou.com/
电子图书搜索网 电脑图书，电脑书籍?;?;?;

http://www.vvsoft.net/
维维软件园 - 软件开发，电脑书籍

http://www.pconline.com.cn/pcedu/
太平洋电脑网，最丰富的网上教程站，强烈推荐?;?;?;?;?;

http://it.sohu.com/34/12/it_column15071234.shtml
搜狐IT频道，在线教程，强烈推荐?;?;?;?;?;

http://www.hongen.com/pc
洪恩学院，对于网页的教程精美绝伦，强烈推荐?;?;?;?;?;


揭密windows系统目录功能

揭密windows系统目录功能[转帖]
相信大家对于Windows是再熟悉不过了，我们天天都在用它，但是对于Windwows中系统目录你又了解多少呢？本文将对Win9x、WinME和Win2000中的系统目录做个详细的介绍，包括功能和简单应用。
所谓系统目录就是指操作系统的主要文件存放的目录，目录中的文件直接影响到系统是否正常工作，了解这些目录的功能，相信对你更好的使用系统会有很大的帮助。以下介绍的目录若不做特殊说明，在Win9x/ME系统下，它们在Windows目录中，在Win2000系统下，他们在Winnt目录中。
All Users文件夹：
『Win9x/ME』所有用户文件夹，里面里面包括系统缺省登录时的桌面文件和开始菜单的内容。
『Win2000』在Win2000的系统目录中没有这个文件夹，Win2000将用户的信息放在根目录下的Documents and Settings文件夹中，每个用户对应一个目录，包括开始菜单、桌面、收藏夹、我的文档等等。
Application Data文件夹：
『Win9x/ME』应用程序数据文件夹。包括任务栏中的快捷方式，输入法的一些文件等等。根据你系统中使用不同的软件，该目录中的内容也有所不同。
『Win2000』在Documents and Settings文件夹中，每个用户都对应一个Application Data文件夹，同样每个用户由于使用的软件不同，目录内容也相同。
Applog文件夹：
『Win9x/ME』应用程序逻辑文件目录。逻辑文件是用来记录应用软件在运行时，需要调用的文件、使用的地址等信息的文件。要查看这些文件，用记事本打开即可。
Catroot文件夹：
『Win9x』计算机启动测试信息目录，目录中包括的文件大多是关于计算机启动时检测的硬软件信息。
『WinME』该文件夹位于系统目录的system目录中。
『Win2000』该文件夹位于系统目录的system32目录中。
Command文件夹：
『Win9x/ME』DOS命令目录。包括很多DOS下的外部命令，虽说都是些小工具，但真的很好用，特别是对于系统崩溃时。
『Win2000』这些DOS命令位于系统目录的system32目录中。
Config文件夹：
『Win9x/ME/2000』配置文件夹，目录中包括一些MIDI乐器的定义文件。
Cookies文件夹：
『Win9x/ME』Cookies又叫小甜饼，是你在浏览某些网站时，留在你硬盘上的一些资料，包括用户名、用户资料、网址等等。
『Win2000』每个用户都有一个Cookies文件夹，位于Documents and Settings文件夹的每个用户目录中。
Cursors文件夹：
『Win9x/ME/2000』鼠标动画文件夹。目录中包括鼠标在不同状态下的动画文件。
Desktop文件夹：
『Win9x/ME』桌面文件夹。包括桌面上的一些图标。
『Win2000』这个文件夹在系统目录中也存在，同时在Documents and Settings文件夹的每个用户目录中还有“桌面”文件夹。
Downloaded Program Files文件夹：
『Win9x/ME/2000』下载文件文件夹。该文件夹包含显示已打开的Web页所需的文件，其中大部分文件是用来运行Web页面上的动画。
Drwatson文件夹：
『Win9x/ME/2000』华生医生文件夹。本来华生医生可以在系统发生错误时拍下系统快照，但这个目录只有一个超文本文件。
Favorites文件夹：
『Win9x/ME』收藏夹文件夹。如果需要重新安装系统，请备份这个目录，这样可以保留收藏夹中的内容。
『Win200』每个用户都有一个Favorites文件夹，位于Documents and Settings文件夹的每个用户目录中。
Fonts文件夹：
『Win9x/ME/2000』字体文件夹。在这个目录中可以添加删除字体文件，也可以删除一些不必要的文件而减少系统占用硬盘的空间。
Help文件夹：
『Win9x/ME/2000』帮助文件的文件夹，Windows有个好处就是有详细的帮助文件，这个目录里面就包括很多帮助文件，遇到问题多看看帮助文件，对你会有很大的帮助。
History文件夹：
『Win9x/ME』历史文件夹。IE浏览器有一个功能可以自己记录用户浏览过的网址，这个目录就是用来存放这些网址的。
『Win2000』每个用户的历史文件都是相互独立的。位于Documents and Settings文件夹的每个用户目录中Local Settings目录里面。
Inf文件夹：
『Win9x/ME/2000』安装文件文件夹。在安装驱动程序时，系统会提示我们指定相应的Inf文件。要使用这些文件也很简单，直接选取其右键菜单中的“安装”即可。
Java文件夹：
『Win9x/ME/2000』和JAVA相关的一些文件夹。包括Classes和Packages两个子文件夹，其中Packages中包含了一些压缩文件和一些数据文件。在Win2000中还包括Trustlib子目录。
Media文件夹：
『Win9x/ME/2000』媒体文件夹。主要包括一些声音和MIDI文件，系统启动、错误等时候发出的声音就是使用这个目录下的文件。
NetHood文件夹：
『Win9x/ME』网络覆盖目录，使用网上邻居时需要用到此目录。
『Win2000』位于Documents and Settings文件夹的每个用户目录中。
Offline Web Pages文件夹：
『WinME/2000』脱机Web页面。当某个站点设置成允许脱机使用时，相应的在这个文件夹中会有所对应。
OPTIONS文件夹：
『WinME』WinME特有的文件夹，用来存放安装文件。
Pif文件夹：
『Win9x/ME』程序信息文件目录。Pif文件是DOS程序的快捷方式。
PrintHood文件夹：
『Win9x/ME』打印覆盖目录。
Recent文件夹：
『Win9x/ME』最近打开文档文件夹。这个目录中的内容对应“开始”菜单中“文档”里面的内容。
『Win2000』位于Documents and Settings文件夹的每个用户目录中。
Samples文件夹：
『Win9x/ME』模板文件夹。主要是Windows利用脚本文件处理一些事情的范例，你可以通过记事本来查看这些范例。
SendTo文件夹：
『Win9x/ME』发送文件夹。目录中的内容对应于鼠标右键菜单中发送的内容，你可以在这里面进行添加而修改发送菜单中的项目。
『Win2000』位于Documents and Settings文件夹的每个用户目录中。
ShellNew文件夹：
『Win9x/ME/2000』新建文件夹。文件夹中的文件是对应鼠标右键菜单“新建”中文件的模板。当你选择“新建”中选择某个文件，，系统就在目录中寻找相对应的模板文件。
Spool文件夹：
『Win9x/ME』Spool文件夹中有一个Printers目录，在进行打印操作时，打印所产生的转换文件就暂存于这个目录中。
Start Menu文件夹：
『Win9x/ME』开始菜单文件夹。对应开始菜单中的程序，你可以在这个目录下对开始菜单进行修改。
『Win2000』在Documents and Settings文件夹的每个用户目录中有个“「开始」菜单”目录，也是同样的功能。
Sysbckup文件夹：
『Win9x/ME』系统备份文件夹。系统会自动备份注册表以及系统文件，打包放在这个目录下，需要恢复时只需要解开文件将其覆盖会相应的目录即可。
System文件夹：
『Win9x/ME/2000』系统文件夹。系统中的重要文件都放在这个目录下，同时在安装新软件时也会向这个目录中拷贝文件。由于这里面很多文件是多个软件公用的，在删除软件时提示要删除这个目录中的文件最好选择不要删除。
System32文件夹：
『Win9x/ME/2000』32位的系统的文件夹，里面包含了许多虚拟设备文件。同样也是很重要，在对里面的文件进行删减时也要特别注意。
Tasks文件夹：
『Win9x/ME/2000』计划任务文件夹，该文件夹包含已计划的Windows任务。Windows将按照指定的时间来运行这些任务。
Temp文件夹：
『Win9x/ME/2000』临时文件目录。在系统和软件的运行过程中会产生很多临时的文件，就存放在这个目录中。定期清理这个目录中的文件，可以减少硬盘的垃圾。
Temporary Internet Files文件夹：
『Win9x/ME』IE下载文件缓冲区。使用IE浏览器浏览网页时，系统会自动将浏览过的网页内容放在这个目录中，当你再次打开相同的网页时系统会从这个目录中进行提取，这样可以加快浏览的速度。
『Win2000』每个用户都有一个Temporary Internet Files文件夹，位于Documents and Settings文件夹的每个用户目录中的Local Settings目录里面。
Web文件夹：
『Win9x/ME/2000』该文件夹中的文件主要是一些超文本模板、频道的图标和图像等等。Windows系统中一些窗口的布局也是通过这里面的文件来完成的。以前没有觉得这个目录重要，后来发现欢乐时光病毒就是通过感染这个目录中的文件来达到破坏的目的。
由于系统目录中的文件都很重要，所以在进行修改时要特别小心，如果你对系统不是太熟悉，建立你还是不要去动它们。 编辑: eNet


介绍2个能将德法俄等语种网页翻译成英文的网站！
http://babelfish.altavista.com/

http://www.worldlingo.com/products_services/worldlingo_translator.html还有很多语种的互译，不仅能翻译单词，句子，还能翻译整个网页。这下申请老外的空间或信箱就不愁了。


下载及破解网站
抱歉乱七八糟还没来得及整理好多重复，希望大家帮忙整理以及继续添加谢谢
下载网站
台湾--软体王--软件更新最快
http://www.softking.com.tw
台湾--史莱姆的第一个家
http://www.slime.com.tw
台湾--电脑看世界
http://netcity3.web.hinet.net/UserData/w6102280/
飞翔鸟之软体驿站
http://joysoft.cis.com.cn/
鲨鱼丸
http://www.whatisnet.net/index.asp
软件龙宫
http://www.soft999.com/
长春163精品软件基地
http://down.cc163.net/
网虫小竹园
http://go6.163.com/spcriver/index_1.html
网精
http://www.30age.com/
163软件园
http://www.soft163.com/
296软件宝库
http://soft.269.net/
下呀精品园
http://www.downya.com/
软件万花筒
http://61.129.81.123/superdown/index.html
金鑫软件地带
http://www.faji.com/
软件说明书
http://www.softreadme.com/
ZDNet下载软件
http://www.zdnet.com.cn/download/
大家好
http://www.ulong.net/
中华网--下载基地
http://download.china.com/index.html
天之痕软件站
http://skytrace.6to23.com/
天天安全网
http://www.ttian.net/
天空软件站
http://www.skycn.com/
天马行空
http://faey.6to23.com/
天马行空--北方下载
http://www.flyhorse.net/#here
太平洋电脑网
http://www.pconline.com.cn/
火爆软件
http://www.myetoys.com/download/indexok.asp
有风的日子
http://www.windstudio.net/
西部Webmaster俱乐部
http://www.westwebmaster.net/
酷利斯特
http://www.mycoolest.net/
奇妙下载
http://www.qmdown.com/
金港热线--软件下载
http://download.zjg.jsinfo.net:88/
侠盗的家
http://www.paddyliu.com/vgate/
黑白软件
http://soft.jx163.com/
江西热线
http://www.online.jx.cn/
碧海银沙
http://www.silversand.net/
精品软件下载
http://soft.9down.com/
华军软件园
http://www.onlinedown.net/
广明网站
http://www.gmwz.net/
当吾喽
http://www.downla.com/
无优软件网
http://www.51soft.com/
梦缘工作室
http://www.laojia.com.cn/mengyuan/download/index.asp
急速163
http://www.jx163.com/index2.html
eNet下载
http://www.esoftware.com.cn/
纵横天下
http://www.zhtx.net/
电脑信息网
http://it.sdinfo.net/
乡巴佬
http://cnctz.cndx.net/acdown/
软件在线
http://www.softonline.com.cn/
软件屋
http://www.softhouse.com.cn/
软件聚宝盆
http://soft.km169.net/soft/index2.htm
随
http://membres.lycos.fr/sincan/index.php
http://www.softlake.com/index.htm
http://www.51soft.com/
http://www.ohsoft.com/
http://microke.billwang.net/ ;
http://www.downla.com/
http://www.cnarts.net/fwd
http://www.wenchuan.com/
http://cnsw.6to23.com/
http://www.atmdownload.com /;
http://210.34.0.61/toyman/
http://crackerabc.longcity.net /;
http://staryang.com/
http://www.soft120.com/
http://yfox.yesky.net/
http://touch.ccoo.com/
http://micracker.myetang.com/index.htm
http://crack2088.yes8.com/
http://www.xjonline.com/download/
http://gmwz.126.com/
http://www.cnpojie.com/indexshadu.htm ;
http://www.huaeronline.com/gbxfasp/temp/ubb/down/dwdown/default.asp
http://resweb.51.net/
http://bugbug.6to23.co/
http://www.ynkm.com/index/
http://www.husoft.net/
http://winzheng.com/
http://www.highot.net/
http://aho.myrice.com/
http://www.yunfeisoft.com/
http://17down.yeah.net/
http://chzhy.com/
http://zuzusoft.y365.com/
http://www.soft163.com/
http://soft.269.net/
http://www.pc520.net/
http://www.accton-sh.com/downfans/
http://www.clkj.net/soft/
http://www.downfans.coc.cc/
http://yyd.myrice.com/
http://365down.6to23.com/
http://newpc.yesky.net/
http://www.softuser.com/
http://www.flyhorse.net/
http://202.103.134.147/download/
http://xsky.yesky.net/
http://51xz.www71.cn4e.com/51xz/
http://www.csdn.net/
http://520pfcool.www80.cn4e.com/yesyee/index.htm
http://fire2.6to23.com/
http://www.caiqing.net/
http://skytrace.6to23.com/
http://hongye.6to23.com/
http://vdown.d2g.com/
http://wilddown.126.com/
http://www.qqgame.net/gamebox/softmw/down/
http://51down.5dir.com/
http://www.chinacec.net/
http://download.qiandao.net/
http://tq02y7y.longcity.net/
http://xccweb.yeah.net/
http://elag.126.com/
http://eudc.home2.2911.net/
http://www.stardown.com/
http://www.365hz.net/ ;;
http://www.zhtx.net/default.asp
http://game3.zj.cninfo.net/wind/down/
http://www.fansword.com/
http://www.yedown.com/
http://www.activeedu.net/softdown/index.asp
http://www.cnsofte/新OSress.com
http://eyiq.3322.net/
http://64.125.80.150/
http://61.128.98.212/rjxz/
http://www.xfsj.com/
http://llzhshl.myetang.com/
http://download.512city.net/
http://pjptt.com/
http://www.5isoft.com/
http://www.cnsofte/新OSress.com/web/default.asp
http://www.0513online.com/flashnew/flashnew/
http://www.downfans.com/download/default.asp ;
http://211.90.241.27/
http://cnsw.6to23.com/
http://hpok.363.net/download.htm
http://www.iou99.com/
http://www.51crack.com/
http://go7.163.com/smg13/
http://kuruan.myetang.com/
http://zxzku.51.net/
http://www.allcn.net/bar_on_top.html
http://www.jjwb.com/index1.asp
http://www.512city.net/download/
http://www.down365.com/
http://shunsheng.myetang.com/
http://download.363.net/gold-soft1.html
http://yesoft.myrice.com/
http://www.jingya.com/zgx/download/
http://www.liaokai.com/homepage.htm
http://www.ui19b1.chinaw3.com/jj.htm
http://www.gmwz.net/
http://www.superdown.com/
http://soft.redtea.com.cn/
http://soft.qilu.tv/
http://www.52puyang.com/
http://www.wwwlamp.com/
http://94hack.k666.com/
http://www.huaeronline.com/gbxfasp/temp/ubb/down/dwdown/default.asp
http://www.tacwire.com/myis3/index2.htm
http://go5.163.com/28002282/
http://go1.163.com/yf007/soft/main.htm
http://www.flymoon.net/flymoon/software/
http://www.luisye.com/down/index.asp
http://www.whatisnet.net/index.asp
http://www.cdiso.com/
http://202.97.198.155/czty/down/default.asp
http://www.dngs.net/
http://super.5599.net/
http://202.96.126.1/
http://51soyo.net /;
http://go7.163.com/goodnow
破解网址大全 （国内）
无忧软件网 - 不可多得的破解软件下载基地,附有无忧书库,无忧字体,代码基地,无忧教学,免费园地,完全游戏? http://www.51soft.com/ ;

精品软件秀 - 软件下载网页，可惜更新太慢！分类清楚，更新及时,也值得一看。 http://www.ohsoft.com/ ;

163软件园 - 163软件园是国内著名的软件网站,网站定位是提供“提供软硬件资讯专业网站”。 http://www.soft163.com/ ;

中华破解联盟 - 我们的会员达到211人，其中付费的会员45人，成为了一个大家比较欢迎的站点，然而破解站点 [image] http://www.softsdown.com/ ;

软件万花筒 - 一个破解软件下载。本站提供注册码、软件破解文件、精彩Flash动画。软件能做到每天更新，而 [image] http://www.superdown.com/ ;

盗亦有道 - 本站提供：国产软件 国外软件 精品软件 股票软件 加密工具 解密工具 网络安全 ICQ/OICQ 破解? http://forum.winzheng.com/~winzheng...ums.cgi?forum=5 ;

番外地工作室 - 破解文献、破解工具、注册码、口令破解、杀毒软件、国产软件 [image] http://fwd.yeah.net/ ;

破解乐园 - 本站是马思奇之家的子站，建立于公元二零零零年十月八日，主要以破解为主，提供软件下载、软?

中原破解 - 精彩的破解软件收录站点,国产注册,国外注册,光盘工具,解密软件,加密软件,破解学院. http://www.crackbest.net/ ;

天空软件站 - 内容丰富，更新及时。提供各种破解的网络软件,系统工具,应用软件,联络聊天,图形图像,多媒体 [image] http://www.skycn.net/ ;

赢政天下 - 可以说是破解软件下载的最权威的地方了。更新迅速。内容丰富。应有尽有！设有：.:最近更新:. http://soft.winzheng.com/ ;

多快热下载 - 破解软件下载，正如其名，多快热下载，软件丰富，下载速度快的热门软件下载。

肥牛精品 - 破解软件下载站点，内容全面，更新及时，从常用软件到行业软件都有破解版下载。 http://www.51xiazai.com/ ;

注册码搜索大全 - 使用软件注册码搜索引擎AstalAvista.Box.Sk，几乎都能找到您想要的注册码或破解文件。 http://www.netpaste.com/code/ ;

【精品软件下载】 - 正版软件下载、破解软件下载、源代码下载,asp cgi php mysql,Soft Reatil Crack Key [image] http://www.9down.com/ ;

康乐园 - 每天更新多次的破解、软件下载站点。内容极其丰富，几乎所有当今流行的软件都可以找到，是软件? http://64.125.80.150/ ;

无心精品软件下载 - 经典的破解版软件下载基地。系统工具,程序开发,电子阅读,翻译工具,网页制作,压缩工具 [image] http://www.clkj.net/soft/ ;

注册大本营 - 提供注册码和注册机下载。 http://yuanbin.spedia.net/ ;

星月精品网 - 提供破解版的正版软件下载网站，界面美观大方，软件分类齐全,经常更新。

QQ黑客网 - 拥有大量的QQ密码破解程序和轰炸程序，以及一些邮箱的密码破解程序和轰炸程序。 http://www.qq88.net/ ;

豆子软件 - 包括正版软件、破解软件下载、正版游戏下载、查毒杀毒软件下载等。 http://www.ggabc.com/ ;

网虫乐园 - 本网把国外大公司的软件一网打尽，有软件速递 ,Abobe精品, macromedia精品, Microsoft精品 ,U [image] http://www2001.myrice.com/ ;

注册大全 - 提供按照软件名称的开头字母来寻找相关的注册资料 [image] http://www.zx9.net/reg/index.htm ;

suhu注册码天地 - 中外注册码更新,可以查到几乎所有英文软件的注册码和注册机, 最新注册码 国内软件注册 [image] http://yanxz.myetang.com/ ;

星梦之网 - 很cool的软件下载站点，更新及时。本站附有星梦论坛,软件注册机,破解教程,MP3下载,心理测试,? http://www.stardown.com/ ;

飞牌精品软件 - 不会让你失望的已破解网站,内容应有尽有.注册机，系统程序,网络工具,常用工具,媒体工具,? http://www.ayxz.com/ ;

大亨软件园 - 大亨软件园- [image] http://www.jxxw.com正版软件与破解软件的下载基地每天有几十种新正版软件和游 [image] http://www.jxxw.com/ ;

天天软件网 - 经典的破解软件下载站点，软件分类清楚，更新及时，绝对cool.不会让你失望的。 http://bugbug.6to23.com/ ;

Greatboy的网上家园 - 提供大量的注册机(码)及破解软件。 http://greatboy.myrice.com/ ;

珠江路在线 - 888珠江路在线-注册码智能注册中文系统 注册码智能搜索中文系统。提供免费代码。 http://www.zhujiangroad.com/code/ ;

火爆软件下载 - 本站设有：最新更新 软件分类 软件搜索 热门下载 在线管理等栏目。提供的软件都是破解 [image] http://www.myetoys.com/download/indexok.asp ;

软件仓库 - 经典的破解软件下载基地，名副其实，软件资源极其丰富，软件分17大类下载，值得一看。 http://soft.netnest.com.cn/SelectDB.exe? ;

京九网堡下载站 - 非常精彩的破解网站，在这里可以找到你需要的许多实用性很强的软件，此站更新及时，软? http://www.jjwb.com/soft/ ;

阿程软件园 - 最新、最酷的正版软件下载，每天更新，,还有趣味软件、搞怪软件、侠客软件 、动漫壁纸 、游 [image] http://myis.yeah.net/ ;

华夏视窗导航 - 绝对值得一看的网站，此网页模仿windows桌面界面，很有创意。此站含有已破解的软件下载， [image] http://www.gl200.net/ ;

石头软件 - 一个破解软件下载、游戏下载、图片下载的基地。本站提供注册码、软件破解文件、精彩Flash动画 [image] http://stonesoft.my163.com/ ;

网友自助中心 - 以软件加密、解密预防、软件保护、病毒与安全为主，包括电脑应用的各个方面。是一个有一? http://52byte.com/ ;龙龙精品软件 - 破解的正版软件下载站点，更新及时，内容丰富，紧随软件潮流.内含多种著名软件的注册机。 http://yesoft.myrice.com/ ;

鲨鱼丸下载 - 正版软件下载、注册码、破解、游戏、工具、英语学习、音乐、影视 [image] http://www.whatisnet.net/index.asp ;

无忧破解基地 - 提供最新的破解软件下载，每天更新,界面美观，软件实用性强,值得收藏。 http://www.51hot.net/soft/ ;

蔫老虎精品软件资讯网 - 不错的正版和破解软件下载站点。注册码大全，系统工具,主页制作,网络工具,图形图 [image] http://www.softicp.com/ ;

注册码搜索 - Cgi下载，免费服务,国外、国内软件注册、注册码、软件破解、注册码搜索引擎，常用的注册码? http://www.glavenet.com/sn/ ;

听月在线 - 最新、最拽的正版软件下载，还有,听月聊天,听月下载,供求热线,交友频道, FALSH专题, 听月社区 [image] http://www.aptrat.com/ ;

逍遥乐人居 - 软件破解下载,文学下载书籍，最新新闻，逍遥仙剑，精选网址有你想要的东东不想来看看会让你 [image] http://leren.myrice.com/ ;

阿蒙电脑乐园 - 精品软件、软件破解 。 http://www.swhsky.com/ ;

无忧破解基地 - 提供最新破解软件下载（包括正版软件），另有大量注册码、黑客工具下载,如果你喜欢破解软 [image] http://www.51hot.net/soft/ ;

月之门 - 软件破解、正版下载、日剧下载 [image] http://zjhall.51.net/ ;

中华黑客 - 一个黑客组织，组织爱国者为我国计算机安全事业作贡献，站内具有最新最全的黑客工具和黑客资? http://www.hackercn.com/ ;

三脚猫大仓库 - 本站提供软件下载/破解,Mp3,Mtv，游戏，在线影院等等！是大家不可不去的酷站！ http://iww.my163.com/ ;

华娱下载区 - 非常过瘾的破解软件下载网站，每天更新几十个软件，让大家天天可以用上新软件。 http://www.zjdownload.net/ ;

万发网☆超级下载基地！ - 正版软件下载，注册机、码，免费计数器，ASP源程序，网页制作................ http://www.ujd0z1.chinaw3.com/ ;

黑客软件园 - 欢迎光临黑客软件园，本站收集了现在最新的黑客软件跟资料、密码破解、OICQ工具杀毒软件、I [image] http://go5.163.com/happyhot/ ;

城郊漫步下载 - 这里的软件，是我自己常用的经典工具软件，相信也是你拥有或正在寻找的软件。包括系统、? http://cnfjh.y365.com/softdown/softdown.htm ;

六颗太阳 - 主要介绍神秘的东东.并有大量的黑客软件下载,也有很多的黑客教程!!还有一些笑话、漫画和动画? http://wgef3j.home.sohu.com/ ;

大勇之家 - 正版下载，趣味软件，常用破解，杀毒更新，论坛留言，搜索服务，免费服务，破解注册，工具软? http://go4.163.com/dayong/ ;

紫色天空 - 软件注册码大全 软件下载·安全防护 ·杀毒专栏 ·QQ软件库 ·炸弹工具 ·木马控制 ·扫描工? http://go1.163.com/tsst/ ;

福满园共享软件 - 网站提供共享软件注册服务，支持多种在线支付手段。为保障网站，作者及客户三方利益，? http://www.regshareware.com/public/default.asp ;

动感软件站 - 超酷软件下载， 软件下载,最新软件,常用软件, 软件使用, 建站技术,精彩论坛,虚拟城市,教学? http://www.mesky.net/softdown/default.asp ;

当秀 - 老牌的破解软件下载站点，我最喜欢它，还有电影可以下载。下载内容被分成许多类目，方便下载。 http://94down.enorth.com.cn/default.html ;

绵阳青软 - 软件下载 精品软件 精华代码 流行音乐 原创作?软件教学 破解注册 一切仅在 绵阳青软 免费资 [image] http://www.myqr.com/ ;

飓风工作室 - 经典破解类网站,极力推荐：>每天都有几十个软件更新，大家去看看吧!! http://helihua.com/soft/ ;

K886网络工作室 - 提供各种软件下载、注册码、杀毒、破解、黑客技术文章、免费资源及并承接编程、主页制? http://www.qyzsz.com/love/k886/default.asp ;

软件天堂 - 里面搜集了许多特别的工具。破解软件、系统程序、网络工具、媒体工具、图文处理、桌面工具和? http://lzhj.myrice.com/ ;

【软件帝国】 - 想快速找到软件就进来吧！提供最新、最快、最全的软件，还有ADSL技术特区！软件论坛有求? http://aliketen.myetang.com/rj/software.htm ;

明超空间软件下载 - 明超空间是一个汇集各类免费软件、注册码、军事要闻、影视娱乐以及免费图书的综合空? http://go5.163.com/lmc888/index.htm ;

紫色天空 - 黑软 QQ工具 破解 主页素材 主页特效 主页制作 主页教程 动画图片 免费资源 特效软件 安全 防 [image] http://go1.163.com/ccncm/ ;

动域软件 - 提供全方位软件下载！每日多次更新！全能无忧破解。同时提供20M免费ASP空间，限额300，还开通 [image] http://www.asparea.net/soft/ ;

精品软件收藏馆 - 软件、软件破解、安全工具、黑客工具。 http://itbest.net/oldbs/ ;

酷软精品小站 - 提供大量最新最IN的各类精品软件并附有相关注册信息，如：金山毒霸正式版，天网个人防火? http://davy.sosoo.net/ ;

弹弓帮下载基地 - 破解软件下载，最新程序软件下载，电子图书下载，极酷游戏下载，桌面下载，工具软件下? http://diy5.myrice.com/103240135/da...ist.asp?page=11 ;

自由软件 - 每天更新的最新软件下载，最新软件破解，最新软件正式零售版，最新软件热门软件的注册码。 http://evc.ip88.net/ ;

万家下载专区 - 提供最新的破解，正版软件下载,另有大量工具下载，经典软件、OICQ最新工具、黑客工具、趣 [image] http://winjia.com/soft/ ;

软件点播中文网 - 这是一个全新的破解软件下载站点，有大量值得收藏的软件，时时刻刻都有新鲜血液注入.每 [image] http://secret2002.126.com/ ;

奇奇天空软件站 - 新品推荐，正版下载，终级解密，精品下载，杀毒，补丁，趣味东东，软件仓库，分类下载? http://qqskydownload.yeah.net/ ;

中华软件联盟 - 软件下载，软件破解，游戏破解，注册码，游戏下载，破解教程,更新及时。 http://www.softsdown.com/ ;

软件大吧 - 提供全面的软件下载！日日更新！提供正班软件下载！有windows系列下载，各种杀毒软件！数十个 [image] http://crazywiond.myetang.com/ ;

彬彬万页网络 - 注册大全,网络资源，网络安全，在线读书，娱乐咨询，医疗保健，新闻实事，情感天空，生活 [image] http://go1.163.com/bbscn/bibn.htm ;

时空在线 - 时空在线破解软件 [image] http://mhwawa.6to23.com/ ;

软件风暴 - 本站提供全面的更新的破解和注册软件，每个软件都提供注册码或破解文件，软件能做到每天更新? http://software.zhgnet.com/ ;

紫辰软件下载 - 各种正版破解软件提供下载 其中包括：WINDOWS XP（中文简体饧せ畎妫?金山毒霸2001 瑞? http://3254008.126.com/ ;

三维视窗 - 软件注册码搜索（三维视窗） 软件搜索，注册码搜索，网站集锦搜索。 http://www.3dwin.com.cn/c/register.php ;

划破长空 - 精品软件下载，注册及汉化；新歌介绍，歌词查询及MP3搜索；精彩图片，画廊及电子书籍。 http://go5.163.com/tudou110/
驱动程序下载点: http://www.mydrivers.com/

国内 木马帝国 [image] http://trojans.govell.com/

国内 中国红客网络技术联盟 [image] http://www.cnhonker.com

国内 绿色兵团 [image] http://www.vertarmy.org

国内 安全焦点 [image] http://www.xfocus.net

国内 中国信息安全论坛 [image] http://www.chinafirst.org.cn

国内 中国鹰派 [image] http://www.lls268.com

国内 网络安全小组 [image] http://www.dancefires.com

国内 小榕软件 [image] http://www.netxeyes.com

国内 20CN网络安全小组 [image] http://www.20cn.net

国内 黑白网络 [image] http://www.heibai.net

国内 天网安全阵线 [image] http://www.hao123.com/safe/sky.htm

国内 灰色轨迹( [image] http://www.sandflee.net

国内 中联绿盟信息技术公司 [image] http://www.hao123.com/safe/nsf.htm

国内 绿色兵团网络安全基地 [image] http://www.hao123.com/safe/isbase.htm

国内 五四红客 [image] http://www.54honker.com

国内 大学生安盟 [image] http://www.cnasu.com

国内 蓝盾联盟 [image] http://www.landun.org

国内 白菜乐园 [image] http://www.crackbest.com

国内 黑客防线 [image] http://www.hacker-defence.com


提问的智慧——建议每一位发贴之前先看看

Linux:--提问的智慧——建议每一位发贴之前先看看
提问的智慧

Copyright (C) 2001 by Eric S. Raymond
中文版 Copyleft 2001 by D.H.Grand(nOBODY/Ginux)
英文版：http://www.tuxedo.org/~esr/faqs/smart-questions.html
感谢 Eric 的耐心指点和同意，本文才得以完成并发布，
本指南 英文版版权为 Eric Steven Raymond 所有，
中文版版权由 D.H.Grand[nOBODY/Ginux] 所有。

在黑客世界里，当提出一个技术问题时，你能得到怎样的回答？这取决于挖出答案的难度，同样取决于你提问的方法。本指南旨在帮助你提高发问技巧，以获取你最想要的答案。

首先你必须明白，黑客们只偏爱艰巨的任务，或者能激发他们思维的好问题。 如若不然，我们还来干吗？如果你有值得我们反复咀嚼玩味的好问题，我们自会对你感激不尽。好问题是激励，是厚礼，可以提高我们的理解力，而且通常会暴露我们以前从没意识到或者思考过的问题。对黑客而言，“问得好！”是发自内心的大力称赞。

尽管黑客们有蔑视简单问题和不友善的坏名声，有时看起来似乎我们对新手，对知识贫乏者怀有敌意，但其实不是那样的。

我们不想掩饰对这样一些人的蔑视--他们不愿思考，或者在发问前不去完成他们应该做的事。这种人只会谋杀时间--他们只愿索取，从不付出，无端消耗我们的时间，而我们本可以把时间用在更有趣的问题或者更值得回答的人身上。 我们称这样的人为“失败者”（由于历史原因，我们有时把它拼作“lusers”）。

我们在很大程度上属于志愿者，从繁忙的生活中抽出时间来解惑答疑，而且时常被提问淹没。所以我们无情的滤掉一些话题，特别是抛弃那些看起来象失败者的家伙，以便更高效的利用时间来回答胜利者的问题。

如果你觉得我们过于傲慢的态度让你不爽，让你委屈，不妨设身处地想想。我们并没有要求你向我们屈服--事实上，我们中的大多数人最喜欢公平交易不过了，只要你付出小小努力来满足最起码的要求，我们就会欢迎你加入到我们的文化中来。但让我们帮助那些不愿意帮助自己的人是没有 意义的。如果你不能接受这种“歧视”，我们建议你花点钱找家商业公司签个技术支持协议得了，别向黑客乞求帮助。

如果你决定向我们求助，当然不希望被视为失败者，更不愿成为失败者中的一员。立刻得到有效答案的最好方法，就是象胜利者那样提问 —— 聪明、自信、有解决问题的思路，只是偶尔在特定的问题上需要获得一点帮助。

（欢迎对本指南提出改进意见。任何建议请E-mail至esr@thyrsus.com，然而 请注意，本文并非网络礼节的通用指南，我通常会拒绝无助于在技术论坛得到有用答案的建议。） （当然，如果你写中文，最好还是寄DHGrand@hotmail.com;-）

= 提问之前 =
在通过电邮、新闻组或者聊天室提出技术问题前，检查你有没有做到：
1. 通读手册，试着自己找答案。
2. 在FAQ里找答案（一份维护得好的FAQ可以包罗万象:）。
3. 在网上搜索（个人推荐google~~~）。
4. 向你身边精于此道的朋友打听。

当你提出问题的时候，首先要说明在此之前你干了些什么；这将有助于树立你的形象：你不是一个妄图不劳而获的乞讨者，不愿浪费别人的时间。如果提问者能从答案中学到东西，我们更乐于回答他的问题。

周全的思考，准备好你的问题，草率的发问只能得到草率的回答，或者根本得不到任何答案。越表现出在寻求帮助前为解决问题付出的努力，你越能得到实质性的帮助。

小心别问错了问题。如果你的问题基于错误的假设，普通黑客（J. Random Hacker）通常会用无意义的字面解释来答复你，心里想着“蠢问题...”，希望着你会从问题的回答（而非你想得到的答案）中汲取教训。

决不要自以为够资格得到答案，你没这种资格。毕竟你没有为这种服务支付任何报酬。你要自己去“挣”回一个答案，靠提出一个有内涵的，有趣的，有思维激励作用的问题--一个对社区的经验有潜在贡献的问题，而不仅仅是被动的从他人处索要知识--去挣到这个答案。

另一方面，表明你愿意在找答案的过程中做点什么，是一个非常好的开端。“谁能给点提示？”、“我这个例子里缺了什么？”以及“我应该检查什么地方？”比“请把确切的过程贴出来”更容易得到答复。因为你显得只要有人指点正确的方向，你就有完成它的能力和决心。

= 怎样提问 =
- 谨慎选择论坛
小心选择提问的场合。如果象下面描述的那样，你很可能被忽略掉或者被看作失败者：
1. 在风马牛不相及的论坛贴出你的问题
2. 在探讨高级技巧的论坛张贴非常初级的问题；反之亦然
3. 在太多的不同新闻组交叉张贴

- 用辞贴切，语法正确，拼写无误
我们从经验中发现，粗心的写作者通常也是马虎的思考者（我敢打包票）。 回答粗心大意者的问题很不值得，我们宁愿把时间耗在别处。

正确的拼写，标点符号和大小写很重要。
更一般的说，如果你的提问写得象个半文盲，你很有可能被忽视。

如果你在使用非母语的论坛提问，你可以犯点拼写和语法上的小错--但决不能在思考上马虎（没错，我们能弄清两者的分别）

- 使用含义丰富，描述准确的标题
在邮件列表或者新闻组中，大约50字以内的主题标题是抓住资深专家注意力 的黄金时机。别用喋喋不休的“帮帮忙”（更别说“救命啊！！！！！”这 样让人反感的话）来浪费这个机会。不要妄想用你的痛苦程度来打动我们， 别用空格代替问题的描述，哪怕是极其简短的描述。

蠢问题： 救命啊！我的膝上机不能正常显示了！
聪明问题： XFree86 4.1下鼠标光标变形，Fooware MV1005的显示芯片。

如果你在回复中提出问题，记得要修改内容标题，表明里面有一个问题。一个看起来象“Re：测试”或者“Re：新bug”的问题很难引起足够重视。另外，引用并删减前文的内容，给新来的读者留下线索。

- 精确描述，信息量大
1. 谨慎明确的描述症状。
2. 提供问题发生的环境（机器配置、操作系统、应用程序以及别的什么）。
3. 说明你在提问前是怎样去研究和理解这个问题的。
4. 说明你在提问前采取了什么步骤去解决它。
5. 罗列最近做过什么可能有影响的硬件、软件变更。

尽量想象一个黑客会怎样反问你，在提问的时候预先给他答案。

Simon Tatham写过一篇名为《如何有效的报告Bug》的出色短文。强力推荐你也读一读。

- 话不在多
你需要提供精确有效的信息。这并不是要求你简单的把成吨的出错代码或者数据完全转储摘录到你的提问中。如果你有庞大而复杂的测试条件，尽量把它剪裁得越小越好。

这样做的用处至少有三点。第一，表现出你为简化问题付出了努力，这可以使你得 到回答的机会增加；第二，简化问题使你得到有用答案的机会增加；第三，在提炼 你的bug报告的过程中，也许你自己就能找出问题所在或作出更正。

- 只说症状，不说猜想
告诉黑客们你认为问题是怎样引起的没什么帮助。（如果你的推断如此有效，还用向别人求助吗？），因此要确信你原原本本告诉了他们问题的症状，不要加进你自己的理解和推论。让黑客们来诊断吧。

蠢问题： 我在内核编译中一次又一次遇到SIG11错误，我怀疑某条飞线搭在主板的走线上了，这种情况应该怎样检查最好？
聪明问题： 我自制的一套K6/233系统，主板是FIC-PA2007 （VIA Apollo VP2芯片组），256MB Corsair PC133 SDRAM，在内核编译中频频产生SIG11错误，从开机20分钟以后就有这种情况，开机 前20分钟内从没发生过。重启也没有用，但是关机一晚上就又能工作20分钟。所有 内存都换过了，没有效果。相关部分的典型编译记录如下...。

- 按时间顺序列出症状
对找出问题最有帮助的线索，往往就是问题发生前的一系列操作，因此，你的说明 应该包含操作步骤，以及电脑的反应，直到问题产生。

如果你的说明很长（超过四个段落），在开头简述问题会有所帮助，接下来按时间顺序详述。这样黑客们就知道该在你的说明中找什么。

- 明白你想问什么
漫无边际的提问近乎无休无止的时间黑洞。最能给你有用答案的人也正是最忙的人（他们忙是因为要亲自完成大部分工作）。这样的人对无节制的时间黑洞不太感冒，因此也可以说他们对漫无边际的提问不大感冒。

如果你明确表述需要回答者做什么（提供建议，发送一段代码，检查你的补丁 或是别的），就最有可能得到有用的答案。这会定出一个时间和精力的上限，便于回答者集中精力来帮你，这很凑效。要理解专家们生活的世界，要把专业技能想象为充裕的资源，而回复的时间则是贫乏的资源。解决你的问题需要的时间越少，越能从忙碌的专家口中掏出答案。

因此，优化问题的结构，尽量减少专家们解决它所需要的时间，会有很大的帮助--这通常和简化问题有所区别。因此，问“我想更好的理解X，能给点提示吗？”通常比问“你能解释一下X吗？”更好。如果你的代码不能工作，问问它有什么地方不对，比要求别人替你修改要明智得多。

- 别问应该自己解决的问题
黑客们总是善于分辨哪些问题应该由你自己解决；因为我们中的大多数都曾自己解决这类问题。同样，这些问题得由你来搞定，你会从中学到东西。你可以要求给点提示，但别要求得到完整的解决方案。

- 去除无意义的疑问
别用无意义的话结束提问，例如“有人能帮我吗？”或者“有答案吗？”。 首先：如果你对问题的描述不很合适，这样问更是画蛇添足。其次：由于这 样问是画蛇添足，黑客们会很厌烦你--而且通常会用逻辑上正确的回答来表 示他们的蔑视，例如：“没错，有人能帮你”或者“不，没答案”。

- 谦逊绝没有害处，而且常帮大忙
彬彬有礼，多用“请”和“先道个谢了”。让大家都知道你对他们花费时间义务提供帮助心存感激。然而，如果你有很多问题无法解决，礼貌将会增加你得到有用答案的机会。

（我们注意到，自从本指南发布后，从资深黑客处得到的唯一严重缺陷反馈，就是对预先道谢这一条。一些黑客觉得“先谢了”的言外之意是过后就不会再感谢任何人了。我们的建议是：都道谢。）

- 问题解决后，加个简短说明
问题解决后，向所有帮助过你的人发个说明，让他们知道问题是怎样解决的，并再一次向他们表示感谢。如果问题在新闻组或者邮件列表中引起了广泛关注，应该在那里贴一个补充说明。补充说明不必很长或是很深入；简单的一句“你好，原来是网线出了问题！谢谢大家--Bill”比什么也不说要强。事实上，除非结论真的很有技术含量，否则简短可爱的小结比长篇学术论文更好。说明问题是怎样解决的，但大可不必将解决问题的过程复述一遍。除了表示礼貌和反馈信息以外，这种补充有助于他人在邮件列表/新闻组/论坛中搜索对你有过帮助的完整解决方案，这可能对他们也很有用。最后（至少？），这种补充有助于所有提供过帮助的人从中得到满足感。如果你自己不是老手或者黑客，那就相信我们，这种感觉对于那些你向他们求助的导师或者专家而言，是非常重要的。问题久拖未决会让人灰心；黑客们渴望看到问题被解决。好人有好报，满足他们的渴望，你会在下次贴出新问题时尝到甜头。

- 还是不懂
如果你不是很理解答案，别立刻要求对方解释。象你以前试着自己解决问题时那样（利用手册，FAQ，网络，身边的高手），去理解它。如果你真的需要对方解释，记得表现出你已经学到了点什么。比方说，如果我回答你：“看来似乎是zEntry被阻塞了；你应该先清除它。”，然后：一个很糟的后续问题：“zEntry是什么？” 聪明的问法应该是这样：“哦~~~我看过帮助了但是只有-z和-p两个参数中提到了zEntry而且还都没有清楚的解释:<你是指这两个中的哪一个吗？还是我看漏了什么？”

=三思而后问 =
以下是几个经典蠢问题，以及黑客在拒绝回答时的心中所想：

问题：我能在哪找到X程序？
问题：我的程序/配置/SQL申明没有用
问题：我的Windows有问题，你能帮我吗？
问题：我在安装Linux（或者X）时有问题，你能帮我吗？
问题：我怎么才能破解root帐号/窃取OP特权/读别人的邮件呢？

提问：我能在哪找到X程序？
回答：就在我找到它的地方啊蠢货--搜索引擎的那一头。天呐！还有人不会用Google吗？

提问：我的程序（配置、SQL申明）没有用
回答：这不算是问题吧，我对找出你的真正问题没兴趣--如果要我问你二十个问题才找得出来的话--我有更有意思的事要做呢。

在看到这类问题的时候，我的反应通常不外如下三种：

1. 你还有什么要补充的吗？
2. 真糟糕，希望你能搞定。
3. 这跟我有什么鸟相关？

提问：我的Windows有问题，你能帮我吗？
回答：能啊，扔掉萎软的垃圾，换Linux吧。

提问：我在安装Linux（或者X）时有问题，你能帮我吗？
回答：不能，我只有亲自在你的电脑上动手才能找到毛病。还是去找你当地的Linux用户组寻求手把手的指导吧（你能在这儿找到用户组的清单）。

提问：我怎么才能破解root帐号/窃取OP特权/读别人的邮件呢？
回答：想要这样做，说明你是个卑鄙小人；想找个黑客帮你，说明你是个白痴！

= 好问题，坏问题 =

最后，我举一些例子来说明，怎样聪明的提问；同一个问题的两种问法被放在一起，一种是愚蠢的，另一种才是明智的。

蠢问题：我可以在哪儿找到关于Foonly Flurbamatic的资料？
// 这种问法无非想得到“STFW”这样的回答。

聪明问题：我用Google搜索过“Foonly Flurbamatic 2600”，但是没找到有用的结果。谁知道上哪儿去找对这种设备编程的资料？
// 这个问题已经STFW过了，看起来他真的遇到了麻烦。

蠢问题：我从FOO项目找来的源码没法编译。它怎么这么烂？
// 他觉得都是别人的错，这个傲慢自大的家伙

聪明问题：FOO项目代码在Nulix 6.2版下无法编译通过。我读过了FAQ，但里面没有提到跟Nulix有关的问题。这是我编译过程的记录，我有什么做得不对的地方吗？
// 他讲明了环境，也读过了FAQ，还指明了错误，并且他没有把问题的责任推到别人头上，这个家伙值得留意。

蠢问题：我的主板有问题了，谁来帮我？
// 普通黑客对这类问题的回答通常是：“好的，还要帮你拍拍背和换尿布吗？” ，然后按下删除键。

聪明问题：我在S2464主板上试过了X、Y和Z，但没什么作用，我又试了A、B和C。请注意当我尝试C时的奇怪现象。显然边带传输中出现了收缩，但结果出人意料。在多处理器主板上引起边带泄漏的通常原因是什么？谁有好主意接下来我该做些什么测试才能找出问题？
// 这个家伙，从另一个角度来看，值得去回答他。他表现出了解决问题的能力，而不是坐等天上掉答案。

在最后一个问题中，注意“告诉我答案”和“给我启示，指出我还应该做什么诊断工作”之间微妙而又重要的区别。事实上，后一个问题源自于2001年8月在Linux内核邮件列表上的一个真实的提问。我（Eric）就是那个提出问题的人。我在Tyan S2464主板上观察到了这种无法解释的锁定现象，列表成员们提供了解决那一问题的重要信息。

通过我的提问方法，我给了大家值得玩味的东西；我让人们很容易参与并且被吸引进来。我显示了自己具备和他们同等的能力，邀请他们与我共同探讨。我告诉他们我所走过的弯路，以避免他们再浪费时间，这是一种对他人时间价值的尊重。后来，当我向每个人表示感谢，并且赞赏这套程序（指邮件列表中的讨论 --译者注）运作得非常出色的时候，一个Linux内核邮件列（lkml）成员表示，问题得到解决并非由于我是这个列表中的“名人”，而是因为我用了正确的方式来提问。我们黑客从某种角度来说是拥有丰富知识但缺乏人情味的家伙；我相信他是对的，如果我象个乞讨者那样提问，不论我是谁，一定会惹恼某些人或者被他们忽视。他建议我记下这件事，给编写这个指南的人一些指导。

= 找不到答案怎么办 =

如果仍得不到答案，请不要以为我们觉得无法帮助你。有时只是看到你问题的人不知道答案罢了。没有回应不代表你被忽视，虽然不可否认这种差别很难区分。
总的说来，简单的重复张贴问题是个很糟的想法。这将被视为无意义的喧闹。

你可以通过其它渠道获得帮助，这些渠道通常更适合初学者的需要。有许多网上的以及本地的用户组，由狂热的软件爱好者（即使他们可能从没亲自写过任何软件）组成。通常人们组建这样的团体来互相帮助并帮助新手。

另外，你可以向很多商业公司寻求帮助，不论公司大还是小（Red Hat 和LinuxCare 就是两个最常见的例子）。别为要付费才能获得帮助而感到沮丧！毕竟，假使你的汽车发动机汽缸密封圈爆掉了--完全可能如此--你还得把它送到修车铺，并且为维修付费。就算软件没花费你一分钱，你也不能强求技术支持总是免费的。

对大众化的软件，就象Linux之类而言，每个开发者至少会有上万名用户。根本不可能由一个人来处理来自上万名用户的求助电话。要知道，即使你要为帮助付费，同你必须购买同类软件相比，你所付出的也是微不足道的（通常封闭源代码软件的技术支持费用比开放源代码软件要高得多，且内容也不那么丰富）。

回复： 用心良苦！谢谢linux！(21字) － 依然，2002年11月6日
回复： 也不是说绝对的。可能“考”作文能力：）。作文差，不是问题--我的作文就不好，但表达清楚很重要--也比较容易，多实践就可以了。但提问是想知道答案，“问的好”，可能就会少弯路。 他的作用不单单在论坛，生活、工作里面都体现。 但论坛作用更显著。生活、工作中“问”和“答”可能是及时，“问的不好”，及时反馈--但还是“问的好”比较好，但论坛的“问”和“答”互相反馈很慢。(364字) － linux，2002年11月5日
回复： 主要看提问与回答者的心态了，但在我们这样一个氛围的论坛中应该不必拘匿。因为大家的心态都非同一般人的，虽然在技术上并不是黑客级，但我们没有那种极端的思维，我们可以跨过问题来看问题，这是所谓的黑客所远远不及的！不是吗？以上只是小弟想法。.(234字) － 阿蒙，2002年11月5日
回复： 感谢linux的提醒(96字) － qing，2002年11月5日
回复： 天哪！提个问题如此复杂，比问题的本身都要复杂了。(48字) － 蓝天，2002年11月4日