简介

    Nero - Burning Rom是德国ahead公司出品的刻录软件，容易使用，功能强大而齐全，能应付绝大部会的刻录工作。

准备工作：

把刻录机和Nero - Burning Rom安装到电脑上。
nero的官方网站 http://www.nero.com/en/download.htm

国内有很多网站都提供下载。

2,双击这个自解包程序，其默认路径是“C:\Program Files\ahead\Nero\”你可以根据自已的实际情况输入相应的路径。
3，安装汉化包


刻录数据光盘

1,启动nero，这时会出现一个“Nero精灵”虽然这个精灵挺聪明的，但要想使用nero的强大功能我们还是使用手动设置的方式吧。

2,点击“关闭精灵”

3,这时会出现如下的“新建编译”，在这个编译中就可以选择我们要刻录的“只读光碟（ISO）”。

“只读光碟（ISO）”是我们用的最多的光碟类型，在nero中只要使用得当我们就能使用这个编译来完成ISO光碟和多记录光碟的创建（包括追加数据）。

4,如果你的CDR/CDRW是空白的，并且要写入的数据不足一个光碟的容量（650MB/700MB），这时你就可以选以上图中的“开始多记录光碟”。（如果你的CDR/CDRW光碟已经使用过“开始多记录光碟”并没有关闭碟片，这样你可以选“继续多记录光碟”来引入以前曾写入的数据。当使用“继续多记录光碟”并按“新建”按钮时nero会预读取刻录机中光碟最后的ISO轨道，再按确定就可以成功引入了。如果你要一次写满整个光碟或不想再追加数据时就可以选择“无多记录”以获取最大的空间，最好的兼容性和最快的读取速度5,确定了你要刻录的只读光碟类型以后我们就可以进入“文件选项”选项卡的设定了，这一选项卡关系着刻录后的光盘是否能在DOS，UNIX，MAC上读取，是否支持长文件名，是否支持中文文件名和目录名等，所以大家要一一了解清楚。

“文件/目录长度”ISO 1级的文件名和目录名最多只能使用11个字符，也就是不支持长文件名，要放宽这个限制就得选择“ISO 2级”，这样我们就能刻录出长文件名了，即管这样nero也只能制作31个字符（如果想再多就只能使用Discjuggler3来刻录了，在往后的章节中我们就能学习到该软件的使用）。

ISO—9660目前有Level 1和Level 2两个标准。1级与DOS兼容，文件名采用传统的 8.3格式，而且所有字符只能是26个大写英文字母、10个阿拉伯数字及下划线。2级则在Leve l的基础 上加以改进，允许使用长文件名，即管这样可是nero也只能支持31个字符（如果想再多就只能使用Discjuggler3来刻录了，在往后的章节中我们就能学习到该软件的使用），但不支持DOS。

关于“格式”中的模式1和模式2：

黄皮书规格定义了两种不同型态的资料结构： mode 1与mode 2，在CD-ROM族 (Sector)的表头区(Header field)内，含有指示本区内资料为 mode 1 或 mode 2 的 Byte。mode 1代表CD-ROM资料含有错误修正码(Error Correction Code - ECC)，每个磁区存放2048Byte的资料。而mode 2的资料则没有错误修正码，将那些空间省下来，因此每个磁区可以多存放288Byte，达到2336Byte，因此mode 2较适合存放图形，声音或影音资料。您可以指定在CD上的每一个资料轨为mode 1 or mode 2，但是其内的磁区只能有一种格式来存放资料。大部分的CD-ROM电脑用光碟，包括资料库，电脑游戏，百科全书或共享软体，是采用 mode 1方式存放资料，而 mode 2从不采用它最"原始"的方式来存放资料。其它的光碟片，像是相片光碟(Photo CD)，CD-I 及影音光碟 ( Video CD)等，是采用mode 2，Form1及Form2来存放。

关于字符集：

ISO 9660：可使用的字符是26个大写英文字母、10个阿拉伯数字及下划线

DOS：可使用的字符是26个大写英文字母、10个阿拉伯数字、及下划线

ASCII：可使用的字符是ASCII中所有的字符

多字节：可使用的字符是以上所有的字符和中文字符

Joliet：微软公司自行定义的光盘文件系统，也是对ISO—9660文件系统的一种扩展，它支持Windows 9x/NT和DOS，在Windows 9x/NT下文件名可显示64个字符，可以使用中文，但不能被MAC机所读取。

放宽ISO限制： “充许8个目录以上的路径深度”和“充许路径超过255个字符”这两个选项是对ISO 9660标准的放宽，可有效补充该标准的不足，但如果勾选这两个选项会在旧的操作系统和MAC机上不能被读取的。

通过以上的介绍相信大家已经对光碟刻录时的文件系统有所了解。总结一下刻录要在不同操作系统下所能读取的刻录选项：

 | DOS/Windows3.X | Windows9X/NT | UNIX/Linux | MAC
文件/目录长度 | ISO 1级 | ISO 1级,ISO 2级 | ISO 1级 | ISO 1级
格式 | 模式1,模式2 | 模式1,模式2 | 模式1,模式2 | 模式1,模式2
字符集 | ISO 9660，DOS，ASCII | ISO 9660，DOS，ASCII，多字节 | ISO 9660 | ISO 9660
放宽ISO限制 | 不选择 | 选择/不选择 | 不选择 | 不选择

*以上选项只供参考，随着操作系统的升级和改善，选项的选择与否并不能绝对影响结果。

6,点击“卷标描述符”选项卡来输入光碟的名字。

7,点击“日期”选项卡来设定光碟上文件和目录创建的日期和时间，完成设定后即可按“新建”按钮进入文件的选择窗口。

8,把文件浏览器中的文件拖拉到光碟面板上

9,点击按钮打开刻录对话框

如果你下一次还想追加数据请勾选“写入”，如果一次写满整个光盘或不想再写入数据则要勾选“终结光碟”以关闭整个光碟。

“确定最大速度”是在刻录前测试系统是否能跟得上刻录速度，如速度不够则会降低刻录速度，一定程序上避免了刻录失败的发生。

“模拟”的作用是在真正刻录以前模拟一下刻录的整个过程，但不包括激光对碟片的写入，也就是说可以测试出硬盘（光驱，软件，网络等）信息源的传输是否稳定达到指定刻录速度的需求。（1X＝150KB/S，8X的速度就等于系统每秒向刻录机传输8×150＝1200KB的数据，很多系统会吃不消，不过在往后的章节中大家就会学到如何令系统在刻录中更加稳定）

“写入”就是真正写入，只有勾选这个选项才会完成写入光碟的过程。

“终结光碟”是关闭光碟的意思，当选了这个选项则无论用什么方法都不能再往这个光碟再写入任何数据了。

“写速度”可以设定写入的速度，如时间足够应该选尽量低速来刻，不但成功率高而且刻录的质量也高。

“写入方法”中的“光碟一次性”其实就是DAO模式，该模式的序述请参看Easy CD Creator篇已。

“拷贝数”可设定刻录光碟的数量。

“选项”中的“缓存磁盘－及网络文件”和“缓存文件小于”勾选后就会把小文件及网络上的文件先复制到本机硬盘上以提高刻录的成功率。

当以上都设定好我们就可以开始按“写入”按钮开始刻录了。


刻录VCD光碟

1,按新建按钮或文件菜单下的“新建”来打开“新建编译”对话框，选择我们要刻录的“VCD”。

我们在刻录VCD光碟时是把该光碟用于一般的家用VCD机上的，为了令光碟符合VCD机的标准，“创建符合标准的光碟”是必需勾选的,使用CD-I应用程序不选，选PAL分辨率。菜单不选，ISO设置如下图，标签中可填入如“真相"的标签，其他不填 。

这一切都设定好后就可以按“新建”按钮进入VCD节目的编辑了。

2，在窗口1在光盘图标上按右健，选择“建立新文件夹”建立新数据文件夹“书和工具”，打开文件夹，将书和工具放入窗口2，（建议将真相资料和破网工具做成自解压文件，既缩小文件又方便读者，但资料包最好不要超过5M,因为在VCD播放时他要占时间，且在第一个位置，5M约30秒钟，太长 不好。）

（我个人喜欢把相关资料全部放入一个目录然后用WINRAR压缩成后缀为.exe的文件，这样做的好处是可节约空间，并不会出现乱码。然后在readme.txt中标明光盘目录下有更多资料。 然后在autorun.inf中加入以下配置：
[autorun] OPEN=Notepad readme.txt

这样做出来的是可以在电脑自动播放的光盘）

3,把硬盘上的影像文件（窗口4）拖到光碟面版的音轨上（窗口3）

nero可支持的影像文件有dat和mpg，但都要是标准的mpeg-1编码。

在这个步骤上我们要注意的是把影像文件拖到光碟面版下方的音轨窗口3，而不是完成刻录后存放dat文件的mpegav目录，这点很重要！

4，完成后文件放置后，单击菜单栏的“刻录器”-“选择刻录器”-选择“image recorder”即nero的虚拟光驱，单击确定。（要注意，一般刻录机带的nero都没有这个功能，需用注册版的nero）,点击 [image] 按钮打开刻录对话框，设定好刻录时的选项后按“写入”按钮开始刻录。这时刻的是镜像，保存在硬盘。

5，镜像刻好后，打开nero自带的虚拟光驱程序nero imagedrive,单击 [image] 打开刻好的文件，单击load.然后用“超级解霸”播放，若正常便可下一步刻录了。

6，回到4，将刻录机设置为你实际的刻录机。

7，单击“新建”，单击“打开”，打开你刚建的镜像文件，将出现如下界面

在这里，终结cd要选，否则vcd兼容可能不好，刻录速度跟你机子有关，写入方式为上图显示，复制份数不能超过100。如果你有多部刻录机要选上“使用多部刻录机”，没有就不用选了。单击“写入”，便会弹出一个要你放入空白光盘的窗口，放入光盘，你第一张vcd便在5分钟左右出来了！

8，多部刻录机的使用，如7所述选上“使用多部刻录机”，单击单击“写入”，按shift健用鼠标将刻录机全选上，注意，刻录机最好为同一品牌的同一型号，否则刻录的飞盘会让你难过。单击确定。大量复制。（image recorder不要选上）刻录机的接法应是分开接，即一个跟硬盘线接在一起，另一单独接。 同时跳线设置为跟硬盘接设置为“从盘”（slaver)，单独接的设置为“主盘”（master slaver).

9，刻好的盘最好先在vcd机上试过之后大量刻。刻录的速度会影响质量，要在速度和质量之间选择一个合适的平衡点。同时质量跟空盘质量也有关系。空盘的价钱+刻录机的速度+vcd的质量之间应有一个平衡点。（我用的是“莱德”40x的盘，在32xRichon刻录机上可全速刻录，价钱约1.30/张）

10，光盘的封面，在国内而言，应是最简单的方式，不需要华丽的外观，用不干胶打上“赠品，vcd/电脑两用”就行了，多了，人们还不乐意要。 若需要漂亮的光盘封面，可到minghui去找。

11，关于片头。建议用绘声绘影作目录和片头，不建议用nero的菜单功能制作片头（在有的机器上容易不兼容）。

12、关于超刻，最好不要超过30秒，超过最后一个易产生马赛克现象。

13、对于在同一个盘中的节目，由于制作者的不同，可能产生声音大小不一的现象，这时我们可以用TMPGEnc PULS的mpg工具功能将文件分解，得到的是.mp2文件，用超级解霸的“音频工具”功能将其转换为mp3.然后打开nero自带的wave Editor对文件进行编辑。可以对音量大小进行修改。选中其中一段或全部，单击“音量”选择“变更音量”修改音量大小。wave Editor还可以对单声道或立体声文件进行变换，请读者自行研究。处理好的mp3保存后，可用MPGEnc PULS的mpg工具功能将其和分解下来的.m1v文件合成为.mpg文件。这样做来的好处是保证了音频文件和视频文件一致性。并且速度快。

-----------------------qxbbs.zapto.org:81,by jzx


刻录超级VCD光碟

1,按新建按钮或文件菜单下的“新建”来打开“新建编译”对话框，选择我们要刻录的“超级 VCD”。

超级VCD的刻录和VCD的刻录是一样的，我们只要注意它支持是mpeg-2编码的影像文件。刻录时使用和刻录VCD碟时一样的设定即可。


刻录音乐光盘

1,按新建按钮或文件菜单下的“新建”来打开“新建编译”对话框，选择我们要刻录的“音频光碟”。

这时会出现“音频光碟”选项卡，在这里选项卡中我们一般什么都不用输入的而直接按“新建”按钮即可。“在光碟上写入光碟文字”指的就是使用“CD TEXT”功能，该功能的作用是往CD音乐碟中加入音频光碟的信息（这些信息一般的光驱和CD唱机是读不了的）。

2,把硬盘上的音频文件拖到光碟面版上

nero可支持的音频文件有wav,mp3,wma。其中wav文件必须是44.1 kHz及16位元立体声格式。mp3和wma要为112K到160K的速率，高于160K的速度则会引起刻录后可播放但没有声音的现象。

3,点击 [image] 按钮打开刻录对话框，设定好刻录时的选项后按“写入”按钮开始刻录。


刻录混合光碟

按新建按钮或文件菜单下的“新建”来打开“新建编译”对话框，选择我们要刻录的“混合模式光碟”。混合模式光碟其实就是数据光碟和音频光碟的混合体，制作方法也大同小异，这里就不再多作介绍了。


刻录启动光碟

1,按新建按钮或文件菜单下的“新建”来打开“新建编译”对话框，选择我们要刻录的“只读光碟（启动）”。

“启动”选项卡是制作启动光碟的关键，nero除了和一般的刻录软件一样可以使用镜像文件来作为启动源外还额外支持把“可启动逻辑驱动器”制作为启动源。这就意味着能启动的盘都能作为启动源，也太神奇了！

这里就包括一些使用的技巧了：
当我们把软盘作为启动源则在光碟启动时会把启动盘模拟为A：，而像MO，硬盘分区等其他的启动源会被模拟为C：！！可是......很可惜，windows9x和windowsNT系统都不能在不写临时文件的情况下启动，能在这个环境下启动的看来只有DOS和windows3.X了。功能虽然受到了限制，但对在DOS下运行的程序可是个福音，现在的光驱速度越来越快，试想一下，把要求不同运行环境才能运行的软件刻录成不同的光碟，不但可以有效管理程序而且可以把该光盘带在身边随时运行，是多么的方便?

选择好启动源和文件选项后即可按“新建” 按钮进入下一个步骤。

2,把硬盘上的要刻录的文件拖到光碟面版上，点击 [image] 按钮打开刻录对话框，设定好刻录时的选项后按“写入”按钮开始刻录。


原创

原创]打造一张超级全自动系统备份、还原光盘
打造一张超级全自动系统备份、还原光盘

功能：先把BIOS设置光驱启动优先，用此光盘启动系统便会出现一个选择菜单：
1、选择1，可以自动把第1块硬盘的第一分区(就是C:盘)备份到D盘根目录下的system.gho文件中。
2、选择2，则可以把硬盘上的GHO文件还原到硬盘的第一分区(就是C:盘)；
3、选择3，则可以从光盘还原系统。
有了它，根本无须了解ghost怎么用，也不用小心翼翼，因为备份、还原完全傻瓜智能自动化,任何品牌机的还原光盘无法与之媲美。

一、制作全自动系统备份、还原光盘
第一步：准备－－先准备一张优质1.44M软盘。用杀毒软件对系统杀毒，并清理系统垃圾－略。
第二步：制作启动盘－－制作一张windows 98启动软盘，然后启动“资源管理器”，删除除了IO.SYS,MADOS.SYS,COMMAND.COM,AUTOEXEC.BAT,CONFIG.SYS,MSCDEX.EXE,OAKCDROM.SYS,SMARTDRV.EXE,FORMAT.COM（从c:\windows\command下复制到软盘）之外的所有文件，然后再把Ghost的执行文件Ghost.exe也拷贝到软盘上。注意：最好用2001版的ghost，2002版的ghost程序每次要求输入注册号，不支持全自动参数。除非用零售版。
第三步：修改config.sys文件
用记事本程序打开软盘上的config.sys文件，删除里面所有内容，并输入以下内容：
[menu]
menuitem=Clone,Backup your system.
menuitem=RestoreHD,Restore from HD.
menuitem=RestoreCD,Restore from CD.
menudefault=Clone,30
menucolor=7,0

[Clone]
device=himem.sys /testmem:off

[RestoreHD]
device=himem.sys /testmem:off

[RestoreCD]
device=himem.sys /testmem:off
device=oakcdrom.sys /D:oemcd001

[COMMOM]
files=60
buffers=20
dos=high,umb
stacks=9,256
lastdrive=z
（图略）
第四步：修改autoexec.bat文件。
用记事本程序打开软盘上的autoexec.bat文件，删除里面所有内容，并输入以下内容：
@ECHO OFF
set EXPAND=YES
SET DIRCMD=/O:N
cls
set temp=d:\
set tmp=d:\
path=a:\
IF "%config%"=="Clone" GOTO Clone
IF "%config%"=="RestoreHD" GOTO RestoreHD
IF "%config%"=="RestoreCD" GOTO RestoreCD

:Clone
ghost -sure -clone,mode=pdump,src=1:1, dst=d:\system.gho
GOTO QUIT

:RestoreHD
ghost -sure -rb -clone,mode=pload,src=Z:\system.gho:1,dst=1:1
GOTO QUIT

:RestoreCD
LH MSCDEX.EXE /D:OEMCD001 /L:Z
ghost -sure -rb -clone,mode=pload,src=d:\system.gho:1,dst=1:1
GOTO QUIT

:QUIT
第五步:备份第一块光盘第一分区到D:\system.gho文件中。略

第六步：刻录。启动Nero-burning Rom,然后把A盘插入软驱，在打开的“新建专辑”窗口中选择“CD-ROM(可启动)”，
启动选项设置如下：在“启动镜像数据来源”选项中选择A:\，
在“启用专家设置”前打勾，仿真类型选：“软盘仿真1.44兆”。。。

ISO标签选项：格式选择“模式1”，字符集是“ISO 9660”，不要选用Joliet，这样就有最好的DOS兼容性。
补充：如果分区较大，可以制作分片的GHO文件，ghost会提示换盘。

二：如何备份还原系统。
1、备份系统。需要备份系统时，只要进入BIOS，设置优先从光驱启动，插入此恢复光盘，光盘自动启动，选择菜单1：Backup your system，则这张光盘会自动备份你的第1块硬盘第一分区(就是C:盘)备份到D盘根目录下的system.gho文件中。
2、还原系统。如果系统崩溃，那么同样用这张光盘启动，
如果选择第二项Restore from HD，这张光盘就会把D盘根目录下的system.gho文件写到第1块硬盘的C：盘上。
如果选择第三项Restore from CD，会把光盘上的system.gho文件写到第1块硬盘的C：盘上。

-------------qxbbs.zapto.org:81,by no.1


nero的使用技巧

nero的使用技巧(一)

活用影像刻录机上

影像刻录机是nero中的一个很有用的元素，把当前的刻录机设定为nero的影像刻录机后所有刻录动作的结果都会通过影像刻录机制作为影像文件存于硬盘上而不管你是否已经安装了刻录机。

在主菜单上的“光碟记录器”菜单中选择“选择记录器”，找到“Image Recorder - Virtual Device - ”并启用它。

怎么可以只制作光碟的影像文件?

方法一：
“新建编译”中选择“光碟拷贝”，在“拷贝选项”中取消“飞机式”复制模式，再到“镜像”中取消“光碟拷贝后删除镜像文件”，在“刻录”选项卡中只勾选“确定最大速度”、“终结光碟”，这时“拷贝光碟”按钮会变为“速度测试”按钮。点击该按钮即可开始测试速度，当测试完毕就消取剩下的进度，这样我们所需要的光碟影像文件就在你硬盘上了。

方法二：
使用影像刻录机来进行复制的过程。完成制作后按要求保存下影像文件即可。

如何超写?

首先刻录机要支持超写。看刻录机支不支持超写可看下边红色的部份。如果刻录机支持该功能，则我们就能使用超写了。

1,打开File主菜单里的“优先选项”

2,在“专家功能”中勾选“启用一次性过量刻录”，并设定要超写的范围。

3,设定好后就按一般操作方法去使用nero，要注意的是必需使用DAO模式去刻录，多片段光碟不能超写。


nero的使用技巧

nero的使用技巧(二)

保存光碟的轨道

nero可以保存光碟中所有的轨道，数据轨可制作为nero的影像文件，音轨可制作为WAV、MP3、WMA、VQF，以方便我们日后再把轨道还原。

在主菜单上的“光碟记录器”菜单中选择“保存音轨”。选项用于保存音轨的驱动器。

当驱动器中的光碟是数据光碟时会有如下画面：

选择好数据轨道并设定好“路径”后再按“保存”按钮即可保存和nero所使用的nrg格式影像文件。

当驱动器中的光碟是数据光碟时会有如下画面：

择好音频轨道并设定好“路径”和“音频文件格式”后再按“保存”按钮即可保存为我们所想要的音频格式。

这里顺带说一下一些旧型号的光驱在保存数据音轨时没问题，可保存音频音轨时就会产生爆音，如果出现这个情况则光盘复制也会一样产生爆音。解决的方法是更换一个抓音轨不会产生爆音的驱动器。要注意的是播放时没有爆音不一定抓音轨时就没爆音。

快速制作光碟目录

在nero中可以快速的制作光碟上的文件列表。新建任何任务，然后在“文件”的主菜单中选择“页面视图”可显示你要刻录的光碟上所有文件的信息，再按“打印”按钮。


光碟复制

虽然对于光碟复制我们有功能强大的CloneCD和Discjuggler，但nero也有它独特的地方（可忽略很多读错误），是其他刻录软件所没有的。

方便和快速的飞机式光碟复制

按新建按钮或文件菜单下的“新建”来打开“新建编译”对话框，选择我们要刻录的“光碟拷贝”。

如果我们所要复制的母碟读碟很顺利，那么我们可以选择“飞机式”复制以节省时间和硬盘空间。

飞机式(On The Fly，即OTF模式)：
一种很有用的刻录方式，在早期，由于计算机运算速度无法足要求，所以只能在刻录前将数据预先转换成使用ISO—9660格式的image File(映像文件)，然后再进行刻录；目前的电脑处理速度已经可以实现完全实时转换，这种将数据自动实时转换成ISO—9660格式，然后进行烧录的方式就叫飞机式写入。

使用飞机式复制很简单，我们只要勾选“拷贝选项”卡中的“飞机式”并按“拷贝光碟”按钮就可以开始整个拷贝过程了。

强大的影像写入方式

飞机式光碟复制失败的话就要在硬盘上先做影像后再刻录了。

飞机式复制虽然方便和快速，可是在我们要复制的光碟中没有多少是很好读的，不是由于用久了而划花就是碟片本身就不是很好读（基于竞争的需要，即管是正版的软件也不是很好读，不要一味迷信正版光碟就会好读，其实最好读的是刻录出来的光碟）。

当母盘不是很好读或有坏区时就需要我们先做影像文件在硬盘再刻录了。

1,取消“拷贝选项”的“飞机式”复制模式，打开“读取选项”选项卡设定好读取选项。

这里要讲解一下“读取选项”卡中各选项的功能：

把“出现读错误前重试次数”增大可重复读取有错误的地方，最大限度地读出光碟的内容。

当复制音频光碟和VCD影碟时由于这类光碟不带校验，为了提高复制质量减少音频光碟的爆音或减少VCD影碟的方格我们就必需勾选“读取介质目录编号及ISRC”选项。这样nero就会去读取光碟上所有的资讯包括ISRC（International Standard Recording Code），当然，速度就是代价。

某些特别的光碟（只有一个片段的多片段光碟、数据－音轨－数据方式的混合光碟）是需要勾选“忽略非法TOC类型”才能复制的。

对于数据音轨在读取过程中遇到读不到的数据块时我们可以选项“继续拷贝”强制完强光碟的复制。

“强制原始读取”、“读取音频数据及子声道”、“使用抖动纠正”、“忽略读取错误”都勾选能更有效的增大成功复制的机率。

一般的情况下我们只要把所有的选项勾上就基本上能把光碟复制出来。

2,在“镜像”选项卡设定影像文件名

如果我们只要复制一张光碟并且不需要留底，那么勾选“光碟拷贝后删除镜像文件”，让nero在复制光碟后把影像文件删掉。


浅谈刻录模式

---了解一下各种常见的刻录模式。

作者:　老渔翁
日期:2001-03-06

近来宽带上网的流行，令有两种计算机硬件最为抢手－硬盘及光盘刻录机。网友不停下载互联网上的资源，很快便将硬盘机「常满」，这样便需要刻录光盘作备份。虽然光盘刻录差不多也是按部就班操作就可以了，但我们亦要认识不同的刻录模式，因为不同的模式在刻录不同的光盘时有不同的设定。

一、刻录模式

1、Track-at-Once

Track-at-Once 即每样资料以一条轨 Track 为单位，主要用于制作 Multi-Session 上，即是只要未关闭盘片(Close Disc)，每次可以将新的资料写到余下的地方，直至用尽整个光盘为止。由于计算机只可以读取最后一个分段(Session)作为目录结构，如果在刻录新分段之前没有 Import 旧的分段目录结构的话，之前刻录在前方分段的资料便无法读取。

2、Session-at-Once

一次将不同资料写在一个分段(Session)或多个分段内，可以在同一个分段内存放多条音讯轨或一条资料轨，主要用来制作 Mixed-Mode、CD-Extra。在首个分段写入音讯或资料，而在之后的分段则写入另一种资料。

3、Disc-at-Once

Disc-at-Once 与 Session-at-Once 差不多，即是一次由开始写入(Lead-in) 将资料写到光盘上，写完后结束(Lead-out)光盘并将盘片关闭(Close Disc) ，这样就算有余下的空间都不能再写入。

音乐光盘亦一样，由于 CD Player 只能读取首个分段(Session)的资料，Disc-at-once 便可以一次将所有音讯写到光盘上，并关闭盘片(Close Disc)。

4、Packet Writing

Packet Writing 原理有点像硬盘机，将光盘分为一格格，每格可分别写入不同的资料，可以无需连续写入，主要用于 CD-RW 上，但光盘必须预先重新格式化到 Packet Writing模式以及使用支持 Packet Writing 的刻录软件，如 Direct CD。

二、为何在开始写入及结束时会有空间？

在写入(Lead-in)及结束(Lead-out)的位置，是会用来储存光盘的资料，如档案格式、目录结束、开始及结束位置等，这些资料亦会占用光盘原有的空间，所以分段与分段之间的写入/结束地方会令光盘刻录时占用更多光盘空间。

三、档案格式

1、ISO9660 是 DOS 最标准的文件名称格式，以 8.3 的格式储存，让 DOS 及 窗口系统都可读取光盘档案。

2、JOLIET 是一种长文件名支持的格式，可支持最多128字符的长文件名，包括其它双字节的语言，如中文。

3、Hybrid 是一种结合 ISO9660 及 MAC 的 HFS 档案系统，烧出来的光盘可以同时在 PC 及MAC平台下的光驱阅读。

四、Burn Proof 技术

Burn Proof 是近来一种新的刻录光驱技术，每部刻录机都有约 2MB 或以上的暂存记忆(Buffer)，用来记录要刻录的资料，每当开始刻录光盘的时候，资料会由硬盘机传送到暂存记忆，将暂存记忆储满后来开始将记忆上的资料写到光盘上，目的是可以让当硬盘的资料未能及时传送到暂储记忆时，记忆体内仍然有之前的资料可以写到光驱，不会让因为没有资料写入而「烧坏碟」。

而 Burn Proof 技术的原理是当刻录机内的暂存记忆资料跌到指定的界线时，发出指令到光驱令光驱停止刻录，而当资料再次继续传送时，刻录机先寻找回之前停止的位置，再继续将资料写入到光盘上。这样便可以确保光盘不会烧坏。


CD

CD-R刻录盘的原理

随着刻录机的逐渐普及，刻录已经不仅仅是以前发烧友和商业用户所关心的问题，越来越多的个人用户拥有了自己的刻录机，但是面对各种各样的CD-R刻录盘，却有着种种的疑问，现在，让我们一起来看看CD-R刻录盘的一些基本知识，将有助于大家选择CD-R盘以更好地完成刻录。

基本上来说，CD-R的基础科技是建立在空白CD-R盘片上，也就是说，在当时如果没有成功研发出CD-R盘片，也就没有CD-R光驱的问市。CD-Recordable 盘片我们又称为 "Media" 储存媒体，"Blanks" 空白片或是有人干脆依照颜色称为"金盘"或"绿盘"等等，名称很多。一张CD-R空白的盘片上，最常看到的颜色就是金色，这是因为在CD-R空白片上是以24K黄金作为盘片反射层的原料，然而，这个反射层非常非常的薄，如果想要回收CD-R上的黄金原料，可能需要收集到好几千片才有回收的价值。其实在CD-R空白片上最贵的部份不是黄金，而是称为Dye的有机染料层。CD-R空白片的最主要目的是，在一般应用镭射的范围可将资料刻录于其碟片上，也就是我们常见的CD-R光碟刻录机，然后这片烧好的CD-R盘片还必须在一般的CD-ROM光驱上被读取出来，也就是当成一般的CD-Title来读。以下在介绍CD-R空白片的结构前，我们先来看看一般的CD盘片。

一般CD盘片的物理特性

CD，Compact discs，不管上面放的是音乐(Audio)，资料(Data)还是其他影音视讯(Video)，这些资料都是经过数位化处理，变成0与1，然后再存于CD盘片上，其对应的就是盘片上的pits(凹点)与lands(平面)，所有的pits有着相同的深度与宽度，但是长度却不同。一个pits大约只有半微米宽，大概等于五百粒氢原子的长度。一片CD盘片上总共有约28亿个pits。在此还有一个数字给大家参考，那就是在盘片上的螺旋轨大约围绕中心2万圈(以存放满74分钟为例)。当CD光驱上的激光照在盘片上时，如果是照在lands(平面)上，那会有约 70-80% 反射回来，这样 CD读取头可顺利读取到反射信号，如果是照在(pits)凹点上，则造成激光散射，CD读取头无法接收到反射讯号，利用这两种状况就可以解读为数位讯号(0与1)，进而转换成音乐(Audio)或资料(Data)。一片普通CD片的直径是12公分，厚度为1毫米，重量为半盎司，组成部份包括最厚的合成塑胶(Polycarbonate)层，加上一层薄薄的铝(Aluminum)，还有一层保护漆层(UV-Lacquer)。

CD-R的物理特性

CD-R盘片具有与一般CD盘片相同的外观尺寸。当一片CD-R盘片被记录完成后，它上面记载资料的方式与一般CD盘片一样，也是利用激光的反射与否来解读资料，那就是为什么CD-R盘片可以放在CD-ROM上读取。但是其间的原理不同，以下就让我们来探讨一下。CD-R盘片上除了原有CD盘片的合成塑胶层(Poly- carbonate)与保护漆层(UV-Lacquer)外，原来用来反射的铝层改用24K的黄金层(纯银材质也可以)，另外再加上有机染料层(organic dye)与预先做好的轨道凹槽(pregroove)。有的CD-R盘片工厂另外加上了一层供书写用的标签层(label)。

当 CD-R 盘片被记录的时候，光碟刻录机(CD-R)发出高功率的激光打在 CD-R 盘片某特定部位上，其中的有机染料层因此而融化造成化学变化，这些被破坏掉的部位无法顺利反射CD光驱所发出的激光；而没有被高功率镭射照到的地方可以靠着黄金层反射镭射光，就像前面介绍的一般CD盘片上的pits(凹点)与lands(平面)，同样都以“反射/不反射”来记载资料的。这就是CD-R与一般CD盘片有点像又有点不像的地方，不同的记录方式，一样的结果，一样的目的：那就是可以通用于所有的CD光驱。

光标记

在此我们将CD-R盘片上被改变的部份称之为光标记(Optical marks)，这些光标记都是被CD-R光碟记录器上的高功率激光照射后所产生，此部份无法反射激光，功能类似一般CD盘片上的pits，而其他部份则可以靠24K黄金层反射镭射光而被CD光驱侦测到，类似一般CD盘片上的lands，这样就可以和一般CD盘片一样的存放数位资料0或1了。其实在当初研发CD-R时，是先研发出在CD-R盘片上可以改变特性的有机材料(organic dye)，才进而设计出CD-R光碟刻录机。CD-R盘片与一般CD盘片一样都是以固定线性速率(CLV)方式读出资料，这也就是说CD-R不管是读取或是写入资料都是固定的传送速度(Transfer Rate)，所以在盘片内圈与外圈有着不同的转速，外圈转速较慢，而内圈的转速快，如此读取或写入一直保持着相同的线密度。当要将资料写入CD-R盘片时，是必须保持相同而稳定的速度，不可任意中断资料的传送，否则就会发生buffer under-run这样的错误信息而报废了一片CD-R。


CD

CD-R刻录盘的种类

CD-R盘片的种类

CD-R盘片使用有机染料(organic dye)作为记录层的主要材质。这种有机染料是几百万个相同分子连接在一起而形成的组织结构。直到最近，两种基本种类的有机染料才开放各CD-R盘片工厂使用，它们分别为绿色的cyanine与金黄色的phthalocyanine。而三菱化学公司(Mitsubishi Chemical Company)与Verbatim公司联合发表了一种新的有机化学组成材质叫做AZO(蓝色)，它不用一般常见的黄金作为反射层而使用银作为反射层，所以你会看到一边是蓝色，而另一边是银色。我们常常听到使用者在讨论CD-R的盘片，到底是金盘好还是绿盘好? 其实不管是新发表的蓝盘还是市面上常见的金盘或绿盘，各有各的优点，各有各的缺点，以下就来讨论这个问题。

Cyanine (绿盘)

在橘皮书(Orange Book / CD-R 标准书)中对CD-R盘片的规格制定，原来是参考由太阳佑电公司(Taiyo Yuden)所提出的cyanine种类的CD-R盘片材质。Cyanine是由太阳佑电(Taiyo Yuden)所发明，它也是其它两种材质的原型材质。换句话说，是先有cyanine，然后phthalocyanine与AZO才根据 cyanine 改良而成。大多数的 CD-R 光碟刻录机是参考cyanine的特性而设计，而现今 CD-R 盘片的工厂也大多使用cyanine材质，相信它也会在市面上出现最久。Cyanine 原始材质非常怕强光，是属于感光性材料，在制造时必须加入合成适当的铁金属以降低对光的感应能力，一但完成 CD-R 盘片的制作后，只有CD-R光碟刻录机内的高功率激光才能改变它的性质。用Cyanine材质做成的CD-R盘片有着翡翠绿的颜色，但是也有些工厂做出"蓝绿"色的CD-R盘片，其实cyanine本质为青蓝色，所以才称为 cyanine (青蓝)，但是在制作时，因为与黄金反射层合并组合，而成为绿色 (蓝 + 黄 = 绿)。如果是使用银来作为反射层，结果你会发现此种碟片成为深蓝色。

许多CD-R相关技术的公司都建议使用 cyanine 绿盘，原因是这种材质可以接受较广范围的读写镭射，而可相容于大多数型式的CD-R光碟刻录机。而且最新的cyanine材质可以适用于不同的写入速度，从1x(单倍速)到12x(12倍速)皆可接受，且可应用于各种不同镭射强度的机器。更多数新推出厂牌的CD-R光碟刻录机更以cyanine材质CD-R盘片规格来设计测试。前文提到过，CD-R记录资料是利用高功率(高热)激光照射在CD-R盘片上的有机染料层，使其造成熔化(材质改变)而做成pit的功能。这种改变是以独立的分子作为基本的单位，并不会造成扩散。刻录完成的盘片在刻录面可以明显看出两种不同的颜色深度，即代表有资料区(从内圈开始)与无资料区(外圈部份)。

Phthalocyanine(金盘)

Phthalocyanine 的 CD-R 盘片呈现金黄的颜色，这是因为这种有机染料它自己是接近透明的浅黄色。制造此种 CD-R 盘片的工厂只有 Kodak (柯达) 与 Mitsui Toatsu(三井)，其他看到的厂牌源头也是出自这两家公司。Phthalocyanine 碟片的支持者指出，Phthalocyanine材质有更好的抗光性，能延长存放资料的时间，可超过100年以上。Phthalo- cyanine材质的CD-R盘片与Cyanine一样，也是靠利用高功率镭射改变有机染料层(熔化而质变)做成pits来记录资料。

Azo(蓝盘)

Verbatim 公司发表了一种叫做 new DataLifePlus 的 CD-R 盘片，由 Verbatim 的母公司：三菱化学公司(Mitsubishi Chemical Company) 负责生产，这种新的CD-R 碟片是使用金属化Azo有机染料加上低价银材质作为反射层的盘片。这也是三菱化学公司首次将这种材质的盘片量产上市，这种盘片有着银白色的标签面，读写面则呈现深蓝色。与早期太阳佑电发表cyanine材质的CD-R盘片一样，初期的Azo材质只能使用于单倍速或是双倍速的 CD-R 光碟刻录机，而无法顺利使用在高速度(4x)的刻录机机种，然而当DataLifePlus CD-R盘片的发表，Verbatim公司正式宣布此种新配方的 Azo CD-R 盘片克服了速度上的瓶颈，已经可以在 4 倍速的光碟刻录机上使用。

Verbatim公司在早期研发Azo材质时，经过很多的测试发现，此种材质的寿命可达100年，并且提供了产品终身保用，只要记录完成并无错误之盘片，在任何时间产生读取的错误的情况，可免费更换一片全新的 CD-R 盘片。其实真正的问题是，直到今日，业界尚未有一个独立公正客观的公司来对这些 CD-R 盘片产品进行评估，测试查证。

CD-R盘片与写入速度的关系

要成功录制一片CD-R盘片，光碟记录器内部的温度控制，镭射功率控制，写入作业控制及转速都必须控制在理想的范围，这样就可以达到"即时"写入的功能，这里所谓的"即时"是指50分钟的资料，于50分钟就可写入完成，也就是一倍速的写入。在我们还不讨论四倍或六倍的写入速度，我们先来看看红皮书所定的标准。红皮书，代表 CD-Audio 的格式标准，每秒钟可播放频率44.1KHz或是44,100个取样资料的音乐。红皮书规定了 CD 播放的速度为每秒钟 1.2到 1.4公尺磁轨的长度。早期电脑用的CD-ROM光驱采用这种速度来读取资料，等于是每秒钟读取 75个磁区 (Sector)。然而因为CD-ROM资料的读取并不是连续的循序读取，很可能要常常读取为在不同区域(轨道)的资料，因此速度就变成很重要了。以数位图像资料(AVI或是MOV档案)为例，它资料存放的方式就像 CD-Audio 一样，属于循序式存放，然而因为它是使用高压缩比来压缩视讯 (Video)，在播放的时候，如果采用单倍速播放，会因资料传送的速度不足而使画面产生不连续(跳格)的现象。这种现象使得在电脑多媒体的应用上，必须使用更快速度的光驱，许多CD-ROM光驱的硬体制造商发表了高倍速光驱。有一个重点，就是这些光驱还是必须相容于单倍速的播放CD-Audio片子，而在其他电脑资料的盘片采用全速的播放。很自然的，CD-R光碟刻录机也摆脱不了对速度的追求，早期的CD-R光碟刻录机只是用来刻录 CD-Audio 音乐用的，单倍速写入速度，也就是说60分钟的音乐需要60分钟来刻录，另外再加上几分钟时间写 Lead-in与 Lead-out。当改良CD-R产品的设计后，加上新配方CD-R盘片的配合，开始出现双倍速的机器，60分钟的资料，只要半个小时(30分钟) 就可以写完。然后是四倍速的机器出现，同样60分钟的资料，只需15分钟的写入时间即可完成。越高的速度代表越贵的售价。其实真正要了解的重点是，CD-R写入的速度与将来这片CD-R要播放的速度完全无关，用四倍速 CD-R 光碟刻录机写出来的片子，播放时并不一定需要四倍速的CD-ROM。举例来说，数位图像资料 (AVI 或 MOV档案)，用四倍速光碟记录器写完资料后，可以用单倍速的 CD-ROM 来播放，只是播放时并不一定很平顺就是了。


应该选择什么盘片

现在的盘片各式各样，有散片和盒装CDR，盒装的一般价格在10元以上，而散装的价格则比较低，在1-2元之间，一般家用的话，仅仅是进行大容量的数据保存（数据价值不大，一般为一些应用软件），不需要购买很好的的CDR。

另外，如果光盘主要是存贮多媒体、影像资料以及各种原始文件资料，那么，使用CD-R盘应该是最好的选择。通常，准备让外人看的东西，用CD-R盘是明智的，因为CD-R盘可以在普通的CD-ROM上读取；而CD-RW盘就未必可行。

那么CD-RW的作用是什么呢？我们都知道CD-RW的基本特点是可多次擦写。CD-R盘虽然可以用类似删除的操作达到不显示已被"删除"文件的目的，但实际上并不能够将这些文件占据的空间释放出来；而CD-RW盘则可完全删除。如果你需要对光盘的内容经常更新，比如，日常备份系统设置等，用CD-RW盘很合适。另外，对经常测试刻录软件功能的用户来说，使用CD-RW盘可以少浪费一些CD-R盘片。

一般当我们对数据保存的时间和稳妥性有比较高要求时候，金盘是最好的选择，而且最好选用一些名牌大厂的产品，这些盘在工艺及材料上都比较可靠好一些，并且有包装盒也便于盘片的保管。而日常一般使用，散装绿盘或者白金盘就足够了。如果是送给亲友或者是比较好玩的东西，可以用彩色的CDR来刻录，也许会给对方一个惊喜


按照颜色对CDR盘片的分类

CD-R盘片根据记录层使用的有机染料不同可分为三种：绿盘、金盘和蓝盘。绿盘从读盘面看起来是绿色的，因此大家习惯用读盘面的颜色来区分刻录盘的大类，然而从读盘面看到的其实并不是染料的本色，而是映衬于黄金底色上的青色，由于青色＋黄色－>绿色，因此我们看起来盘的背面就是绿色的了。如果盘片采用银底而不是黄金底，我们看到的就是青蓝色，这也就是我们为什么有的时候会看到一些又象绿盘又想蓝盘的CDR了。
这就是蓝盘和绿盘 | 这是白金盘和金盘

金盘呈金黄色，因为这种有机染料本身是接近透明的浅黄色，配上黄金的底色就是我们从读盘面所见到的金黄色了，而有的时候采用银底的话，就是我们现在常看到的白金盘了。蓝盘是采用银材质作反射层，蓝盘使用金属化Azo有机染料加上低价银材质反射层，因此看起来是纯兰色的。

一般的说，金盘保存的时间最长，理论上可以保存100年。但绿盘的适应性是最强的，因为刻录机几乎是参照绿盘而设计的，所以绿盘不太挑刻录机。


刻录盘的保养和管理

刻录盘的保养和管理

同样的刻录盘刻多了，往往会分不清楚哪张盘的内容是什么，这时候可在光盘标签面用专用的油漆笔把盘片的大致内容写在上面，以后就可以一目了然了。

CDR盘片不能承受极端温度和阳光照射，和普通的光盘相比，更容易遭受损坏坏，因此在保管时要避免阳光照射，金盘虽然以优秀的抗光性著称。但是，考虑到盘片的价格和上面存放的珍贵资料，奉劝诸位还是谨慎为上。绿盘、蓝盘的用户则更当小心为妙。

对于刻录盘片，要尽量不要让它受到弯曲和挤压。对于光盘的读盘面，尽量不要用手去触摸，更要避免被硬物划伤和灰尘等，由于CD-R盘片的表面是一层裸露的介质加反射层(金或银)，如果不小心将 CD-R标签面刮了一下，数据将导致最直接的损失！背面(数据面)同样不能划得遍体鳞伤。读多了伤痕累累的烂盘，你心爱的光驱(或刻录机)最容易"英年早逝"。取用光盘时最好用手卡住左右边缘，而不是上下两面。同时要尽量避免把光盘放在潮湿和温度过高过低的地方，这样的环境同样会使盘片受损。


刻录盘的标签

一般我们手里的光盘都是采用由金属母盘在工厂用塑料进行模压成批地生产出来的盘片。在盘片上包含软件的名称；同时读盘面一般为白色且光亮如镜（偶尔也有其他颜色的，如金色）。

CD-R刻录盘绝大多数印有标签，有些也印得花哨。许多人以为它是一张VCD。分辨CD-R盘就得看它的读盘面，带有如前所述的那几种颜色的盘片大多是CD-R盘片。

而刻录盘上一般也有一些字样来标示盘片的质量和品牌以及一些信息，同时最重要的就是要区分出CDR和CDRW，一般从盘底的涂层颜色和盘面的标志都可以看出CD-RW和单片盒装CD-R盘的差别，CD-R（可刻写盘）是Recordable；而CD-RW（可擦写盘）是ReWritable。

在盘片的读盘面可以看出盘片是否已经被使用过，因为刻过的部分会有细小的染料烧化点，经过混色后，一般要比未刻写的部分颜色深些，但有的时候盘片数据刻的比较满的情况下，会比较难以分别。

CD-R盘片还有一项指标也印在包装封面，那就是刻写速度。因为除了刻录机有刻写速度指标外，刻录盘片实际上也有速度限制，一般质量比较好的盘片支持比较高的刻录速度，而一些质量比较差的盘片即使标称可以8X或者更高，实际上往往在极限速度下就会出现不稳定或者挑刻录机的情况。当然也有些盘片是什么都没有写的，这些一般是比较劣质的，目前最便宜（肯定也是最差的拉）至少也能支持到4X了。

从上面可以很清楚的看到这张盘片的各种信息

除了通过CDR盘片的信息，有的刻录软件也可以鉴定盘片的质量，同时也有一些检测CD-R盘片的软件，通过这些软件可以检验CD-R盘片的详细信息。但是最好的检测方法还是用自己的刻录机来刻录一下才知道，所以一般在购买自己没有用过的刻录盘时，最好少买一些，买5-10张回去刻下，效果好再大量购买，毕竟在人家的刻录机上用得很好的盘片和自己的刻录机也不一定100%兼容。


tmpgenc12A 使用详解

TMPGEnc12A 参数设定详解

作者:老枯

1）老枯得益于网上的丰富资源，摸索DV1394和MPEG编码算是入门了。为了回报网友，写了这篇tmpgenc12a参数设定详解，希望能对大家有用。

2）本来呢，tmpgenc虽然没有help文件，但在各个选项的note帮助中已经提供了不少的解释，威龙已经在这方面做了很多了努力，所以老枯这里的很多东西都只是随机注释的扩展而已。

3）要想深入理解mpeg encoder的参数设置，一定要对mpeg标准有了解。老枯以前曾搞过图像处理和压缩专业，所以主要从各个参数的原理上做一些自以为是的解释，使用tmpgenc的实战经验方面我本人也有限，大庆的文章图文并茂可以说是实战指南，请大家参考。

4）本文没有涉及tmpgenc的菜单部分，因为影响mpeg编码效率/质量的主要是参数设置。菜单提供了一些很好的功能，比如压缩完成自动关机等，请大家自己摸索。

5）水平有限，现眼之处请指正，赫赫。另外，枯痴版权，欢迎转载。。

A. video（视频）部分：

本部分设定输出的视频码流的类型和参数，大部分参数在模版中已经固定。

1）基本类型：有mpeg1/mpeg2，mpeg1用于vcd, mpeg2用于svcd/dvd.

2）大小：PAL vcd标准为352x288, pal svcd标准为480x576, pal dvd标准为720x576

3)画面宽高比：一般应该用4:3 625 line PAL, 这是电视机的屏幕比例

4）桢率：pal 的标准为25fps

5) 码率控制：码率控制算法是造成各种编码器编码效率和质量不同的关键因素。mpeg标准中并没有对次算法的具体实现做规定，这通常也是商业版本的知识产权内容。

CBR（固定码率）：保持码率基本维持在平均码率。实现简单，对复杂场景会因码率不足造成马赛克现象，对于简单场景则不能充分利用编码空间。(老枯这里讲的复杂场景是指细节/边缘丰富以及快速变化场景）。

VBR, (2-pass VBR), “二次处理VBR”。老枯认为其意思是通过对整个视频源进行2次处理使编码效率最高：第一遍判断何处为复杂场景和简单场景，第二遍根据码率的上下限，把码率重新分配更多给复杂场景。可以在实验中看出，tmpgenc在进行这种编码时进度指示在50%以前是没有预览图象的，而且桢进度指示为0。所以老枯建议威龙改译为“二次处理”。这种码流控制方式应该在给定码率下得到最好的质量，但是和具体2次分配算法关系很大。同时耗时最长。一些其他编码器甚至有3次处理的码率优化。

MVBR (手动可变码率），设定最大码率和对不同的帧类型设定不同的信息损失量，实现局部码率优化。可以通过手工指定复杂场景为I帧对之进行较精细的编码。参见对于GOP参数设定部分。

CQ-VBR (自动可变码率），设定主观质量值和码率上下限，以主观质量标准对编码器量化环节进行控制，在可选参数中设定主观质量值以后，编码器就在能达到此质量标准的前提下尽量节省码率。关键在于编码器对主观质量的评价方法。这是CQ和VBR的综合，也可以看作自动的MVBR. 威龙汉化5版在可选参数中有一行是“不破坏最小码率的状态而填充数据”，老枯的理解是，如果码率过低就填充无意义码（好浪费啊，不过可能是为了兼容性的原因），英文版这一句没有翻译，还是日文。 :-(

CQ (固定品质），就是比MVBR多了一个主观质量值的设定。老枯不明白到底是怎么控制的。

RT-CBR (实时固定码率）：连GOP层次的码率优化也不做了的CBR,快一点，质量不高

RT-CQ (实时固定品质）：连GOP层次的码率优化也不做了的CQ,快一点，质量不高

6）码率：这个码率是指CBR方式下的平均码率

7）VBV缓冲区大小：缓冲区大的话，编码优化会好一些，但是解码的时候也要求大一些的缓冲区。因此，vcd/svcd标准中参数是固定的，否则可能机器无法播放。

8）Pofile & level(类别与级别）: 这个参数是mpeg1没有的。在svcd/dvd应用中应该是MP&ML,模版自动选定。 MP&HL是为HDTV定义的，分辨率可以高达 19??x11?? .

9)制式：好象这个也是mpeg2相关的参数。我们应该用PAL.

10) 隔行扫描：mpeg1只支持逐行扫描（25 frame/sec)，mpeg2可以选择隔行(50 field/sec)。如果成品在电视上播放，老枯建议选择隔行，使运动平滑。但是隔行的视频在pc上看会有毛刺现象，在水平运动景象中尤其明显。

11）播放时实现3:2下拉： 这是在film/NTSC制式转换中需要的，即在编码时维持帧率不变，不做3:2下拉，而在播放中实现。参见 B.advanced部分。感谢威龙指正。

12）YUV格式：给亮度/红色差/蓝色差分配的码位。对于人眼来说，亮度信号是最敏感的，所以就分配比较多的编码空间以求精细，对于色差则粗糙些。一般就是4:2:0了。（其实4:2:0方案给蓝色差的码位不是0，老枯不知道为什么这样写）

13）DC分量精度：在mpeg编码中需要对8x8的图象块进行DCT(离散余弦变换），DC分量的意义基本是代表8x8块中的平均值，一般需要为之分配比较大的编码空间，否则马赛克的边缘效应就比较明显。（8bit就不小啦，图象压缩中是每个bit的油水都要榨干的）

14）运动检测精度：mpeg是对I帧进行帧内编码，对P帧进行预测误差编码。就是对于P帧的图块，在I帧中寻找对应的部分，然后对两个图块的差异部分进行编码，可以大大节省码率。运动检测精度越高，图块搜索匹配的范围越大，编码效率越高，同时编码速度越慢。这部分算法同样没有在mpeg标准中定义，各个厂商实现水平相差会很大。一般来说，在tmpgenc中设置为普通即可。

B. Advanced (影象源）部分：

本部分设置视频源相关的参数，以及在编码之前对视频源进行的预处理。

1）视频源类型：隔行扫描/逐行扫描。这个参数在打开视频源文件的时候会对之自动判断设置。Tmpgenc12版不能自动识别type 1 DV，在12a版本中已经解决。参看老枯的编码测试页。

2）场顺序：这是整个tmpgenc甚至整个桌面视频领域中最混乱的一部分。tmpgenc12a好象也不能根据视频源自动设置这个参数。老枯在这个问题上搞了很久，才算明白了一点。这个参数是至关重要的，设置反了会造成生成图象的明显闪动，打个比方，一个物体的运动位置次序本来是1-2-3-4-5-6-……，设置反了以后就成了2-1-4-3-6-5-8……对于模拟视频源，其场序是由捕捉卡类型决定的，对于dv,则定义为 field order A。讲到这里还没有什么麻烦，但麻烦的是虽然场序只有2种，对于他们的叫法却有3种: field order A/B (在ulead软件中的叫法）, even/odd line first （tmpgenc的叫法）, field top/bottom first（bitrate viewer叫法），这3种叫法之间的对应关系是最让人头疼的。在英文版的tmpgenc12a中，缺省的设置为“even line first (field A)”，，但在威龙汉化中缺省设置为“奇数场->偶数场”，老枯曾就此请教威龙，威龙讲这是日文版的原意，注意不要在字面上混淆了。总之，3种叫法的关系是这样的：field A = even line first(奇数场->偶数场) = field bottom first。最可靠的方法，是用不同的设置对高速运动场景各生成一段隔行扫描的视频，并在电视上观察，应该能够看到差别。

3）视频源的宽高比：tmpgenc可以自动识别设置，一般应该为4:3 625line PAL.

4) 画面显示比例和位置：一般选用“全画面显示并宽高比不变”，所谓“全画面显示并宽高比不变2”选项可能是会造成部分画面不可见，老枯没有尝试过这一种。在4:3视频源中可能没有差别，但对于16:9宽屏影象在4:3屏幕上输出而言，“全画面显示并宽高比不变”是在上下留出空白，“全画面显示并宽高比不变2”会截掉左右两端画面。。。没有这样试过，仅为老枯猜测，不正确的地方请朋友们指正。

5）滤镜选项组：

这一组设置可以对视频源进行预处理以提高影象质量。一般来说，老枯都是在非编软件中实现这些功能的。另外，对滤镜的使用要适度，因为客观上任何滤镜的使用都是引入了信息损失，这是对低品质视频源提高主观质量的代价。

影象源范围：选取部分影象源进行压缩

24fps化：24fps是电影标准，一般不选

消除鬼影：鬼影是影象的重影，视频源不好的时候会出现。老枯在dv中没有遇到过。

消除噪点：在低光条件下的拍摄中影响中回出现明显的颗粒噪点，利用此滤镜可以消除。不过副作用是平滑了图象，比如人的面部会象橡皮娃娃一样，光滑但没有质感。

锐化边缘：可以对横向/纵向边缘分别设置参数，做增强处理。

简单色彩校正：调整亮度，对比度，gamma，色度等

高级色彩校正：可以按照不同的色彩空间RGB/YUV等进行色彩校正。

消除交错信号（de-interlace)：把隔行扫描的视频源转换成逐行扫描的视频，如果对输出的视频设置为隔行扫描（如在打算电视上播放的svcd/dvd)，则不要选用。老枯认为在做vcd（逐行扫描mpeg1)时候也未必需要选用，要看视频源的大小决定。比如老枯用dv 576线，在做vcd时候只需要288线，简单舍弃一个场就可以，不需要deinterlace. 相反，如果视频源是352x288的隔行扫描视频，则需要做de-interlace.

裁剑画面：由于电视机播放视频的时候对边缘四周的部分做舍弃，所以可以利用这一点只对可见部分进行编码，这样可以加快编码速度，并且因为节省的码率可以利用在未裁剪区域从而提高画面质量。一般来说对上下左右各裁剪5%是安全的。

3:2下拉变换：因film 24fps和 NTSC 30fps帧率不同，在制式转换中所需要做的调整。一般不用。

帧率不变：没什么好讲的

声音处理：可以增大/减小音量，并做声音的淡入/淡出。

C. GOP结构

GOP = group of picture. 在mpeg中一个GOP就是一组时间上连续的画面。mpeg中的画面分为3种：I,P,B. I是内部编码帧，编码方式基本上就是jpeg的格式。P是前向预测帧，编码方式是使用运动检测误差编码，参看A部分对运动检测的说明；B是双向内插帧，根据前后I/P帧进行插值运算，对插值误差进行编码。

建议一般不要修改GOP结构，以取得压缩比例和图象质量之间的最好平衡。极端的例子是只用I帧，图象质量会有保证，但码流会很大。

1）输出编辑用的码流：这个选项会把GOP最后的B帧取消。因为B帧是双向内插的，其编码/解码不仅需要以前的I/P,也需要以后的I/P帧。取消最后的B帧，可以去除GOP之间的依赖性，从而便于编辑。

2）检测场景变化：对于快速变化的场景，强行设置为I帧，以保证画面质量

3）手工强制设定帧类型：手工设定需要精细编码的画面帧为I帧。结合MVBR码流控制可以全面控制码流分配。

D、量化矩阵

mpeg中的量化是对8x8 YUV 信号图块进行DCT变换之后的系数的量化。通过对高频分量使用比较大的量化阶从而达到减小高频分量的编码空间，达到压缩的目的。代价就是丧失图像细节，边缘模糊等。

1）帧内编码量化矩阵：这是指对I帧使用的帧内编码量化矩阵

2）帧间编码量化矩阵：是指对非I帧的帧间预测误差编码所用的量化矩阵。威龙汉化版中叫外部矩阵。

3）矩阵模版的选择：建议对一般的视频选用mpeg标准，可以看到，其帧间编码矩阵统一为16，这是因为帧间误差已经抵消了低频分量，高频分量丰富，所以和帧内编码矩阵有所不同。对于计算机动画尤其是2维线条为主的动画，建议选用CG模版，可以看到因为CG本身高频信号丰富，其帧内编码矩阵也统一为32。

另外，有朋友尝试减小量化矩阵的各个数值，老枯认为这样做的意义不大。因为量化矩阵并不是量化的唯一因素，事实上的量化程度要根据码流控制部分的反馈信息而自适应调整。这样，即使量化阶减小，在码率有限的前提下，量化系数还是会加大的。

4）YUV输出为YCrCb: YCrCb色彩空间分配给Y亮度信号的编码空间更大，如果视频源是YCrCb格式的话，这个选项可以增加画面质量。不过一般都是采用YUV(CCIR601),如dv,所以不要选择这个选项，否则白白浪费码率。

5）浮点离散余弦变换：整点运算的速度比浮点要快很多，但精度不如浮点。老枯猜测这里的浮点其实只是把DCT变换的系数从8bit增大为16bit的精度，并不需要浮点运算器单元参与变换，否则速度是不可忍耐的。

6）不对静止部分做半像素的运动检测：由于视频源是隔行的，对于精细的静止边缘线条（1个像素宽度）比如静止字幕会出现一个场中出现，另一个场中不出现的闪动。选中这个选项会消除闪动。。不过老枯觉得好像这个和量化矩阵无关。

7）柔化马赛克：没什么好说的。就是在8x8图块的边缘做一些特别处理。能用足够的码率或者码率控制手段解决马赛克最好，因为这里的柔化虽然只对边缘进行低频滤波，毕竟还是会对画面造成影响模糊化。

E. 音频：

这部分大多不需要改动vcd/svcd模版。也没有大的影响。不多讨论。

F. 系统：

mpeg的系统是指视频+音频。vcd/svcd/dvd模版中已经设定好。没有什么可多讲的。


TMPGEnc应用点滴

MPEG压缩软件TMPGEnc的应用

一、基本操作：

    １、打开文件：

    启动TMPGEnc，点“浏览”，调入视频源文件。可以是avi，也可以是mpg、图片及其它多种类型文件。再指定输出文件名和路径。

    ２、载入设置：

    点按钮“读取”，调入MPEG设定模板。通常它们处在TMPGEnc的下面的一个Template目录中。本例中，我用的是VideoCD (NTSC)的模板，因我的视频是NTSC的avi。大家用的可能PAL的较多，这就要用VideoCD(PAL)模板。做SVCD则只要调用SVCD的模板即可。

    ３、修改设置：

    最好检查一下摸板的设置，TMPGEnc自带的有点问题，有必要修改一下，否则压缩出来的mpg播放时不满屏或有黑边。点“设定”，找到“影像源”：

    “宽高比”NTSC设为“4:3 525 line (NTSC)”，PAL设为“4:3 625 line (PAL)”；

    “画面显示的设定”为“全画面显示”。

    “运动检测精度”是用来调节画面品质的，以我的眼光，“标准”状态已经不错了。画质高则压缩时间长。

    最好把设置存盘，下次打开就不用再改了。点“保存”，输入自己的自定义设置模板名。

    ４、开始压缩：

    点“开始”按钮，压缩开始，原始时间是当前所进行到的视频位置。压缩中途，可以用“已用时间”＋“剩余时间”的和来估算总共需要的时间。图中的数字“７２００”是该视频源的祯数。压缩结束，可以看到实际所用时间。

二、MPEG工具：

    TMPGEnc的菜单里有一个“MPEG工具”，用这些工具可以对MPEG文件进行分解成MPV／MPA、或反过程合成、剪接等等操作。这里介绍常用的两个功能。

    １、简易合成：

    这个工具通常可以把某些似乎符合VCD而又不能刻盘的MPG文件变成标准的VCD文件（俗话说“过一遍”），速度很快，基本上也就是copy的速度。同样对SVCD有效，当然类型别忘了选“MPEG-2 Super VCD”。

    大庆经验：用CCE lite 2.291压MPEG-1，选2304 pack size、1150kbps，再用TMPGEnc“过一遍”可以做VCD。

    ２、MPEG剪接：

    “增加”MPG文件到列表中，每个文件可以调入多次，设置好输出的文件和路径，

然后双击文件名，设置每一个段的范围，全部段落设置好后，点“修正”，完成后，点执行即可完成MPG的剪接。速度很快！

    我们又多了一个MPEG的剪接软件，按TMPGEnc的风格，这个剪接输出的MPG不再需要再“过一遍”了吧？影音不同步现象也应该没有了？请大家反馈使用心得。

三、高级应用：

    在MPEG设定里，有若干影像源高级调整设置（滤镜），双击它即可打开设置。打勾后，即可应用这些设置。本人介绍其中常用的几个。

    注意：某些滤镜的应用将大幅度降低压缩速度，请酌情使用。

    １、影像源的范围：

    使用它，可以根据需要，从大段的AVI（也可以是MPG等其他视频文件）中压缩某一区域。将滑块拖到需要的起止位置，分别点“设定开始桢”和“设定结束桢”，更可以直接调节数值达到精确位置。点“默认值”回到原始状态（从文件头到文件尾）。

    ２、消除噪点：

    家用摄象机的信噪比往往不高，在光线不足的环境下，拍摄的画面噪点很多。这个滤镜对于消除视频噪点有显著效果。

调节三个滑块以达到自己满意为止。此滤镜同时也会削弱图象的部分细节。

    ３、色彩校正：

    TMPGEnc有色彩校正功能。打开“高级色彩校正”，点“增加”，左边的列表中即有“RGB亮度”项，在“种类”里有若干选项可以改变当前项。选用不同的“方法”里的选项，可以调节图象色彩、对比度、亮度及色相等等。

    ４、裁减画面：

    用于裁掉画面４边的部分。

    大庆经验：由于视频在电视上播放时，四周将有１０％左右在荧屏外，看不到，所以，将VCD的MPG的四周也裁掉若干，既降低了图象的总信息量，从而增加图象的画面品质，又不影响在电视上收看。

    ５、声音处理：

    有时，视频源的整体音量不理想，可以用此功能整体调节－－放大或衰减。也可以将视频源的声音作出淡入（从无声到正常）淡出（从正常到无声）的效果，避免有的MPG结尾时的声音噶然而止，给人措手不及的尴尬感觉。

    如果能处理画面的淡入淡出就好了！

四、双CPU设置：

    如果拥有双CPU，那既可享受TMPGEnc的高品质，又可以享受它的高速度。把下面的勾打满也就差不多了。“先读取影像”的值可调节，可能是我的内存不够大（128M），16M到64M，速度上没有什么区别。但0与16M区别就很大。

五、压缩速度测试：

    最近的应用发现，TMPGEnc已经不是以前的慢工出细活的那个了，现在的版本（从威龙主页--火烧岛下载了新的β12a版）在我的双P3-550/128M/BX Iwill DBD100的机器上，已经达到了前所未有的高速度(超频状态)：1:0.97(4分钟的AVI只用3分52秒)。并且PVMJPEG编码的AVI比BW编码的AVI更快。

    下面是测试报告：

    １、AVI源文件：

AVI文件 | 1# | 2#
编码 | PVM-JPEG | Broadway I-Frame MPEG
品质 | 1023 KB/秒，Q=19 | 1063 KB/秒，55M/Min
制式 | NTSC,352x240,29.97fps
片长 | 4分钟，,7200frames
压缩目标 | VideoCD MPEG-1

    ２、版本比较：β12a比β12提高速度16%-18%。

P3-550E 超频 | TMPGEncβ12a （威龙汉化） | TMPGEncβ12 （英文版） | AVI源文件
616/112 | 4'32" (272") | 5'23" (323") | 1#，PVM-JPEG
733/133 | 3'52" (232") | 4'28" (268") | 1#，PVM-JPEG

    ３、AVI编码比较：1#PVM-JPEG格式比2#BW格式提高速度12%。

AVI文件 | 时间 | 测试用版本
1#，PVM-JPEG | 5'23" (323") | TMPGEncβ12a
2#，BW | 6'02" (362) | TMPGEncβ12a

    TMPGEnc这个软件确实是个好东东，并且还是免费的！